Протокол IP : Протокол EIGRP

Перераспределение протоколов маршрутизации

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (21 мая 2008) | Английский (22 августа 2015) | Отзыв


Содержание

RIP

Введение

Использование протокола маршрутизации для объявления маршрутов, которые изучены некоторыми другими средствами, такой как другим протоколом маршрутизации, статическими маршрутами или маршрутами прямого соединения, называют перераспределением. Хотя во всей объединенной IP-сети желательно использовать единый протокол маршрутизации, по ряду причин часто используется многопротокольная маршрутизация: например, при слиянии компаний, в случае, если несколькими подразделениями управляют несколько сетевых администраторов, или в средах, где используются компоненты от разных поставщиков. При проектировании сети часто используются разные протоколы маршрутизации. В любом случае, наличие среды с несколькими протоколами делает перераспределение необходимым.

Различия в характеристиках протокола маршрутизации, таких как метрики, административное расстояние, классовые и бесклассовые возможности, могут повлиять на перераспределение. Эти отличия необходимо учитывать, чтобы перераспределение прошло успешно.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco выпуск ПО IOS� 12.2 (10b)

  • Маршрутизаторы Cisco серии 2500

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Метрики

При перераспределении одного протокола в другой следует помнить, что метрики каждого протокола играют важную роль в перераспределении. Каждый протокол использует разные метрики. Например, метрика протокола RIP основана на количестве переходов, однако протоколы IGRP и EIGRP используют составную метрику в зависимости от пропускной способности, задержки, надежности, загрузки и максимального размера передаваемого блока данных (MTU), где пропускная способность и задержка являются единственными параметрами, используемыми по умолчанию. В процессе перераспределения маршрутов необходимо определить метрику, понятную принимающему протоколу. Есть два метода определения метрик при перераспределении маршрутов.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-a.gif

Можно определить метрику только для данного распределения:

router rip
redistribute static metric 1
redistribute ospf 1 metric 1

Или можно использовать одну и ту же метрику по умолчанию для всего перераспределения (использование команды default-metric упрощает задачу, так как в этом случае не нужно определять метрику отдельно для каждого перераспределения).):

router rip
redistribute static
redistribute ospf 1
default-metric 1

Административное расстояние

Если маршрутизатор использует более одного протокола маршрутизации и определяет маршрут до одного и того же места назначения с помощью обоих протоколов, какой из маршрутов должен быть признан лучшим? Каждый протокол использует свой тип метрики для определения лучшего маршрута. Сравнение маршрутов с разными типами метрик невозможно. Административные расстояния решают эту проблему. Административные расстояния назначаются источникам маршрута, так чтобы маршрут от наиболее предпочтительного источника был выбран в качестве оптимального. Дополнительные сведения об административных расстояниях и выборе маршрутов см. в документе "Выбор маршрутов в маршрутизаторах Cisco".

Административные расстояния помогают выбрать маршрут среди различных протоколов маршрутизации, но могут привести к проблемам при перераспределении. Среди этих проблем могут быть петли маршрутизации, проблемы сходимости и неэффективная маршрутизация. Ниже представлена топология и описание возможной проблемы.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-b.gif

В указанной выше топологии, если в маршрутизаторе R1 применяется RIP, а в R2 и R5 одновременно применяются RIP и IGRP с перераспределением RIP в IGRP, возможно возникновение проблем. Например, R2 и R5 оба узнают о сети 192.168.1.0 от R1 через протокол RIP. Эти данные перераспределяются в IGRP. R2 получит информацию о сети 192.168.1.0 через R3, а R5 получит эту информацию через R4 с помощью IGRP. У IGRP административное расстояние меньше, чем у RIP (100 против 120), поэтому в таблице маршрутизации используется маршрут IGRP. Теперь существует опасность цикличной маршрутизации. Даже при наличии разделения горизонта или другой функции, предназначенной для предотвращения петель маршрутизации, все равно имеет место проблема сходимости.

Если R2 и R5 также распределяют IGRP в RIP (эта операция иначе называется обоюдным перераспределением), и сеть 192.168.1.0 не подключена непосредственно к R1 (R1 получает восходящие пакеты из нее от другого маршрутизатора), то существует потенциальная опасность, что R1 будет получать информацию о сети с R2 или R5 с лучшей метрикой, чем из оригинального источника.

Примечание: Механика перераспределения маршрутов является составляющей собственность на маршрутизаторах Cisco. Правила перераспределения на маршрутизаторах Cisco требуют, чтобы перераспределяемый маршрут присутствовал в таблице маршрутизации. Присутствия маршрута в топологии или базе данных маршрутизации недостаточно. В таблицу маршрутизации всегда заносятся маршруты с меньшим административным расстоянием (AD) . Например, если статический маршрут перераспределяется в IGRP на маршрутизаторе R5 и затем IGRP в свою очередь перераспределяется в RIP на том же самом маршрутизаторе (R5), этот статический маршрут не перераспределяется в RIP, поскольку он не был занесен в таблицу маршрутизации IGRP. Это происходит потому, что у статических маршрутов AD равно 1, а у маршрутов IGRP AD равно 100, и в таблицу маршрутизации занесен статический маршрут. Для перераспределения статического маршрута в IGRP на R5 необходимо использовать команду redistribute static при команде router rip.

Стандартное поведение RIP, IGRP и EIGRP — объявлять напрямую подключенные маршруты, когда инструкция network для протокола маршрутизации включает подключенную подсеть интерфейса. Есть два способа получить подключенный маршрут:

  • Интерфейс настроен с IP-адресом и маской — эта соответствующая подсеть считается подключенным маршрутом.

  • Статический маршрут настроен только с исходящим интерфейсом и без IP-адреса следующего перехода — это также считается подключенным маршрутом.

Router#conf t
   Router(config)#ip route 10.0.77.0 255.255.255.0 ethernet 0/0
   Router(config)#end

   Router#show ip route static
   10.0.0.0/24 is subnetted, 1 subnets
   S 10.0.77.0 is directly connected, Ethernet0/0

Команда network, указанная для EIGRP, RIP или IGRP и включающая ("охватывающая") каждый из этих типов подключенных маршрутов, включает эту подсеть для объявления.

Например, если у интерфейса адрес 10.0.23.1 и маска 255.255.255.0, подсеть 10.0.23.0/24 является подключенным маршрутом и будет объявлена этими протоколами маршрутизации, когда будет выполнена следующая инструкция network:

router rip | igrp # | eigrp #
   network 10.0.0.0

Статический маршрут 10.0.77.0/24 также объявляется этими протоколами маршрутизации, так как он подключен и "охвачен" инструкцией network.

Дополнительную информацию по предотвращению данной проблемы см. в разделе "Как избежать проблем при перераспределении".

Примеры и синтаксис конфигурации перераспределения

IGRP и EIGRP

В следующих выходных данных показано перераспределение маршрутизатором IGRP/EIGRP следующих маршрутов: статических, OSPF, RIP и IS-IS.

router igrp/eigrp 1 
network 131.108.0.0 
redistribute static
redistribute ospf 1 
redistribute rip 
redistribute isis 
default-metric 10000 100 255 1 1500

Когда протоколы IGRP и EIGRP перераспределяют другие протоколы, им нужно 5 метрик: пропускная способность, задержка, надежность, загрузка и MTU, соответственно. Пример идентификации метрики IGRP:

Метрика Значение
bandwidth В единицах килобитов в секунду; 10000 для Ethernet
задержка В единицах десятых мксек; 100 x 10 микросекунд = 1 миллисекунда для Ethernet
надежность 255 для 100-процентной надежности
load Эффективная загрузка канала выражается числом от 0 до 255 (где 255 – 100-процентная загрузка)
MTU Минимальный MTU пути; обычно равен MTU для интерфейса Ethernet, то есть 1500 байт

Несколько процессов IGRP и EIGRP могут запускаться на одном маршрутизаторе с их автоматическим перераспределением. Например, IGRP1 и IGRP2 могут выполняться на одном маршрутизаторе. Однако выполнение двух процессов одного протокола на одном и том же маршрутизаторе редко бывает необходимо и может потреблять память и процессорные ресурсы маршрутизатора.

Перераспределение IGRP/EIGRP в другой процесс IGRP/EIGRP не требует какого-либо преобразования метрик, поэтому во время перераспределения нет необходимости определять метрики или использовать команду default-metric.

Перераспределенный статический маршрут имеет приоритет по объединенному маршруту, потому что статический маршрут имеет административное расстояние 1, тогда как объединенный маршрут Eigrp имеет административное расстояние 5. Это происходит, когда статический маршрут перераспределен с использованием, перераспределяют статичный в соответствии с процессом EIGRP, и процесс EIGRP имеет маршрут по умолчанию.

OSPF

Эти выходные данные показывают маршрутизатор OSPF, перераспределяющий статичный, RIP, IGRP, EIGRP и маршруты IS-IS.

router ospf 1 
network 131.108.0.0 0.0.255.255 area 0 
redistribute static metric 200 subnets
redistribute rip metric 200 subnets 
redistribute igrp 1 metric 100 subnets 
redistribute eigrp 1 metric 100 subnets 
redistribute isis metric 10 subnets

Метрика OSPF — это значение стоимости, основанное на значении 108/ пропускная способность канала в битах в секунду. Например, стоимость OSPF для Ethernet равна 10: 108/107 = 10

Примечание: Если метрика не определена, OSPF при перераспределении маршрутов от всех протоколов подставляет значение по умолчанию, равное 20, за исключением маршрутов пограничного шлюзового протокола (BGP), метрика которого равна 1.

Если есть основная сеть и подсети, при перераспределении протоколов в OSPF необходимо использовать ключевое слово "subnet". Без этого ключевого слова протокол OSPF перераспределяет только главные сети, не разбитые на подсети.

На одном и том же маршрутизаторе можно запускать несколько процессов OSPF. Однако запуск более одного процесса одного и того же протокола требуется редко и потребляет память и процессорные ресурсы маршрутизатора.

Перераспределение одного процесса OSPF в другом не требует определения метрики или использования команды default-metric.

RIP

Примечание: Изложенные в документе принципы применимы к RIP версий I и II.

Эти выходные данные показывают маршрутизатор RIP, перераспределяющий статичный, IGRP, EIGRP, OSPF и маршруты IS-IS.

router rip 
network 131.108.0.0 
redistribute static
redistribute igrp 1 
redistribute eigrp 1 
redistribute ospf 1 
redistribute isis 
default-metric 1

Метрика RIP состоит из количества переходов, и максимально допустимое значение этой метрики составляет 15. Все, что превышает 15, считается бесконечным. Для описания бесконечного значения в RIP можно использовать значение 16. Компания Cisco рекомендует использовать при перераспределении протоколов в RIP низкие метрики, например 1. Высокая метрика, такая как 10 еще больше ограничивает RIP. Если для перераспределяемых маршрутов определить метрику 10, эти маршруты можно будет объявлять только маршрутизаторам, которые находятся на расстоянии до 5 переходов, после которых метрика (количество переходов) превысит значение 15. Определяя для метрики значение 1, вы разрешаете маршруту максимальное количество переходов в домене RIP. Однако это увеличивает возможность петель маршрутизации, если есть несколько точек перераспределения и маршрутизатор получает данные о сети с лучшей метрикой из точки перераспределения, а не из оригинального источника, как описано в разделе Административное расстояние этого документа. Поэтому необходимо удостовериться, что метрика ни один слишком высока, препятствуя тому, чтобы он был объявлен ко всем маршрутизаторам, или слишком низко, приводя к циклам маршрутизации, когда существуют множественные точки перераспределения.

Перераспределение Статических маршрутов Кроме Шлюза последней очереди в RIP с помощью Карты маршрутизации

Эта конфигурация является примером перераспределения статических маршрутов кроме шлюза последнего курорта шлюза в RIP через routemap.

Начальная конфигурация для данного примера:

router rip

version 2

network 10.0.0.0

default-information originate

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.32.32.3

ip route 10.32.42.211 255.255.255.255 192.192.192.102

ip route 10.98.0.0 255.255.255.0 10.32.32.1

ip route 10.99.0.0 255.255.255.0 10.32.32.1

ip route 10.99.99.0 255.255.255.252 10.32.32.5

ip route 67.129.103.128 255.255.255.240 10.32.31.1

ip route 156.55.231.0 255.255.255.0 10.32.32.5

ip route 172.16.28.0 255.255.252.0 10.32.32.5

ip route 192.168.248.0 255.255.255.0 10.32.32.5

ip route 199.43.0.0 255.255.255.0 10.32.32.5

ip route 204.103.0.0 255.255.255.0 10.32.32.5

Выполните эти шаги для настройки этого:

  1. Создайте access-list для соответствия со всеми сетями, который должен быть перераспределен

    Router#show access-lists 10
    
    Standard IP access list 10
    
        10 permit 10.32.42.211
    
        20 permit 10.98.0.0, wildcard bits 0.0.0.255
    
        30 permit 10.99.0.0, wildcard bits 0.0.0.255
    
        40 permit 67.129.103.128, wildcard bits 0.0.0.15
    
        50 permit 156.55.231.0, wildcard bits 0.0.0.255
    
        60 permit 172.16.28.0, wildcard bits 0.0.3.255
    
        70 permit 192.168.248.0, wildcard bits 0.0.0.255
    
        80 permit 199.43.0.0, wildcard bits 0.0.0.255
    
        90 permit 204.103.0.0, wildcard bits 0.0.0.255
  2. Вызовите этот access-list в route-map.

    Route-map TEST
    
     Match ip address 10
  3. Перераспределите в RIP с помощью route-map в и удалите команду default information originate из процесса RIP.

    Router RIP
    
    version 2
    
    network 10.0.0.0
    
    redistribute static route-map TEST
    
    no auto-summary

IS-IS

Эти выходные данные показывают маршрутизатор IS-IS, перераспределяющий статичный, RIP, IGRP, EIGRP и маршруты OSPF.

router isis 
network 49.1234.1111.1111.1111.00
redistribute static
redistribute rip metric 20 
redistribute igrp 1 metric 20 
redistribute eigrp 1 metric 20 
redistribute ospf 1 metric 20

Метрика IS-IS должна иметь значение от 1 до 63. В IS-IS нет возможности использовать команду "default-metric" — необходимо определять метрику для каждого протокола, как показано в примере выше. Если для маршрутов, перераспределяемых в IS-IS, метрика не указана, по умолчанию используется метрика, равная 0.

Подключенные маршруты

Перераспределение непосредственно связанных сетей в протоколы маршрутизации не является общей практикой и не показано ни в одном из приведенных выше примеров поэтому. Однако важно отметить, что его можно выполнить — как прямо, так и косвенно. Для прямого перераспределения связанных маршрутов используйте перераспределять команду настройки подключенного маршрутизатора. Также в этом случае необходимо определить метрику. Можно также косвенно перераспределить связанные маршруты в протоколы маршрутизации как показано в данном примере.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-cnctd.gif

Маршрутизатор B в данном примере имеет два интерфейса Fast Ethernet. FastEthernet 0/0 находится в сети 10.1.1.0/24, а FastEthernet 0/1 — в сети 20.1.1.0/24. Маршрутизатор B выполняет EIGRP с маршрутизатором A и OSPF с маршрутизатором C. Маршрутизатор B выполняет взаимное перераспределение между процессами EIGRP и OSPF. Следующие данные необходимы маршрутизатору B:

Маршрутизатор В
interface FastEthernet0/0
 ip address 10.1.1.4 255.255.255.0

interface FastEthernet0/1
 ip address 20.1.1.4 255.255.255.0

router eigrp 7
 redistribute ospf 7 metric 10000 100 255 1 1500
 network 10.1.1.0 0.0.0.255
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 7
 log-adjacency-changes
 redistribute eigrp 7 subnets
 network 20.1.1.0 0.0.0.255 area 0

Если в таблице маршрутизации найти маршрутизатор B, то можно увидеть следующее:

routerB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

Есть три вещи, о которых нужно сказать о представленных выше конфигурации и таблице маршрутизации:

  • Рассматриваемые сети представлены в таблице маршрутизации маршрутизатора Б как непосредственно связанные сети.

  • Сеть 10.1.1.0/24 является частью процесса EIGRP, а сеть 20.1.1.0/24 - частью процесса OSPF.

  • Маршрутизатор B выполняет взаимное перераспределение между EIGRP и OSPF.

Ниже показаны таблицы маршрутизации для маршрутизаторов A и C.

routerA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0
     20.0.0.0/24 is subnetted, 1 subnets
D EX    20.1.1.0 [170/284160] via 10.1.1.4, 00:07:26, FastEthernet0


routerC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet1
O E2    10.1.1.0 [110/20] via 20.1.1.4, 00:07:32, FastEthernet1

Маршрутизатор A определил сеть 20.1.1.0/24 через EIGRP, который показан как внешний маршрут, поскольку он был перераспределен из OSPF в EIGRP. Маршрутизатор C определил сеть 10.1.1.0/24 через OSPF, используемый как внешний маршрут, поскольку он был перераспределен из EIGRP в OSPF. Хотя маршрутизатор B не перераспределяет подключенные сети, он объявляет сеть 10.1.1.0/24, которая является частью процесса EIGRP, перераспределенного в OSPF. Аналогичным образом маршрутизатор В объявляет сеть 20.1.1.0/24, которая является частью процесса OSPF, перераспределенного в EIGRP.

Дополнительные сведения о перераспределении подключенных маршрутов в OSPF см. в статье Перераспределение подключенных сетей в OSPF.

Примечание: По умолчанию, когда команда redistibute bgp выполнена, только изученной EBGP информацией является кандидат, чтобы быть перераспределенной в IGP. Маршруты IBGP не перераспределены в IGP, пока команда bgp redistribute-internal не настроена при команде router bgp. Когда Маршруты IBGP являются redistirbuted в IGP, но меры предосторожности должны быть приняты во избежание петель в Автономной системе.

Как избежать проблем из-за перераспределения

В разделе административного расстояния были рассмотрены проблемы, которые могут возникнуть в процессе перераспределения, в том числе неоптимальная маршрутизация, зацикливание маршрутизации и низкая скорость конвергенции. Избежать этих проблем в действительности довольно просто — никогда не объявлять информацию, изначально полученную от процесса маршрутизации X, обратно процессу маршрутизации X.

Пример 1

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-b.gif

В предыдущей топологии R2 и R5 делают обоюдное перераспределение. RIP перераспределяется в IGRP, и IGRP является перераспределением в RIP, поскольку эта конфигурация показывает.

_________________________ М2:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2

R5:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2

С предыдущей конфигурацией у вас есть потенциал для любого проблемы, ранее описанные. Во избежание их можно фильтровать обновления маршрута следующим образом:

_________________________ М2:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2
 
access-list 1 deny 192.168.1.0
access-list 1 permit any

R5:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1 
 
router rip
network 178.1.0.0

redistribute igrp 7 metric 2 
 
access-list 1 deny 192.168.1.0
access-list 1 permit any

Распределить списки, добавленные к конфигурациям, как показано выше, фильтруют любые Обновления IGRP, которые входят в последовательный 1 интерфейс маршрутизаторов. Если маршруты, указанные в обновлениях, разрешены списком доступа 1, маршрутизатор принимает их в обновлении, в противном случае — нет. В этом примере маршрутизаторам говорится, что они не должны определять сеть 192.168.1.0 через обновления IGRP, поступающие в их последовательный интерфейс 1; поэтому эти маршрутизаторы получают данные о сети 192.168.1.0 только через RIP от R1.

Также помните, что в этом случае для процесса RIP необязательно использовать ту же стратегию фильтрации, поскольку у RIP административное расстояние больше, чем у IGRP. Если маршруты, берущие начало в домене IGRP, вернутся в R2 и R5 через RIP, маршруты IGRP все равно будут иметь преимущество.

Пример 2

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-c.gif

Использование топологии как выше, другой метод, который иногда более предпочтителен, для предотвращения проблем перераспределения, может быть продемонстрировано. Этот метод использует карты маршрутов, чтобы задать теги для различных маршрутов. Процессы маршрутизации затем могут выполнять перераспределение на основе этих тегов. Обратите внимание, что перераспределение на основе тегов не работает с RIP версии 1 и IGRP.

Одна из проблем, с которыми можно столкнуться в предыдущей топологии, следующие:

R1 объявляет сеть 192.168.1.0 R2. R2 затем перераспределяется на EIGRP. R5 изучает сеть через EIGRP и перераспределяет для RIPv2. В зависимости от метрики, что наборы R5 для маршрута RIPv2, R6 мог бы предпочесть, чтобы непредпочтительный маршрут через R5 вместо через R1 достиг сети. Предотвратить это помогает следующая конфигурация с помощью установки тегов, а также перераспределения на основе этих тегов.

_________________________ М2:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

!--- Redistributes RIP routes that are
 

!--- permitted by the route-map rip_to_eigrp




router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Redistributes EIGRP routes and set the tags
 

!--- according to the eigrp_to_rip route-map



route-map rip_to_eigrp deny 10
match tag 88

!--- Route-map statement to deny any routes that have a tag of "88"


!--- from being redistributed into EIGRP
  

!--- Notice the routes tagged with "88" should be the EIGRP
 

!--- routes that are redistributed into RIPv2


route-map rip_to_eigrp permit 20
set tag 77

!--- Route-map statement to set the tag 


!--- on RIPv2 routes redistributed into EIGRP to "77"


route-map eigrp_to_rip deny 10
match tag 77

!--- Route-map statement to deny any routes that have a
 

!--- tag of "77" from being redistributed into RIPv2


!--- Notice the routes tagged with "77" should be the RIPv2
 

!--- routes that are redistributed into EIGRP



route-map eigrp_to_rip permit 20
set tag 88

!--- Route-map statement to set the tag on EIGRP
 

!--- routes redistributed into RIPv2 to "88"

R5:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

!--- Redistributes RIPv2 routes that are permitted 


!--- by the route-map rip_to_eigrp




router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Redistributes EIGRP routes and sets the tags 


!--- according to the eigrp_to_rip route-map




route-map rip_to_eigrp deny 10
match tag 88

!--- Route-map statement to deny any routes that have a tag
 

!--- of "88" from being redistributed into EIGRP


!--- Notice the routes tagged with "88" should be the EIGRP routes
 

!--- that are redistributed into RIPv2


route-map rip_to_eigrp permit 20
set tag 77

!--- Route-map statement to set the tag on rip routes 


!--- redistributed into EIGRP to "77"


route-map eigrp_to_rip deny 10
match tag 77

!--- Route-map statement to deny any routes that have a tag 


!--- of "77" from being redistributed into RIPv2


!--- Notice the routes tagged with "77" should be the RIPv2 routes
 

!--- that are redistributed into EIGRP


route-map eigrp_to_rip permit 20
set tag 88

!--- Route-map statement to set the tag on EIGRP routes 


!--- redistributed into RIPv2 to "88"

Выполнив вышеуказанную конфигурацию, можно проверить некоторые конкретные маршруты в таблице маршрутизации, чтобы убедиться, что теги установлены. Ниже приведены выходные данные команды show ip route для определенных маршрутов в R3 и R1:

R3#show ip route 178.1.10.8
Routing entry for 178.1.10.8/30
  Known via "eigrp 7", distance 170, metric 2560512256
  Tag 77, type external
  Redistributing via eigrp 7
  Last update from 181.16.2.10 on Serial0, 00:07:22 ago
  Routing Descriptor Blocks:
  * 181.16.2.10, from 181.16.2.10, 00:07:22 ago, via Serial0
      Route metric is 2560512256, traffic share count is 1
      Total delay is 20010 microseconds, minimum bandwidth is 1 Kbit
      Reliability 1/255, minimum MTU 1 bytes
      Loading 1/255, Hops 1


R1#show ip route 181.16.2.4
Routing entry for 181.16.0.0/16
  Known via "rip", distance 120, metric 2
  Tag 88
  Redistributing via rip
  Last update from 178.1.10.5 on Serial0, 00:00:15 ago
  Routing Descriptor Blocks:
  * 178.1.10.5, from 178.1.10.5, 00:00:15 ago, via Serial0
      Route metric is 2, traffic share count is 1

EIGRP использует пять других переменных для вычисления метрики. Однако перераспределенные маршруты не имеют этих параметров, который заставляет маршруты не быть установленными однородно. Оптимальный метод должен установить Default-metric при перераспределении маршрутов. Путем установки метрики по умолчанию может быть улучшена производительность EIGRP. Для EIGRP значения по умолчанию введены с этой командой:

Router(config-router)#default-metric 10000 100 255 100 1500

Пример 3

Перераспределение производится также среди различных процессов одного протокола маршрутизации. Следующая конфигурация является примером использования политики перераспределения для перераспределения двух процессов EIGRP, выполняющихся на одном или нескольких маршрутизаторах:

router eigrp 3
 redistribute eigrp 5 route-map to_eigrp_3
 default-metric 10000 100 255 1 1500

!--- Redistributes EIGRP 5 into EIGRP 3, setting the tags 


!--- according to the route map "to_eigrp_3"



router eigrp 5
 redistribute eigrp 3 route-map to_eigrp_5
 default-metric 10000 100 255 1 1500

!--- Redistributes EIGRP 3 into EIGRP 5


!--- Routes with tag 33 will not be redistributed
 

!--- due to route map "to_eigrp_5"
!--- Though the default-metric command is not required
!--- when redistributing between different EIGRP processes,
!--- you can use it optionally as shown above to advertise 
!--- the routes with specific values for calculating the metric.


route-map to_eigrp_3 deny 10
match tag 55

!--- Route-map statement used to deny any routes that have a tag
 

!--- of "55" from being redistributed into EIGRP 3


!--- Notice the routes tagged with "55" should be the EIGRP 3 routes
 

!--- that are redistributed into EIGRP 5


route-map to_eigrp_3 permit 20
 set tag 33

!--- Route-map statement used to set the tag on routes
 

!--- redistributed from EIGRP 5 to EIGRP 3 to "33"


route-map to_eigrp_5 deny 10
 match tag 33

!--- Route-map statement used to deny any routes that have a tag 


!--- of "33" from being redistributed into EIGRP 5


!--- Notice the routes tagged with "33" should be the EIGRP 5 routes
 

!--- that are redistributed into EIGRP 3


route-map to_eigrp_5 permit 20
set tag 55

!--- Route-map statement used to set the tag on routes
 

!--- redistributed from EIGRP 3 to EIGRP 5 to "55"

Это всего несколько примеров фильтрования стратегий, используемых для намерения этого документа. Однако могли бы быть другие допустимые стратегии, которые можно использовать. Дополнительные сведения см. в разделе фильтрации информации о маршрутизации в документе Настройка независимых от протокола функций IP-маршрутизации.

Пример 4

Например, у вас есть два маршрутизатора, каждый - маршрутизатор высокого уровня рабочий протокол BGP, и другой является низкопроизводительным маршрутизатором рабочий протокол RIP. При перераспределении маршрутов BGP в RIP возможно, что вы видите, что некоторые пакеты становятся потерянными.

Перераспределение BGP в протокол RIP обычно не рекомендуется и протоколы как iBGP, OSPF, и EIGRP является масштабируемым и имеет широкие опции в наличии.

В случае, если вы встречаетесь с этим сценарием, который является перераспределением между BGP к RIP, и потеряйте некоторый packest, это возможный, что необходимо настроить эту команду на процессе RIP:

Router(config)#router rip

Маршрутизатор (маршрутизатор config) # input-queue 1024

Примечание: Рассмотрите использование команды input-queue, если у вас есть высокопроизводительный маршрутизатор, который передает в высокой скорости до низкоскоростного маршрутизатора, который не мог бы быть в состоянии получить в высокой скорости. Конфигурация этой команды помогает предотвращать потерю информации от таблицы маршрутизации.

Пример 5

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-d.gif

Данный пример иллюстрирует Статический маршрут Перераспределения в Протокол маршрутизации RIP. Согласно топологии, у нас есть три маршрутизатора (R1, R2 и R3). R1 и R2 настроили RIP на Ethernet интерфейса быстрого 0/0. R1 имеет статический маршрут для достижения Lo 0 интерфейсов (IP-адрес 3.3.3.3/32) Маршрутизатора R3. Этот статический маршрут перераспределен в Протоколе маршрутизации RIP. Маршрутизатор R3 настроен с маршрутом по умолчанию R3# ip route 0.0.0.0 0.0.0.0 FastEthernet 0/0.

R1(config)# ip route 3.3.3.3 255.255.255.255 10.13.13.3
R1(config)# router rip
R1(config-router) redistribute static metric 10

На Маршрутизаторе R2 маршрут 3.3.3.3 может быть замечен через команду show ip route:

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.12.12.0/24 is directly connected, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
R      3.3.3.3 [120/10] via 192.12.12.1, 00:00:07, FastEthernet0/0

Как перераспределить одиночный статический маршрут

Для перераспределения одиночного статического маршрута используйте route-map для выбора статического маршрута, который должен быть перераспределен.

Router(config)#access-list 1 permit <network no> <mask>

Router(config)#route-map <route-map name> permit 10
Router(config-route-map)#match ip address access list number

Router(config)#router eigrp <As number>

Router(config-router)#redistribute static route-map <map-name> metric <value>

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 8606