Протокол IP : Протокол BGP

Общие сведения о перераспределении маршрутов OSPF в BGP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (29 июля 2008) | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В данных технических примечаниях объясняется поведение протокола OSPF (первоочередное открытие кратчайших маршрутов) при перераспределении протокола BGP (пограничный межсетевой протокол) на маршрутизаторах Cisco. Поведение протокола OSPF по отношению к перераспределению BGP описывается в RFC 1403 . leavingcisco.com

Существует несколько типов маршрутов OSPF:

  • Внутриобластной. В многообластной сети OSPF маршруты, созданные в пределах определенной области, известны маршрутизаторам в той же области, в которой известны внутриобластные маршруты. Эти маршруты помечаются как O в выходных данных команды show ip route..

  • Межобластные. Если маршрут проходит через пограничный маршрутизатор области (ABR) OSPF, он известен как межобластной маршрут OSPF. Данные маршруты отмечаются как O IA в выходных данных команды show ip route.

    Как внутриобластные, так и межобластные маршруты также известны как внутренние маршруты OSPF, поскольку они создаются непосредственно протоколом OSPF, если на интерфейс распространяется команда OSPF network.

  • Внешние маршруты типа 2 или внешние маршруты типа 1. Маршруты, которые были перераспределены в OSPF, например протокол подключенных, статических или иных маршрутов, известны как внешние маршруты типа 2 или внешние маршруты типа 1. Данные маршруты отмечаются как O E2 или O E1 в выходных данных команды show ip route.

  • Внешний маршрут NSSA типа 2 или внешний маршрут NSSA типа 1. Если область настроена как не полностью шлейфная область (NSSA), и маршруты перераспределяются в OSPF, маршруты получают обозначение внешних маршрутов NSSA типа 2 или внешних маршрутов NSSA типа 1. Данные маршруты отмечаются в качестве O N2 или O N1 в выходных данных команды show ip route.

    В данном документе не описываются различия между внешним маршрутом и маршрутом NSSA типа 2 или 1. Для получения дополнительных сведений см. Руководство по проектированию OSPF.

Поведение по умолчанию не предусматривает перераспределение маршрутов из OSPF в BGP. Перераспределение необходимо настроить. Используйте команду route-map для фильтрации маршрутов во время перераспределения OSPF в BGP. При перераспределении требуются специальные ключевые слова, такие как internal, external и nssa-external, для перераспределения соответствующих маршрутов.

Предварительные условия

Требования

Для работы с данным документом необходимы основные знания типов маршрутов OSPF.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка сети

Ниже описываются четыре случая перераспределения маршрутов OSPF в BGP. Схема сети относится к первым трем случаям. Схему и настройку для четвертого случая можно найти в разделе Перераспределение внешних маршрутов OSPF NSSA в BGP.

/image/gif/paws/5242/bgp-ospf-redis1.jpg

Перераспределение только внутренних (Intra- и Inter-Area) маршрутов OSPF в BGP

При настройке перераспределения OSPF в BGP без ключевых слов только внутри-областной OSPF и межобластные маршруты перераспределен в BGP по умолчанию. Используйте ключевое слово internal наряду с командой redistribute в router bgp для перераспределения внутриобластных и межобластных маршрутов OSPF.

Данная конфигурация является новой конфигурацией маршрутизатора B, который перераспределяет только внутриобластной маршрут (131.108.2.0/24) и межобластной маршрут (131.108.1.0/24) в BGP, а также только внутренние маршруты OSPF (внутриобластные и межобластные) в BGP:

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.3 255.255.255.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1


!-- This redistributes only OSPF intra- and inter-area routes into BGP.


 neighbor 3.3.3.2 remote-as 200
!
end

RTB# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Ethernet0/0
C    3.0.0.0/8 is directly connected, Serial1/0
O E2 200.1.1.0/24 [110/20] via 2.2.2.2, 00:16:17, Ethernet0/0
O E1 200.2.2.0/24 [110/104] via 2.2.2.2, 00:00:41, Ethernet0/0
     131.108.0.0/24 is subnetted, 2 subnets
O       131.108.2.0 [110/74] via 2.2.2.2, 00:16:17, Ethernet0/0
O IA    131.108.1.0 [110/84] via 2.2.2.2, 00:16:17, Ethernet0/0
RTB#

Маршрутизатор B перераспределяет только внутренние маршруты OSPF:

RTB# show ip bgp
BGP table version is 10, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       0.0.0.0                  0         32768 ?
*> 131.108.1.0/24   2.2.2.2                 84         32768 ?
*> 131.108.2.0/24   2.2.2.2                 74         32768 ?
RTB#

Маршрутизатор C получает информацию о данных маршрутах от BGP:

RTC# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 3.3.3.1, 00:11:19
C    3.0.0.0/8 is directly connected, Serial0/0
     131.108.0.0/24 is subnetted, 2 subnets
B       131.108.2.0 [20/74] via 3.3.3.1, 00:03:56
B       131.108.1.0 [20/84] via 3.3.3.1, 00:03:28
RTC#

Перераспределение только внешних (тип 1 и 2) маршрутов OSPF на BGP

Используйте ключевое слово external наряду с командой redistribute в router bgp для перераспределения внешних маршрутов OSPF в BGP. При использовании ключевого слова external имеется три варианта:

  • перераспределение как внешних маршрутов типа 1, так и внешних маршрутов типа 2 (по умолчанию)

  • перераспределение маршрутов типа 1

  • перераспределение маршрутов типа 2

Введите команды в режиме конфигурации в соответствии с тем, как описано ниже:

RTB(config-router)# router bgp 100
RTB(config-router)# redistribute ospf 1 match external

В данной конфигурации маршрутизатора B происходит перераспределение только внешних маршрутов OSPF но как типа 1, так и типа 2:

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1 match external 1 external 2


!--- This redistributes ONLY OSPF External routes, 
!--- but both type-1 and type-2.


 neighbor 3.3.3.3 remote-as 200
!
end

Примечание: Конфигурация показывает соответствие, которым были внешний 1 внешний 2 и введенная команда, перераспределяют внешнее соответствие ospf 1. Это нормально, так как OSPF автоматически добавляет "external 1 external 2" в конфигурацию. Данная команда подходит как к внешнему, так и к внутреннему маршруту OSPF типов 1 и 2, и перераспределяет оба маршрута в BGP.

Маршрутизатор B перераспределяет только внешние маршруты OSPF:

RTB# show ip bgp
BGP table version is 21, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.1.1.0        2.2.2.2                 20         32768 ?
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

Маршрутизатор C получает информацию об этих двух внешних маршрутах OSPF от BGP:

RTC# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

B    200.1.1.0/24 [20/20] via 3.3.3.1, 00:01:43
B    200.2.2.0/24 [20/0] via 3.3.3.1, 00:01:43
C    3.0.0.0/8 is directly connected, Serial0/0

Перераспределение только внешних маршрутов OSPF типа 1 или типа 2 в BGP

Введите эту команду в router bgp 100 на маршрутизаторе B для перераспределения только внешних маршрутов OSPF 1:

router bgp 100
 redistribute ospf 1 match external 1

На таблице BGP маршрутизатора B указывается, что маршрутизатор перераспределяет только внешние маршруты 1 в BGP; остальные маршруты OSPF в BGP не перераспределяются:

RTB# show ip bgp
BGP table version is 24, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

Таким же образом введите данную команду в router bgp 100 на маршрутизаторе B для перераспределения только внешних маршрутов OSPF 2:

router bgp 100
 redistribute ospf 1 match external 2

Перераспределение внутренних и внешних маршрутов OSPF в BGP

В данном случае все маршруты OSPF перераспределяются в BGP с помощью ключевых слов internal и external, как показано в конфигурации маршрутизатора B:

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1 match internal external 1 external 2


!--- This redistributes all OSPF routes into BGP.


 neighbor 3.3.3.3 remote-as 200
!
end

Команда external также заменяется командой external 1 external 2 в конфигурации. Это нормально, если только не указаны определенные внешние маршруты, которые необходимо перераспределить в BGP. После изменения конфигурации маршрутизатор B перераспределяет все маршруты OSPF, а маршрутизатор C начинает получать информацию о всех маршрутах от BGP:

RTB# show ip bgp
BGP table version is 30, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       0.0.0.0                  0         32768 ?
*> 131.108.1.0/24   2.2.2.2                 84         32768 ?
*> 131.108.2.0/24   2.2.2.2                 74         32768 ?
*> 200.1.1.0        2.2.2.2                 20         32768 ?
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

RTC# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 3.3.3.1, 00:01:24
C    3.0.0.0/8 is directly connected, Serial0/0
B    200.1.1.0/24 [20/20] via 3.3.3.1, 00:01:24
B    200.2.2.0/24 [20/104] via 3.3.3.1, 00:01:24
     131.108.0.0/24 is subnetted, 2 subnets
B       131.108.2.0 [20/74] via 3.3.3.1, 00:01:24
B       131.108.1.0 [20/84] via 3.3.3.1, 00:01:24
RTC#

Перераспределение внешних маршрутов областей NSSA OSPF в BGP

Это особый случай, в котором происходит перераспределение только маршрутов не полностью шлейфной области (NSSA) в BGP. Данный случай аналогичен случаю, описанному в разделе Перераспределение только внешних маршрутов OSPF (тип 1 и 2) в BGP. Единственное отличие состоит в том, что BGP сопоставляет внешние маршруты NSSA, а не только внешние маршруты. В таблице маршрутизатора B показаны эти внешние маршруты OSPF NSSA:

RTB# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O N2 200.1.1.0/24 [110/20] via 2.2.2.1, 00:22:53, Ethernet0
O N1 200.2.2.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
O IA 131.108.1.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
O 131.108.2.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
C    2.0.0.0/8 is directly connected, Ethernet0
C    3.0.0.0/8 is directly connected, Serial1

Для данного случая применяется следующая схема сети:

/image/gif/paws/5242/bgp-ospf-redis2.jpg

На схеме сети показано, что маршрутизатор В получает как маршруты OSPF N1, так и маршруты N2. Поведение по умолчанию предусматривает перераспределение как маршрутов N1, так и маршрутов N2 при использовании ключевого слова nssa-external. Данная конфигурация маршрутизатора B позволяет перераспределять маршруты OSPF N1 (200.1.1.0/24) и OSPF N2 (200.2.2.0/24) в BGP:

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1 
nssa

!
router bgp 100
 redistribute ospf 1 match nssa-external 1 nssa-external 2


!--- This redistributes only OSPF NSSA-external routes 
!--- Type-1 and Type-2 into BGP.


 neighbor 3.3.3.3 remote-as 200
!
end

Примечание: Как внешняя настройка OSPF, вышеупомянутый nssa-external 1 nssa-external 2 соответствия показов конфигурации и введенная команда был, перераспределяют nssa-external соответствия ospf 1. Это нормально, так как OSPF автоматически добавляет "nssa-external 1 nssa-external 2" в конфигурацию. Данная команда подходит как к маршруту OSPF N1, так и к маршруту OSPF N2, и перераспределяет оба маршрута в BGP.

После изменения конфигурации на маршрутизаторе B этот маршрутизатор перераспределяет внешние маршруты OSPF NSSA, а маршрутизатор C начинает получать информацию о внешних маршрутах OSPF NSSA от BGP:

RTB# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Ethernet0/0
C    3.0.0.0/8 is directly connected, Serial1/0
O N2 200.1.1.0/24 [110/94] via 2.2.2.1, 00:11:12, Ethernet0/0
O N1 200.2.2.0/24 [110/20] via 2.2.2.2, 00:12:23, Ethernet0/0
     131.108.0.0/24 is subnetted, 2 subnets
O       131.108.2.0 [110/74] via 2.2.2.2, 00:12:23, Ethernet0/0
O IA    131.108.1.0 [110/84] via 2.2.2.2, 00:12:11, Ethernet0/0
RTB#

RTB# show ip bgp 
BGP table version is 21, local router ID is 3.3.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.1.1.0        2.2.2.2                 94         32768 ?
*> 200.2.2.0        2.2.2.1                 20         32768 ?
RTB#

RTC# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    3.0.0.0/8 is directly connected, Serial0/0
B    200.1.1.0/24 [20/94] via 3.3.3.1, 00:02:06
B    200.2.2.0/24 [20/20] via 3.3.3.1, 00:02:06
RTC#

Так же, как и при работе с внешними маршрутами OSPF, для перераспределения только маршрутов OSPF N1 введите следующую команду в router BGP 100 на маршрутизаторе B:

router bgp 100
 redistribute ospf 1 match nssa-external 1

!--- This redistributes only OSPF NSSA-external 
!--- Type-1 routes into BGP.

Для перераспределения только маршрутов OSPF N2 введите следующую команду в router BGP 100 на маршрутизаторе B:

router bgp 100
 redistribute ospf 1 match nssa-external 2

!--- This redistributes only OSPF NSSA-external 
!--- Type-2 routes into BGP.

Примечание: Route-map могут также использоваться для перераспределения Типа OSPF 1/2 в BGP. Отнеситесь для Перераспределения Маршрутов OSPF E2 в BGP для получения дополнительной информации.

Изменение параметров перераспределения в OSPF

Важно понимать, каким образом последовательное изменение конфигурации может повлиять на конфигурацию. Новая команда с параметром сопоставления не заменяет прежнюю команду, но добавляется к ней.. В данном примере команды конфигурации показано воздействие команды на перераспределение:

R4# conf t
R4(config)# router bgp 100
R4(config-router)# redistribute ospf 1 match internal
R4(config-router)# ^Z

!--- Initially, we redistribute internal OSPF routes into BGP 100.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal
R4# conf t
R4(config)# router bgp 100
R4(config-router)# redistribute ospf 1 match external
R4(config-router)# ^Z

!--- With this second command, we tell BGP 
!--- to also redistribute external OSPF routes.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal external 1 external 2
R4#
R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 match external 2
R4(config-router)# ^Z

!--- With this no command, we only disable the 
!--- redistribution of external type 2 into BGP. 
!--- All other types of routes previously configured remain.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal external 1
 
!--- As you can see, internal and external type 1 remain.

R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 match internal external 1
R4(config-router)# ^Z 

!--- Now, with this no command, which includes all configured 
!--- keywords, it is important to note that we 
!--- still do not disable the redistribution fully.
!--- We only removed the keyword. After this, 
!--- the IOS still acts as default—redistributing
!--- internal routes only.


R4# sh run | i redistribute ospf
 redistribute ospf 1
R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 

!--- Always use this command in order to completely
!--- disable redistribution.

R4(config-router)# ^Z
R4# sh run | i redistribute ospf
R4#

Невозможность перераспределения известных маршрутов iBGP в IGP, например EIGRP, OSPF

Перераспределение маршрутов используется для передачи маршрутов, изученных с помощью одного протокола, в другой протокол маршрутизации. Если BGP перераспределяется в IGP, происходит перераспределение только изученных маршрутов eBGP. Изученные маршруты iBGP, известные на маршрутизаторе, не вводятся в IGP в целях предотвращения образования петель маршрутизации.

По умолчанию повторная передача iBGP в IGP отключена. Задайте команду bgp redistribute-internal, чтобы включить повторную передачу маршрутов iBGP в IGP. При перераспределении конкретных маршрутов в IGP с использованием карт маршрутов должны быть приняты меры предосторожности.

Ниже приведен пример конфигурации перераспределения маршрутов iBGP в OSPF:

router bgp 65345 
bgp redistribute-internal
!
router ospf 100
redistribute bgp 65345 subnets

Примечание: Перераспределение маршрутов внутреннего протокола граничного шлюза (iBGP) в Протокол внутреннего шлюза может вызвать циклы маршрутизации в Автономной системе (AS). Выполнение данного действия не рекомендуется. Для контроля данных, импортируемых в IGP, необходимо настроить фильтры маршрутизации.

Перераспределите маршруты настроек протокола OSPF по умолчанию в к BGP

Для перераспределения маршрутов по умолчанию в к BGP используйте инструкцию сети, и default-information происходит. В нашем примере маршруты Настроек протокола OSPF по умолчанию перераспределены в к BGP. Это сделано с созданием route-map и распределением сети по умолчанию, которая разрешена стандартным ACL.

!
route-map map_default_only permit 10

 match ip address acl_default_only

!

ip access-list standard acl_default_only

 permit 0.0.0.0

!

router bgp 64601

network 0.0.0.0

 redistribute ospf 1 route-map map_default_only

 default-information originate

!--- distributes the default route in bgp

!

После конфигурации очистите сеансы BGP с командой clear ip bgp *.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 5242