Голосовая связь и система унифицированных коммуникаций : Cisco Unified Border Element

Пример конфигурации перекодирования Unified Border Element

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Cisco Unified Border Element (CUBE) поддерживает перекодировку для вызовов, которые проходят и которые требуют других кодеков на этих двух ветвях вызовов. Перекодировка между различными кодеками поддерживается, и CUBE вставляет перекодировщик на основе конфигурации, а также несоответствия между кодеками, о которых выполняют согласование относительно двух ветвей вызовов вызовов.

Перекодировка требует, чтобы DSP завершили поток RTP и декодировали и закодировали речевые данные с соответствующим кодеком. DSP, используемые CUBE для перекодировки, могут быть или совместно расположены на том же маршрутизатор как CUBE или могут быть расположены на платформе отдельного маршрутизатора.

Предварительные условия

Требования

Рассматриваемая процедура настройки предполагает выполнение следующих условий:

Используемые компоненты

Информация в данном документе основана на следующих положениях:

  • Cisco Unified Border Element, который работает на маршрутизаторе Cisco 3745 и использует Cisco IOS Release 12.3.11T или позже

  • Ресурсы DSP перекодировки на сервере доступа Cisco AS5400XM с функциональной картой AS5X-FC, заполненной с платами DSP AS5X-PVDM2-64

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

Эти данные показывают пример CUBE с внешними DSP для перекодировки:

/image/gif/paws/100480/cube_transcode.gif

Ресурсы DSP могут также быть внутренними к (или совместно расположенными из), платформа того жя маршрутизатор, которая размещает CUBE. Если это верно, контроль ресурсов DSP локален для маршрутизатора, и поток управления SCCP на рисунке не присутствует.

Ресурсы DSP, что использование CUBE для перекодировки должно быть настроено независимо от того, совместно расположены ли DSP с CUBE. Единственной разницей в конфигурациях является IP-адресация между CUBE и ресурсами DSP. Для совместно расположенной конфигурации IP-адрес является тем же для обоих.

Порядок действий для настройки

В этом разделе описывается настроить внешнюю перекодировку DSP. Маршрутизатор Cisco 3745 используется в качестве CUBE, и AS5400XM используется для хостинга ресурсов DSP для перекодировки.

Конфигурация применяется к этому потоку вызовов:

  1. Вызов запускается с OGW к CUBE через H.323 с G.711.

  2. CUBE переводит вызов через H.323 к OGW (который настроен для G.729).

  3. Для настройки вызова к TGW, чтобы быть успешным, преобразование кодека требуется от G.711 до G.729. Если ресурсы перекодировки не настроены или не доступны, сбои настройки вызова.

Конфигурация CUBE для внешнего контроля за перекодировкой

Маршрутизатор CUBE настроен для управления ресурсами DSP для перекодировки. Эта конфигурация использует команду telephony-service, которая подобна конфигурации перекодировки для Cisco Unified Communication Manager Express. Ресурсы DSP регистрируются в объекте управления (который в данном примере является CUBE, но мог также быть CUCME или CUCM).

3745 CUBE
vdouut3#show running-config | begin telephony
!
telephony-service
sdspfarm units 1 -- Specifies the maximum number of DSP farms that can
                    be registered to CUBE. A maximum of 5 DSP resource units
                    (farms) can be configured.
sdspfarm transcode sessions 128 -- Specifies the maximum transcoding
                    sessions supported across all DSP farms registered
                    with CUBE.
sdspfarm tag 1 vdouut1 -- Specifies the device name of the DSP farm. For
                    uniqueness the device name can be the MAC address of the 
                    DSP source interface. In this example the hostname of
                    the DSP farm router is used.
ip source-address 1.2.61.73 port 2000 – The IP address and port-no: (TCP)
                    of the interface through which SCCP messages are
                    transmitted/received from CUBE.

Конфигурация цифрового процессора DSP Farm для хостинга внешних ресурсов DSP перекодировки

Маршрутизатор настроен для хостинга ресурсов DSP для перекодировки, используемой объектом управления, который в данном примере является CUBE на другом маршрутизаторе. Ресурсы DSP зарегистрированы в объекте управления для предоставления доступа к ним доступными для диаграмм вызовов.

Цифровой процессор DSP Farm
vdouut1#show running-config | begin voice-card
voice-card 1
  dsp services dspfarm –- This makes the DSPs available for “DSP farming”
                    which includes transcoding services.

vdouut1#show running-config | begin sccp
sccp local GigabitEthernet0/0 -- Defines the source interface of the DSP
                    farm through which SCCP messages are exchanged with
                    controlling CUBE.               
sccp ccm 1.2.61.73 identifier 1 -- Specifies the IP address of the CUBE
                    system that the DSP farm registers to. This should
                    match the CUBE IP address on the “ip source-address”
                    configuration on CUBE.
sccp
sccp ccm group 1 -- Group configuration for linking “sccp ccm global”
                    configurations as well as the dspfarm profile(s)
  bind interface GigabitEthernet0/0
associate ccm 1 priority 1 -- Associate the sccp identifier “ccm” with
                  the “sccp ccm group”.
associate profile 1 register vdouut1 -- Associate the dspfarm profile 
                  with the DSP farm device name. In this example the 
                  hostname of the DSP farm hosted router is used
                  (vdouut1). The same name must be used on CUBE where
                  “sdspfarm tag 1” is configured.
!
dspfarm profile 1 transcode -- Configure the dspfarm profile to define
                     the codecs supported, the maximum sessions, and
                     enable SCCP.
  codec g711ulaw
  codec g711alaw
  codec g729ar8
  codec g729abr8
  codec g729r8
  codec g729br8
  maximum sessions 128
  associate application SCCP

Полные примеры конфигурации для внутренней перекодировки

Этот раздел предоставляет пример полной конфигурации для настройки, где то же маршрутизатор (AS5400XM) настроено и для хостинга CUBE и ресурсов DSP для перекодировки. Существенные части конфигурации aredisplayed полужирным текст.

Различия между этой настройкой конфигурации и Конфигурацией Цифрового процессора DSP Farm для Хостинга Внешних Ресурсов DSP Перекодировки следующие:

  • Фактические ресурсы DSP (“голосовая карта x”> “dsp services dspfarm”) и объект управления (“telephony-service”) появляются на том же маршрутизатор.

  • IP-адрес ресурсов DSP (“sccp ccm 9.13.29.30 идентификаторов 1”) и IP-адрес объекта управления (“telephony-service”> “IP source-address 9.13.29.30 портов”) являются тем же.

5400XM
5400XM#show run
Building configuration...

Current configuration : 3149 bytes
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 5400XM
!
boot-start-marker
no boot startup-test
boot-end-marker
!
logging buffered 100000000 debugging
no logging console
enable secret 5 $1$g301$4BVklIIq97tihABYS6Guy/
enable password xxx
!
resource-pool disable
no aaa new-model
!
resource policy
!
voice-card 1
 dsp services dspfarm
!
voice-card 5
!
ip cef
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 h323
 modem passthrough none codec g729r8 pre-ietf
!
controller T1 5/0
 framing sf
 linecode ami
!
controller T1 5/1
 framing sf
 linecode ami
!
controller T1 5/2
 framing sf
 linecode ami
!
controller T1 5/3
 framing sf
 linecode ami
!
controller T1 5/4
 framing sf
 linecode ami
!
controller T1 5/5
 framing sf
 linecode ami
!
controller T1 5/6
 framing sf
 linecode ami
!
controller T1 5/7
 framing sf
 linecode ami
!
interface GigabitEthernet0/0
 ip address 9.13.29.30 255.255.255.0
 duplex auto
 speed auto
 negotiation auto
 no cdp enable
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 negotiation auto
 no cdp enable
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
 no fair-queue
!
interface Serial5/0
 no ip address
 shutdown
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
 no cdp enable
!
ip route 0.0.0.0 0.0.0.0 9.13.29.1
!
no ip http server
!
dialer-list 1 protocol ip permit
!
sccp local GigabitEthernet0/0
sccp ccm 9.13.29.30 identifier 1 version 4.0 -- Use its own IP address
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 1 register XCODE123456
 keepalive retries 1
 keepalive timeout 10
 switchover method immediate
 switchback method immediate
!
dspfarm profile 1 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec gsmfr
 codec g729r8
 codec g729br8
 maximum sessions 10
 associate application SCCP
!
dial-peer voice 1 voip
 destination-pattern 630222100.
 session protocol sipv2
 session target ipv4:9.13.29.22
 dtmf-relay rtp-nte digit-drop
 codec g711ulaw
!
dial-peer voice 2 voip
 session protocol sipv2
 incoming called-number 630222100.
 codec g729br8 bytes 10
!
dial-peer voice 3 voip
 destination-pattern 2000
 session protocol sipv2
 session target ipv4:9.13.29.22
 dtmf-relay rtp-nte digit-drop
!
dial-peer voice 4 voip
 session protocol sipv2
 incoming called-number 2000
 codec g711ulaw
!
gatekeeper
 shutdown
!
telephony-service
 max-ephones 1
 max-dn 1
 ip source-address 9.13.29.30 port 2000 --> Use its own IP address
 sdspfarm units 1
 sdspfarm transcode sessions 10
 sdspfarm tag 1 XCODE123456
 ss7 mtp2-variant Bellcore 0
 ss7 mtp2-variant Bellcore 1
 ss7 mtp2-variant Bellcore 2
 ss7 mtp2-variant Bellcore 3
 !
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password cisco
 login
!
scheduler allocate 10000 400
no process cpu extended
no process cpu autoprofile hog
end

Проверка.

Выходные данные в этом разделе принадлежат настройке конфигурации для внешней перекодировки.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

CUBE

Имя устройства, с которым Цифровой процессор DSP Farm зарегистрирован в CUBE и IP-адресе узлового маршрутизатора Цифрового процессора DSP Farm, отображено полужирным текст.

vdouut3#show sdspfarm units
Load for five secs: 0%/0%; one minute: 0%; five minutes: 3%
Time source is NTP, 23:46:40.649 PST Tue Nov 21 2006


mtp-1 Device:vdouut1 TCP socket:[1] REGISTERED
actual_stream:256 max_stream 256 IP:1.2.61.71  27519  MTP YOKO keepalive 45  
Supported codec:
                 G711Ulaw
                 G711Alaw
                 G729
                 G729a
                 G729b
                 G729ab
 max-mtps:1, max-streams:256, alloc-streams:256, act-streams:0

Эти выходные данные показывают настройку конфигурации CUBE.

vdouut3#show telephony-service
ip source-address 1.2.61.73 port 2000
max-ephones 128
max-dn 1
max-conferences 8 gain -6
dspfarm units 1
dspfarm transcode sessions 128
dspfarm 1 vdouut1

Эти выходные данные показывают, что после того, как вызов выполнен кодеки (отображенный полужирным текст), которые используются для ветвей вызовов через CUBE.

vdouut3#show sdspfarm sessions active 
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 23:52:43.922 PST Tue Nov 21 2006

Stream-ID:37 mtp:1 1.2.61.71  20190  Local:2000 START  
 usage: Ip-Ip                        
 codec:G729  duration:20 vad:0 peer Stream-ID:38 

Stream-ID:38 mtp:1 1.2.61.71  21326  Local:2000 START  
 usage: Ip-Ip                        
 codec:G711Ulaw64k  duration:20 vad:0 peer Stream-ID:37

Эти выходные данные показывают сеансы, активные между OGW и TGW через CUBE.

vdouut3#show voip rtp connections     
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 23:54:22.722 PST Tue Nov 21 2006
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
1   3991       3992       18496    17430  1.2.61.73       1.2.61.48      
2   3992       3991       17382    19706  1.2.61.73       1.2.61.68      
Found 2 active RTP connections

Эти выходные данные показывают компактную сводку активных сеансов и кодеков (отображенный полужирным текст) используемый ветвями вызовов.

vdouut3#show call active voice compact 
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 02:31:58.156 PST Wed Nov 22 2006
 <callID>  A/O FAX T<sec> Codec     type  Peer Address  IP R<ip>:<udp>
Total call-legs: 2
      4023 ANS     T25    g711ulaw  VOIP  P5200         1.2.61.48:16934
      4024 ORG     T25    g729r8    VOIP  P6200         1.2.61.68:17040

Хост цифрового процессора DSP Farm

Эти выходные данные показывают статус состояния регистрации ресурсов DSP. Существенная информация появляется полужирным текст.

vdouut1#show sccp
SCCP Admin State: UP
Gateway IP Address: 1.2.61.71, Port Number: 2000
IP Precedence: 5
User Masked Codec list: None
Call Manager: 1.2.61.73, Port Number: 2000
                Priority: N/A, Version: 3.1, Identifier: 1

Transcoding Oper State: ACTIVE - Cause Code: NONE
Active Call Manager: 1.2.61.73, Port Number: 2000
TCP Link Status: CONNECTED, Profile Identifier: 1
Reported Max Streams: 256, Reported Max OOS Streams: 0
Supported Codec: g711ulaw, Maximum Packetization Period: 30
Supported Codec: g711alaw, Maximum Packetization Period: 30
Supported Codec: g729ar8, Maximum Packetization Period: 60
Supported Codec: g729abr8, Maximum Packetization Period: 60
Supported Codec: g729r8, Maximum Packetization Period: 60
Supported Codec: g729br8, Maximum Packetization Period: 60
Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30
Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30
Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization Period: 30

Эти выходные данные показывают конфигурацию ресурсов DSP (в то время как простаивающий).

vdouut1#show dspfarm all
Dspfarm Profile Configuration

 Profile ID = 1, Service = TRANSCODING, Resource ID = 1  
 Profile Description :  
 Profile Admin State : UP 
 Profile Operation State : ACTIVE 
 Application : SCCP   Status : ASSOCIATED 
 Resource Provider : FLEX_DSPRM   Status : UP 
 Number of Resource Configured : 128 
 Number of Resource Available : 128
 Codec Configuration 
 Codec : g711ulaw, Maximum Packetization Period : 30 
Codec : g711alaw, Maximum Packetization Period : 30 
 Codec : g729ar8, Maximum Packetization Period : 60 
 Codec : g729abr8, Maximum Packetization Period : 60 
 Codec : g729r8, Maximum Packetization Period : 60 
 Codec : g729br8, Maximum Packetization Period : 60


SLOT DSP VERSION  STATUS CHNL USE   TYPE   RSC_ID BRIDGE_ID PKTS_TXED PKTS_RXED

1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -        
1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -        
1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -  

Эти выходные данные показывают статус ресурсов DSP (после того, как вызов будет выполнен).

vdouut1#show sccp connections summary 
  SCCP Application Service(s) Statistics Summary:
  Total Conferencing Sessions: 0, Connections: 0
  Total Transcoding Sessions: 1, Connections: 2
  Total MTP Sessions: 0, Connections: 0
  Total ALG-Phone Sessions: 0, Connections: 0
  Total BRI-Phone Sessions: 0, Connections: 0
  Total SCCP Sessions: 1, Connections: 2

vdouut1#show dspfarm dsp active 
SLOT DSP VERSION  STATUS CHNL USE   TYPE   RSC_ID BRIDGE_ID PKTS_TXED PKTS_RXED

1    1   9.2.1    UP     1    USED  xcode  1      15        9400      9405     
1    1   9.2.1    UP     1    USED  xcode  1      16        9400      9394     

Total number of DSPFARM DSP channel(s) 1

Эти выходные данные показывают сеансы RTP между ресурсами DSP (этот маршрутизатор) и объект управления (CUBE). Две ветви вызова VoIP с другими кодеками показывают. Участки оба установлены с CUBE (1.2.61.73).

vdouut1#show voip rtp connections 
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
1   46         47         17668    2000   1.2.61.71       1.2.61.73      
2   48         47         21530    2000   1.2.61.71       1.2.61.73      
Found 2 active RTP connections

vdouut1#show call active voice compact 
 <callID>  A/O FAX T<sec> Codec     type   Peer Address  IP R<ip>:<udp>
Total call-legs: 2
        46 ORG     T150   g711ulaw  VOIP   P             1.2.61.73:2000 
        48 ORG     T150   g729r8    VOIP   P             1.2.61.73:2000

Устранение неполадок

Вот некоторые полезные команды устранения проблем для перекодировки:

  • сообщения debug sccp

  • ephone отладки mtp

  • debug ephone state

Примечание: Прежде чем выполнять какие-либо команды отладки , ознакомьтесь с документом "Важные сведения о командах отладки".

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 100480