Голосовая связь и система унифицированных коммуникаций : Cisco Unified Communications Manager Express

CISCO UNIFIED COMMUNICATIONS MANAGER EXPRESS: Руководство по внедрению SIP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

Этот документ предоставляет пошаговые инструкции для того, чтобы установить автономный Cisco Unified Communications Manager Express (CME), который использует SIP-телефоны. Документ выделяет систему Cisco Unified Communications Manager Express с четырьмя SIP-телефонами с конфигурациями для того, чтобы установить систему Cisco Unified Communications Manager Express и SIP-телефоны.

Примечание: Хотя действия настройки документа охватывает, чтобы позволить Cisco Unified Communications Manager Express взаимодействовать с Cisco Unity Express, конфигурация Cisco Unity Express за пределами области этой бумаги. Обратитесь к Примеру конфигурации Cisco CallManager Express/Cisco Unity Express для получения дополнительной информации о конфигурациях Cisco Unity Express и Cisco Unified Communications Manager Express.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, относятся к следующим версиям оборудования:

  • Cisco 2801, который выполняет Cisco Unified Communications Manager Express 4.2 с Cisco Выпуск ПО IOS� 12.4 (11) XW2

  • Двойные ширины с 9 портами 10/100BASE-T HWIC Коммутатора Ethernet

  • SIP-телефоны Cisco 7970

  • SIP-телефон Cisco 3911

Сведения в этом документе основываются на этих версиях микропрограммы:

  • 7970 IP-телефонов (SIP) — SIP70.8-2-1S

  • 3911 IP-телефонов (SIP) — SIP3951.8-0-2-9

Обратитесь к Cisco Унифицированный CME и Матрицу совместимости версии программного обеспечения Cisco IOS для определения соответствующего микропрограммного обеспечения SIP для использования для каждой версии Cisco Unified Communications Manager Express. Так как Cisco Unified Communications Manager Express 4.2 используется, обратитесь к Cisco Unified Communications Manager Express 4.2 ссылки Спецификаций.

SIP phoneloads может быть загружен от этих местоположений:

После разархивации обоих Файлы архива zip в папке TFTP скопируйте все файлы микропрограммного обеспечения на флэш-память Cisco Unified Communications Manager Express с TFTP server. Удостоверьтесь, что вы копируете все эти файлы на флэш-память.

SIP3951.8-0-2-9.loads
SIP3951.8-0-2-9.zz
DSP3951.0-0-0-1.zz
BOOT3951.0-0-0-9.zz
SIP70.8-2-1S.loads
term70.default.loads
term71.default.loads
apps70.8-0-2-55.sbn
cnu70.8-2-0-55.sbn 
cvm70.sip.8-2-0-55.sbn
dsp70.8-2-0-55.sbn
jar70.sip.8-0-2-25.sbn

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Эти таблицы выделяют схемы адресации, которые используются в этой настройке.

Цель Сети VLAN Сеть Интерфейс Интерфейсный адрес
Речь 192 192.168.10.0/24 VLAN 192 192.168.10.1/24
Данные 100 10.10.10.0/24 VLAN 100 10.10.10.1/24

Протокол Тип телефона Добавочный номер Номер телефона внешняя маска
SIP 7970 101 4085251001
SIP 7970 102 4085251002
SIP 3911 103 4085251003
SIP 3911 104 4085251004

Voice Mail Pilot Number (Сервисный номер голосовой почты) 100 Пилот AA 110
MWI включен 800 MWI Выкл 801

Примечание: Используйте для получения дополнительных сведений о командах, используемых в этом разделе.

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/99946/cme-sip-guide01.gif

Конфигурации системы

Эти конфигурации используются в данном документе:

Настройте DHCP

Необходимо настроить два отдельных пула DHCP; IP-телефоны используют Речевой пул DHCP, и PC используют пул DHCP Данных. IP-телефоны должны использовать параметр DHCP 150 для обеспечения IP-адреса TFTP Server.

Если существуют какие-либо устройства в любом пуле со статическими IP - адресами, удостоверьтесь, что эти адреса исключены из пула DHCP во избежание адресации к конфликтам. Можно использовать команду show ip dhcp binding для подтверждения, какие адреса IP-телефоны и PC получают от маршрутизатора.

Конфигурация DHCP
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool data
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1 
!
ip dhcp pool voice
   network 192.168.10.0 255.255.255.0
   option 150 ip 192.168.10.1
   default-router 192.168.10.1

Настройте FastEthernet Interface и Switchports

В этом разделе вы настраиваете интерфейсы виртуальной локальной сети (VLAN) и для Данных и для Голосового VLAN и назначаете switchports в их соответствующие виртуальные локальные сети (VLAN).

Примечание: До конфигурации VLAN, убедиться добавить предыдущие VLAN к базе данных VLAN с этими командами:

Интерфейс Fast Ethernet и конфигурация порта коммутатора
CME-SIP#vlan database
% Warning: It is recommended to configure VLAN from config mode,
 as VLAN database mode is being deprecated. Please consult user
  documentation for configuring VTP/VLAN in config mode.

CME-SIP(vlan)#vlan 100
VLAN 100 modified:
CME-SIP(vlan)#vlan 192
VLAN 192 modified:
CME-SIP(vlan)#exit
APPLY completed.
Exiting....
CME-SIP#

Настройте switchports, который будет связан с обоими сети VLAN для передачи голоса и данных. IP-телефоны автоматически назначены в Голосовой VLAN и PC, связанные или с switchport непосредственно, или соединились с switchport на IP-телефоне, который назначен на VLAN ДЛЯ ПЕРЕДАЧИ ДАННЫХ.

Конфигурация DHCP
interface FastEthernet0/3/0
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/1
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
! 
 interface FastEthernet0/3/2
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/3
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
! !
interface Vlan100
description Data VLAN
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan192
description Voice VLAN
 ip address 192.168.10.1 255.255.255.0

Настройте TFTP

Эта конфигурация позволяет Cisco Unified Communications Manager Express служить IP-телефонам их микропрограммное обеспечение.

Примечание: Эта конфигурация является обязательной.

Настройка TFTP
tftp-server flash:SIP3951.8-0-2-9.loads
tftp-server flash:SIP3951.8-0-2-9.zz
tftp-server flash:DSP3951.0-0-0-1.zz
tftp-server flash:BOOT3951.0-0-0-9.zz
tftp-server flash:SIP70.8-2-1S.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:apps70.8-0-2-55.sbn
tftp-server flash:cnu70.8-2-0-55.sbn 
tftp-server flash:cvm70.sip.8-2-0-55.sbn
tftp-server flash:dsp70.8-2-0-55.sbn
tftp-server flash:jar70.sip.8-0-2-25.sbn

Настройте основные функции телефонии

Настройте параметры Голосового сервиса

Настройте систему, чтобы позволить вызовы от SIP до оконечных точек SIP и включить регистратору SIP.

Примечание: Эта конфигурация является обязательной.

Настройка параметров голосового сервиса
voice service voip
allow-connections sip to sip 

!--- Enable SIP to SIP calls.

sip
registrar server expires max 1200 min 300 

!--- Enable Cisco IOS SIP registrar.

Настройте речевые глобальные параметры регистра

В этом разделе вы настраиваете речевые глобальные параметры регистра.

Примечание: Речевые глобальные конфигурации регистра для SIP подобны параметрам конфигурации telephony-service для телефонов SCCP.

Примечание: Эта конфигурация является обязательной.

Речевая глобальная настройка параметров регистра
voice register global                     
 mode cme  

!--- Set Cisco IOS SIP registrar to CME mode.

 source-address 192.168.10.1 port 5060 

!--- Set the source address for phone registration.

 max-dn 20 

!--- Set max extensions.

 max-pool 10 

!--- Set max phones.

 load 7970 SIP7 SIP70.8-2-1S 

!--- Specify phone loads for each phone type.

 load 3911 SIP3951.8-0-2-9 

!--- Specify phone loads for each phone type.

 authenticate register 

!--- Set authentication for phone registration.

 authenticate realm cisco.com 
 tftp-path flash:  

!--- Specify path for tftp files.

 create profile 

!--- Create configuration files for all phones.

 dialplan-pattern 1 4085251... extension-length 3  

!--- Configure dial-plan pattern for the system.

Вот ссылка на видео на Сообществе Cisco Support leavingcisco.com, которое объясняет процедуру для регистрации IP-телефона в Cisco Unified Communications Manager Express (CME) с помощью Протокола SIP:

Регистрация 79xx IP-телефон Серии с помощью Протокола SIP на CUCME leavingcisco.com

/image/gif/paws/99946/cme-sip-guide02.gif

Настройте соединение с Cisco Unity Express

Настройте необходимые точки вызова и ephone-dn MWI для взаимодействия с Cisco Unity Express. Для Cisco Unified Communications Manager Express для взаимодействия с Cisco Unity Express необходимо настроить Cisco Unified Communications Manager Express SIP как последовательного клиента User Agent (B2BUA), что означает, что весь поток сигнализации и RTP проходит через Cisco Unified Communications Manager Express. Эта конфигурация требуется для включения подключения к Cisco Unity Express.

Настройка подключения Cisco Unity Express
dial-peer voice 2 voip
    destination-pattern 1.0  

!--- Specify destination-pattern to reach CUE VM and AA.

    session target ipv4:10.1.10.1  

!--- Configure IP address to reach Cisco Unity Express.

    session protocol sipv2
    dtmf-relay sip-notify  

!--- Configure DTMF method to communicate with Cisco Unity Express.

    b2bua  

!--- Enable B2BUA for Cisco Unified Communications Manager Express
!--- for calls to Cisco Unity Express.

    codec g711ulaw 
    no vad

Настройте поддержку MWI Cisco Unity Express вызова на дом для включения MWI для SIP-телефонов.

Конфигурация MWI Cisco Unity Express
ephone-dn 11
number 800
mwi on
!
ephone-dn 12
number 801
mwi off

Настройте расширение и параметры

Настройте речевого dn регистра для создания добавочных номеров для ephone. В предыдущей топологии сети существует четыре расширения, которые должны быть созданы, как дали здесь.

Примечание: Эта конфигурация является обязательной.

Добавочная конфигурация
voice register dn 1 
name Phone1 

!--- Set display name.

label 4085251001  

!--- Set display label.

number 101 

!--- Set extension number.

call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch  

!--- Allow this number to be watched (presence).

! 
voice register dn 2 
name Phone2
label 4085251002
number 102 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch
!
voice register dn 3 
name Phone3
label 4085251003
number 103 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch 
! 
voice register dn 4 
name Phone4
label 4085251004
number 104 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch

Настройте SIP-телефон

Настройте речевые параметры пула регистра для каждого SIP-телефона.

Примечание: Речевой пул регистра для SIP-телефонов идентичен ephone для телефонов SCCP.

Примечание: Эта конфигурация является обязательной.

Речевая настройка параметров пула регистра
voice register pool  3
 id mac 001A.A11B.500E  

!--- Specify phone mac-address.

 type 3911  

!--- Specify phone type.

 number 1 dn 3  

!--- Assign button 1 dn tag 3.

 dtmf-relay sip-notify  

!--- Configure dtmf-relay sip-notify to work 
!--- with Cisco Unity Express.

 codec g711ulaw  

!--- Specify codec.

 username user1 password cisco  

!--- Configure username and password for SIP registrar.

Примечание: Несколька способов для DTMF могут быть настроены под речевым пулом регистра, но для каждого SIP-телефона, который имеет коробку голосовой почты на Cisco Unity Express, настройте dtmf-relay sip-notify.

Настройте усовершенствованные параметры

В этом разделе вы настраиваете усовершенствованные параметры для SIP-телефонов, таких как присутствие со статусом Поля индикатора занятости (BLF). Присутствие с BLF позволяет или телефону SCCP или SIP-телефону контролировать статус другого SIP расширения, который включает информацию о присутствии между телефонами.

Примечание: Это - произвольная конфигурация.

Эти телефоны поддерживают сервис присутствия SIP на Cisco Unified Communications Manager Express.

Ограничения

BLF Call-List
Supported only on Cisco Unified IP Phone 7941G, 7941GE, 7961G, 7961GE, 7970G, and 7971GE.
BLF Speed-Dial
Supported only on Cisco Unified IP Phone 7941G, 7941GE, 7961G, 7961GE, 7970G, and 7971GE.

Включите Присутствие для внутренних линий

Выполните эти шаги, чтобы позволить маршрутизатору принять входящие запросы присутствия от внутренних наблюдателей и магистралей SIP.

1.  enable 
2.  configure terminal 
3.  sip-ua 
4.  presence enable 
5.  exit 
6.  presence 
7.  max-subscription number 
8.  presence call-list 
9.  end
Включите присутствие для внутренних линий
Presence  

!--- Enable presence service.

 presence call-list  

!--- Enable BLF monitoring of directory numbers.

 max-subscription 120  

!--- Configure max number watched sessions.

!
sip-ua
 presence enable  

!--- Enable router to accept incoming presence request.

Позвольте Номеру каталога наблюдаться

Выполните эти шаги, чтобы позволить линии, привязанной к номеру каталога быть проверенной телефоном, зарегистрированным к маршрутизатору Cisco Unified Communications Express. Линия включена как объект присутствия, и телефоны могут подписаться на его статус линии через список вызовов BLF и функции ускоренного набора BLG. Нет никакого ограничения на тип телефона, которому можно было контролировать его линии; любая линия на любом IP-телефоне или на аналоговом телефоне на поддерживаемых голосовых шлюзах может быть объектом присутствия.

1.  enable 
2.  configure terminal 
3.  voice register dn dn-tag 
4.  number number 
5.  allow watch 
6.  end
Позвольте Номеру каталога Наблюдаться
voice register dn  1
 number 101
 allow watch  

!--- Allow this number to be watched.

 name Phone1
 label 4085251001

Примечание: Повторите эту конфигурацию для каждого добавочного номера, который должен наблюдаться. Этот шаг был уже выполнен когда вы сначала dns регистра настроенного голоса.

Позвольте SIP-телефону контролировать статус BLF для ускоренных наборов и списков вызовов

Наблюдатель может контролировать состояние линий, связанных с внутренними и внешними абонентскими номерами (объектами присутствия) посредством индикации BLF ускоренного вызова BLF и функций присутствия для списка вызова BLF. Выполните эти шаги для активации опций уведомления BLF на SIP-телефоне:

1.  enable 
2.  configure terminal 
3.  voice register pool pool-tag 
4.  number tag dn dn-tag 
5.  blf-speed-dial tag number label string 
6.  presence call-list 
7.  exit 
8.  voice register global 
9.  mode cme 
10.  create profile 
11.  restart 
12.  end
Позвольте SIP-телефону контролировать статус BLF для ускоренных наборов и списков вызовов
voice register pool  1
 id mac 0016.47CD.9BD7
 type 7970
 number 1 dn 1
 presence call-list  

!--- Enable this phone to have presence call list.

 dtmf-relay sip-notify  
 username user1 password cisco
 codec g711ulaw
 blf-speed-dial 2 102 label "Phone2"  

!--- Enable this line to monitor extension 1002.

 blf-speed-dial 3 103 label "3911-1"  

!--- Enable this line to monitor extension 1003.

 blf-speed-dial 4 104 label "3911-2"  

!--- Enable this line to monitor extension 1004.

Примечание: Обязательно выполните перезапуск каждый раз, когда вы изменяете конфигурацию SIP-телефона.

Примечание: Обратитесь к тому, Как Настроить Сервис Присутствия для получения дополнительной информации о конфигурациях Сервиса Присутствия SIP.

Настройте параллельную группу поиска

В этом разделе расширения 102, 103, и 104 назначены в параллельную группу поиска. Параллельная группа поиска является группой последовательного поиска, которая звонит всем участникам в группе одновременно.

Конфигурация параллельной группы поиска
voice hunt-group 1
pilot 180  

!--- Configure Hunt group pilot number.

list 102, 103, 104  

!--- Specify members in hunt-group.

final 100  

!--- Specify final number as Voicemail Pilot.

CME - реализация SIP: Пример конфигурации

Этот раздел предоставляет конфигурацию полной выборки для того, чтобы установить автономный Cisco Unified Communications Manager Express, который использует SIP-телефоны.

CME - реализация SIP: Пример конфигурации
CME-SIP#show version
Cisco IOS Software, 2801 Software (C2801-IPVOICE-M), Version 12.4(11)XW2, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Mon 02-Jul-07 19:10 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)T6, RELEASE SOFTWARE (fc1)

CME-SIP uptime is 18 hours, 55 minutes
System returned to ROM by reload at 17:01:34 UTC Wed Oct 3 2007
System image file is "flash:c2801-ipvoice-mz.124-11.XW2.bin"

Cisco 2801 (revision 4.1) with 235520K/26624K bytes of memory.
Processor board ID FHK084510HS
11 FastEthernet interfaces
1 terminal line
2 Voice FXO interfaces
3 DSPs, 48 Voice resources
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

CME-SIP#show running-config
Building configuration...

Current configuration : 6227 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-SIP
!
boot-start-marker
boot-end-marker
!
logging buffered 999999
no logging console
enable password cisco
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool data
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1 
!
ip dhcp pool voice
   network 192.168.10.0 255.255.255.0
   option 150 ip 192.168.10.1 
   default-router 192.168.10.1 
!
!
no ip domain lookup
multilink bundle-name authenticated
!
!
!
voice service voip 
 allow-connections sip to sip
 sip
  registrar server expires max 1200 min 300
!
!
!
!
!
voice register global
 mode cme
 source-address 192.168.10.1 port 5060
 max-dn 20
 max-pool 10
 load 7970 SIP70.8-2-1S
 load 3911 SIP3951.8-0-2-9
 authenticate register
 authenticate realm cisco.com
 voicemail 100
 tftp-path flash:
 create profile sync 0000589556325309
!
voice register dn  1
 number 101
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone1
 label 4085251001
!
voice register dn  2
 number 102
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone2
 label 4085251002
!
voice register dn  3
 number 103
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone3
 label 4085251003
!
voice register dn  4
 number 104
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone4
 label 4085251004
!
voice register pool  1
 id mac 0016.47CD.9BD7
 type 7970
 number 1 dn 1
 presence call-list
 dtmf-relay sip-notify
 username user1 password cisco
 codec g711ulaw
 blf-speed-dial 2 102 label "Phone2"
 blf-speed-dial 3 103 label "3911-1"
 blf-speed-dial 4 104 label "3911-2"
!
voice register pool  2
 id mac 0014.6948.1D52
 type 7970
 number 1 dn 2
 dtmf-relay sip-notify
 username user2 password cisco
 codec g711ulaw
!
voice register pool  3
 id mac 001A.A11B.4FCE
 type 3911
 number 1 dn 3
 dtmf-relay sip-notify
 username user3 password cisco
 codec g711ulaw
!
voice register pool  4
 id mac 001A.A11B.500E
 type 3911
 number 1 dn 4
 dtmf-relay sip-notify
 username user4 password cisco
 codec g711ulaw
!
voice hunt-group 1 parallel
 final 100
 list 102,103,104
 pilot 180 
!
!
!
!
voice-card 0
!
!
!
archive
 log config
 hidekeys
!
!
!
interface Loopback0
 ip address 10.1.10.2 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine0/0
 ip unnumbered Loopback0
 service-module ip address 10.1.10.1 255.255.255.0
 service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/3/0
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/1
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/2
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/3
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/4
 description Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/5
 description Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/6
 description Phone
 switchport access vlan 192
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/7
 description Phone
 switchport access vlan 192
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/8
 switchport access vlan 192
!
interface Vlan1
 no ip address
!
interface Vlan100
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan192
 ip address 192.168.10.1 255.255.255.0
!
ip route 10.1.10.1 255.255.255.255 Service-Engine0/0
!
!
ip http server
!
!
!
tftp-server flash:BOOT3951.0-0-0-9.zz
tftp-server flash:SIP3951.8-0-2-9.zz
tftp-server flash:DSP3951.0-0-0-1.zz
tftp-server flash:SIP3951.8-0-2-9.loads
tftp-server flash:SIP70.8-2-1S.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:apps70.8-0-2-55.sbn
tftp-server flash:cnu70.8-2-0-55.sbn 
tftp-server flash:cvm70.sip.8-2-0-55.sbn
tftp-server flash:dsp70.8-2-0-55.sbn
tftp-server flash:jar70.sip.8-0-2-25.sbn
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
!
!
!
dial-peer voice 2 voip
 description ** cue voicemail pilot number **
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 100
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 3 voip
 description ** cue auto attendant number **
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 110
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
!
presence
 presence call-list
 max-subscription 120
!
sip-ua 
 presence enable
!
!
telephony-service
 max-ephones 24
 max-dn 72
 ip source-address 10.100.100.10 port 2000
 system message CME1
 time-zone 5
 voicemail 100
 max-conferences 8 gain -6
 call-forward pattern .T
 web admin system name cisco secret 5 $1$4FC/$CMer08o/KELFlVrhL5QRO0
 dn-webedit 
 time-webedit 
 transfer-system full-blind
 transfer-pattern 9.T
!
!
ephone-dn  11
 number 800
 mwi on
!
!
ephone-dn  12
 number 801
 mwi off
!
!
line con 0
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

CME-SIP#

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

IP-телефон SIP не получает тональный сигнал готовности к набору номера

Типичная причина для IP-телефонов SIP, которые не в состоянии получить тональный сигнал готовности к набору номера, - то, что существует другой телефон с тем же расширением. С Cisco Unified Communications Manager Express 4.2, общая линия не поддерживается на SIP-телефонах. Таким образом SIP-телефоны не могут совместно использовать то же расширение среди множественных телефонов. Кроме того, удостоверьтесь, что SIP-телефон обеспечен с надлежащим расширением.

Для решения этого вопроса удостоверьтесь, что они происходят:

  • SIP-телефону настроили расширение, и расширение показывает на SIP-телефоне.

  • Нет другого телефона SIP или SCCP, установленного настройки с тем же расширением.

IP-телефон не может обновить к последним версиям микропрограммного обеспечения

Наиболее вероятные причины для сбоя, чтобы быть в состоянии обновить телефон пропускают файлы микропрограммного обеспечения, размещенные во флэш-память Cisco Unified Communications Manager Express или недостающие команды tftp-server.

Попробуйте эти шаги для решения этого вопроса:

  • Проверьте, что файлы необходимого программного обеспечения хранятся на флэш-памяти. Выполните команду dir flash: для проверки флэш-памяти для файлов.

  • Проверьте, чтобы видеть, обновили ли вы файл OS79XX.TXT для отражения корректного микропрограммного обеспечения. 79XX телефоны проверяют этот файл для загрузки соответствующей микропрограммы и изменения от SCCP до SIP.

  • Проверьте, чтобы удостовериться, что корректные операторы tftp-server добавлены для каждого файла микропрограммного обеспечения. Посмотрите Настраивать раздел TFTP.

  • Удостоверьтесь, что команда load под голосом регистрируется, глобальный добавлен для каждого типа SIP-телефона. Посмотрите, что Настраивать Голос регистрирует раздел глобальных параметров.

Для устранения проблем далее, соберите эти отладки, чтобы видеть, ли телефон в состоянии получить соответствующие нагрузки телефона от флэш-памяти Cisco Unified Communications Manager Express.

Debug tftp events

Неспособный обеспечить телефон

Наиболее вероятные причины для неспособности обеспечить являются телефоном, то, что телефон не имеет надлежащего IP-адреса с опцией TFTP server.

  • Проверьте, чтобы видеть, что телефон получает IP-адрес и надлежащий IP-адрес сервера TFTP.

  • Удостоверьтесь, что добавлены все надлежащие команды voice register global. Посмотрите, что Настраивать Голос регистрирует раздел глобальных параметров.

  • Проверьте использование корректного MAC-адреса под каждой речевой конфигурацией пула регистра.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения