Коммутаторы : ??????????? Cisco Catalyst ????? 3750

Маршрутизация с использованием заглушек PIM на коммутаторах Catalyst 3750, and 3560 Series

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Трафик плоскости управления групповой адресацией всегда замечается каждым маршрутизатором на среде локальной сети. Тупиковая Групповая IP-адресация используется, чтобы уменьшить и минимизировать ненужный многоадресный трафик, который замечен на LAN в уровне доступа, и сохраните пропускную способность на средах для передачи многоадресного трафика восходящему распределению/магистральному уровню.

В Catalyst 3750 и Коммутаторах серии 3560, многоадресной маршрутизации поддержек характеристик Групповой адресации Фиктивного модуля PIM между уровнем распределения и уровнем доступа. Это поддерживает два типа интерфейсов PIM: соединительные интерфейсы PIM и пассивные интерфейсы PIM. В частности маршрутизируемый интерфейс, настроенный с Пассивным режимом PIM, не передает/передает трафик уровня управления PIM; это только трафик IGMP проходов/форвардов.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Тупиковый маршрутизатор PIM не направляет транзитный трафик между маршрутизаторами распределения. Это поведение принуждено индивидуальной рассылкой (EIGRP) маршрутизация с использованием заглушек. Надлежащая конфигурация маршрутизации с использованием заглушек индивидуальной рассылки требуется, чтобы помогать этому поведению тупикового маршрутизатора PIM. Функция фиктивного модуля PIM не предотвращает администратора маршрутизатора, настраивающего RIP, статические маршруты или RP PIM для обхода этого ограничения.

  • Только связанная прямым образом групповая адресация (IGMP) приемники и источники позволена в доменах доступа уровня 2. Протокол PIM не поддерживается в доменах доступа.

  • Избыточная топология тупикового маршрутизатора PIM не поддерживается.

Используемые компоненты

Сведения в этом документе основываются на выходных данных от Коммутатора Catalyst 3750.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Родственные продукты

Эта конфигурация может также использоваться с этими типами коммутатора:

  • Catalyst 3750 и коммутаторы серии 3560

Cisco Catalyst 3750 и 3560 коммутаторов поддерживают SE Версии кода 12.2 (37) Многоадресной маршрутизации с использованием заглушек PIM и позже.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

SSM PIM используется на каналах связи для передачи с вышестоящим маршрутизатором. Пользователи могут использовать любой другой Режим PIM (например, Плотный или Редкий).

Для дополнительных сведений о конфигурации Многоадресной маршрутизации на Коммутаторах серии 3750 обратитесь к Маршрутизации групповой IP-адресации Настройки.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/98289/pim_stub-1.gif

Конфигурации

Эти конфигурации используются в данном документе:

Выполните эти шаги для настройки Маршрутизации с использованием заглушек PIM:

  1. Выполните эту команду для включения многоадресной маршрутизации глобально на стеке коммутаторов или стеке коммутаторов:

    mix_stack(config)#ip multicast-routing distributed
    
  2. Выполните эту команду для определения диапазона SSM адреса групповой IP-адресации с диапазоном группы по умолчанию:

    mix_stack(config)#ip pim ssm default
    
  3. Выполните эту команду для включения SSM PIM на канале связи:

    mix_stack(config)#interface GigabitEthernet3/0/25
    
    
    !--- By default switch configures the Layer 2 parameters.
    So in order to configure the Layer 3 parameter, use the next command.
    
    mix_stack(config-if)#no switchport
    
    mix_stack(config-if)#ip pim sparse-dense-mode
    
  4. Выполните эту команду для включения Маршрутизации с использованием заглушек PIM на интерфейсе виртуальной локальной сети (VLAN):

    mix_stack(config)#interface vlan100
    mix_stack(config-if)#ip pim passive
    

Коммутатор (mix_stack) конфигурация

mix_stack#show run
Building configuration...
 
Current configuration : 7810 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mix_stack
!
!
switch 2 provision ws-c3750e-24pd
switch 3 provision ws-c3750g-24ts
switch 5 provision ws-c3750-24fs
switch 9 provision ws-c3750e-24pd
!
ip routing
!
!
ip multicast-routing distributed
!
!--- Output suppressed.
!
!
vlan 100
!
!
interface GigabitEthernet2/0/1
switchport access vlan 100
no keepalive
spanning-tree portfast
!
interface GigabitEthernet2/0/2
switchport access vlan 100
no keepalive
spanning-tree portfast
!
!
!--- Output suppressed.
!
!
interface GigabitEthernet3/0/25
no switchport
ip address 3.1.1.2 255.255.255.248
ip pim sparse-dense-mode
!
!
!--- Output suppressed.
!
!
interface GigabitEthernet9/0/24
no switchport
ip address 10.1.1.1 255.255.255.0
ip pim passive
no keepalive
!
!
!--- Output suppressed.
!
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 100.1.1.1 255.255.255.0
ip pim passive
!
!
!--- Output suppressed.
!
! 
ip pim ssm default
!
!
!--- Output suppressed.
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
speed 115200
line vty 0 4
login
line vty 5 15
login
!
end

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Выполните команду show ip pim interface для отображения Фиктивного модуля PIM, который является, включают для каждого интерфейса.

mix_stack#show ip pim interface 

Address    Interface               Ver/    Nbr     Query   DR     DR
                                   Mode    Count   Intvl   Prior

3.1.1.2    GigabitEthernet3/0/25   v2/SD   1       30      1      3.1.1.2
100.1.1.1  Vlan100                 v2/P    0       30      1      100.1.1.1
10.1.1.1   GigabitEthernet9/0/24   v2/P    0       30      1      10.1.1.1

Выполните подробность show ip igmp groups для отображения заинтересованного клиента, который присоединился к определенному Источнику групповой адресации / группа.

mix_stack#show ip igmp groups 232.0.0.9 det

Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
SS - Static Source, VS - Virtual Source,
Ac - Group accounted towards access control limit

Interface: GigabitEthernet9/0/24
Group: 232.0.0.9
Flags: SSM 
Uptime: 00:00:10
Group mode: INCLUDE
Last reporter: 10.1.1.2
CSR Grp Exp: 00:02:57
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 00:00:10 stopped 00:02:57 Yes CM

Interface: Vlan100
Group: 232.0.0.9
Flags: SSM 
Uptime: 01:42:08
Group mode: INCLUDE
Last reporter: 100.1.1.3
CSR Grp Exp: 00:02:00
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 01:42:12 stopped 00:02:00 Yes CM
mix_stack#

Выполните show ip mroute , чтобы проверить что Многоадресная рассылка вперед от источника до заинтересованных клиентов.

mix_stack#show ip mroute 232.0.0.9
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, 
Z - Multicast Tunnel, z - MDT-data group sender, 
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(200.1.1.3, 232.0.0.9), 01:44:23/00:02:52, flags: sTI
Incoming interface: GigabitEthernet3/0/25, RPF nbr 3.1.1.1
Outgoing interface list:
GigabitEthernet9/0/24, Forward/Sparse-Dense, 00:02:24/00:02:50
Vlan100, Forward/Sparse-Dense, 01:44:23/00:02:52

Дополнительные сведения


Document ID: 98289