Коммутаторы : Коммутаторы Cisco Catalyst серии 6500

Настройка коммутаторов Catalyst для работы с телефонами Polycom Conference

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

Этот документ содержит примеры конфигурации коммутаторов Catalyst для соединения с системами Polycom IP Conference Station 7935/7936 и Polycom IP SoundPoint 430. В этом документе не рассматриваются конфигурации качества обслуживания (QoS) и линейного питания.

Предварительные условия

Требования

Рассматриваемая процедура настройки предполагает выполнение следующих условий:

Используемые компоненты

Сведения в этом документе основываются на коммутаторе Cisco Catalyst серии 6500 с модулем управления Supervisor Engine 720 и рабочим Cisco Выпуск ПО IOS� 12.2 (18) SXD6 и коммутатор Cisco Catalyst серии 6500 с Supervisor Engine 2 и рабочим Релизом прогрммного обеспечения Catos Cisco 8.4 (4).

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Родственные продукты

Эта конфигурация может также использоваться с коммутаторами Cisco Catalyst, которые выполняют программное обеспечение Cisco IOS, кроме Cisco 2900XL и 3500XL series. Конфигурации CatOS могут использоваться с любыми коммутаторами Cisco Catalyst, которые выполняют Программное обеспечение операционной системы Catalyst.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Общие сведения

Этот документ объясняет конфигурацию коммутаторов, которые подключают PC и IP-телефон Polycom SoundPoint IP 430 на порту коммутатора. Этот документ также объясняет конфигурацию коммутаторов, которые подключают со Станцией IP-конференцсвязи Polycom 7935/7936 порт коммутатора.

Станция IP-конференцсвязи Polycom 7935/7936 имеет одиночное 10/100BaseTx соединение Локальной сети Ethernet с сетью через интерфейс кабеля RJ-45 и в отличие от других IP-телефонов Cisco Unified серии 7900, это не имеет 10/100BaseTx соединения Локальной сети Ethernet для соединения с ПК.

Из-за отсутствия условия для соединения с ПК с 10/100BaseTx соединением Локальной сети Ethernet по Телефону Конференции по IP Cisco 7935/7936 понятие голоса или дополнительной VLAN непосредственно не применяется и может вызвать проблемы. Одиночное 10/100BaseTx соединение Локальной сети Ethernet, которое имеет Станция IP-конференцсвязи Cisco 7935/7936, используется для соединения этого устройства с портом коммутатора. Так как это соединение переносит трафик для только голоса, порт коммутатора должен принадлежать одиночной VLAN.

Polycom SoundPoint IP 430 имеет двойные Порты Ethernet на 10/100 Мбит/с. Один порт соединяется с коммутатором и другими подключениями порта к ПК. В этом соединении порт переносит трафик для этих двух VLAN:

  • Данные (ПК) трафик

  • Голос (IP-телефон) трафик

В этом сценарии вы требуете магистрального порта для прохождения трафика для нескольких VLAN.

Примечание: Станция IP-конференцсвязи Polycom 7935/7936 не имеет внешнего источника питания, таким образом, или коммутатор должен подать питание через свои порты PoE, или должен использоваться отдельный инжектор питания.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-series-switches/97229-config-cat-switches-polycom.gif

Конфигурации Cisco IOS

В данном документе используется следующая конфигурация:

  • Catalyst 6500

Catalyst 6500 в собственном режиме Cisco IOS
Cat6500#show running-config 
 Building configuration...
Current configuration : 5869 bytes
!
version 12.1 
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!

boot system sup-bootflash:s72033-psv-mz.122-18.SXD6.bin


main-cpu
 auto-sync standard
ip subnet-zero
!
!
no ip finger
!
!
!
!
vlan 1
name DataVlan
!
vlan 2
name VoiceVlan
!
interface FastEthernet4/1
 no ip address 
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1
 switchport trunk allowed vlan 1,2
 switchport mode trunk
 spanning-tree portfast

!--- Use PortFast only when you connect a single end station to a
!--- Layer 2 access port. Otherwise, you create a network loop.
!--- Refer to Using Portfast and Other Commands to Fix Workstation Startup
!--- Connectivity Delays for more information on how to enable portfast.

!
interface FastEthernet4/2
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast

!--- Use PortFast only when you connect a single end station to a 
Layer 2 access port. Otherwise, you create a network loop.

!
interface FastEthernet4/3
 no ip address
 shutdown
!

!--- Output suppressed.

!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line vty 0 4 
!
end

Конфигурации CatOS

Данный пример объясняет конфигурацию коммутаторов в Гибридном режиме, которые подключают ПК и IP-телефон Polycom SoundPoint IP 430 на порту коммутатора. Этот документ также объясняет конфигурацию коммутаторов, которые подключают со Станцией IP-конференцсвязи Polycom 7935/7936 порт коммутатора. Эта конфигурация использует ту же схему в качестве предыдущего примера.

Catalyst 6500 в гибридном режиме

!--- Set the VLAN Trunk Protocol (VTP) mode.
!--- In this example, the mode is set to transparent.
!--- Dependent upon your network, set the VTP mode accordingly.
!--- Refer to Understanding and Configuring VLAN Trunk Protocol (VTP) 
!--- for more information on VTP.

Catalyst6500> (enable) set vtp mode transparent
VTP domain modified


!--- Add VLAN 2. VLAN 1 already exists by default.
 
Catalyst6500> (enable) set vlan 2
VLAN 2 configuration successful


!--- Add port 4/2 to VLAN 2.

Catalyst6500> (enable) set vlan 2 4/2
VLAN 2 modified.
VLAN 1 modified.
VLAN  Mod/Ports
---- -----------------------
2     4/2


!--- Enable trunking on port 4/1.

Catalyst6500> (enable) set trunk 4/1 1,2 dot1q on
Vlan(s) 1,2 already allowed on the trunk
Please use the 'clear trunk' command to remove vlans from allowed list.
Port(s)  4/1 trunk mode set to on.
Port(s)  4/1 trunk type set to dot1q.
Catalyst6500> (enable) 


!--- Enable spanning tree portfast on the ports. Refer to 
!--- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays
!--- for more information on how to enable portfast.

Catalyst6500> (enable) set spantree portfast 4/1 enable

Warning: Connecting Layer 2 devices to a fast start port can cause
temporary spanning tree loops. Use with caution.

Spantree port  4/1 fast start enabled.
Catalyst6500> (enable) set spantree portfast 4/2 enable

Warning: Connecting Layer 2 devices to a fast start port can cause
temporary spanning tree loops. Use with caution.

Spantree port  4/2 fast start enabled.
Catalyst6500> (enable)


!--- If you want to ONLY allow VLAN 1 and VLAN 2 on trunk port 4/1, do this.
!--- A trunk port allows all VLANs by default.

Catalyst6500> (enable) show trunk 4/1
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
$ - indicates non-default dot1q-ethertype value
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 4/1      on           dot1q          not-trunking  1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 4/1      1-4094

Port      Vlans allowed and active in management domain 
--------  ---------------------------------------------------------------------
 4/1      1

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 4/1       
Catalyst6500> (enable) clear trunk 4/1 1-4094
Removing Vlan(s) 1-4094 from allowed list.
Port  4/1 allowed vlans modified to none.


!--- Allow only VLAN 1 and VLAN 2 on trunk port 4/1.

Catalyst6500> (enable) set trunk 4/1 1,2 dot1q on
Adding vlans 1,2 to allowed list.
Port(s)  4/1 allowed vlans modified to 1,2.
Port(s)  4/1 trunk mode set to on.
Port(s)  4/1 trunk type set to dot1q.

Catalyst6500> (enable) show trunk 4/1
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
$ - indicates non-default dot1q-ethertype value
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 4/1      on           dot1q          not-trunking  1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 4/1      1,2

Port      Vlans allowed and active in management domain 
--------  ---------------------------------------------------------------------
 4/1      1

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 4/1       

!--- Refer to Configuring Ethernet VLAN Trunks for more
!--- information on how to configure trunk ports. 


!--- Issue the show config <module_number> command 
!--- in order to check the configuration.

Catalyst6500> (enable) show config 4
This command shows non-default configurations only.
Use 'show config <mod> all' to show both default and non-default configurations.
.................................
begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Thu Jun 21 2007, 23:37:51 
!
# default port status is enable
!
!
#module 4 : 16-port 1000BaseX Ethernet
set vlan 2    4/2
clear trunk 4/1  1-9,11-39,41-4094
set trunk 4/1  on dot1q 1,2
set spantree portfast    4/1-2 enable
end
Catalyst6500> (enable) 

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Этот раздел обеспечивает информацию, которую вы можете использовать для того, чтобы устранить неисправность в вашей конфигурации.

Петля связующего дерева из-за IP-телефонов Polycom

При соединении IP-телефона с коммутатором это может испытать петли STP, который заставляет ЦПУ коммутатора подходить к 100 процентам использования. Петли STP могут произойти, даже если portfast включен на порту коммутатора, где связан IP-телефон.

  1. Проверьте конфигурацию портов коммутатора. Если порт, где IP-телефон связан, входит в статус err-disabled и если нет никакой физической петли, можно попытаться восстановить порт со статуса err-disabled. Обратитесь к Восстановлению Состояния порта отключение из-за ошибки на платформах Cisco IOS для получения дополнительной информации.

  2. Во избежание порта для входа в статус err-disabled, когда существует риск, что конечные пользователи создают физическую петлю по ошибке можно включить восстановление err-disable, таким образом, нет потребности вручную перезагрузить порт, который становится отключенным. Обратитесь к Усовершенствованиям Протокола связующего дерева с помощью Защиты от петель и Характеристик обнаружения отклонений BPDU для получения дополнительной информации о Защите петли STP.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения