Голосовая связь и система унифицированных коммуникаций : Cisco Unified Communications Manager Express

Пример конфиграции "Cisco CallManager Express (CME) SIP Tranking"

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

В настоящее время телекоммуникационная отрасль переживает процесс перехода с устоявшихся технологий коммутации и транспорта на технологии граничных устройств и устройств на основе IP. Революционное использование IP-связи начало приводить к грандиозным коммерческим переменам в сферах малого и среднего бизнеса. Предприятия малого и среднего бизнеса все больше осознают всю эффективность использования протокола IP, так как по одной сети можно передавать звук, видео и данные, а не использовать для этих целей три специальные сети. На рис. 1 показано развертывание IP-телефонии с использованием магистральной сети IP.

Рис. 1. Система IP-телефонии

cme-sip-trunking-config1.gif

Офисные АТС на основе IP начинают доминировать в качестве решений передачи голосовых данных, а АТС на основе TDM уже перестают быть основным средством передачи данных между двумя голосовыми сетями. За последние несколько лет использование офисных АТС на основе TDM уменьшилось, а офисные АТС на основе IP превращаются в удачные инвестиции в локальные и глобальные сети на основе IP. Чтобы подключиться к ТфОП, офисные АТС нуждаются в магистральных линиях, таких как TDM (T1/E1) или аналоговые линии. Офисные АТС на основе IP могут получать доступ к ТфОП посредством этих типов магистральных каналов, но помимо этого нуждаются в медиашлюзе, который будет преобразовывать данные IP-телефонии в сигналы традиционной ТфОП, что может привести к последовательному преобразованию из домена IP в домен TDM. Эти последовательные преобразования увеличивают стоимость поддержки шлюзов, увеличивают задержки и уменьшают качество голосовой связи.

Чтобы избежать этого, в офисных АТС на основе IP используются протоколы инициализации и управления сеансами, самым известным из которых является протокол SIP (Session Initiation Protocol). В этом документе приводится описание Cisco CallManager Express (CME) и магистрального канала с использованием протокола SIP, а также конфигурация системы IP-телефонии на основе CME с использованием магистрального канала SIP для входящих и исходящих вызовов.

Предварительные условия

Требования

Рассматриваемая процедура настройки предполагает выполнение следующих условий:

  • Установлено программное обеспечение CME версии 4.1

  • Образ Cisco Выпуск ПО IOS� 12.4 (11) XJ или IOS 12.4 (6-й) T находится на маршрутизаторе

  • В CUE версии 2.3.4 установлен модуль NM-CUE

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Маршрутизатор Cisco 3825 с Cisco IOS Software Release 12.4(11)XJ

  • Коммутатор Cisco Catalyst 3550 Switch с Cisco IOS Software Release 12.4

  • IP-телефон Cisco 7960

  • Cisco CallManager Express 4.1

  • Cisco Unity Express 2.3.4

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Протокол SIP

Протокол SIP – это основанный на ASCII протокол управления на уровне приложений, который может использоваться для создания, поддержки и прерывания вызовов между несколькими конечными точками. Протокол SIP быстро стал стандартным протоколом для использования в IP-коммуникациях, так как является протоколом мультимедиа, который может использоваться для видео-сеансов, мгновенных сообщений и голосовых данных. Также при использовании протокола SIP могут обрабатываться сеансы конференций и широковещательные рассылки наряду с сеансами «один-на-один». В использовании протокола SIP содержатся возможности формирования и изменения способов общения людей. По этой причине корпорация Cisco уделяет особое внимание поддержке своего лидирующего положения в создании новых технологий, которые сделают протокол SIP стандартом IP-коммуникаций.

Магистральные каналы SIP схожи с телефонными линиями, однако для их функционирования используются IP-сети, а не ТфОП. Кроме того, в магистральных каналах SIP разрешается конвергенция голоса и данных по стандартным IP-подключениям. Чтобы получить доступ к сети IP посредством магистрального канала SIP, необходимо изменить конфигурацию как на стороне поставщика услуг, так и на стороне клиента. Клиенты должны установить и настроить CME – офисная АТС, которая будет правильно обрабатывать сигналы SIP и успешно передавать трафик. Поставщик услуг должен настроить SIP Proxy Server. Однако магистральные каналы SIP более сложны в создании, чем обычные магистральные каналы ТфОП. Причина заключается в том, что клиент может испытывать трудности при обработке различных версий и реализаций протокола SIP от различных поставщиков оборудования, обеспечении безопасности, управлении качеством обслуживания (QoS), включении преобразования NAT и пересечении межсетевого экрана, а также при обеспечении надежности категории сигнала и непрерывности обслуживания.

Ниже описаны очевидные преимущества использования магистральных каналов SIP на предприятиях малого и среднего бизнеса:

  • Быстрое и простое развертывание

  • Улучшенное использование пропускной способности сети

  • Возможность консолидации и снижение стоимости телефонии

  • Экономичная технология Direct Inward Dial (DID)

  • Непрерывность бизнеса

Поддержка магистральных линий SIP CME

Cisco CME – это решение IP-телефонии, которое интегрировано напрямую в программное обеспечение Cisco IOS. С помощью CME предприятия малого и среднего бизнеса могут развертывать передачу голоса, видео и данных на одной платформе. Сеть IP-телефонии проста в настройке, так как CME работает на одном маршрутизаторе, который предоставляет функциональные возможности офисной АТС. Поэтому использование CME дает малому и среднему бизнесу возможность использовать IP-телефонию и маршрутизацию данных посредством единого конвергированного решения с минимальными затратами.

Передача сигналов DTMF для магистральных каналов SIP

Поддержка магистральных каналов SIP поддерживается, начиная с CME версии 3.1. Однако при вызове SCCP-телефона c SIP-телефона или при попытке получения доступа к голосовой почте с SIP-телефона могут возникать некоторые неполадки. Одна из проблем заключатся в том, что SCCP-телефоны, подключенные к CME, нуждаются во внеполосной передаче сигналов DTMF (цифры) по подключениям VoIP, а SIP-телефоны используют внутриполосные транспорты. Между этими двумя устройствами возникало искажение DTMF. В версии CME 3.2 была добавлена поддержка передачи сигналов DTMF. Цифры DTMF с устройств SCCP могут преобразовываться в механизм внутриполосной передачи сигналов DTMF посредством RFC2833 или методов Notify.

В настоящее время CME поддерживает приведенный ниже список сетевых технологий DTMF для вызовов SIP-SIP:

  • Уведомьте <--->, Уведомляют с тех пор 12.4 (4) T

  • RFC2833 <---> Уведомляет с тех пор 12.4 (4) T

  • Уведомьте <---> RFC2833 с тех пор 12.4 (4) T

  • Inband G711 <---> с версии 12.4(11)T [необходим транскодер]

В настоящее время CME поддерживает следующие сетевые технологии DTMF для вызовов SIP-SCCP:

  • Внеполосный SCCP — SIP Уведомляет / RFC2833 с тех пор 12.4 (4) T

Поддержка кодеков и транскодирование

Кодеки являются еще одним важным аспектом, который следует учитывать при настройке магистрального канала SIP. Кодеки представляют пример кодово-импульсной модуляции сигналов на голосовых частотах. Магистральные каналы SIP поддерживают кодеки: G.711 и G.729. Однако для прочих функциональных возможностей, таких как Cisco Unity Express (CUE) и Music on Hold (MOH), поддерживается только кодек G.711. Это означает, что голосовые кодеки, для которых используются магистральные каналы SIP и кодек G.729, не смогут получить доступ к CUE, если не будет в наличии транскодера, позволяющего выполнять сжатие и распаковку голосовых потоков, соответствующего возможностям CUE. Технология MOH также использует кодек G.729 для экономии пропускной способности, однако указанный кодек не может обеспечивать достаточное качество потоков MOH. Так как кодек G.729 оптимизирован для речи. Поэтому необходимо принудительно указать кодек G.711 для данных MOH.

Переадресация вызовов

При возникновении вызова на магистральном канале SIP и переадресации этого вызова (CFNA / CFB / CFA) поведением по умолчанию является отправка CME сообщения SIP 302 "Moved Temporarily" на прокси-сервер поставщика услуг. Может понадобиться преобразовать пользовательскую часть заголовка Contact Header в сообщении 302 для отражения порта DID, который может служить целью маршрутизации для прокси-сервера поставщика услуг. Часть, содержащая узел, в заголовке Contact Header сообщения 302 должна быть изменена для отражения адреса записи с помощью host-registrarинтерфейса командной строки sip-ua и интерфейса командной строки b2bua для точки вызова VoIP, направленной в CUE.

Это может не поддерживаться некоторыми прокси-серверами SIP. В этом случае следует ввести приведенные ниже команды:

Router(config)#voice service voip
Router(conf-voi-serv)#no supplementary-service sip moved-temporarily

На рис. 2 показано поведение системы CME при отключенном сообщении 302.

Рис. 2. Диаграмма переадресации вызовов, если линия занята, при отключенном сообщении 302

/image/gif/paws/91535/cme-sip-trunking-config2.gif

Этот метод позволит использовать возврат сообщений SIP 302 для переадресации вызовов на CME. Это также необходимо при наличии определенных добавочных номеров, не имеющих сопоставлений DID, так как прокси-сервер поставщика услуг может не иметь достаточных сведений для маршрутизации подобных вызовов. При отключении ответа 3xx инициатор вызывающего номера может быть использован для сохранения идентификатора исходной вызывающей стороны.

Передача вызова

При возникновении вызова на магистральном канале SIP, который предназначен для телефона SCCP или CUE AutoAttendant (AA), и передаче этого вызова по умолчанию CME отправит сообщение SIP REFER на прокси-сервер поставщика услуг. Большинство прокси-серверов поставщиков услуг не поддерживают метод REFER. Необходимо настроить приведенные ниже элементы, чтобы в CME можно было принудительно возвращать вызов:

Router(config)#voice service voip
Router(conf-voi-serv)#no supplementary-service sip refer

На рис. 3 показано поведение системы CME при отключенном методе REFER.

Рис. 3. Передача при отключенном методе REFER

cme-sip-trunking-config3.gif

Если на прокси-сервере SIP поддерживается метод REFER, пользовательская часть Refer-To и Referred-By должны быть преобразованы в формат DID, который распознается прокси-сервером поставщика услуг. Часть узла в полях Refer-To и Referred-By должна представлять собой IP-адрес или DNS-имя, которые должны быть доступными и для прокси-сервера поставщика услуг (это происходит по умолчанию в системе CME 4.1).

Удержание вызова

Если SCCP-телефон удерживает вызов с ТфОП, система CME изменяет носитель. Сообщения SIP не передаются по магистральному каналу SIP. Мелодия в режиме удержания будет проиграна по магистральному каналу SIP в зависимости от конфигурации CME.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/91535/cme-sip-trunking-config4.gif

Конфигурации

В этих элементах конфигурации содержится последовательность шагов, необходимая для настройки магистральных каналов SIP в системе CME:

  • Элементы инфраструктуры: Интерфейсы, службы TFTP и DHCP, NTP и т. д

  • Telephony-service: Включение управления вызовами офисной АТС в IOS на платформе CME, включая элементы управления телефоном

  • Ephones и Ephones-dns: Определение IP-телефонов и их номеров

  • План дозвона: Точки вызовов, добавочные номера, правила голосового преобразования

  • Конфигурация IOS SIP: Включение SIP, регистрация телефона на прокси-сервере SIP, маршрутизация вызовов по магистральным каналам и т. д

  • Поддержка голосовой почты: Cisco Unity Express

  • Конфигурация Switch Catalyst: IP-адрес, интерфейсы и т. д

Это полная конфигурация, необходимая для развертывания системы CME с магистральными каналами SIP:

Конфигурация маршрутизатора CME
!
AUSNML-3825-01#show run
Building configuration...

Current configuration : 8634 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AUSNML-3825-01
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$vBU1$MCMG1rXM5ejME8Wap6W0H1
!
no aaa new-model
clock timezone central -8
clock summer-time central recurring
ip cef
!

!--- DHCP Configuration ---

ip dhcp pool Voice
   network 172.22.100.0 255.255.255.0
   option 150 ip 172.22.1.107 
   default-router 172.22.100.1 
!
ip dhcp pool Data
   network 172.22.101.0 255.255.255.0
   option 150 ip 172.22.1.107 
   default-router 172.22.101.1 
!
!
ip domain name cisco.com
ip name-server 205.152.0.20
multilink bundle-name authenticated
!
voice-card 0
 no dspfarm
!
!
!
!

!--- Voice Class and Service VoIP Configuration ---

voice service voip 
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily

!---Disable 302 sending

 no supplementary-service sip refer

!---Disable REFER sending

 sip
  registrar server expires max 3600 min 3600
  localhost dns:domain.test.com 
!
!
voice class codec 1
 codec preference 1 g711ulaw
!
!
!
!
!
!
!
!
!
!
!

!--- Voice Translation Rules ---

voice translation-rule 1
 rule 1 /5123781291/ /601/

!--- An inbound rule for AA pilot "601

 rule 2 /5123781290/ /600/

!--- An inbound rule for the voicemail pilot "600"

!
voice translation-rule 2
 rule 1 /^911$/ /911/

!--- An outbound rule to allow "911"

 rule 2 /^9\(.*\)/ /\1/


!--- An outbound rule to strip "9" from PSTN calls

!
voice translation-rule 3
 rule 1 /^.*/ /5123781291/

!--- An outbound rule to change calling-number CLID to a
!--- "main" number

!
voice translation-rule 4
 rule 1 /^9(.......)$/ /512\1/

!--- An outbound rule to add areacode for local calls

 rule 2 /600/ /5123788000/

!--- An outbound rule to present the voicemail pilot extension as DID

 rule 3 /601/ /5123788001/

!--- An outbound rule to present the AA pilot extension as DID

 rule 4 /^2(..)$/ /51237812\1/

!--- An outbound rule to support transfers and call-forwards

 rule 5 /^9(.*)/ /\1/

!--- An outbound rule to strip "9" from "9+" transfers and call-forwards

!
!
voice translation-profile CUE_Voicemail/AutoAttendant

!--- Applied to the inbound dial-peers for CUE

 translate called 1
!
voice translation-profile PSTN_CallForwarding

!--- Applied to CUE dial-peers

 translate redirect-target 4
 translate redirect-called 4
!
voice translation-profile PSTN_Outgoing

!--- Applied to all outbound dial-peers

 translate calling 3
 translate called 2
 translate redirect-target 4
 translate redirect-called 4
!
!
!
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!

!--- Internet Connection Configuration ---

interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
 no keepalive
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 172.22.1.71 255.255.255.0
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
 ip address 172.22.101.1 255.255.255.0
!
interface GigabitEthernet0/0.100
 encapsulation dot1Q 100
 ip address 172.22.100.1 255.255.255.0
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
 no keepalive
!
interface Service-Engine1/0
 ip unnumbered GigabitEthernet0/0.1
 service-module ip address 172.22.1.253 255.255.255.0
 service-module ip default-gateway 172.22.1.71
!
ip route 0.0.0.0 0.0.0.0 172.22.1.1
ip route 172.22.1.253 255.255.255.255 Service-Engine1/0
!
!
ip http server
no ip http secure-server
!
!
!

!--- TFTP Server Configuration  ---

tftp-server flash:P0030702T023.bin
tftp-server flash:P0030702T023.loads
tftp-server flash:P0030702T023.sb2
tftp-server flash:P0030702T023.sbn
!
control-plane
!
!
!
!
!
!
!

!--- SIP Trunk Configuration ---

dial-peer voice 1 voip
 description **Incoming Call from SIP Trunk**
 translation-profile incoming CUE_Voicemail/AutoAttendant
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 incoming called-number .%
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 2 voip
 description **Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9........
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 3 voip
 description **Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[2-9]..[2-9]......
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 4 voip
 description **Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[0-1][2-9]..[2-9]......
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 5 voip
 description **911 Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 911
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 6 voip
 description **Emergency Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9911
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 7 voip
 description **911/411 Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[2-9]11
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 8 voip
 description **International Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9011T
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 9 voip
 description **Star Code to SIP Trunk**
 destination-pattern *..
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!

!--- Voicemail Configuration ---

dial-peer voice 10 voip
 description **CUE Voicemail**
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 600
 b2bua

!--- Used by CME to send its IP address to SP proxy instead of CUE

 session protocol sipv2
 session target ipv4:172.22.1.155
 dtmf-relay sip-notify

!--- This can also be RFC2833 going to CUE

 codec g711ulaw

!--- CUE only supports G711ulaw as the codec

 no vad

!--- With VAD enabled, messages left on CUE could be blank or poor quality

!
!
!
dial-peer voice 11 voip
 description **CUE Auto Attendant**
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 601
 b2bua
 session protocol sipv2
 session target ipv4:172.22.1.155
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
!

!--- SIP UA Configuration ---

sip-ua 
 authentication username 5123781000 password 075A701E1D5E415447425B
 no remote-party-id
 retry invite 2
 retry register 10
 retry options 0
 timers connect 100
 registrar dns:domain.test.com expires 3600
 sip-server dns:domain.test.com
  host-registrar
!
!

!--- CME Telephony Service Configuration ---

telephony-service
 no auto-reg-ephone
 load 7960-7940 P0030702T023
 max-ephones 168
 max-dn 500
 ip source-address 172.22.1.107 port 2000
 calling-number initiator

!--- Preserves the caller-id of a call when transferred or forwarded

 dialplan-pattern 1 51237812.. extension-length 3 extension-pattern 2.. no-reg
 voicemail 600
 max-conferences 12 gain -6
 call-forward pattern .T
 call-forward system redirecting-expanded

!--- Enables translation rule features for call-forwarding

 moh music-on-hold.au
 transfer-system full-consult dss
 transfer-pattern 9.T
 secondary-dialtone 9
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!

!--- Ephone and Ephone-dn Configuration ---

ephone-dn  11  dual-line
 number 201 secondary 5123781201 no-reg both

!---"no-reg both" means do not try to register either extension with SP SIP Proxy

 name John Smith
 call-forward busy 600
 call-forward noan 600 timeout 15
!
!
ephone-dn  12  dual-line
 number 202 secondary 5123781202 no-reg both
 name Enrique Zurita
 call-forward busy 600
 call-forward noan 600 timeout 15
!
!
ephone-dn  13
 number 5123788000
 description **DID Number for Voicemail**
!
!
ephone-dn  14
 number 5123788001
 description **DID Number for Auto Attendant*
!
!
ephone-dn  15
 number 8000... no-reg primary
 mwi on
!
!
ephone-dn  16
 number 8001... no-reg primary
 mwi off
!
!
ephone  1
 mac-address 0008.A371.28E9
 type 7960
 button  1:11
!
!
!
ephone  2
 mac-address 0008.A346.5C7F
 type 7960
 button  1:12
!
!
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 password ut69coe
 login
!
scheduler allocate 20000 1000
ntp server 172.22.1.107
!
end

Конфигурация маршрутизатора CUE
se-172-22-1-253#show run
 
Generating configuration:


clock timezone America/Chicago

hostname se-172-22-1-253

ip domain-name localdomain



groupname Administrators create
groupname Broadcasters create


!--- Users ---

username Enrique create
username John create
username Enrique phonenumberE164 "5123781202"
username John phonenumberE164 "5123781201"
username Enrique phonenumber "202"
username John phonenumber "201"


!--- AutoAttendant ---

ccn application autoattendant
 description "**AutoAttendant**"
 enabled
 maxsessions 4
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "operExtn" "601"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "disconnectAfterMenu" "false"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "false"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "businessSchedule" "systemschedule"
 parameter "MaxRetry" "3"
 end application


!--- MWI ---

ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "CallControlGroupID" "0"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 end application


!--- Voicemail ---

ccn application voicemail
 description "**Voicemail**"
 enabled
 maxsessions 4
 script "voicebrowser.aef"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 end application


!--- SIP ---

ccn subsystem sip
 gateway address "172.22.100.1"

!--- Must match the "ip source-address" in telephony-service

 dtmf-relay sip-notify
 mwi sip outcall

!--- Subscribe / Notify and Unsolicited Notify have not been tested

 transfer-mode blind bye-also

!--- Testing with REFER method on CUE has caused certain call flows to break

 end subsystem


!--- Trigger Phones ---

ccn trigger sip phonenumber 600
 application "voicemail"
 enabled
 maxsessions 4
 end trigger

ccn trigger sip phonenumber 601
 application "autoattendant"
 enabled
 maxsessions 4
 end trigger

service phone-authentication
 end phone-authentication

service voiceview
 enable
 end voiceview


!--- Voicemail Mailboxes ---

voicemail default mailboxsize 21120
voicemail broadcast recording time 300

voicemail mailbox owner "Enrique" size 300
 description "**Enrique_Mailbox**"
 expiration time 10
 messagesize 120
 end mailbox

voicemail mailbox owner "John" size 300
 description "**John'sMailbox**"
 expiration time 10
 messagesize 120
 end mailbox

end

Конфигурация коммутатора

!--- Interface Connected to CME/CUE Router ---

interface FastEthernet0/2
 description Trunk to 3825
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
 duplex full
 speed 100


!--- Interfaces Connected to the IP Phones ---

interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20

!--- Data Traffic ---

 switchport mode trunk
 switchport voice vlan 100

!--- Voice Traffic ---

 no ip address
 spanning-tree portfast


interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport mode trunk
 switchport voice vlan 100
 no ip address
 spanning-tree portfast
 

!--- IP Address ---

interface Vlan1
 ip address 172.22.1.194 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.22.1.1
ip http server

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Прежде чем выполнять какие-либо команды отладки , ознакомьтесь с документом "Важные сведения о командах отладки".

Устранение неполадок, связанных с регистрацией

Для устранения неполадок, связанных с магистральным каналом SIP в CME, используются те же команды, что и для устранения неполадок, связанных с IOS SIP GW и CME. Используйте эти команды для проверки регистрации доменного имени:

  • show sip-ua register status — Используйте эту команду для показа статуса количества E.164, которое шлюз SIP зарегистрировал во внешнем основном регистраторе SIP.

  • сообщение CCSIP отладки — Включает все отслеживание сообщения SPI SIP, такое как те, которыми обмениваются между клиентом агента пользователя SIP (UAC) и сервером доступа.

Устранение неполадок, связанных с настройкой вызовов

Команды устранения неполадок, связанных с вызовами по магистральным каналам SIP, по существу, не отличаются от обычных команд устранения неполадок, связанных с SIP GW и CME.

Команды "show":

  • show ephone registered — Проверяет регистрацию ephone.

  • show voip rtp connection — Отображает информацию о пакетах именованного события RTP, таких как количество caller-ID, IP-адрес и порты и для локальных и для удаленных оконечных точек.

  • покажите, что вызов sip-ua — Отображает активный UAC и информацию о сервере клиента User Agent (UAS) о вызовах SIP.

  • show call active voice brief Сведения об активных вызовах Показов для голосовых вызовов или происходящих передач факса.

Команды "debug":

  • сообщение CCSIP отладки — Включает все отслеживание сообщения SPI SIP, такое как те, которыми обмениваются между UAC SIP и сервером доступа.

  • debug voip ccapi inout путь выполнения через API управления вызовами.

  • речевая трансляция отладки — Проверяет функциональность правила трансляции.

  • mac-address debug ephone detail <Mac телефона> — Устанавливает подробную отладку для Cisco IP Phone.

  • именованные события сеанса debug voip rtp — Включают отладку для Протокола RTP, названного пакетами событий.

  • сообщение debug sccp — Отображает последовательность сообщений SCCP.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения