Беспроводные сети / Мобильные решения : "Беспроводные сети, LAN (WLAN)"

Пример конфигурации многоадресности с контроллерами беспроводных LAN (WLC) и точками доступа Lightweight (LAP)

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (20 декабря 2015) | Отзыв


Содержание


Введение

В этом документе представлен пример конфигурации , иллюстрирующий настройку контроллеров беспроводных локальных сетей (WLC) и облегченных точек доступа (LAP) для многоадресной передачи и взаимодействия с проводной сетью, в которой включена многоадресная передача.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Основные сведения о конфигурации точек LAPи контроллеров Cisco WLC

  • Знание того, как настроить базовую маршрутизацию и передающий в многоадресном режиме в проводной сети

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • WLC Cisco 4400, который выполняет микропрограмму версии 4.0

  • Облегченные точки доступа Cisco 1000 серии

  • Беспроводной клиентский адаптер Cisco 802.11a/b/g, использующий микропрограммное обеспечение версии 2.6

  • Маршрутизатор Cisco 2500, который выполняет Cisco Выпуск ПО IOS� 12.4 (2)

  • Два коммутатора серии "3500 XL" Cisco, которые выполняют программное обеспечение Cisco IOS версии 12.0(5) WC3b

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Групповая адресация в контроллерах беспроводной локальной сети (WLC)

Перед Выпуском ПО единой беспроводной сети Cisco (UWN) 3.2, когда групповая IP-адресация была включена, контроллер, отправленный пакеты групповой адресации беспроводной локальной сети (WLAN) клиенты путем создания копий пакетов групповой адресации, затем передал пакеты через туннель Протокола LWAPP индивидуальной рассылки к каждой точке доступа (AP), связанный с контроллером. Каждый многоадресный кадр, полученный контроллером от VLAN на первом маршрутизаторе перехода, был скопирован и передан по туннелю LWAPP каждому из AP, связанных с ним.

Контроллер, возможно, должен был бы генерировать до 300 копий каждого пакета групповой адресации, который зависит от количества AP. Этот механизм неэффективен, и размещает большую нагрузку обработки в контроллер. Это лавинно рассылает сеть с большим числом двойных одноадресных пакетов.

В Выпусках ПО единой беспроводной сети Cisco (UWN) 3.2 и позже, была оптимизирована производительность групповой адресации единой беспроводной сети Cisco (UWN). Эти версии представляют более эффективный способ освободить многоадресный трафик от контроллера до AP. Вместо того, чтобы использовать индивидуальную рассылку для отправки каждого пакета групповой адресации по туннелю LWAPP к каждому AP группа многоадресной рассылки LWAPP используется для отправки пакета групповой адресации каждому AP. Это позволяет маршрутизаторам в сети использовать стандартные способы групповой адресации, чтобы реплицировать и отправить пакеты групповой адресации AP. Для группы многоадресной рассылки LWAPP контроллер становится источником групповой адресации, и AP становятся получателями групповой адресации. Для технической характеристики групповой адресации AP признают, что Протокол IGMP делает запрос только от маршрутизатора и пакетов групповой адресации с IP - адресом источника контроллера, к которому они в настоящее время привязываются.

Если ваша сеть поддерживает пакетную групповую адресацию, можно настроить метод групповой адресации, который использует контроллер. Контроллер выполняет групповую адресацию в двух режимах:

  • Одноадресный режим — В этом режиме, контроллер одноадресно передает каждый пакет групповой адресации к каждому AP, привязанному к контроллеру. Этот режим неэффективен, но мог бы требоваться в сетях, которые не поддерживают групповую адресацию.

  • Режим многоадресной рассылки — В этом режиме, контроллер передает пакеты групповой адресации к группе многоадресной рассылки LWAPP. Этот метод уменьшает издержки на процессоре controller и смещает работу репликации пакетов к вашей сети, которая очень более эффективна, чем метод индивидуальной рассылки.

    Можно включить многоадресный режим с помощью графического интерфейса контроллера или CLI.

Поведение групповой адресации в других версиях программного обеспечения WLC

Перед релизом микропрограммы WLC 4.0.206.0, передача пакета групповой адресации включила или в одноадресном или многоадресном режиме, также включила передачу транслируемого пакета. В релизе микропрограммы WLC 4.0.206.0, широковещание и многоадресный трафик должны быть включены отдельно. Широковещание отключено по умолчанию. Выполните эту команду от CLI WLC для включения широковещания:

config network broadcast enable

Кроме того, широковещание использует многоадресный режим, который настроен на WLC, даже если переданный в многоадресном режиме не включен. Если вы хотите включить широковещание, не включая групповую адресацию, вы выполняете это через CLI, но не через GUI. Это вызвано тем, что вы не можете установить IP-адрес или режим, пока вы не включаете групповую адресацию в GUI. Поэтому, если многоадресный режим одноадресно передан и передан, включен, это - широковещательное использование режима (широковещательный трафик реплицирован и одноадресно передан к каждому AP). Если многоадресный режим собирается передать в многоадресном режиме с адресом групповой адресации, то переданное использование этот режим (каждый транслируемый пакет передается через группу многоадресной рассылки AP).

config network multicast mode multicast 
                           Or
config network multicast unicast

Групповая адресация с заменой AAA поддерживается от выпуска 4.2 Контроллера беспроводной локальной сети и позже. Необходимо позволить отслеживанию IGMP на контроллере заставить групповую адресацию работать с заменой AAA.

В выпуске ПО контроллера 4.2, отслеживание IGMP представлено лучшим прямым пакетам групповой адресации. Когда эта опция активирована, контроллер собирает отчеты IGMP от клиентов, обрабатывает отчёты, создает уникальные ID группы многоадресной рассылки (MGIDs) из отчетов IGMP после проверки адреса групповой адресации Уровня 3 и номера виртуальной локальной сети (VLAN), и передает отчеты IGMP к коммутатору инфраструктуры. Контроллер передает эти отчёты с адресом источника как интерфейсный адрес, на котором это получило отчёты от клиентов.

Контроллер тогда обновляет точку доступа таблица MGID на AP с MAC - адресом клиента. Когда контроллер получает многоадресный трафик для определенной многоадресной группы, это вперед это ко всем AP. Однако только те AP, которые имеют активных клиентов, слушающих или подписанный на ту группу многоадресной рассылки, передают многоадресный трафик на том определенном WLAN. Пакеты IP переданы с MGID, который уникален для входной VLAN и целевой группы многоадресной рассылки. Пакеты групповой адресации уровня 2 переданы с MGID, который уникален для входного интерфейса.

Примечание: Отслеживание IGMP не поддерживается на контроллерах серии 2000, контроллерах серии 2100 или Сетевом модуле контроллера беспроводной локальной сети Cisco для Cisco ISR.

Приложения групповой адресации знали ограничения производительности на контроллерах серии 2100 и Сетевом модуле контроллера беспроводной локальной сети Cisco для Cisco ISR. Cisco работает для адресации к этим ограничениям в будущем производственном релизе кода. Тем временем Cisco рекомендует использовать контроллеры серии 4400 или контроллеры WiSM для групповой адресации интенсивные приложения.

Примечание: Групповая адресация не поддерживается на AP, которые связаны непосредственно с локальным портом контроллера серии 2100.

См. главу Дизайна Групповой адресации унифицированной беспроводной связи Cisco руководства по дизайну Мобильности Предприятия для получения дополнительной информации о групповой адресации с WLC.

Этот документ предоставляет пример конфигурации, который иллюстрирует, как настроить групповую адресацию на WLC для соединения с включенной проводной сетью групповой адресации.

Беспроводной роуминг групповой адресации

Основная проблема для клиента многоадресной передачи в Беспроводной среде состоит в том, чтобы поддержать свое членство в группе многоадресной рассылки, когда перемещено WLAN. Заглядывает беспроводному соединению, которые перемещаются от ОТ AP К AP, может вызвать разрушение в приложении групповой адресации клиента. Протокол IGMP играет важную роль в обслуживании динамической информации о составе группы.

Базовое понимание IGMP важно для понимания то, что происходит с сеансом многоадресной передачи клиента, когда это перемещается о сети. В случае роуминга Уровня 2 сеансы поддержаны просто, потому что внешний AP, если настроено должным образом, уже принадлежит группе многоадресной рассылки, и трафик не туннелирован к другой точке привязки в сети. Среды роуминга уровня 3 немного более сложны этим способом, и, зависят, на какой туннелирующий режим вы настроили на своих контроллерах, на сообщения IGMP, передаваемые от беспроводного клиента, можно влиять. Мобильность по умолчанию, туннелирующая режим на контроллере, асимметрична. Это означает, что ответный трафик клиенту передан WLC привязки и затем передан внешнему WLC, где находится cвязанное клиентское соединение. Исходящие пакеты переданы внешний интерфейс WLC. В симметричной мобильности, туннелирующей режим, оба входящих и исходящих трафика туннелированы к якорному контроллеру.

Рекомендации для Использования режима многоадресной рассылки

Используйте эти рекомендации при включении многоадресного режима в сети:

  • Решение для единой беспроводной сети Cisco (UWN) использует некоторые Диапазоны IP-адресов в определенных целях. Помните эти диапазоны при настройке группы многоадресной рассылки:

    Несмотря на то, что не рекомендуемый, любой адрес групповой адресации может быть назначен на группу многоадресной рассылки LWAPP; это включает зарезервированную ссылку локальные адреса групповой адресации, используемые OSPF, EIGRP, PIM, HSRP и другими протоколами групповой адресации.

    Cisco рекомендует, чтобы адреса групповой адресации были назначены от административно ограниченного по объему блока 239/8. IANA резервировал диапазон 239.0.0.0-239.255.255.255 как административно адреса областей действия для использования в частных доменах групповой адресации. Посмотрите примечание для дополнительных ограничений. Эти адреса подобны по своей природе зарезервированным частным IP диапазонам индивидуальной рассылки, таковы как 10.0.0.0/8, определенный в RFC 1918. Администраторы сети свободны использовать адреса групповой адресации в этом диапазоне в их домене без страха перед конфликтом с другими в другом месте в Интернете. Это административное или частное пространство адресов должно использоваться в предприятии и его выходе или записи, заблокированной от автономного домена (AS).

    Примечание: Не используйте 239.0.0. X диапазонов адресов или 239.128.0. X диапазонов адресов. Адреса в этих диапазонах накладываются на локальные MAC - адреса ссылки и хлынули все порты коммутатора, даже на включенное отслеживание IGMP.

    Cisco рекомендует, чтобы администраторы корпоративной сети далее подразделили этот диапазон адресов на меньшие географические административные области в корпоративной сети для ограничения "области" определенных приложений групповой адресации. Это препятствует тому, чтобы высокоскоростной многоадресный трафик покинул кампус (где пропускная способность многочисленна), и переполнение каналов WAN. Это также обеспечивает эффективную фильтрацию групповой адресации высокой пропускной способности от достижения контроллера и беспроводной сети. Для получения дополнительной информации об адресе групповой адресации рекомендации обратитесь к Рекомендациям для Выделения Адреса групповой IP-адресации Предприятия.

  • При включении многоадресного режима на контроллере необходимо настроить адрес группы многоадресной рассылки LWAPP на контроллере. AP подписываются на группу многоадресной рассылки LWAPP с помощью Протокола IGMP.

  • Cisco 1100, 1130, 1200, 1230, и 1240 AP использует Версии IGMP 1, 2, и 3. Однако AP Серии Cisco 1000 используют только v1 IGMP для присоединения к группе многоадресной рассылки.

  • Режим многоадресной рассылки работает только в режиме LWAPP Уровня 3.

  • AP в режиме отслеживания, режиме анализатора или постороннем режиме детектора не присоединяются к адресу группы многоадресной рассылки LWAPP.

  • Когда вы используете контроллеры, которые выполняют версию 4.1 или ранее, можно использовать тот же адрес групповой адресации на всех контроллерах. При использовании контроллеры, которые выполняют версию 4.2 или позже, группа многоадресной рассылки LWAPP, настроенная на контроллерах, должна быть другой для каждого контроллера, используемого в сети.

  • При использовании контроллеров с версией 4.1 или ранее многоадресный режим не работает через события mobility межподсети, такие как гостевое туннелирование, определяемые узлом VLAN, или взаимодействует замена, которая использует RADIUS. Многоадресный режим действительно работает в этих событиях mobility подсети при отключении отслеживания IGMP Уровня 2 / функции CGMP на проводной LAN.

    В более поздних версиях, т.е. 4.2 или позже, многоадресный режим не работает через события mobility межподсети, такие как гостевое туннелирование. Это действительно, однако, работает с интерфейсными заменами, которые используют RADIUS (но только когда отслеживание IGMP включено), и с определяемыми узлом VLAN (VLAN группы точек доступа).

  • Контроллер отбрасывает любые пакеты групповой адресации, передаваемые Номерам порта UDP 12222, 12223, и 12224. Удостоверьтесь, что приложения групповой адресации в вашей сети не используют те номера портов.

  • Многоадресный трафик передан в 6 Мбит/с в 802.11a сеть. Поэтому, если несколько WLAN пытаются передать в 1.5 Мбит/с, потеря пакета происходит. Это ломает сеанс многоадресной передачи.

Настройка сети

В этой настройке проводная сеть состоит из этих трех маршрутизаторов, R1, R2 и R3, того OSPF выполнения между ними.

Проводные узлы соединяются с сетью через Коммутатор уровня 2, который связан с маршрутизатором R1. Беспроводная сеть соединяется с сетью через маршрутизатор R3, как показано в схеме.

Устройства должны быть настроены для базового IP - подключения и позволить передать в многоадресном режиме в сети. Поэтому пользователи могут передать и получить многоадресный трафик с проводной стороны до беспроводной стороны и наоборот.

Этот документ использует эти IP-адреса для WLC, LAP и беспроводных клиентов:

WLC Management Interface IP address: 172.16.1.30/16
WLC AP Manager Interface IP address: 172.16.1.31/16
LAP IP address: 172.16.1.50/16
Wireless Client C1 IP address: 172.16.1.75/16
Wireless Client C2 IP address: 172.16.1.76/16
Wired Client W1 IP address: 192.168.0.20/16
Wired Client W2 IP address: 192.168.0.30/16
Wired Client W3 IP address: 192.168.0.40/16

/image/gif/paws/81671/multicast-wlc-lap1.gif

Настройка

Для настройки устройств для этой настройки они должны быть выполнены:

Настройте беспроводную сеть для групповой адресации

Перед настройкой групповой адресации на WLC необходимо настроить WLC для главной операции и зарегистрировать облегченные точки доступа на контроллере. Этот документ предполагает, что WLC настроен для главной операции и что LAP зарегистрированы к WLC. Если вы - новый пользователь, пытающийся устанавливать WLC для главной операции с LAP, обратитесь к регистрации облегченных точек доступа к Контроллеру беспроводной локальной сети (WLC).

Примечание: Не используйте 239.0.0. X или 239.128.0. X диапазонов адресов. Адреса в этих диапазонах накладываются с локальными MAC - адресами ссылки и лавинной рассылкой на все порты коммутатора, даже с включенным отслеживанием IGMP. См. раздел Адресов групповой адресации Уровня 2 Обзора технологии многоадресной передачи IP для получения дополнительной информации о перекрывающихся MAC-адресах групповой адресации.

Как только LAP зарегистрированы к WLC, выполняют эти задачи для настройки LAP и WLC для этой настройки:

  1. Настройте WLAN для клиентов

  2. Включите режим многоадресной рассылки Ethernet через GUI

Настройте WLAN для клиентов

Первый шаг, создают WLAN, к которому беспроводные клиенты могут соединиться с и получить доступ к сети. Выполните эти шаги для создания WLAN на WLC:

  1. Нажмите WLANs в графическом интерфейсе контроллера для создания WLAN.

  2. Нажмите New для настройки новой WLAN.

    В данном примере WLAN называют MulticastUsers, и ИДЕНТИФИКАТОР WLAN равняется 1.

    /image/gif/paws/81671/multicast-wlc-lap2.gif

  3. Щелкните "Применить".

  4. В окне WLAN > Edit укажите параметры сети.

    1. Для WLAN выберите соответствующий интерфейс из поля Interface Name.

      Данный пример сопоставляет интерфейс управления с WLAN.

    2. Выберите другие параметры, который зависит от требований к проектированию.

      Значения по умолчанию используются в данном примере.

    3. Щелкните "Применить".

      multicast-wlc-lap3.gif

      Примечание: В данном примере не используются методы безопасности уровня 2 для аутентификации пользователей беспроводной связи. Поэтому в поле обеспечения безопасности уровня 2 выберите None. Параметр обеспечения безопасности уровня 2 установлен на 802.1x по умолчанию.

      Примечание: Вместо того, чтобы сопоставить WLAN (SSID) с интерфейсом управления, динамические интерфейсы могут также быть настроены на WLC для сегментации пользователей беспроводной связи, и WLAN может быть сопоставлен с динамическими интерфейсами. См. VLAN на Примере конфигурации Контроллеров беспроводной локальной сети для получения информации о том, как настроить динамические интерфейсы на WLC.

Выполните эти команды для настройки WLAN на WLC с помощью CLI:

  1. Config wlan create <wlan-id> <wlan-name>, чтобы создать новую WLAN. Для wlan-идентификатора введите идентификатор от 1 до 16. Для имени WLAN введите SSID до 31 алфавитно-цифрового знака.

  2. Config wlan enable <wlan-id>, чтобы включить WLAN.

    Для примера в этом документе команды:

    config wlan create 1 MulticastUsers
    config wlan enable 1
    

Включите режим многоадресной рассылки Ethernet через GUI

Следующий шаг должен настроить WLC для групповой адресации. Выполните следующие действия:

  1. От веб-страницы генерального инспектора гарантируйте, что транспортный режим LWAPP установлен в Уровень 3.

    Техническая характеристика групповой адресации работает только в этом режиме.

    /image/gif/paws/81671/multicast-wlc-lap4.gif

    Примечание: Когда включено широковещание в одноадресном режиме, каждая точка доступа получает по отдельной копии пакета; это значительно нагружает процессор, так что будьте осторожны. Групповая адресация включила, как передано в многоадресном режиме, групповая адресация использует назначенный адрес групповой адресации пользователя для убирания более традиционной групповой адресации к AP.

  2. От раскрывающегося меню для режима многоадресной рассылки Ethernet выберите Multicast и введите Адрес группы многоадресной рассылки.

    В данном примере адрес 239.255.1.60.

    /image/gif/paws/81671/multicast-wlc-lap7.gif

  3. Щелкните "Применить".

    Примечание: WLC 4100 не поддерживает многоадресный режим. Групповая адресация только сделана в одноадресном режиме. Это означает, что контроллер должен реплицировать пакет групповой адресации для каждого AP и одноадресно передать пакет групповой адресации к каждому из AP.

    Выполните эти команды для включения групповой адресации через CLI:

    1. Из командной строки выполните команду config network multicast global enable.

    2. Из командной строки выполните команду <multicast-group-ip-address> config network multicast mode multicast.

      Для примера в этом документе команды:

      config network multicast global enable
      config network multicast mode multicast 239.255.1.60
      

После того, как администратор включает групповую адресацию (многоадресный режим отключен по умолчанию), и настраивает группу многоадресной рассылки LWAPP, новый алгоритм групповой адресации работает одним из этих способов:

Когда источник группы многоадресной рассылки находится на проводной LAN:

AP LWAPP загружают адрес группы многоадресной рассылки LWAPP контроллера во время обычного процесса соединения (во время начальной загрузки) к контроллеру. После того, как AP присоединяется к контроллеру и загружает его конфигурацию, AP выполняет запрос IGMP для присоединения к группе многоадресной рассылки LWAPP контроллера. Это инициирует обычную настройку для состояния групповой адресации в поддерживающих групповую адресацию маршрутизаторах между контроллером и AP. IP - адрес источника для группы многоадресной рассылки является интерфейсом управления контроллера IP address, не IP-адресом AP - диспетчера, используемым для режима Уровня 3.

Когда контроллер получает пакет групповой адресации от любой из клиентских VLAN на первом маршрутизаторе перехода, он передает пакет к группе многоадресной рассылки LWAPP через интерфейс управления на самом низком уровне QoS. Биты QoS для пакета групповой адресации LWAPP жестко закодированы на самом низком уровне и не могут быть изменены пользователем.

Поддерживающая групповую адресацию сеть отправляет пакет групповой адресации LWAPP каждому из AP, которые присоединились к группе многоадресной рассылки LWAPP. Поддерживающие групповую адресацию использования сети обычные механизмы групповой адресации в маршрутизаторах для репликации пакета по пути, по мере необходимости, так, чтобы пакет групповой адресации достиг всех AP. Это уменьшает контроллер от репликации пакетов групповой адресации.

AP могут получить другие пакеты групповой адресации, но обработать только пакеты групповой адресации, которые прибывают от контроллера, до которого к ним в настоящее время присоединяются. От любых других копий сбрасывают. Если несколько SSID WLAN привязаны к VLAN от того, куда исходный пакет групповой адресации передавался, AP передает пакет групповой адресации по каждому SSID WLAN (после к битовому массиву WLAN в заголовке LWAPP). Кроме того, если тот SSID WLAN находится по обоим радио (802.11g и 802.11a), оба радио передают пакет групповой адресации на SSID WLAN, если существуют клиенты, привязанные к нему, даже если те клиенты не запрашивали многоадресный трафик.

Когда источник группы многоадресной рассылки является беспроводным клиентом:

Пакет групповой адресации одноадресно передан (инкапсулировавший LWAPP) с AP на контроллер, подобный стандартному трафику беспроводного клиента.

Контроллер делает две копии пакета групповой адресации. Одна копия отослана VLAN, привязанная к SSID WLAN, в который это поступило. Это позволяет приемникам на проводной LAN получить многоадресную рассылку и маршрутизатор для обучения о новой группе многоадресной рассылки. Вторая копия пакета инкапсулируется LWAPP и передается группе многоадресной рассылки LWAPP так, чтобы беспроводные клиенты могли получить многоадресную рассылку.

Настройте проводную сеть для групповой адресации

Для настройки проводной сети для этой настройки необходимо настроить подключение маршрутизаторов для основы и позволить передать в многоадресном режиме в проводной сети.

Как отмечалось ранее, OSPF используется в качестве протокола одноадресной маршрутизации.

Любой протокол групповой адресации может использоваться в проводной сети. Этот документ использует PIM-DM в качестве протокола групповой адресации. См. Руководство по конфигурации Групповой IP-адресации Cisco IOS для получения дальнейшей информации на других протоколах, которые могут использоваться для групповой адресации в проводной сети.

Это конфигурации для маршрутизаторов R1, R2 и R3:

Маршрутизатор М1
RouterR1#show run
Building configuration...

Current configuration : 836 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterR1
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 ip address 192.168.0.1 255.255.0.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

 ip cgmp

!--- Enables Cisco Group Management Protocol (CGMP) on the interface 
!--- connected to the Layer 2 switch.

!
interface Serial0
 description Connected to RouterR2
 ip address 10.2.3.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR3
 ip address 10.2.4.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial2
 no ip address
 shutdown
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
 !
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Маршрутизатор М2
RouterR2#show run
Building configuration...

Current configuration : 616 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterR2
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 description Connnected to RouterR3
 ip address 10.2.2.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR1
 ip address 10.2.3.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Маршрутизатор R3
RouterR3#show run
Building configuration...

Current configuration : 711 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterR3
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 ip address 172.16.1.1 255.255.0.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

 ip cgmp

!--- Enables Cisco Group Management Protocol (CGMP) on the interface 
!--- connected to the Layer 2 switch.

 
!
interface Serial0
 description Connected to RouterR2
 ip address 10.2.2.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR1
 ip address 10.2.4.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 10.0.0.0 0.255.255.255 area 0
!
ip classless
ip http server
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Для Коммутаторов уровня 2 никакая конфигурация не требуется для групповой адресации. Всем на основе IOS Коммутаторы уровня 2 включили CGMP по умолчанию. Поэтому коммутаторы автоматически обрабатывают сообщения CGMP от маршрутизаторов.

Проверка и устранение неполадок

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Если многоадресный трафик течет через проводную сеть и достигает проводных и беспроводных элементов группы, W2, C1 и C2, для проверки конфигурации необходимо передать многоадресный трафик от источника W1 и проверка.

Выполните эту задачу, чтобы протестировать, если групповая IP-адресация настроена правильно в вашей сети.

Если весь с поддержкой многоадресного трафика маршрутизаторы являются участниками группы многоадресной рассылки, пропинговывание той группы заставляет все маршрутизаторы отвечать, который может быть полезным административным и средством отладки.

Другая причина иметь маршрутизатор присоединяется, группа многоадресной рассылки - когда другие хосты в сети имеют конфигурацию Протокола IGRP, которая предотвращает их от корректного ответа на запросы IGMP. Когда у вас есть соединение маршрутизатора группа многоадресной рассылки, это заставляет вышестоящие маршрутизаторы поддерживать информацию о таблице многоадресной маршрутизации для той группы и поддерживать пути для той группы активными. Для настройки маршрутизатора, чтобы быть частью группы многоадресной рассылки, выполните эту команду от режима конфигурации интерфейса:

ip igmp join-group <group-address> 
Example: Router(config-if)#ip igmp join-group 239.255.1.60

Вот выходные данные эхо-запроса от маршрутизатора R3:

RouterR3#ping 239.255.1.60

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.255.1.60, timeout is 2 seconds:

Reply to request 0 from 10.2.2.2, 40 ms
Reply to request 0 from 10.2.3.1, 84 ms
Reply to request 0 from 10.2.4.1, 44 ms

Определение местоположения неисправного перехода

Выполните эту задачу, чтобы контролировать и диагностировать основную конфигурацию групповой IP-адресации. Когда получатель и источник не работают как ожидалось, можно использовать эту процедуру.

/image/gif/paws/81671/multicast-wlc-lap6.gif

Вот выходные данные команд show ip igmp membership и show ip mroute count для примера конфигурации. Эти выходные данные были взяты от маршрутизатора R3.

RouterR3#sh ip igmp membership
Flags: A  - aggregate, T - tracked
       L  - Local, S - static, V - virtual, R - Reported through v3
       I - v3lite, U - Urd, M - SSM (S,G) channel
       1,2,3 - The version of IGMP the group is in
Channel/Group-Flags:
       / - Filtering entry (Exclude mode (S,G), Include mode (*,G))
Reporter:
       <ip-address> - last reporter if group is not explicitly tracked
       <n>/<m>      - <n> reporter in include mode, <m> reporter in exclude

 Channel/Group                  Reporter        Uptime   Exp.  Flags  Interface
 *,224.0.1.40                   10.2.2.1        1d21h    stop  2LA    Se0
 *,239.255.1.60                    172.16.1.1      1d06h    02:17 1LA    Et0
RouterR3#sh ip mroute count
IP Multicast Statistics
5 routes using 3094 bytes of memory
2 groups, 1.50 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 239.255.1.60, Source count: 3, Packets forwarded: 6860, 
Packets received: 7087
  Source: 172.16.1.30/32, Forwarding: 304/1/147/0, Other: 304/0/0
  Source: 172.16.1.75/32, Forwarding: 6329/8/57/3, Other: 6329/0/0
  Source: 192.168.0.20/32, Forwarding: 227/1/69/0, Other: 454/227/0

Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0

От этих выходных данных вы видите, что многоадресный трафик вытекает из источника W1 и получен элементами группы.


Дополнительные сведения


Document ID: 81671