Технологии LRE и xDSL : Поддержка асимметричных цифровых абонентских линий (ADSL)

Руководство по настройке, поиску и устранению неполадок маршрутизатора Cisco DSL Router – Cisco DSL Router, работающий в качестве клиента PPPoE со статическим IP-адресом

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Интернет-провайдер (ISP) назначил одиночный статический открытый IP - адрес на Маршрутизатор Цифровой абонентской линии (DSL) Cisco.

Совет: Если вы не знакомы с тем, как настроить устройства Сisco и хотели бы придерживаться пошаговой конфигурации, обратитесь к пошаговой Конфигурации PPPoE со Статическим IP - адресом.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Задачи для выполнения

  • Дизайн схема IP-адресации для частной локальной сети (LAN).

  • Настройте IP-адрес, маску подсети и корректировку Maximum Segment Size (MSS) TCP на Интерфейсе Ethernet маршрутизатора Cisco DSL.

  • Настройте ATM-интерфейс (интерфейс Ассиметричной цифровой абонентской линии (ADSL)) маршрутизатора Cisco DSL с постоянной виртуальной цепью (PVC) ATM и инкапсуляцией.

  • Настройте группу действительной Сети передачи данных общего пользования (VPDN) Протокола PPPoE для Cisco программное обеспечение IOS� позже, чем 12.2 (13) T.

  • Создайте и настройте Интерфейс номеронабирателя маршрутизатора Cisco DSL для PPPoE со статическим IP - адресом.

  • Для Технологии NAT: Настройте NAT на маршрутизаторе Cisco DSL, чтобы позволить совместно использовать динамического открытый IP-адреса Интерфейса номеронабирателя.

    • Дополнительно: Пул NAT, если дополнительные IP-адреса были предоставлены интернет-провайдером.

    • Дополнительно: Статический NAT, если интернет-пользователи требуют доступа к внутренним серверам.

  • Настройте каждого ПК - клиента с IP-адресом, маской подсети, шлюзом по умолчанию и сервером (ами) Системы доменных имен (DNS).

    Для Протокола DHCP (динамического конфигурирования узла): Также, если вы хотите, чтобы маршрутизатор Cisco DSL назначил динамические IP - адреса ПК - клиентов, настройте каждый ПК для получения IP-адреса и сервера (ов) DNS автоматически через DHCP.

Возможные обязательные шаги настройки конфигурации на ПК

Если поддержки программного обеспечения маршрутизатора Cisco DSL ip tcp adjust-mss 1452 или IP adjust-mss 1452 команды настройки, никакие дальнейшие действия не необходимы, и можно продолжить Настраивать раздел.

Если программное обеспечение маршрутизатора Cisco DSL не поддерживает ip tcp adjust-mss 1452 или IP adjust-mss 1452 команды настройки, необходимо изменить максимальный размер передаваемого блока данных (MTU) на каждом ПК в LAN, которая имеет доступ к Интернету через маршрутизатор Cisco DSL. Выполните эти шаги для изменения максимального размера передаваемого блока данных.

  1. Загрузите последнюю версию утилиты Dr. TCP Доктора от http://www.dslreports.com/front/drtcp.html leavingcisco.com.

  2. Обновите страницу браузера, чтобы гарантировать, что страница является текущей.

  3. Выполните утилиту Dr. TCP Доктора.

  4. Из меню выбирают Адаптер ethernet.

  5. В поле MTU введите 1492.

  6. Нажмите кнопку "Apply" для сохранения изменений, после чего нажмите кнопку "Exit".

  7. Перезагрузите ПК - клиента PPPoE.

Когда процедура заканчивается, изменение в реестре сохранено. Поэтому только необходимо выполнить утилиту один раз на пк.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Конфигурации

Совет: Если вы не знакомы с тем, как настроить устройства Сisco и хотели бы придерживаться пошаговой конфигурации, обратитесь к пошаговой Конфигурации PPPoE со Статическим IP - адресом.

Маршрутизатор Cisco DSL со статическим IP - адресом

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
vpdn enable
 no vpdn logging
  vpdn-group pppoe
   request-dialin
    protocol pppoe

!--- These commands are needed only on Cisco IOS Software earlier than than 12.2(13)T.

!
!
ip subnet-zero
!

!--- For DHCP:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server> 
!
interface ethernet0  
 no shut  
 ip address <ip address> <subnet mask> 
 ip tcp adjust-mss 1452 
 
!--- If the ip tcp adjust-mss 1452 command is not supported, try this
 !--- configuration statement: ip adjust-mss 1452. If this command is not
 !--- supported in your current Cisco DSL Router software release, upgrade to the 
 !--- latest Cisco DSL Router software or follow the procedure in the
 !--- "Possible Required Configuration Steps on the PC" section of this document. 


!--- For NAT:

 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no ip address
 bundle-enable
 dsl operating-mode auto
!
interface atm0.1 point-to-point
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
  pppoe-client dial-pool-number 1
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!
interface dialer1
 ip address <ip address> <subnet mask>
 mtu 1492

!--- For NAT:

 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname <username>
 ppp chap password <password>
 ppp pap sent-username <username> password <password>
!

!--- For NAT:

ip nat inside source list 1 interface dialer1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface dialer1 overload

 
 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!---  <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless
ip route 0.0.0.0 0.0.0.0 interface dialer1

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Обратитесь к Устранению проблем PPPoE-клиента маршрутизатора Cisco DSL, если услуга DSL не работает должным образом.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 71122