Технологии LRE и xDSL : Поддержка асимметричных цифровых абонентских линий (ADSL)

Руководство по настройке и устранению неисправностей для маршрутизатора Cisco DSL - IRB со статическим IP-адресом

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Ваш интернет-провайдер (ISP) назначил статический открытый IP - адрес на ваш маршрутизатор Cisco DSL.

Совет: Если вы не знакомы с тем, как настроить устройства Сisco и хотели бы придерживаться пошаговой конфигурации, обратитесь к Пошаговой Конфигурации IRB со Статическим IP - адресом.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Задачи для выполнения

Примечание: Данный пример выделяет два типа конфигураций:

  • DHCP-сервер

  • !--- преобразования сетевых адресов (NAT).

Задачи выполнить:

  • Разработайте схему IP-адресации для своей частной локальной сети (LAN).

  • Настройте IP-адрес и маску подсети на Интерфейсе Ethernet маршрутизатора Cisco DSL.

  • Настройте ATM-интерфейс (интерфейс Ассиметричной цифровой абонентской линии (ADSL)) маршрутизатора Cisco DSL с постоянной виртуальной цепью (PVC) ATM и инкапсуляцией.

  • Включите Integrated routing and bridging (IRB).

  • Создайте и настройте Виртуальный интерфейс группы мостовой передачи (BVI) маршрутизатора Cisco DSL для IRB со статическим IP - адресом.

  • Для NAT: Настройте NAT на маршрутизаторе Cisco DSL, чтобы позволить совместно использовать статического открытого IP - адреса интерфейса BVI.

    • Дополнительно: Пул NAT, если дополнительные IP-адреса были предоставлены вашим интернет-провайдером.

    • Дополнительно: Статический NAT, если интернет-пользователи требуют доступа к внутренним серверам.

  • Настройте каждый ПК хоста с IP-адресом, маской подсети, шлюзом по умолчанию и сервером (серверами) Системы доменных имен (DNS).

    Для Сервера DHCP: Также, если вы хотите, чтобы маршрутизатор Cisco DSL назначил динамические IP - адреса вашего ПК - клиента, настройте каждый ПК для получения IP-адреса и сервера (серверов) DNS автоматически через DHCP.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

!--- конфигурацию

Совет: Если вы не знакомы с тем, как настроить устройства Сisco и хотели бы придерживаться пошаговой конфигурации, обратитесь к Пошаговой Конфигурации IRB со Статическим IP - адресом.

Маршрутизатор Cisco DSL со статическим IP - адресом

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
!
bridge irb
!
ip subnet-zero
!

!--- For DHCP Server:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>

!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>
 
!--- For NAT:


 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
 bridge-group 1
!
interface bvi1
 ip address <ip address> <subnet mask>

!--- For NAT:


 ip nat outside
 no ip directed-broadcast
!

!--- For NAT:


ip nat inside source list 1 interface bvi1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface bvi1 overload
!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!--- netmask <subnet mask>



!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!---  <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:


access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, the configuration of  
!--- access-list 1 permit 10.10.10.0 0.0.0.255 allows NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
bridge 1 protocol ieee
 bridge 1 route ip
!
end

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

См. Устранение проблем Мостового соединения RFC1483 с IRB, если ваш сервис ADSL не работает должным образом.

Возвратитесь к предыдущей странице этого руководства конфигурации и устранения проблем - Мостовое соединение RFC1483 с Параметрами реализации IRB.

Возвратитесь к главной странице руководства по настройке и устранению проблем для маршрутизатора Cisco DSL.


Дополнительные сведения


Document ID: 71103