Беспроводные сети / Мобильные решения : Безопасность беспроводных сетей

Пример настройки беспроводного маршрутизатора 1800 ISR с внутренним DHCP-сервером и открытой аутентификацией

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации беспроводной локальной сети (WLAN) на Маршрутизаторе ISR (ISR) Cisco 1800.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • ISR 1800 года на Cisco Выпуск ПО IOS� 12.3 или позже с Усовершенствованным набором функций IP-сервисов

    Примечание: Можно применить одинаковую конфигурацию к любому из ISR. Конфигурация не является определенной для серии 1800.

  • ПК с этими картами беспроводной сети:

    • 802.11a

    • 802.11b

    • A/b/g 802.11b/g

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

Беспроводное соединение к маршрутизатору

1800_isr_wireless1.gif

!--- конфигурацию

Пошаговые инструкции

Выполните следующие действия:

  1. Установите область DHCP и исключенные адреса.

    Примечание: Исключенные адреса являются дополнительными.

    См. сервер DHCP в Cisco IOS для большего количества подробного объяснения сервера DHCP в программном обеспечении Cisco IOS.

  2. Включите интегрированную маршрутизацию и соединение при помощи мостов и установите группу мостов.

  3. Назначьте IP-адрес взаимодействовать Виртуальный интерфейс мостовой группы 1 (BVI1).

  4. Установите радио.

    1. Назначьте интерфейсный Dot11Radio0 или Dot11Radio1 к группе мостов 1.

    2. Назначьте идентификатор набора сервисов (SSID) на радиоинтерфейс, и затем определите открытую аутентификацию.

!--- конфигурацию

В данном документе используется следующая конфигурация:

Беспроводные сети ISR серии 1800 и конфигурация DHCP
1800-ISR#show running-config 
 Building configuration...
 .
 .
!
hostname 1800-ISR
!

!--- Output suppressed.

!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.2.1 192.168.2.100

!--- This sets up DHCP and excluded addresses. Excluded addresses are optional.

!
ip dhcp pool 1800-ISR
   network 192.168.2.0 255.255.255.0
!
!
bridge irb

!--- Turn on integrated routing and bridging.

!
!
interface Dot11Radio0

!--- This is the wireless radio interface configuration.

 no ip address
 !
 ssid Cisco

!--- Here, the SSID is given as "Cisco".
  
    authentication open 

!--- This defines the authentication as open.

 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
!
interface BVI1
 ip address 192.168.2.1 255.255.255.0
!
ip classless
!

!--- Note: Configure the bridge 1 protocol IEEE and the bridge 1 route IP 
!--- before you create interface BVI1 or add the radio interface to bridge group 1.

!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Используйте эти команды для проверки надлежащего DHCP и беспроводной работы:

  • show dot11 associations

  • show ip dhcp binding

MAC и IP-адреса должны совпасть в выходных данных команды show dot11 associations и выходных данных команды show ip dhcp binding. Например:

1800-ISR#show dot11 associations

802.11 Client Stations on Dot11Radio0: 

SSID [Cisco] : 

MAC Address��� �IP address����� Device������� ���Name����������Parent�������� State��� �
0040.96ac.345c  192.168.2.101�� CB21AG/PI21AG��� WLCLIENT� ��� self���������� Associated
!

!--- Output suppressed.

!
1800-ISR#show ip dhcp binding 
Bindings from all pools not associated with VRF:
IP address��������� Client-ID/������������� Lease expiration������ Type
���������������������Hardware address/
���������������������User name
192.168.2.101��     0100.4096.ac34.5c������ Dec 18 2005 05:07 PM�� Automatic
1800-ISR#

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Команда устранения проблем

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

Выполните команду debug ip dhcp server packet для отладки IP DHCP server. С незашифрованным WLAN открытой проверки подлинности эта команда предоставляет самое быстрое и большую часть эффективного способа для устранения проблем.

Команда debug ip dhcp server packet показывает эти трансакции данных:

/image/gif/paws/68099/1800_isr_wireless2.gif

Эти выходные данные команды debug ip dhcp server packet являются примером успешного запроса DHCP:

1800-ISR#debug ip dhcp server packet

*Dec 17 15:40:50.379: DHCPD: DHCPREQUEST received from client 0100.4096.ac34.5c.
!

!--- This shows the client DHCP discover packet that is sent to the router.

!
*Dec 17 15:40:50.379: DHCPD: No default domain to append - abort update
*Dec 17 15:40:50.379: DHCPD: Sending DHCPACK to client 0100.4096.ac34.5c (192.168.2.101)
!

!--- This shows the router DHCP acknowledgment (ACK) that is sent back to the client.

!
*Dec 17 15:40:50.379: DHCPD: creating ARP entry (192.168.2.101, 0040.96ac.345c).
*Dec 17 15:40:50.379: DHCPD: unicasting BOOTREPLY to client 0040.96ac.345c (192.168.2.101)

Процедура устранения неполадок

Если вы не видите предложение DHCP в выходных данных команды debug ip dhcp server packet, начинаете устранять неполадки протокола 802.11. Выполните следующие действия:

  1. Проверьте параметры настройки беспроводного клиента, SSID и никакую безопасность/настройку шифрования.

    Примечание: SSID должен быть тем же в ISR и клиентах. В этом случае SSID является "Cisco". Рисунок 1 и рисунок 2 показывают параметры настройки SSID и в утилите Cisco Aironet Desktop Utility (ADU) и в Aironet Client Utility (ACU). Окно, которое вы видите, зависит от клиентской беспроводной карты и версий микропрограммы, которые вы используете.

    Рисунок 1 – параметры настройки SSID ADU Cisco

    1800_isr_wireless3.gif

    Рисунок 2 – параметры настройки SSID Cisco ACU

    1800_isr_wireless4.gif

    Рисунок 3 – Windows Wireless Zero Settings

    /image/gif/paws/68099/1800_isr_wireless5.gif

  2. Проверьте совместимость Wi-Fi.

    См. leavingcisco.comстраницу Wi-Fi Alliance для проверки совместимости Wi-Fi интерфейсной карты беспроводной сети (NIC), который используется.

  3. Обратитесь в техническую поддержку Cisco для дальнейшей технической поддержки.


Дополнительные сведения


Document ID: 68099