Голосовая связь : Протокол MGCP

Настройка PRI-магистралей Q.SIG между Call Manager и Avaya S8700/G650 с интеграцией голосовой почты Unity

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (11 ноября 2015) | Отзыв


Содержание


Введение

Цель этого документа состоит в ознакомлении заказчиков Cisco и деловых партнеров Cisco с порядком действий для настройки PRI-магистралей Q.SIG между Cisco Call Manager и Avaya S8700/G650. Кроме того, в этом документе излагается подробный порядок действий для добавления Cisco Unity на платформе Cisco Call Manager для реализации поддержки голосовой почты для IP-телефонов Cisco и Avaya. Это особенно важно в ситуациях, где требуется функциональная совместимость с IP-АТС и интеграция голосовой почты. Снимки окна конфигурации Avaya созданы с помощью стандартного средства эмуляции. В качестве альтернативы можно также использовать программное средство администрирования узла Avaya (ASA) для задач конфигурации на Avaya S8700/G650. Выходные данные на экране в обоих случаях совпадают. Этот документ о функциональной совместимости и интеграции голосовой почты с IP-АТС предназначен для внешнего распространения.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Используемая система IP-PBX Avaya является Avaya S8700/G650 рабочий диспетчер связи Avaya 2.0. Набор функций Q.SIG прибывает стандарт с этой версией программного обеспечения.

  • IP-телефоны Avaya, используемые в этом документе, 4610SW и 4620 рабочих Телефонных Версий микропрограммы 2.01.

  • Cisco Call Manager 4.1. (2) использовался для управления 3745 шлюзами Протокола MGCP с модулем NM-HDV, рабочий Cisco версия 12.2.15ZJ3 IOS�. Тесты были также повторены с Cisco версия 12.3.8. T5 IOS�.

  • Рабочая версия 4.0 (4) SR1 Cisco Unity использовалась для тестирования интеграции голосовой почты.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Контрольная настройка

Используемая система IP-PBX Avaya была Avaya S8700/G650 рабочий диспетчер связи Avaya 2.0. Набор функций Q.SIG прибывает стандарт с этой версией программного обеспечения. Используемые Телефоны AvayaIP были 4610SW и 4620 рабочих Телефонных Версий микропрограммы 2.01. На стороне Cisco Cisco Call Manager 4.1.2 использовался для управления 3745 шлюзами MGCP с модулем NM-HDV, рабочий Cisco версия 12.2.15ZJ3 IOS�. Тесты были также повторены с Cisco версия 12.3.8. T5 IOS�. Рабочая версия 4.0 (4) SR1 Cisco Unity использовалась для тестирования интеграции голосовой почты.

Проверка топологии

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-top.gif

Совместимость между Cisco и системами IP-PBX Avaya

Следующие разделы предоставляют процедуры и снимки экрана, чтобы помочь вам настраивать транк Q.SIG между Avaya S8700/G650 рабочий диспетчер связи Avaya 2.0 и платформой Cisco Call Manager рабочая версия 4.1 (2) Call Manager с устройством MGCP Cisco 3745, которое предоставляет физическое соединение ISDN PRI Avaya S8700/G650.

Процедура в системе IP-PBX Avaya S8700/G650

Выполните следующие действия:

  1. Вход в систему к серверу S8700. Выполните команду display system-parameters customer, чтобы гарантировать, что все необходимые опции Q.SIG активированы на сервере S8700.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-proced1.gif

  2. Настройте ДВУХСТОРОННЮЮ ДИСКЕТУ 1 карта для PRI Q.SIG.

    2.gif

  3. Настройте группу транков. Тип добавляет trunk-group #, где # является требуемым транком.

    Следующие три снимка экрана касаются конфигурации магистрали. Как только группа транков создана, добавьте 23 канала DS0 к группе. Это - пример назначения порта: средства 01A0901: Gateway# 1, Корпус A, Slot# 9, DS0 channel# group1.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-3.gif

    4.gif

    5.gif

  4. Добавьте сигнальную группу и точку к группе транков, созданной ранее.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-6.gif

  5. Добавьте шаблон маршрута и укажите его к сигнальной группе. В данном примере, шаблон маршрута 4 точки к сигнальному group# 1, который был создан в шаге 4.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-7.gif

  6. Добавьте запись в таблицу AAR для использования шаблона маршрута, который вы создали для маршрутизации вызовов. В данном примере вызовы к расширению Cisco IP Phone 4XXX используют элемент таблицы AAR начиная с 4, который в свою очередь указывает к шаблону маршрута # 4.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-8.gif

  7. Гарантируйте, что идентификатор вызывающего абонента позволен на каждом IP-телефоне передать название вызывающей стороны.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-9.gif

Процедура на Cisco Call Manager

Выполните следующие действия:

  1. Под Параметрами сервиса удостоверьтесь, что значения Минимума и Максимального времени Замены тракта запуска установлены соответственно для предотвращения любых проблем (таких как прикрепление).

    Следующие два снимка экрана касаются параметров настройки Параметров сервиса Q.SIG:

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-10.gif

    11.gif

  2. Добавьте Cisco 3745 как шлюз MGCP и настройте NM-HDV T-1 модуль для PRI Q.SIG.

    Следующие пять снимков экрана касаются этой конфигурации:

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-2.gif

    13.gif

    15.gif

    16.gif

    17.gif

  3. Как заключительный шаг, создайте группу перехвата вызовов Cisco Call Manager для обеспечения предложенного расширения пути УАТС. Удостоверьтесь, что номер перехвата вызовов также введен в Параметр сервиса идентификатора замены пути PINX (см. к step# 1). Кроме того, система Avaya требует шаблона маршрута для маршрутизации к группе перехвата вызовов.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-8.gif

    Примечание: Удостоверьтесь что эти два общекластерных параметра (Устройство - PRI и Шлюз MGCP) под Параметрами Сервиса Cisco CallManager (Усовершенствованное) соответствие конфигурация Q.SIG в УАТС. Все транки УАТС должны быть настроены точно как эти параметры Сisco CallManager.

    • Кодирование OID ROSE ASN.1: Этот параметр задает, как закодировать Вызывать Идентификатор объекта (OID) для Удаленного элемента обслуживания операций (ROSE). Поддержите этот набор параметров к значению по умолчанию, пока специалист службы технической поддержки Cisco не сообщает в противном случае. Это обязательное поле, и по умолчанию является Использованием Локальное Значение.

      Это допустимые значения для этого параметра:

      • Используйте Локальное Значение, которое поддерживается большинством систем телефонии и должно использоваться, когда параметр сервиса Варианта Q.SIG установлен в ISO (Профиль Протокола 0x9F).

      • Используйте Глобальное Значение (ISO), который используется, только если связанная УАТС не поддерживает Использование Локальное Значение.

      • Используйте Глобальное Значение (ECMA), который должен использоваться, если параметр сервиса Варианта Q.SIG установлен в ECMA (Профиль Протокола 0x91).

    • Вопрос. . Вариант SIG: Когда транк настроен для Q.SIG, этот параметр задает профиль протокола, передаваемый в исходящих информационных элементах средства Q.SIG. Поддержите этот набор параметров к значению по умолчанию, пока специалист службы технической поддержки Cisco не сообщает в противном случае. Это - обязательное поле, и по умолчанию является ISO (Профиль Протокола 0x9F).

      Это доступные значения для этого параметра:

      • ECMA (Профиль Протокола 0x91), который, как правило, используется с ECMA PBXs и может только использовать Профиль Протокола 0x91. Если этот параметр сервиса установлен в ECMA (Профиль Протокола 0x91), ASN.1 Повысился, параметр сервиса Кодирования OID должен собираться Использовать Глобальное Значение (ECMA).

      • ISO (Профиль Протокола 0x9F), который является текущей рекомендацией ISO. Если этот параметр установлен на ISO (Профиль Протокола 0x9F), то ASN.1 Повысился, параметр сервиса Кодирования OID должен собираться Использовать Локальное Значение.

        warningПредупреждение: Сisco CallManager не поддерживает ECMA при использовании внутрикластерных магистралей с набором поля Tunneled Protocol к Q.SIG в окне Trunk Configuration в Администрировании CallManager. При установке этого параметра сервиса в ECMA (Профиль Протокола 0x91), всем внутрикластерным магистралям нужно было установить поле Tunneled Protocol ни в Один.

        qsig.gif

Конфигурация Cisco 3745

Это - show version и выходные данные команды show running-configuration на устройстве MGCP Cisco 3745. Controller T1 1/0 на Cisco 3745 связан с картой DS1 PRI Avaya S8700/G650. Вопрос. . Сигнализация SIG настроена на ссылке PRI между Cisco 3745 и Avaya S8700/G650.

CCME_CUE_3745# sh vers
Cisco Internetwork Operating System Software 
IOS (tm) 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Thu 25-Sep-03 22:25 by eaarmas
Image text-base: 0x60008954, data-base: 0x61C2C000

ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)
ROM: 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)

CCME_CUE_3745 uptime is 39 minutes
System returned to ROM by reload
System image file is "flash:c3745-is-mz.122-15.ZJ3.bin"

cisco 3745 (R7000) processor (revision 2.0) with 246784K/15360K bytes of memory.
Processor board ID JMX0814L3E2
R7000 CPU at 350Mhz, Implementation 39, Rev 3.3, 256KB L2, 2048KB L3 Cache
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
Primary Rate ISDN software, Version 1.1.
2 FastEthernet/IEEE 802.3 interface(s)
25 Serial network interface(s)
1 terminal line(s)
2 Channelized T1/PRI port(s)
1 ATM AIM(s)
2 Voice FXS interface(s)
2 Voice E & M interface(s)
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity disabled.
151K bytes of non-volatile configuration memory.
125184K bytes of ATA System CompactFlash (Read/Write)
Configuration register is 0x2102

CCME_CUE_3745# sh run
Building configuration...

Current configuration : 3291 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CCME_CUE_3745
!
logging queue-limit 100
!
voice-card 1
 dspfarm
!
voice-card 5
 dspfarm
!
ip subnet-zero
!
!
no ip domain lookup
!
isdn switch-type primary-qsig
!
no voice hpi capture buffer
no voice hpi capture destination 
!
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 172.28.221.18  
ccm-manager config
mta receive maximum-recipients 0
!
!
controller T1 1/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 1/1
 framing sf
 linecode ami
!
!
!
interface FastEthernet0/0
 description CCME-CUE-3745_to_cat3550
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 99
!
interface FastEthernet0/0.2
 description NEW_S8700_G650
 encapsulation dot1Q 300
 ip address 172.28.221.49 255.255.255.240
 ip helper-address 172.28.221.19
 h323-gateway voip bind srcaddr 172.28.221.49
!
interface FastEthernet0/0.3
 description MODULAR_MESSAGING_SOLUTION
 encapsulation dot1Q 900
 ip address 172.28.221.129 255.255.255.240
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.4
 encapsulation dot1Q 301
 ip address 10.1.3.1 255.255.255.128
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.5
 encapsulation dot1Q 302
 ip address 10.1.3.129 255.255.255.128
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.6
 encapsulation dot1Q 90
 ip address 90.1.1.254 255.255.255.0
 ip helper-address 172.28.221.19
!
interface Serial0/0
 description CCME-CUE-3745_to_3600
 ip address 25.0.0.1 255.0.0.0
 clockrate 256000
 no fair-queue
!
interface Serial1/0:23
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 isdn bchan-number-order ascending
 no cdp enable
!
interface Service-Engine2/0
 no ip address
 shutdown
!
router eigrp 100
 network 10.0.0.0
 network 25.0.0.0
 network 90.0.0.0
 network 172.28.0.0
 auto-summary
!
ip http server
ip classless
!
call rsvp-sync
!
voice-port 1/0:23
!
voice-port 4/0/0
!
voice-port 4/0/1
!
voice-port 4/1/0
!
voice-port 4/1/1
!
mgcp
mgcp call-agent 172.28.221.18 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
!
!
dial-peer cor custom
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/0:23
!
dial-peer voice 999410 pots
 application mgcpapp
 port 4/1/0
!
!
line con 0
 password cisco
 login
line 65
 flush-at-activation
 no activation-character
 no exec
 transport preferred none
 transport input all
line aux 0
line vty 0 4
 password cisco
 login
!
end

Функции, протестированные на совместимость между Cisco и системами IP-PBX Avaya

Этот раздел предоставляет список функций, протестированных между Cisco Call Manager 4.1 (2) платформа и Avaya S8700/G650, выполняющим Менеджера Связи 2.0 посредством PRI - магистрали Q.SIG:

  • (Двунаправленный) показ имени и номера

  • Передача вызова

  • Циркулярный вызов между этими двумя системами

Интеграция Cisco Unity Voice Mail для поддержки Cisco и IP-телефонов Avaya

На этом этапе можно использовать транк Q.SIG для совершения вызовов между Avaya S8700/G650 рабочий диспетчер связи Avaya 2.0 и платформой Cisco Call Manager рабочая версия 4.1 (2) Call Manager с устройством MGCP Cisco 3745, предоставляющим физическое соединение ISDN PRI Avaya S8700/G650. Сервер Cisco Unity может быть добавлен на платформе Cisco Call Manager для оказания поддержки голосовой почты и Cisco и IP-телефонам Avaya. Для включения этого администратор должен настроить Cisco Unity на платформе Cisco Call Manager. Этот раздел включает процедуры со снимками экрана для того, как настроить Cisco Unity на странице административного управления Cisco Call Manager.

Примечание: Большая часть конфигурации выполнена на Мастере Порта голосовой почты Cisco.

Добавьте Cisco Unity к Cisco Call Manager

Выполните следующие действия:

  1. Под Функцией выберите Voice Mail> Voice Mail Port Wizard. Выберите Create новый сервер голосовой почты и добавьте порты к нему и нажмите Next.

    19.gif

  2. Введите имя Сервера голосовой почты Cisco, такое как AvayaUM3, и нажмите Next.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-20.gif

  3. Выберите количество требуемых Портов голосовой почты и нажмите Next.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-21.gif

  4. Введите Описание и Аппаратный пул для Портов голосовой почты. В примере конфигурации Avaya VMailPorts был введен как описание и По умолчанию как аппаратный пул.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-4.gif

  5. Введите Начинающийся Номер каталога, такой как 4406, и Показ, такой как Голосовая почта, и нажмите Next.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-2.gif

  6. Следующий экран спрашивает, "Вы хотите добавить эти номера каталога к Группе каналов?" Выберите Да. Добавьте номера каталога к Группе новой линии и нажмите Next.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-3.gif

  7. Введите Имя Группы каналов, которое совпадает с Сервером голосовой почты, который вы ранее ввели, такие как AvayaUM3.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-4.gif

  8. Следующий экран показывает конфигурацию, введенную до сих пор. Нажмите Finish, при отсутствии изменений к конфигурации.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-5.gif

  9. Нажмите Add Новый Список поиска на Административной веб - странице Списка поиска.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-6.gif

  10. Введите Имя Списка поиска и Описание, такое как Avaya VMailHL. Кроме того, выберите Default для Cisco Call Manager Group.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-7.gif

  11. Этот снимок экрана является результатом успешного добавления Списка поиска. Нажмите Add Группу каналов.

    28.gif

  12. Выберите Line Group, ранее настроенный. В этом случае это - AvayaUM3.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-9.gif

  13. Перехват следующего экрана показывает результат успешной вставки группы каналов.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-30.gif

  14. Перейдите к Таблице маршрутизации> Маршрут/Поиск> Пилот Поиска. Нажмите Add Нового Пилота Поиска с экрана Hunt Pilot, который заканчивается.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-31.gif

  15. Войдите в Пилоте Поиска, такой как 4408, и выберите Hunt List, такой как Avaya HL VMail и нажмите Insert.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-2.gif

  16. Перейдите к Функции> Голосовая почта> Контрольный номер голосовой почты и нажмите Add Новый Контрольный номер голосовой почты на экране, который заканчивается.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-3.gif

  17. Введите Сервисный номер голосовой почты, совпадающий с Контрольным номером Поиска, ранее настроенным. В этом случае и Контрольные номера Поиска и Сервисные номера голосовой почты 4408.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-4.gif

  18. Перейдите к Функции> Голосовая почта> Профиль голосовой почты и нажмите Add Новый Профиль голосовой почты.

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-5.gif

  19. Введите Имя Профиля голосовой почты и Описание, такое как AvayaVMailProfile, и выберите Сервисный номер голосовой почты в шаге 17. В этом случае Сервисный номер голосовой почты 4408.

    36.gif

  20. Нажмите Features> Voice Mail> Message Waiting Indicator> Add a New Message Waiting Number для добавления Индикатора ожидания сообщения (MWI) количество Включения - выключения. Включенный здесь два снимка экрана для Индикатора ожидающего сообщения количество Включения - выключения.

    37.gif

    38.gif

Протестированные функции Cisco Unity Voice Mail

Это - список функций Cisco Unity Voice Mail, протестированных с IP-телефонами Avaya, используемыми для доступа к Cisco Unity Voice Mail посредством PRI - магистрали Q.SIG между Cisco Call Manager 4.1 (2) платформа и Avaya S8700/G650, выполняющим Менеджера Связи 2.0:

  • Внутреннее приветствие

  • Занятое приветствие

  • MWI

  • Простой доступ сообщения

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 63790