Голосовая связь и система унифицированных коммуникаций : Cisco Unity

Устранение неполадок исходящей связи IP-факса Unity

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Исходящее отправление факсом поддерживается с Мастером настройки Факса IP Unity и запускается с Cisco Unity 4.04 и Cisco Выпуск ПО IOS� 12.3 (7) T. Этот сервис позволяет пользователям передавать исходящие факсы через простую Электронную почту. Целевой номер телефона факса включен в Строку темы Электронной почты и передается почтовому ящику, который проверяет Услуга передачи факсов IP Unity. Сервис переформатировал сообщение, представляет все присоединения в соответствующем формате, переадресовывает и передает сообщение. Сообщение передается через Протокол SMTP IOS-шлюзу, настроенному с T.37 функцию без почтового ящика для передачи факса к телефонному номеру адресата. Этот документ фокусируется на действиях настройки для шлюза Cisco IOS.

Предварительные условия

Требования

Читатели этого документа должны быть знакомы с протоколом SMTP и с конфигурацией VoIP в Cisco IOS. Рабочий сервер Cisco Unity с версией 2.0.0.19 Мастера настройки Факса IP Unity или позже установленными потребностями, которые будут использоваться в сочетании с конфигурацией шлюза, определенной в этом документе для имения завершенной рабочей системы. На стороне IOS-шлюза, маршрутизатор Cisco IOS, который поддерживает T.37 функциональность без почтового ящика и программное обеспечение Cisco IOS версии 12.3(7)T или позже требуется вместе с версией 4.04 Cisco Unity или позже с Microsoft Exchange 2000 или 2003 как партнерский банк сообщений. Дополнительные сведения о части Cisco Unity конфигурации Факса IP могут быть найдены в Мастере настройки Факса IP Unity.

Примечание: T. 37, без почтового ящика, не поддерживается на сетях MGCP. Обратитесь к руководству по конфигурации Store и Forward Fax T.37 для получения дополнительной информации о платформе и других ограничениях для использования T.37.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco 3725 в качестве IOS-шлюза

  • ПО Cisco IOS версии 12.3(8)T4

Примечание: Шлюз не ограничен платформой Cisco 37xx. Любой голосовой шлюз с IP PLUS и программным обеспечением Cisco IOS версии 12.3(7)T работает.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Общие сведения

Когда пользователь посылает Электронное письмо почтовому ящику Услуги передачи факсов IP, это содержит [FAXPHONE=####] в предмете, где #### является количеством целевого факса. Обязанности по Услуге передачи факсов IP к:

  • Гарантируйте присоединения, которые должны быть переданы, допустимы и представлены в формате файла типа TIF F.

  • Адрес и Электронная почта с новым файлом TIF в приложении к FAX=####@gateway.com.

  • Интерпретируйте и примите меры на любом Сообщении о состоянии доставки (DSN), полученном от шлюза. Это может включать повторную передачу сообщения в шлюз (например, сигнал занято или никакой ответ), или передача уведомления конечному пользователю (например, неверный номер).

Microsoft Exchange ответственен за:

  • Доставка Электронной почты, адресованной gateway.com к IOS-шлюзу.

  • Доставка любой почты между конечным пользователем к почтовому ящику факса IP и между IOS-шлюзом и почтовым ящиком факса IP. Никакие сообщения не передаются или от конечного пользователя до шлюза или наоборот.

Обязанности по IOS-шлюзу к:

  • Интерпретируйте FAX=####@gateway.com, размещения вызова к #### и реле факса с помощью стандартных протоколов факса G3 (T.30 и T.4).

  • Передайте Сообщение о состоянии доставки (DSN), отмеченное как "постоянная ошибка" к почтовому ящику Факса IP для каждого размещенного факса - вызова. Это позволяет Услуге передачи факсов IP знать, что факс передавался правильно, или если была проблема (такой как занятая, без ответа, и т.д). Услуга передачи факсов IP полностью ответственна за обработку повторных попыток и отправку отклика отправителю в противоположность доверию конфигурации почтовой системы.

Конфигурация шлюза

Существует несколько команд, которые вы должны иметь в Конфигурации Cisco IOS для этого рвения. Некоторые из них накладываются с командами настройки, требуемыми для входящего факса ("on-ramp") на функциональность. Если эти сценарии взяты отдельно, Обратите внимание на то, что проще понять и устранить неполадки:

  • факсовые сообщения fax interface-type — Настраивают эту команду на шлюзе. Эта команда приводит к обработке шлюзом хранилища T.37 и переадресации вызовов факса. Отсутствие этой команды заставляет Электронные почты входящего факсимильного сообщения от Exchange/сервера Unity отказывать, и отладки маршрутизатора T.37 недоступны, пока не добавлена эта команда. Следует помнить, что после настройки этой команды следует перезагрузить маршрутизатор.

    vnt-3725-51(config)#fax interface-type fax-mail
    You must reload the router
  • Шлюз Cisco требует дополнительного программного обеспечения для выполнения факса T.37, без почтового ящика. Это программное обеспечение является скриптом TCL, который выполнен шлюзом при необходимости для факса, без почтового ящика. Это программное обеспечение сценария может быть загружено на внутренней флэш - памяти маршрутизатора или загружено прочь TFTP server. Файл для загрузки для факса, без почтового ящика, является app-faxmail-offramp.2.0.1.1.zip файлом, расположенным в Центре ПО Cisco (только зарегистрированные клиенты). Этот файл должен быть доступен с шлюза. В этом примере выходных данных файл загружен во внутреннюю флэш - память маршрутизатора, так как существует много пространства.

    vnt-3725-51#show flash
    System CompactFlash directory:
    File Length Name/status
    1 23454000 c3725-ipvoice-mz.123-8.T4.bin 
    [23454064 bytes used, 104734348 available, 128188412 total]
    125184K bytes of ATA System CompactFlash (Read/Write)
    vnt-3725-51#copy tftp flash:
    Address or name of remote host []? 172.18.106.4
    Source filename []? app_faxmail_offramp.2.0.1.1.tcl
    Destination filename [app_faxmail_offramp.2.0.1.1.tcl]?
    Accessing tftp://172.18.106.4/app_faxmail_offramp.2.0.1.1.tcl...
    Erase flash: before copying? [confirm]n
    Loading app_faxmail_offramp.2.0.1.1.tcl from 172.18.106.4 (via FastEthernet0/0): !
    [OK - 5095 bytes]
    Verifying checksum... OK (0xB729)
    5095 bytes copied in 0.076 secs (67039 bytes/sec)
    vnt-3725-51#show flash
    System CompactFlash directory:
    File Length Name/status
    1 23454000 c3725-ipvoice-mz.123-8.T4.bin 
    2 5095 app_faxmail_offramp.2.0.1.1.tcl 
    [23459224 bytes used, 104729188 available, 128188412 total]
    125184K bytes of ATA System CompactFlash (Read/Write)

    Маршрутизатору следует указать, где расположен этот файл. Используйте offramp call application voice flash:app_faxmail_offramp.2.0.1.1.tcl команда глобальной кофигурации для выполнения этого.

    Если файл расположен на TFTP server вместо Флэша, команда похожа на это:

    call application voice offramp tftp://172.18.106.4/app_faxmail_offramp.2.0.1.1.tcl
  • mta получают максимум <получатели> — Эта команда задает количество одновременных получателей для подключений SMTP на шлюзе. Эта команда используется для ограничения использования ресурса шлюза. Важно помнить, что значение по умолчанию для этой команды 0. Если эта команда является "not set" к значению, больше, чем 0, шлюз не отвечает ни на какие запросы SMTP. Это заставляет все транзакции без почтового ящика сразу отказывать.

  • <string> mta receive aliases — Эта команда важна, потому что это определяет допустимое имя хоста, которое принято как псевдоним SMTP для отправки факса через шлюз. Строкой в этой команде может или быть IP-адрес или имя хоста типа DNS. Эта команда очень важна, потому что все соединения SMTP отказывают, если домен поля "rcpt to:" не совпадает точно, что настроено как псевдоним с помощью этой команды. Другими словами, если имя хоста назначения входящей почты совпадает с настроенным псевдонимом, шлюз только принимает входящую почту. Множественные псевдонимы могут быть настроены (максимум равняется 10) для размещения других доменных имен и даже IP-адресов. Например, когда Услуга передачи факсов IP передает сообщение к "FAX=####@gateway.com", команда похожа:

    mta receive aliases gateway.com
  • mta receive generate permanent-error — Эта команда требуется, потому что без нее, не все сообщения DSN передают обратно почтовому ящику Услуги передачи факсов IP. Так как сообщения DSN являются частью спецификации SMTP, почтовый сервер (Microsoft Exchange), как ожидают, попытается обработать что-либо, что не является "постоянной" ошибкой, прежде чем это передаст сообщение обратно отправителю (в этом случае почтовый ящик Услуги передачи факсов IP). Сообщения, такие как абонент занят (по умолчанию) отмечены как "переходные" ошибки DSN. Exchange пытается повторно передать сообщение отдельно в течение длительного времени времени. Конфигурация команды mta receive generate permanent-error вынуждает маршрутизатор отметить каждое сообщение DSN как постоянную ошибку, таким образом, их сразу передают обратно отправителю (почтовый ящик Услуги передачи факсов IP). Сам сервис (на основе пользовательской конфигурации) может определить, сколько повторных попыток на занятом/нет ответе должно быть предпринято. Эта команда находится только в программном обеспечении Cisco IOS версии 12.3(7)T и позже. Если эта команда не присутствует на маршрутизаторе, возможности - вы, выполняют Cisco IOS Release, который является более старым, чем, что требуется.

  • mta send server <сервер Exchange> порт 25 — Эта команда задает сервер, который будет использоваться, для возврата сообщений к почтовому ящику факса (таких как DSNs). Это должно быть IP-адресом Сервера Exchange или может быть именем DNS. Если имя DNS задано, команда ip name-server <ip address> требуется так, чтобы DNS мог решить название.

  • Входящие и исходящие адресуемые точки вызова требуются, чтобы привязывать входящее SMTP - сообщение к вызванному номеру факса, а также направлять вызов к исходящему каналу Телефонии. Например: :

    dial-peer voice 5590 pots
    destination-pattern 991....
    port 2/0:23
    forward-digits all
    prefix 9
    !
    dial-peer voice 2 mmoip
    description off-ramp inbound VoiP from Unity
    application offramp
    information-type fax
    incoming called-number 991
    dsn delayed
    dsn success
    dsn failure
    !

    Сам узел обычной телефонной сети не является ничем специальным. Это необходимо для маршрутизатора для маршрутизации голосового вызова к каналу. Важным элементом здесь является Одноранговое телефонное соединение MMOIP. Это имеет "приложение передачи сообщений через шлюз", которое является названием, привязанным к скрипту TCL ("offramp call application voice flash:app_faxmail_offramp.2.0.1.1.tcl"). "Факс information-type" также необходим, чтобы позволить системе знать, что вызывает то соответствие, эта точка вызова является факсами - вызовами. Кроме того, оператор incoming called-number необходим. Это - самый простой способ привязать набранный номер к точке вызова. Обратите внимание на то, что нет никакого destination-pattern. Это не требуется, потому что эта точка вызова только используется для входящих вызовов (со стороны VoIP). В данном примере маршрутизатору позволяют принять факсы - вызовы для любого количества, которое начинается 991. Сообщение SMTP должно быть адресовано "991XXXX@gateway.com", где XXXX может совпасть с любым четырехзначным числом. Узел обычной телефонной сети, из-за "destination-pattern 991....", передает вызов к PRI (порт 2/0:23) при добавлении префикса 9. Поэтому сообщение к "9912345@gateway.com" заставляет вызов быть размещенным в PRI в порту 2/0 к количеству 99912345 (из-за команды prefix 9).

    Команды DSN на Одноранговом телефонном соединении MMOIP заставляют статус доставки передаваться за каждым условием (задерживать/успех/сбой). Это одно не достаточно. Команда mta receive generate permanent-error также требуется так, чтобы эти сообщения DSN были все переданы с Состоянием ошибки вместо возможно переходного процесса. Переходный процесс не (в течение потенциально долгого времени) передан обратно почтовому ящику Услуги передачи факсов IP.

    Дальнейшая документация по продукту и подробные данные команды могут быть найдены в разделе Store и Forward Fax T.37 Настройки Услуг передачи факсов Cisco по Руководству IP-приложения . Полная конфигурация рабочего шлюза T.37, связанного с сервером Cisco Unity, расположена в Разделе конфигурации Полной выборки этого документа. Вызовы SMTP от сервера Cisco Unity получены на Порту FastEthernet шлюза и затем подняли T1 PRI ISDN с постели 2/0:23.

Конфигурация полной выборки

Эта конфигурация является примером минимальной Конфигурации Cisco IOS для Cisco Unity исходящая отправляющая факсом возможность. Самые важные команды выделены полужирным шрифтом.

vnt-3725-51#show run
Building configuration...
Current configuration : 1608 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname vnt-3725-51
!
boot-start-marker
boot-end-marker
!
no network-clock-participate slot 2
no network-clock-participate aim 0
no network-clock-participate aim 1
voice-card 2
dspfarm
!
no aaa new-model
ip subnet-zero
ip cef
! 
no ftp-server write-enable
isdn switch-type primary-ni
!
fax interface-type fax-mail
mta send server 14.84.31.12 port 25
mta receive aliases vnt-3725-51.gateway.com
mta receive maximum-recipients 10
mta receive generate permanent-error
! 
controller T1 2/0
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 2/1
framing sf
linecode ami
!
interface FastEthernet0/0
ip address 14.80.51.14 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
ip default-gateway 14.80.51.1
ip classless
ip route 0.0.0.0 0.0.0.0 14.80.51.1
ip http server
!
control-plane
!
call application voice offramp flash:app_faxmail_offramp.2.0.1.1.tcl
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 2/0:23
!
dial-peer voice 5590 pots
destination-pattern 991....
port 2/0:23
forward-digits all
prefix 9
!
dial-peer voice 2 mmoip
description off-ramp inbound SMTP from Unity
application offramp
information-type fax
incoming called-number 991
dsn delayed
dsn success
dsn failure
! 
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end
vnt-3725-51#

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 62995