Технологии LRE и xDSL : Поддержка асимметричных цифровых абонентских линий (ADSL)

Завершение сеанса PPPoA с помощью статических маршрутов: xDSL к UAC Cisco 6400 с помощью aal5ciscoppp

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (11 ноября 2015) | Отзыв


Содержание


Введение

Этот пример конфигурации позволяет ПК, связанному с маршрутизатором Ассиметричной цифровой абонентской линии (ADSL) Cisco 677 подключить через Advanced Digital Subscriber Line Access Multiplexer (ADSLAM) Cisco 6130 с одиночным или множественным Cisco Универсальные концентраторы доступа (UAC). Определенное оборудование, которое использует эта конфигурация, не требуется. Например, можно заменить Cisco 677 Cisco 678.

Этот пример конфигурации имеет несколько опций, активированных на Cisco 677, которые характерны для развертывания ADSL. Этими функциями является Технология NAT, Преобразование адресов портов (PAT) и Протокол DHCP (динамического конфигурирования узла). Эти функции обеспечивают внедрение обрезки файлов cookie. Так как все коробки имеют одинаковую конфигурацию, существует сокращение высокой стоимости для развертывания и документации.

Можно скопировать и вставить код для Cisco Процессор Маршрутизации Узлов IOS�-based и Процессор коммутатора узлов (NSP) к конфигурациям. Однако Cisco 677 использует Широкополосную операционную систему Cisco (CBOS), и вы не можете скопировать и вставить этот код. Команды, которые вы используете для настройки Cisco 677, также включены в этот пример конфигурации.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

Аппаратные средства

  • ПК или рабочая станция

  • Customer Premises Equipment (CPE) ADSL Cisco 677

  • Сервис ADSL от местной телефонной компании

  • ADSLAM Cisco 6130 с NI-2, ATU-C DMT-II

  • UAC Cisco 6400 с 1 x nrp и 1 x NSP

Программное обеспечение

  • Cisco IOS Software Release 12.0. С 7 DC для nrp UAC Cisco 6400

  • Cisco IOS Software Release 12.0. 7 дБ для NSP UAC Cisco 6400

  • Выпуск 2.3.0.012 CBOS для маршрутизатора ADSL Cisco 677

  • Cisco IOS Software Release 12.0. 8-DA1 для ADSLAM Cisco 6130

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе вам предоставляется информация для того, чтобы настроить функциональные возможности, описанные в этом документе.

Примечание: Чтобы найти, что дополнительные сведения о командах, используемых в этом документе, обращаются к Средству поиска команд Command Lookup Tool (только зарегистрированные клиенты).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/12851/6400dsl_pppoa_stat.gif

Конфигурации

Примечания по конфигурации

Необходимо настроить постоянное виртуальное соединение (PVC) на Cisco 6130, который позволяет тестовому абоненту соединяться. Когда вы настраиваете PVP на NSP и завершаете сеанс PPP на nrp, идентификатор виртуального тракта/виртуальный идентификатор канала (VPI/VCI), конфигурация должна быть зарегистрирована на Cisco 6400.

Этот пример конфигурации показывает виртуальный тракт на NSP. Этот путь позволяет Cisco 6400 проходить через ячейки от ADSLAM до оконечного маршрутизатора, или к другому коммутатору ATM. Здесь можно заставить PVP коммутировать ячейки ATM к корпоративной сети или интернет-провайдеру без завершения сеанса PPP в Cisco 6400, расположенном в центральной АТС.

Этот пример конфигурации позволяет прозрачный адрес удаленных пользователей их корпоративным сетям (если они связаны) для электронной почты, для совместного использования файла/печати, корпоративной внутренней сети, и к Интернету для Просмотра веб - ресурсов, и т.д. без использования корпоративного подключения к Интернету.

Когда множественный PVCs настроены на Cisco 677, возможно направить трафик через каждый PVC. Конфигурация ADSLAM и NSP UAC направляет/переключает эти PVCs к правильному месту назначения, ISP/ASP или корпоративный, где может завершиться PPP. Эта конфигурация уменьшает трафик, и таким образом увеличивает доступную пропускную способность на корпоративной сети и использует текущую учетную запись интернет-провайдера для переноса Веба - трафика.

Эти конфигурации используются в данном документе:

Конфигурация ПК
IP-адресация Набора так, чтобы это получило IP-адрес автоматически. WINS набора так, чтобы это использовало DHCP для разрешения WINS. Гарантируйте, что не установлен никакой шлюз по умолчанию. Может быть необходимо установить доменное имя, потому что DHCP не может передать эту информацию.

CPE Cisco 67x (покажите выполненный)
[[ IP Routing = Section Start ]]
IP NAT = enabled
IP Port Address = 00, 172.22.10.254
IP Default Route for Unnumbered Links = 002, 01, 0
IP Static Route Table Entries for Unnumbered Links = 172.22.32.0, 001, 255.255.2
55.0, 1, 0;
[[ CBOS = Section Start ]]
NSOS Maximum Number of VCs = 2
NSOS Root Password = <
root password
>
NSOS Enable Password = <
enable password
>
[[ PPP Device Driver = Section Start ]]
PPP Port User Name = 00, <
username for wan0-0
>
PPP Port User Password = 00, <
password for wan0-0
>
PPP Port User Name = 01, <
username for wan0-1
>
PPP Port User Password = 01, <
password for wan0-1
>
PPP Port Option = 01, IPCP,IP Address,3,Auto,Negotiation Not Required,Negotiable
,IP,0.0.0.0
[[ DHCP = Section Start ]]
DHCP Server = enabled
DHCP Server Pool IP = 00, 172.22.10.0
DHCP Server Pool Gateway = 00, 172.22.10.254
[[ ATM WAN Device Driver = Section Start ]]
ATM WAN Virtual Connection Parms = 00, 1, 32, 0
ATM WAN Virtual Connection Parms = 01, 2, 63, 0

Команды для запуска к CPE Cisco 67x
cbos#set nat enabled
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos#set int wan0 maxvcs 2
You must use "write" and reboot for changes to take effect.

cbos#write
NVRAM written.

cbos#reboot
 Hello! Expanding CBOS image...
CBOS v2.3.5.012 - Release Software
User Access Verification
Password:<
root password
>

cbos>en
Password:<
enable password
>

cbos#set ppp wan0-0 login <username for wan0-0>
User name for wan0-0 has been set to router.

cbos#set ppp wan0-0 password <password for wan0-0>
Password for wan0-0 has been set to <password for wan0-0>

cbos#set ppp wan0-1 login <username for wan0-1>
Password for wan0-1 has been set to <username for wan0-1>

cbos#set ppp wan0-1 password <password for wan0-1>
Password for wan0-1 has been set to <password for wan0-1>

cbos#set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos#set ppp wan0-1 ipcp 0.0.0.0
PPP wan0-1 IPCP Address set to 0.0.0.0

cbos#set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos#set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0
You must use "write" then reboot for changes to take effect

cbos#set dhcp server enable
DHCP Server enabled

cbos#set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos#set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0
Size of pool 0 is automatically changed to max size 252

cbos#set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos#set password exec <root password>
Exec Password Change Successful! 

cbos#set password enable <enable password>
Enable Password Change Successful! 

cbos#set route default wan0-1
Default Route set

cbos#set route add ip 172.22.32.0 mask 255.255.255.0 gw wan0-0
Route added
cbos#set int wan0-0 close
Closing connection wan0-0

cbos#set int wan0-1 close
Closing connection wan0-1

cbos#set int wan0-0 vpi 1
Change completed.

cbos#set int wan0-0 vc1 32
Change completed.

cbos#set int wan0-1 vpi 2
Change completed.

cbos#set int wan0-1 vci 63
Change completed.

cbos#set int wan0-0 open
Opening connection wan0-0

cbos#set int wan0-1 open
Opening connection wan0-1

cbos#write
NVRAM written

cbos#reboot

61xx ADSLAM
interface ATM 1/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 1 32 int atm 0/1 40 40
 pvc 2 63 int atm 0/1 50 51

6400 NSP (слот 8)
interface ATM 8/0/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvp 40 interface ATM 1/0/0 40
 atm pvp 50 interface ATM 2/0/0 50

6400 nrp (слот 1)
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-0> password <password for wan0-0>
!
!
interface ATM 0/0/0.200 multipoint
 no ip directed-broadcast
 pvc 40/40 
  encapsulation aal5ciscoppp Virtual-Template 2
!
!
interface FastEthernet 0/0/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 2
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name A>
 ppp authentication pap
!
!
ip local pool <pool name A> 172.22.40.25 172.22.40.50

6400 nrp (слот 2)
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-1> password <password for wan0-1>
!
!
interface ATM 0/0/0.300 multipoint
 no ip directed-broadcast
 pvc 50/51 
  encapsulation aal5ciscoppp Virtual-Template 21
!
!
interface FastEthernet 0/0/0
 ip address 172.16.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 21
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name B>
 ppp authentication pap
!
!
ip local pool <pool name B> 172.16.100.10 172.16.100.25

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Используйте эти команды на CPE Cisco 675:

  • show interface wan0 — Показывает обучаемый скорость для соединения ADSL.

  • show interface wan0-0 — Показывает информацию о сеансе PPP о wan0-0.

  • show interface wan0 1 — Показывает информацию о сеансе PPP о wan0-1.

  • show dhcp server pool 0 — Показывает сведения DHCP в узле клиента.

Используйте эту команду на UAC Cisco 6400:

  • show atm pvc , установлен ли корректный PVC.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Используйте эти команды на UAC Cisco 6400:

  • debug ppp negotiation — Показывает сообщения отладки согласования PPP.

  • debug ppp authenticaion — Показывает, передает ли клиент аутентификацию.

  • debug ppp error – отображает ошибки протокола и статистику ошибок, связанных с согласованием и функционированием PPP-соединения.

Перед попыткой любой из команд отладки обратитесь к разделу Важные сведения о командах отладки.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12851