Асинхронный режим передачи (ATM) : Коммутация и туннели VP (Virtual Path)

LANE, CES и VBR PVC в сформированных туннелях виртуального пути

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ показывает пример конфигурации эмуляции LAN (LANE), сервиса эмуляции соединений (СES) и Permanent Virtual Connections переменной скорости передачи данных (VBR) (PVCs) в имеющих форму туннелях виртуального тракта (VP). В конфигурации, показанной в этом документе, LANE, CES и non с переменной скоростью передачи, в реальном времени (VBR-nrt), PVCs транспортируются по глобальной сети (WAN). Эти примеры используют сформированные туннели виртуального пути для обеспечения соответствия контрактами по трафику. При использовании сформированных туннелей виртуального пути с параметрами трафика, идентичными поставщику услуг, сеть ATM поставщика услуг не должна отбрасывать ячейки.

Туннель VP должен иметь категорию сервиса постоянной скорости передачи данных (CBR), чтобы быть сформированным: это - единственный сформированный туннель, который в настоящее время поддерживает Cisco. У вас должно быть три Туннеля VP, потому что LANE использует коммутируемые виртуальные соединения неуказанной скорости передачи данных (UBR) (SVC), CES использует CBR PVCs, у вас есть PVC VBR, и вы используете сформированные туннели виртуального пути. Вы имеете один для каждой категории сервиса: виртуальные каналы CBR (VC) и VC UBR. Вы, возможно, использовали один туннель при помощи Hierarchical VP Tunnel.

Предварительные условия

Требования

Для использования данного документа требуется знание следующих тем:

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco Выпуск ПО IOS� 11.3 (0.8) ASP TWA4 или позже для LightStream 1010 (LS1010)

  • Любая версия MSR Cisco 8540

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Предположения

Пример, показанный в этом документе, принимает эти факты:

  • Сформированные туннели должны иметь категорию сервиса CBR, таким образом, данный пример имеет Туннель VP CBR, который может только содержать VC CBR. Это используется для CBR CES PVCs (маркированный VPI1 в схеме сети). Обратите внимание на то, что количество идентификатора виртуального тракта (VPI) является локально значительным к порту коммутатора, таким образом, у вас может быть то же количество VPI на том же коммутаторе, но два других порта коммутатора.

  • Поскольку сформированные туннели виртуального пути не могут одновременно транспортировать VC категорий множественного обслуживания, первый Туннель VP, используемый для VC CBR, не может использоваться для VC UBR LANE или PVC VBR-nrt. Необходимо создать другой Туннель VP для LANE (который использует VC категории сервиса UBR). Поэтому второй Туннель VP (маркированный VPI2 в схеме сети) является сформированным туннелем виртуального пути CBR, через который только разрешены VC UBR.

  • Третий сформированный туннель виртуального пути транспортирует PVC VBR-nrt (маркированный VPI3 в схеме сети).

  • Необходимо купить три VP CBR от поставщика услуг.

  • Предполагается то, что три VP CBR имеют пиковую скорость передачи ячеек (PCR) 10 Мбит/с и допустимое отклонение задержки ячейки (CDVT) 500 ячеек. Обратите внимание на то, что сумма PCR всех Туннелей VP, определенных на том же физическом интерфейсе, должна быть меньшей, чем 95 процентов скорости линии физического интерфейса (предполагающий, что только Туннели VP настроены на физическом интерфейсе).

  • Для PVC VBR устойчивая скорость передачи ячеек (SCR) PVC должна быть меньшей, чем 95 процентов PCR сформированного туннеля виртуального пути CBR. Другими словами, SCR PVC должен быть меньшим, чем 9.5 Мбит/с для VBR-nrt. Если существует множественный VBR прохождение через PVCs туннеля CBR, суммы SCR всего VBR, PVCs должен быть меньшим, чем 95 процентов PCR сформированного туннеля виртуального пути. Остающихся 5 процентов зарезервированы для сигнализации и других обязательных протоколов.

  • 5500 asp-f устройства для Переключения виртуального пути. Поставщик услуг, как правило, выполняет эту функцию.

  • Сервисы LANe определены на с 8540 MSR; Клиенты эмуляции LAN (LEC) определены на с 8540 MSR и с 5500 asp-e.

    Примечание: В данном примере Сервисы LANe размещены в коммутатор ATM для простоты. Это не, однако, оптимальное расположение для Сервисов LANe. Лучшее место для Сервера эмуляции LAN (LES) или сервера широковещательных и неизвестных сообщений (ШИНА) находится на Модуле LANE Catalyst 5500. Идеальное место для LEC находится на маршрутизаторе Cisco серии 7500.

  • Эти две учрежденческих телефонных станции с выходом в город (PBXs) в схеме используют канал CBR CES. Для получения дополнительной информации о том, как настроить эмуляцию соединений, обратитесь к Сервисам эмуляции соединений Настройки.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

Щелкните по коммутаторам в этой схеме для просмотра примеров конфигурации:

/image/gif/paws/10493/PVPshap.gif

Конфигурации

Эти конфигурации используются в данном документе:

Пример конфигурации с 5500 asp-e

5500 asp-e
5500-asp-e# show running-config

Building configuration...
Current configuration:
!
version 11.3
no service pad
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname 5500-asp-e
!
boot system flash slot0:LS1010-wp-mz.120-3c.W5.9.bin
!
ip host-routing
!
atm connection-traffic-table-row index 63997 vbr-nrt pcr 20480 scr10 9000  mbs 100
atm connection-traffic-table-row index 64000 cbr pcr 10240  cdvt 500
atm lecs-address-default 47.0091.8100.0000.0090.2144.8401.0090.2144.8405.00 1
atm address 47.0091.8100.0000.0050.537e.1401.0050.537e.1401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
!
!
interface CBR10/0/0
 no ip address
 ces circuit 0 circuit-name test
 ces pvc 0 interface ATM11/0/1.6 vpi 6 vci 100
!
interface ATM11/0/1
 no atm signaling enable
 no ip address
 atm pvp 5 shaped rx-cttr 64000 tx-cttr 64000
 atm pvp 6 shaped rx-cttr 64000 tx-cttr 64000
 atm pvp 7 shaped rx-cttr 64000 tx-cttr 64000
!
interface ATM11/0/1.5 point-to-point
 atm cac service-category cbr deny
 atm cac service-category ubr permit
!
interface ATM11/0/1.6 point-to-point
!
interface ATM11/0/1.7 point-to-point
 atm cac service-category cbr deny
 atm cac service-category vbr-nrt permit
 atm pvc 7 100 rx-cttr 63997 tx-cttr 63997  interface  ATM10/1/0 0 100
!
interface ATM11/0/2
 no ip address
!
interface ATM11/0/3
 no ip address
!
interface ATM11/1/0
 no ip address
!
interface ATM11/1/1
 no ip address
!
interface ATM11/1/2
 no ip address
!
interface ATM11/1/3
 no ip address
!
interface ATM13/0/0
 no ip address
 atm maxvp-number 0
!
interface ATM13/0/0.1 multipoint
 ip address 100.100.100.2 255.255.255.0
 lane client ethernet test
!
interface Ethernet13/0/0
 no ip address
!
no ip classless
logging buffered 16000 debugging
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Вывод характеристик

Можно использовать команды показа в этом разделе для подтверждения функций конфигурации на устройстве. Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Можно использовать дополнительные команды показа для подтверждения конфигурации; не все они включены в этот документ.

Чтобы гарантировать, что весь LANE VCS идет по корректному Туннелю VP (другими словами, чтобы препятствовать тому, чтобы сигнализация инициировалась через основной интерфейс), сигнализация отключена на интерфейсе atm11/0/1 использование команды no atm signaling enable. Та же операция была выполнена на с 8540 MSR.

Для наблюдения, какие VC проходят через Туннель VP с VPI 7 выполните команду interface-number show atm vc interface:

5500-asp-e# show atm vc interface atm11/0/1.7

Interface    VPI   VCI   Type    X-Interface  X-VPI X-VCI  Encap Status

ATM11/0/1.7  7     3      PVC     ATM13/0/0    0     181   SNAP   UP
ATM11/0/1.7  7     4      PVC     ATM13/0/0    0     182   SNAP   UP
ATM11/0/1.7  7     5      PVC     ATM13/0/0    0     180   QSAAL  UP
ATM11/0/1.7  7     16     PVC     ATM13/0/0    0     179   ILMI   UP
ATM11/0/1.7  7     18     PVC     ATM13/0/0    0     183   PNNI   UP
ATM11/0/1.7  7     100    PVC     ATM10/1/0    0     100          UP

5500-asp-e# show atm interface resource atm11/0/1.7

Resource Management configuration:
    Service Categories supported: vbr-nrt
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none vbr,
        Peak-cell-rate TX: none vbr,
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none vbr,
        CDVT TX: none vbr,
        MBS: none vbr RX, none vbr TX
Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 613 vbr RX, 613 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 9114 vbr RX, 9114 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

5500-asp-e# show atm interface resource atm11/0/1

Resource Management configuration:
    Service Classes:
        Service Category map: c1 cbr, c2 vbr-rt, c3 vbr-nrt, c4 abr, c5 ubr
        Scheduling: RS c1 WRR c2, WRR c3, WRR c4, WRR c5
        WRR Weight: 8 c2, 1 c3, 1 c4, 1 c5
    Pacing: disabled   0 Kbps rate configured, 0 Kbps rate installed
    Service Categories supported: cbr,vbr-rt,vbr-nrt,abr,ubr
    Link Distance: 0 kilometers
    Controlled Link sharing:
        Max aggregate guaranteed services: none RX,  none TX
        Max bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
        Min bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none cbr, none vbr, none abr, none ubr
        Peak-cell-rate TX: none cbr, none vbr, none abr, none ubr
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX: none abr, none ubr
        Minimum-cell-rate TX: none abr, none ubr
        CDVT RX: none cbr, none vbr, none abr, none ubr
        CDVT TX: none cbr, none vbr, none abr, none ubr
        MBS: none vbr RX, none vbr TX

Resource Management state:
    Available bit rates (in Kbps):
        117023 cbr RX, 117023 cbr TX, 117023 vbr RX, 117023 vbr TX,
        117023 abr RX, 117023 abr TX, 117023 ubr RX, 117023 ubr TX
    Allocated bit rates:
        30720 cbr RX, 30720 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Best effort connections: 0 pvcs,  4 svcs

Пример конфигурации с 5500 asp-f

Коммутатор настроен для Переключения виртуального пути.

5500 asp-f
5500-asp-f# show running-config

Building configuration...
Current configuration:
!
version 11.3
no service padservice timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 5500-asp-f
!
!
!
atm connection-traffic-table-row index 63997 vbr-nrt pcr 20480 scr10 9000  mbs 100
atm connection-traffic-table-row index 64000 cbr pcr 10240  cdvt 500
atm address 47.0091.8100.0000.0050.5308.2401.0050.5308.2401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
!
!
interface ATM11/0/0
 no ip address
!
interface ATM11/0/1
 no ip address
 atm pvp 5  interface  ATM11/0/0 10
 atm pvp 6 rx-cttr 64000 tx-cttr 64000 interface ATM11/0/0 6 rx-cttr 64000 tx-cttr 64000
 atm pvp 7 rx-cttr 63997 tx-cttr 63997 interface ATM11/0/0 7 rx-cttr 63997 tx-cttr 63997
!
interface ATM13/0/0
 no ip address
 atm maxvp-number 0
!
interface Ethernet13/0/0
 no ip address
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Отображение характеристик

Чтобы проверить, что VP в рабочем состоянии, выполните команду show atm vp:

5500-asp-f# show atm vp

Interface    VPI    Type  X-Interface     X-VPI     Status
ATM11/0/0    6       PVP     ATM11/0/1    6         UP
ATM11/0/0    7       PVP     ATM11/0/1    7         UP
ATM11/0/0    10      PVP     ATM11/0/1    5         UP
ATM11/0/1    5       PVP     ATM11/0/0    10        UP
ATM11/0/1    6       PVP     ATM11/0/0    6         UP
ATM11/0/1    7       PVP     ATM11/0/0    7         UP

Пример конфигурации с 8540 MSR

С 8540 MSR
8540-MSR# show running-config

Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 8540-MSR
!
logging buffered 4096 debugging
!
redundancy
 main-cpu
  sync config startup
  sync config running
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
ip subnet-zero
!
atm connection-traffic-table-row index 63997 vbr-nrt pcr 20480 scr10 9000  mbs 100
atm connection-traffic-table-row index 63998 cbr pcr 10000
atm connection-traffic-table-row index 63999 cbr pcr 10240  cdvt 500
atm lecs-address-default 47.0091.8100.0000.0090.2144.8401.0090.2144.8405.00 1
atm address 47.0091.8100.0000.0090.2144.8401.0090.2144.8401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
!
lane database PVP
  name test server-atm-address 47.009181000000009021448401.009021448403.01
!
!
interface CBR1/0/0
 no ip address
 no ip directed-broadcast
 shutdown
 ces circuit 0 circuit-name test
 ces pvc 0 interface ATM2/1/0.6 vpi 6 vci 100
!
interface ATM2/1/0
 no atm signaling enable
 no ip address
 no ip directed-broadcast
 atm pvp 6 shaped rx-cttr 63999 tx-cttr 63999
 atm pvp 7 shaped rx-cttr 63999 tx-cttr 63999
 atm pvp 10 shaped rx-cttr 63999 tx-cttr 63999
!
interface ATM2/1/0.6 point-to-point
 no ip directed-broadcast
!
interface ATM2/1/0.7 point-to-point
 no ip directed-broadcast
 atm cac service-category cbr deny
 atm cac service-category vbr-nrt permit
 atm pvc 7 100 rx-cttr 63997 tx-cttr 63997  interface  ATM1/1/0 0 100
!
interface ATM2/1/0.10 point-to-point
 no ip directed-broadcast
 atm cac service-category cbr deny
 atm cac service-category ubr permit
!
interface ATM2/1/1
 no ip address
 no ip directed-broadcast
!
interface ATM2/1/2
 no ip address
 no ip directed-broadcast
!
interface ATM2/1/3
 no ip address
 no ip directed-broadcast
!
interface ATM0
 no ip address
 no ip directed-broadcast
 atm maxvp-number 0
 lane config auto-config-atm-address
 lane config database PVP
!
interface ATM0.1 multipoint
 ip address 100.100.100.1 255.255.255.0
 no ip directed-broadcast
 lane server-bus ethernet test
 lane client ethernet test
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
!
ip classless
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end

Вывод характеристик

Можно использовать команды показа в этом разделе для подтверждения функций конфигурации на устройстве.

8540-MSR# show atm interface resource atm2/1/0.7

Resource Management configuration:
    Service Categories supported: vbr-nrt
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none vbr,
        Peak-cell-rate TX: none vbr,
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none vbr,
        CDVT TX: none vbr,
        MBS: none vbr RX, none vbr TX
Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 613 vbr RX, 613 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 9114 vbr RX, 9114 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

8540-MSR# show atm interface resource atm2/1/0

Resource Management configuration:
    Service Classes:
        Service Category map: c2 cbr, c2 vbr-rt, c3 vbr-nrt, c4 abr, c5 ubr
        Scheduling: RS c1 WRR c2, WRR c3, WRR c4, WRR c5
        WRR Weight: 8 c2, 1 c3, 1 c4, 1 c5
    Pacing: disabled   0 Kbps rate configured, 0 Kbps rate installed
    Service Categories supported: cbr,vbr-rt,vbr-nrt,abr,ubr
    Link Distance: 0 kilometers
    Controlled Link sharing:
        Max aggregate guaranteed services: none RX,  none TX
        Max bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
        Min bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none cbr, none vbr, none abr, none ubr
        Peak-cell-rate TX: none cbr, none vbr, none abr, none ubr
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX: none abr, none ubr
        Minimum-cell-rate TX: none abr, none ubr
        CDVT RX: none cbr, none vbr, none abr, none ubr
        CDVT TX: none cbr, none vbr, none abr, none ubr
        MBS: none vbr RX, none vbr TX

Resource Management state:
    Available bit rates (in Kbps):
        117023 cbr RX, 117023 cbr TX, 117023 vbr RX, 117023 vbr TX,
        117023 abr RX, 117023 abr TX, 117023 ubr RX, 117023 ubr TX
    Allocated bit rates:
        30720 cbr RX, 30720 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Best effort connections: 0 pvcs,  0 svcs

8540-MSR# show atm interface resource atm2/1/0.6

Resource Management configuration:
    Service Categories supported: cbr
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none cbr,
        Peak-cell-rate TX: none cbr,
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none cbr,
        CDVT TX: none cbr,

Resource Management state:
    Available bit rates (in Kbps):
        9727 cbr RX, 9727 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        1741 cbr RX, 1741 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

8540-MSR# show atm interface resource atm2/1/0.7

Resource Management configuration:
    Service Categories supported: vbr-nrt
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none vbr,
        Peak-cell-rate TX: none vbr,
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none vbr,
        CDVT TX: none vbr,
        MBS: none vbr RX, none vbr TX

Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 613 vbr RX, 613 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 9114 vbr RX, 9114 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

8540-MSR# show atm interface resource atm2/1/0.10

Resource Management configuration:
    Service Categories supported: ubr
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none ubr
        Peak-cell-rate TX: none ubr
        Minimum-cell-rate RX: none ubr
        Minimum-cell-rate TX: none ubr
        CDVT RX: none ubr
        CDVT TX: none ubr

Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения

Нажмите для наблюдения конфигурации коммутатора с 5500 asp-e. Нажмите для наблюдения конфигурации коммутатора с 5500 asp-f. Нажмите для наблюдения конфигурации коммутатора с 8540 MSR.


Document ID: 10493