Cервисы организации сетевого доступа к приложениям : Коммутаторы контент-сервисов Cisco серии CSS 11500

Пример организации избыточности за счет запасного аппарата CSS 11xxx

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для Коммутатора контент-сервисов (CSS) 11xxx физическое резервирование. Физическое резервирование обеспечивает избыточность уровня стойки между два, тождественно настроил CSSs.

Предварительные условия

Требования

Прежде чем использовать эту конфигурацию, убедитесь, что выполняются эти требования:

  • Оба из CSSs, которые вы используете для этой избыточной конфигурации, должны выполнять ту же версию кода. Выполнение других версий кода не поддерживается для резервирования.

  • Ожидайте поведение CSSs быть активным (основным) / резервом (резервная копия); только основной CSS обрабатывает потоки.

  • Необходимо настроить специализированную ссылку Fast Ethernet (FE) между CSSs для биения Протокола VRRP.

  • Не используйте от коробки к коробке при требовании соединения устройства Уровня 2 между избыточными узлами CSS. Используйте резервирование VIP вместо этого. Обратитесь к VIP Настройки и Резервированию Виртуального интерфейса для получения дополнительной информации.

Используемые компоненты

Сведения в этом документе основываются на версии SW CSS 11150: 6.10 Сборка 107.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Родственные продукты

Эта конфигурация может также использоваться со следующими версиями программного/аппаратного обеспечения:

  • весь CSS 11000 Cisco - продукты CSS серии 11500

  • Выпуск 5.0 Программного обеспечения webns Cisco и позже

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общие сведения

Когда канал резервирования был определен между двумя CSSs, CSSs участвуют в избыточной конфигурации. Протокол, используемый для этого канала резервирования, является VRRP, с помощью адреса групповой адресации 224.0.0.18. CSSs используют эту ссылку для поддержания контакта и состояния активности друг с другом. Только одна перекрестная ссылка между CSSs поддерживается. Необходимо использовать перекрестный кабель для соединения непосредственно с внешними портами на избыточном CSSs. Не используйте устройства Уровня 2 между двумя CSSs на избыточном соединении. Не устанавливайте перекрестный кабель на портах Гигабитного Ethernet (GE); такая конфигурация не поддерживается.

Примечание: Протокол физического резервирования CSS теперь поддерживается на CSS 11501, CSS 11503 и портах CSS 11506 GE в версии программного обеспечения 7.10.1.02 и 7.20.0.01 и позже.

Существует два основных состояния, обнаруженные на этом канале резервирования, которые ведут основные и состояния резервирования на двух CSSs:

  • Первое условие поддерживает биение, которое является рекламой каждую секунду. Основной CSS предоставляет это биение на канале резервирования, и резервный CSS отслеживает биение каждые три секунды (по умолчанию). Если биение испытывает таймаут (например, биения не обнаружены в этот период), то резервная копия вступает во владение как ведущее устройство.

    Новый основной CSS начинает отсылать сообщения протокола резервирования, а также предварительный запрос ARP (протокол разрешения адресов) (ARP) сообщения для обновления таблиц ARP на соседних узлах и таблицах пересылки подключенных мостовых устройств (например, Коммутаторы уровня 2) с новым основным MAC-адресом CSS. CSS передает один Пакет запроса ARP и один пакет ответа ARP для каждого вызова предварительного ARP запрос.

  • Второе условие является условием изменения приоритета коммутатора VRRP. О CSS, объявляя наивысший приоритет выполняют согласование для становления ведущим устройством. Это - механизм, используемый сервисами uplink, и некоторые специальные команды (описанный ниже) для инициирования события аварийного переключения.

Обратите внимание на то, что, если CSSs неправильно сконфигурированы (например, два или больше CSSs установлены как ведущее устройство избыточности IP), CSS с самым высоким адресом VRRP IP вступает во владение как ведущее устройство.

Программное обеспечение webns Cisco позволяет вам:

  • настройте сервисы Multiple Uplink

  • используйте аварийное переключение на основе ссылки потеря работоспособности

  • используйте синхронизацию настроек; обратитесь к Синхронизации Избыточной конфигурации для получения дополнительной информации

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Выполните команду избыточности IP для включения резервирования от CSS к CSS на двух CSSs, взаимодействовавших с перекрестным кабелем. По умолчанию резервирование отключено на CSSs, пока вы не выполняете эту команду на обоих CSSs.

При включении основной опции с этой командой можно определять, какой CSS является основным CSS. Первоначально, загрузка двух CSSs, взаимодействовавших с перекрестным кабелем, определяет, который является ведущим устройством и который является резервной копией. CSS, который загружается сначала, является основным CSS. Если начальная загрузка CSSs в то же время, CSS с численно более высоким IP-адресом становится ведущим устройством.

При запуске команды ip redundancy master на CSS CSS становится основным CSS. Можно выполнить эту команду или на текущем ведущем устройстве или на резервной копии. При запуске основной опции на резервном CSS CSS становится ведущим устройством, и другой CSS автоматически становится резервной копией.

При обозначении основного CSS CSS возвращает ведущий статус после потери работоспособности и затем подходит снова. Например, когда основной CSS выключается, резервный CSS становится ведущим устройством. Когда прежний определяемый основной CSS подходит снова, однако, CSS становится ведущим устройством снова.

Если у вас нет требования для обозначения CSS как ведущее устройство, когда оба, на которых возросли CSSs, не включают основную опцию при включении резервирования на основном CSS.

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/50405/box_to_box_config.jpg

Конфигурации

Эти конфигурации используются в данном документе:

  • CSS 11150 ФУТ-ЛАМБЕРТОВ

  • nws-4-5

CSS 11150 ФУТ-ЛАМБЕРТОВ
CSS-11150-FL# sh running-config
!Generated on 03/22/2004 18:32:17
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 		


!--- Redundancy is enabled.


  app     			


!--- This is optional if you want to synchronize the configurations.

  app session 172.17.6.2   

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.1 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.2 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

CSS-11150-FL# 

nws-4-5
nws-4-5# sh running-config 
!Generated on 03/22/2004 18:53:37
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 	


!--- Redundancy is enabled.



  app 


!--- This is optional if you want to syncronize the configurations.

  app session 172.17.6.1 

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.2 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.1 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

nws-4-5# 


Поддержка различных служб каскадного подключения

Можно создать сервис, который привязан к IP-адресу маршрутизатора. Этот сервис позволяет основному CSS контролировать маршрутизатор с поддержкой активности (ICMP). Если поддержка активности отказывает, ведущее устройство оставляет контроль, и резервный CSS берет на себя управление. Можно настроить несколько сервисов путем запуска команды type redundancy-up; CSSs используют все каналы связи резервирования при создании решения о восстановлении при отказе.

Если CSS активен, и теряет все каналы связи, определяемые как redundancy-up, CSS оставляет активное состояние и становится резервной копией. CSS использует протокол резервирования для информирования другому CSS для становления активным. Если оба, CSSs потеряли свои каналы связи, CSS, остаются в активном состоянии в течение 45 секунд, ждущих канала связи для оживания. После 45 секунд, если нет все еще никакого жизнеспособного канала связи, CSS входит в режим резервирования, давая другому коммутатору попытку. Это позволяет обоим CSSs для получения шанса протестировать их каналы связи, не перегружаясь назад и вперед много раз каждую минуту.

Примечание: Когда больше нет оперативных сервисов uplink, CSS входит в аварийное переключение.

Факторы

Когда команда ip redundancy master выполнена, эта опция отключена. Когда команда ip redundancy master выполнена, команда type redundancy-up не может быть настроена. Когда сервис настроен путем запуска команды type redundancy-up, команда ip redundancy master не может быть выполнена.

Конфигурация

CSS11150# configure terminal
CSS11150(config)# service uplink1
CSS11150(config-service[uplink1])# type redundancy-up           

!--- If this upstream router goes down, then fail the switch over.

CSS11150(config-service[uplink1])# ip address 10.66.86.33
CSS11150(config-service[uplink1])# active

Поддержка отказоустойчивости физических интерфейсов

Если кто-либо из физических интерфейсов, настроенных для резервирования, выключается, CSS оставляет контроль, и резервный CSS сразу вступает во владение как ведущее устройство. Эта функция основывается на состоянии канала в противоположность сервису redundancy-up, который основывается на возможности подключения с помощью IP-адреса. CSS может определить состояние канала когда в режиме резервирования. Необходимо удостовериться, что восходящий или нисходящий путь резервного CSS также не пробегают этот тот же интерфейс; это заставит коробки CSS махать владением ведущего статуса.

Факторы

Эта опция отключена путем запуска команды ip redundancy master. Когда команда ip redundancy master выполнена, сбои команды интерфейса phy резервирования. Когда команда интерфейса phy резервирования выполнена, сбои команды ip redundancy master.

Конфигурация

CSS-11150-FL# configure terminal
CSS-11150-FL(config)# interface e1
CSS-11150-FL(config-if[e1])# redundancy-phy

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • резервирование sh — Эта команда проверяет, что CSSs работают в избыточной конфигурации; эта команда также отображается, какой CSS является ведущим устройством и который является резервной копией, а также причиной для последнего аварийного переключения.

    nws-4-5# sh redundancy
    Redundancy:               Enabled    Redundancy Protocol:      Running   
    Redundancy State:         Master     MasterMode:               No        
    Number of times redundancy state changed to Master:            2         
                                             to Backup:            2         
    Redundancy interface:     172.17.6.2
    Current State Duration:   1 day 02:54:04
    Last Fail Reason:         No Fail    
    VRID:                     128        Priority:                 100 
  • show log sys.log — Эта команда отображает сообщения со сведениями для обладания между устройствами CSS.

    CSS-11150-FL# sh log sys.log
    
    APR 15 18:05:49 5/1 85 REDUNDANCY-4: Redundancy force master temporarily
    APR 15 18:05:52 5/1 86 REDUNDANCY-4: Transition to redundancy master
    APR 15 18:05:52 5/1 87 VRRP-4: Virtual router 128: master on interface 172.17.6.1
  • покажите приложение и покажите сеанс приложения — Эта команда отображает состояние сессии APP.

    nws-4-5# sh app
    APP CONFIGURATION:
    Enabled PortNumber: 5001 MaxFrameSize: 10240
    
    nws-4-5# sh app session
    App Session Information 'no hostname':
    Session ID: 87df3710 IP Address: 172.17.6.1 State: APP_SESSION_UP

Можно вызвать резервную копию к ведущему устройству для целей обслуживания. Выполните команду redundancy force-master для настройки резервного CSS как временного ведущего устройства. Это - временная установка, потому что команда не скопирована к текущей конфигурации. Когда необходимо вывести основной CSS из эксплуатации для обслуживания или обновления, эта команда полезна в избыточной конфигурации.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 50405