Протокол IP : Протокол IS-IS

Понимание LSP псевдоузла IS-IS

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этом документе описывается псевдоузел пакета состояния соединения (LSP). Псевдоузел является логическим представлением LAN, которое формируется назначенной промежуточной системой (DIS) на сегменте LAN. В документе также описывается передача информации маршрутизаторам.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения в этом документе основываются на версиях программного и аппаратного обеспечения, привязанных к:

  • Cisco выпуск ПО IOS� 12.1 (5) T9.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

DIS и псевдоузел

В этом разделе описываются DIS и псевдоузел.

Что такое DIS?

На широковещательных сетях множественного доступа одиночный маршрутизатор избран DIS. Нет никакого резервного избранного DIS. DIS является маршрутизатором, который создает псевдоузел и действия от имени псевдоузла.

Две основных задачи выполнены DIS:

  • Создание и обновление псевдоузла lsp для создания отчетов о ссылках на все системы на широковещательной подсети. Посмотрите раздел LSP Pseudenode для получения дополнительной информации.

  • Затопление LSP по LAN.

Затопление по LAN означает, что DIS передает периодические протокольные информационные единицы полного порядкового номера (CSNP) (настройка по умолчанию 10 секунд) суммирование следующей информации:

  • ИДЕНТИФИКАТОР LSP

  • Порядковый номер

  • Контрольная сумма

  • Оставшийся срок действия

DIS ответственен за затопление. Это создает и лавинно рассылает новый псевдоузел lsp для каждого уровня маршрутизации, в котором это участвует (Уровень 1 или Уровень 2) и для каждой LAN, с которой это связано. Маршрутизатор может быть DIS для всех связанных LAN или подмножества связанных LAN, в зависимости от Приоритета IS-IS или адреса Уровня 2. DIS также создаст и лавинно разошлет новый псевдоузел lsp, когда соседство будет установлено, разъединено, или интервал обновления истекает. Механизм DIS уменьшает сумму затопления на LAN.

Выбор DIS

На LAN один из маршрутизаторов выбирает себя DIS, на основе приоритета интерфейса (по умолчанию равняется 64). Если все приоритеты интерфейса являются тем же, маршрутизатор с самой высокой точкой подключения подсети (SNPA) выбран. SNPA является MAC-адресом на LAN и идентификатором соединения по звену передачи данных локальных данных (DLCI) на Сети Frame Relay. Если SNPA является DLCI и является тем же в обеих сторонах ссылки, маршрутизатор с более высоким идентификатором системы становится DIS, Каждый интерфейс маршрутизатора IS-IS назначен и приоритет L1 и приоритет L2 в диапазоне от 0 до 127.

Выбор DIS является вытесняющим (в отличие от OSPF). Если новые загрузки маршрутизатора на LAN с более высоким приоритетом интерфейса, новый маршрутизатор становится DIS. Это удаляет старый псевдоузел lsp и лавинно рассылает новый набор LSP.

Что такое псевдоузел (PSN)?

Для сокращения количества смежностей полной сетки между узлами на мультисоединениях доступа само мультисоединение доступа смоделировано как псевдоузел. Это - виртуальный узел, поскольку название подразумевает. DIS создает псевдоузел. Все маршрутизаторы на широковещательном канале, включая DIS, формируют смежности с псевдоузлом.

Представление псевдоузла:

pseodonode.gif

В IS-IS DIS не синхронизируется с его соседними узлами. После того, как DIS создает псевдоузел для LAN, это передает пакеты приветствия за каждым Уровнем (1 и 2) каждые три секунды и CSNP каждые десять секунд. Пакеты приветствия указывают, что это - DIS на LAN для того уровня, и CSNP описывают сводку всех LSP, включая ИДЕНТИФИКАТОР LSP, порядковый номер, контрольную сумму и оставшийся срок действия. LSP всегда лавинно рассылаются к адресу групповой адресации, и механизм CSNP только исправляет для любых потерянных протокольных информационных единиц (PDU). Например, маршрутизатор может попросить у DIS недостающего LSP с помощью частичного пакета порядкового номера (PSNP) или, в свою очередь, дать DIS новый LSP.

CSNP используются для сообщения других маршрутизаторов обо всех LSP в базе данных одного маршрутизатора. Подобный пакету дескриптора базы данных OSPF, PSNP используются, чтобы запросить LSP и подтвердить получение LSP.

Путь коммутации по метке для псевдоузла

Псевдоузел lsp генерируется DIS, DIS сообщает обо всех соседях LAN (включая DIS) в псевдоузле lsp с метрикой нуля. Все маршрутизаторы LAN, включая DIS, сообщают о подключении псевдоузлу в их LSP. Это подобно в понятии сети LSA в OSPF.

Пример

Мы будем использовать следующую схему сети, чтобы продемонстрировать, как псевдоузел lsp, генерируемый DIS, используется для создания отчетов обо всех соседях LAN.

Примечание: В примере ниже, динамическая функция имени хоста, включают. Поэтому идентификаторы системы автоматически сопоставлены с именами хоста маршрутизатора, показанными в результате команд показа ниже.

Схема сети

isis-pnode.jpg

Конфигурации

Эти конфигурации использовались для маршрутизаторов, показанных в схеме сети:

Маршрутизатор ISIS
Router 6
  
       interface e0
       ip address 172.16.126.6 255.255.255.0 
       ip router isis
       Isis priority 127
	   
       router isis
       net 49.0001.0000.0c4a.4598.00
       is-type level-1
  
  Router 2

       interface e0
       ip address 172.16.126.2 255.255.255.0
       ip router isis
	
       router isis
       net 49.0001.0000.0c8d.e6b4.00
       is-type level-1
	   
  Router 1

       interface e0
       ip address 172.16.126.1 255.255.255.0
       ip router isis


       interface s1
       ip address 172.16.1.1 255.255.255.0
       ip router isis

       router isis
       net 49.0001.0000.5c75.d0e9.00
       is-type level-1
	   
  Router 8
 
       interface s1
       ip address 172.16.1.8 255.255.255.0
       ip router isis
	  
       router isis
       net 49.0001.0000.0c31.c2fd.00
       is-type level-1c

Следующая таблица ломает область, MAC-адрес и сеть для каждого из маршрутизаторов, настроенных выше. Заметьте, что все маршрутизаторы находятся в той же области.

Маршрутизатор Область MAC-адрес СЕТЬ (заголовок сетевого объекта)
6 49.0001 0000.0c4a.4598 49.0001.0000.0c4a.4598.00
2 0000.0c8d.e6b4 49.0001.0000.0c8d.e6b4.00
1 0000.5c75.d0e9 49.0001.0000.5c75.d0e9.00
8 0000.0c31.c2fd 49.0001.0000.0c31.c2fd.00

С маршрутизаторами, настроенными, как описано в этом разделе, можно использовать команду show clns is-neighbor для просмотра соседних маршрутизаторов IS-IS:

router-6# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-2       Et0         Up     L1   64        router-6.01        Phase V
router-1       Et0         Up     L1   64        router-6.01        Phase V
router-6#

router-2# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-6       Et0         Up     L1   127       router-6.01        Phase V
router-1       Et0         Up     L1   64        router-6.01        Phase V
router-2#

router-1# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-6       Et0         Up     L1   127       router-6.01        Phase V
router-2       Et0         Up     L1   64        router-6.01        Phase V
router-8       Se1         Up     L1   0         00                 Phase V
router-1#

router-8# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
Router-1       Se1         Up     L1   0         00                 Phase V
router-8#

В предыдущих соседних списках заметьте маршрутизаторы, связанные с сетью со множественным доступом (Ethernet), у всех есть тот же идентификатор канала. Идентификатор канала является однооктетным номером что использование маршрутизатора для однозначного определения Интерфейса IS-IS. Если интерфейс присоединен к сети со множественным доступом, идентификатор канала связан с идентификатором системы DIS. Это известно как ID псевдоузла. Заметьте также, что DIS является маршрутизатором 6 из-за Приоритета IS-IS, настроенного под его Интерфейсом Ethernet.

База данных связи между промежуточными системами

Эти выходные данные отображают базу данных IS-IS от каждого из маршрутизаторов, описанных в предыдущем разделе:

Router-6# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        960               0/0/0
router-6.00-00      * 0x0000006D   0xDD58        648               0/0/0
router-6.01-00      * 0x00000069   0x6DCB        1188              0/0/0
router-2.00-00        0x0000006D   0x59DE        589               0/0/0
router-1.00-00        0x00000074   0xC4B0        759               0/0/0
router-6#

router-2# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        947               0/0/0
router-6.00-00        0x0000006D   0xDD58        633               0/0/0
router-6.01-00        0x00000069   0x6DCB        1172              0/0/0
router-2.00-00      * 0x0000006D   0x59DE        577               0/0/0
router-1.00-00        0x00000074   0xC4B0        746               0/0/0
router-2#

router-1# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        934               0/0/0
router-6.00-00        0x0000006D   0xDD58        619               0/0/0
router-6.01-00        0x00000069   0x6DCB        1158              0/0/0
router-2.00-00        0x0000006D   0x59DE        561               0/0/0
router-1.00-00      * 0x00000074   0xC4B0        734               0/0/0
router-1#

router-8# show isis database
IS-IS Level-1 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
router-8.00-00*       0x0000006E   0xFF1A        927           0/0/0
router-6.00-00        0x0000006D   0xDD58        607           0/0/0
router-6.01-00        0x00000069   0x6DCB        1147          0/0/0
router-2.00-00        0x0000006D   0x59DE        550           0/0/0
router-1.00-00        0x00000074   0xC4B0        723           0/0/0
router-8#

Как предыдущие выходные данные указывают, команда show isis database отображает список LSP в базе данных. В этом случае все маршрутизаторы являются маршрутизаторами Уровня 1 в той же области, таким образом, у них всех есть те же LSP в их базе данных IS-IS. Заметьте, что каждый из маршрутизаторов генерирует LSP. DIS генерирует LSP для себя, и он также генерирует LSP от имени псевдоузла. Псевдоузел lsp в данном примере является 0000.0C4A.4598.01-00.

Мы упомянули, что маршрутизаторы на LAN только передают рекламные объявления к псевдоузлу LAN. Псевдоузел сообщает обо всех соседях LAN, в псевдоузле lsp, с метрикой нуля — как показано в них show isis database lsp подробные примеры выходных данных команды:

  • LSP маршрутизатора 6 (как замечено по маршрутизатору 8)

    Заметьте, что маршрутизатор 6 объявляет это, он может только достигнуть своей сети с прямым подключением и псевдоузла. В этом случае псевдоузел имеет метрику 10. Как мы упомянули, маршрутизаторы на LAN объявят это, они могут быть достигнуты на псевдоузел LAN только.

    router-8# show isis database router-6.00-00 detail
    IS-IS Level-1 LSP router-6.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-6.00-00        0x00000071   0xD55C        456           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.126.6
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IS router-6.01
    router-8#
  • Псевдоузел lsp (как замечено по маршрутизатору 8)

    Псевдоузел lsp объявляет всех соседей LAN с метрикой нуля. Псевдоузел lsp генерируется DIS, маршрутизатор 6 в этом случае, от имени псевдоузла.

    Router-8# show isis database router-6.01-00 detail
    IS-IS Level-1 LSP router-6.01-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-6.01-00        0x0000006D   0x65CF        759           0/0/0
      Metric: 0  IS router-6.00
      Metric: 0  IS router-2.00
      Metric: 0  IS router-1.00
    router-8#
  • LSP маршрутизатора 2 (как замечено по маршрутизатору 8)

    Снова, LSP маршрутизатора 2 содержит информацию относительно того, может ли это достигнуть своей сети с прямым подключением и псевдоузла только.

    Router-8# show isis database router-2.00-00 detail
    IS-IS Level-1 LSP router-2.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-2.00-00        0x00000072   0x4FE3        791           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.126.2
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IS router-6.01
    router-8#
  • LSP маршрутизатора 1 (как замечено по маршрутизатору 8)

    Единственной информацией, которую LSP маршрутизатора 1 содержит для локальной сети, является сама сеть и может ли это достигнуть псевдоузла. Так как маршрутизатор 1 также связан с другой сетью, последовательной сетью, эта сеть с прямым подключением также объявлена.

    Router-8# show isis database router-1.00-00 detail
    IS-IS Level-1 LSP router-1.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-1.00-00        0x00000079   0xBAB5        822           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.1.1
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IP 172.16.1.0 255.255.255.0
      Metric: 10 IS router-6.01
      Metric: 10 IS router-8.00
    router-8#
  • LSP маршрутизатора 8

    В этом случае маршрутизатор 8 не связан с LAN, таким образом, это не дает объявление к псевдоузлу, что это может быть достигнуто. Это действительно, однако, дает объявление (что это может быть достигнуто) к себе, маршрутизатору 1, и к сети с прямым подключением.

    Router-8# show isis database router-8.00-00 detail
    IS-IS Level-1 LSP router-8.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-8.00-00*       0x00000072   0xF71E        554           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      IP Address:  172.16.1.8
      Metric: 10 IP 172.16.1.0 255.255.255.0
      Metric: 10 IS router-1.00
      Metric: 0  ES router-8
    router-8#

Дополнительные сведения


Document ID: 49627