Протокол IP : Протоколы IP-маршрутизации

Маршрутизация на основе политики с примером конфигурации Catalyst 3550 Series Switch

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (6 октября 2015) | Отзыв


Содержание


Введение

В этом документе приводится пример конфигурации для маршрутизации в соответствии с политикой на коммутаторе Catalyst серии 3550. Коммутаторы серии Catalyst 3550 имеют основанную передачу аппаратных средств, таким образом информация перенаправления запрограммирована в Ternary Content Addressable Memory (TCAM). Для TCAM к политике поддержки Базирующаяся Маршрутизация (PBR) это должно быть отформатировано путем изменения шаблона Управления базой данных коммутатора (SDM). Необходимо модифицировать шаблон SDM, такой, что он поддерживает 144-разрядный TCAM Уровня 3. См. Понимают и Настраивают Switching Database Manager на Коммутаторах серии Catalyst 3550 для получения дополнительной информации о SDM.

Примечание: Catalyst 3550 имеет ограничения на команды route-map, которые можно использовать.

Предварительные условия

Требования

Гарантируйте, что вы хорошо осведомлены относительно этих областей перед попыткой этой конфигурации:

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Cisco выпуск ПО IOS�, с 12.1.19 EA1a

  • Cisco Catalyst 3550

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Чтобы включить политику маршрутизации, необходимо настроить одну из этих команд в режиме глобальной конфигурации, а затем следует записать конфигурацию и перезагрузить коммутатор:

  • sdm prefer extended-match

  • sdm prefer access extended-match

  • sdm prefer routing extended-match

CAT3550(config)# access-list 10 permit 20.20.20.0 0.0.0.255
CAT3550(config)# route-map pbr permit 10
CAT3550(config-route-map)# match ip address 10
CAT3550(config-route-map)# set ip next-hop 12.12.12.12

CAT3550(config)# int vlan 3
CAT3550(config-if)# ip policy route-map pbr
CAT3550(config-if)#
06:12:31: %L3TCAM-3-SIZE_CONFLICT: PBR requires enabling extended routing

CAT3550# show run int vlan 3
Building configuration...

Current configuration : 60 bytes
!
interface Vlan3
ip address 55.55.55.1 255.255.255.0

!--- Command not taken - you need to enable SDM.

end

CAT3550# conf t
Enter configuration commands, one per line. End with CNTL/Z.
CAT3550(config)# sdm prefer extended-match
Changes to the running SDM preferences have been stored, but cannot take effect 
until the next reload.
Use 'show sdm prefer' to see what SDM preference is currently active.
CAT3550(config)# end

CAT3550# write
06:14:11: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
[OK] 

ltd-1-2# reload
Proceed with reload? [confirm]

Необходимо избегать неподдерживаемых команд—обратитесь к Неподдерживаемым Командам Построения Маршрута, если эта конфигурация существует:

!
access-list 10 permit 20.20.20.0 0.0.0.255
route-map pbr permit 10
match ip address 10
set ip default next-hop 12.12.12.12
!

Сообщение об ошибках создается при попытке конфигурации карты маршрутизации на интерфейсе:

CAT3550(config)# int vlan 3
CAT3550(config-if)# ip policy route-map pbr
CAT3550(config-if)# end
CAT3550#
00:02:29: %PBR-3-UNSUPPORTED_RMAP: Route-map pbr not supported for Policy-Based Routing

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/47900/cat3550pbr-1.gif

Конфигурации

В данном документе используется следующая конфигурация:

Конфигурация заимствует источник трафика от 20.20.20.X (access-list 10) и посылает его на 30.30.30.2 вЂ" конфигурация переназначает шлюз по умолчанию 10.10.10.2.

CAT3550 (Cisco Catalyst 3550)
CAT3550# show running-config 
Building configuration...
.
.
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan2
 ip address 20.20.20.1 255.255.255.0
 ip policy route-map pbr
!
interface Vlan3
 ip address 30.30.30.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.10.10.2
ip classless
ip http server
!
!
access-list 10 permit 20.20.20.0 0.0.0.255
route-map pbr permit 10
 match ip address 10
 set ip next-hop 30.30.30.2
!
.
!
end

Когда команда set ip next-hop помещена, аналогичный трафик не может быть замечен в выходных данных, и это - нормальное поведение на коммутаторе. Это вызвано тем, что коммутатор работает на аппаратные средства только, и команды показа только представляют информацию, которая обрабатывается в программном обеспечении. Set ip next-hop работает все время в аппаратных средствах, потому что таблица маршрутизации и процесс никогда не проверяются коммутатор. Это получает пакет и если это попадает в операторы route-map тогда, это передается непосредственно следующему переходу, который вы задали, не проверяя таблицу маршрутизации.

Первые проверки команды set ip default next-hop вся таблица маршрутизации, чтобы видеть, существует ли другой маршрут назначению. Если никакой маршрут не найден, то следующий переход по умолчанию используется.

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

  • debug ip policy - показывает пакеты, маршрутизируемые в соответствии с политикой или отклоняемые в соответствии с политикой. Пример выходных данных команды debug ip policy:

  *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.607: IP: route map pbr, item 10, permit
  *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
  *Dec 5 13:33:23.607: IP: Vlan2 to Vlan3 30.30.30.1
  *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.707: IP: route map pbr, item 10, permit
  *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
  *Dec 5 13:33:23.707: IP: Vlan2 to Vlan3 30.30.30.1
  *Dec 5 13:33:23.847: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.847: IP: route map pbr, item 10, permit

Дополнительные сведения


Document ID: 47900