Протокол IP : Протокол OSPF

Как OSPF вводит стандартный маршрут в почти шлейфную зону

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ иллюстрирует введение маршрута по умолчанию протоколом OSPF в частично тупиковую область (NSSA). Граничный маршрутизатор области (ABR) для NSSA не создает по умолчанию стандартный маршрут к NSSA. Следует использовать команду area <x> nssa default-information originate.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме.

/image/gif/paws/47870/ospfdb11a.gif

Конфигурации

В данном документе используются конфигурации, показанные ниже.

Маршрутизатор 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 area 1 nssa

end

Маршрутизатор 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 area 1 nssa default-information originate

end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show ip ospf database — Отображает список Объявлений о состоянии канала (LSA) и вводит их в базу данных состояния канала. Этот список показывает только информацию в заголовке LSA.

  • nssa-external show ip ospf database — Отображает информацию только о внешних LSA NSSA.

  • show ip route текущий статус таблицы маршрутизации.

Исследуйте базу данных OSPF в не так плотная область

Чтобы видеть, как База данных OSPF смотрит, используйте команду show ip ospf database .

r2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

           Router Link States (Area 0) 

Link ID    ADV Router     Age     Seq#          Checksum   Link count 
2.2.2.2    2.2.2.2        600     0x80000001    0x9583          1 

           Summary Net Link States (Area 0) 

Link ID    ADV Router      Age     Seq#          Checksum 
5.0.0.0     2.2.2.2        600     0x80000001    0x8E61 

           Router Link States (Area 1) 

Link ID    ADV Router     Age     Seq#           Checksum   Link count 
1.1.1.1    1.1.1.1        864     0x8000005E     0xD350         2 
2.2.2.2    2.2.2.2        584     0x8000001E     0xF667         2 

           Summary Net Link States (Area 1) 

Link ID    ADV Router     Age     Seq#          Checksum 
6.0.0.0    2.2.2.2        585     0x80000004    0xA87C 

           Type-7 AS External Link States (Area 1) 

Link ID    ADV Router     Age     Seq#          Checksum   Tag 
0.0.0.0    2.2.2.2        601     0x80000001    0xD0D8      0 

ABR для NSSA инициирует тип 7 и LSA с идентификатором канала 0.0.0.0. Это результат команды area 1 nssa default-information-originate в ее OSPF конфигурации.

r2.2.2.2#show ip ospf database nssa-external 0.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-7 AS External Link States (Area 1) 

  LS age: 650 
  Options: (No TOS-capability, No Type 7/5 translation, DC) 
  LS Type: AS External Link 
  Link State ID: 0.0.0.0 (External Network Number ) 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xD0D8 
  Length: 36 
  Network Mask: /0 
        Metric Type: 2 (Larger than any link state path) 
        TOS: 0 
        Metric: 1 
        Forward Address: 0.0.0.0 
        External Route Tag: 0 

ABR инициирует 0.0.0.0 типа 7 LSA, даже при том, что это не имеет маршрута по умолчанию.

r2.2.2.2#show ip route 0.0.0.0 
% Network not in table 

r1.1.1.1#show ip route ospf 
O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:00:18, Serial2/1/0 
O*N2 0.0.0.0/0 [110/1] via 5.0.0.2, 00:00:18, Serial2/1/0 

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 47870