Протокол IP : Протокол OSPF

Как OSPF вводит стандартный маршрут в шлейфную или полностью шлейфную зону

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этом документе иллюстрируется, как протокол OSPF вводит маршрут по умолчанию в тупиковую или полностью тупиковую зону.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме.

/image/gif/paws/47869/ospfdb10a.gif

Конфигурации

В данном документе используются конфигурации, показанные ниже.

Маршрутизатор 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 area 1 stub

end

Маршрутизатор 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 area 1 stub

end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • show ip ospf database — Отображает список Объявлений о состоянии канала (LSA) и вводит их в базу данных состояния канала. Этот список показывает только информацию в заголовке LSA.

  • сводка show ip ospf database <идентификатор состояния канала> — Отображает суммарные каналы пограничного маршрутизатора области (ABR).

  • show ip route текущий статус таблицы маршрутизации.

Исследуйте базу данных OSPF в изолированной области

ABR для изолированной области инициирует суммарное объявление о состоянии каналов с идентификатором канала 0.0.0.0. Это делает это, даже если это не имеет маршрута по умолчанию. Вы видите, что это происходит с командой show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#           Checksum   Link count 
2.2.2.2    2.2.2.2     19     0x80000001     0x8F8B         1 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age     Seq#           Checksum 
5.0.0.0    2.2.2.2     9       0x80000001     0x8E61 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#           Checksum   Link count 
1.1.1.1    1.1.1.1     1335    0x80000059     0x56DA         2 
2.2.2.2    2.2.2.2     4       0x80000013     0x7FF3         2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#               Checksum 
0.0.0.0    2.2.2.2     20      0x80000001         0x75C0 
6.0.0.0    2.2.2.2     13      0x80000001         0x2709 


r2.2.2.2#show ip ospf database summary 0.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Summary Net Link States (Area 1) 

  LS age: 184 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 0.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) injects a default route 
  !--- into the stub area. 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x75C0 
  Length: 28 
  Network Mask: /0 
        TOS: 0  Metric: 1 
  

r2.2.2.2#show ip route 0.0.0.0 
% Network not in table

!--- The ABR (Router 2.2.2.2) does not have a default route
!--- in its routing table.


r1.1.1.1#show ip route ospf 
O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:04:23, Serial2/1/0 
O*IA 0.0.0.0/0 [110/65] via 5.0.0.2, 00:04:23, Serial2/1/0 

Исследуйте базу данных OSPF в общим образом изолированная область

При изменении области 1 в примере изолированной области от изолированной области до полностью изолированная область ABR все еще вводит 0.0.0.0 суммарных объявления о состоянии каналов в область 1. Единственная разница - то, что другие суммарные объявления о состоянии каналов не передаются в полностью изолированная область.

Примечание: Единственное сделанное изменение конфигурации было к ABR. Оператор no-summary был добавлен к его конфигурации OSPF: команда area 1 stub no-summary.

Эти выходные данные command показывают то, на что база данных OSPF похожа в полностью изолированная область.

r2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum     Link count 
2.2.2.2    2.2.2.2     617     0x80000001   0x8F8B           1 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum 
5.0.0.0    2.2.2.2     608     0x80000001   0x8E61 

                Summary ASB Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum 
1.1.1.1    2.2.2.2     243     0x80000003   0x8F5E 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#         Checksum     Link count 
1.1.1.1    1.1.1.1     1934    0x80000059   0x56DA           2 
2.2.2.2    2.2.2.2     247     0x80000015   0x7BF5           2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#               Checksum 
0.0.0.0    2.2.2.2     249     0x80000003         0x71C2  

!--- Notice that this is the only summary LSA 
!--- in the totally stub area. 


r1.1.1.1#show ip route ospf 
O*IA 0.0.0.0/0 [110/65] via 5.0.0.2, 00:04:11, Serial2/1/0 

ABR не инициирует суммарное объявление о состоянии каналов для 6.0.0.0/8. В результате Маршрутизатор 1.1.1.1 больше не имеет маршрут для 6.0.0.0/8. Единственный межобластной маршрут данного маршрутизатора – маршрут по умолчанию.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 47869