Протокол IP : Протокол OSPF

Как OSPF вставляет маршрут по умолчанию в обычную зону

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этом документе демонстрируется механизм внедрения маршрута по умолчанию в обычную зону протоколом OSPF. По умолчанию маршруты, внедренные в обычную зону, могут создаваться любым маршрутизатором OSPF. Маршрутизатор OSPF не генерирует путь по умолчанию к домену OSPF. Для того, чтобы протокол OSPF сгенерировал маршрут по умолчанию, необходимо использовать команду default-information originate.

Существует два способа извещения о маршруте по умолчанию в обычной области. Первый способ – объявить 0.0.0.0 в домене OSPF, при условии, что объявляющий маршрутизатор уже имеет маршрут по умолчанию. Второй - объявление 0.0.0.0 независимо от наличия маршрута по умолчанию у объявляющего маршрутизатора. Второй метод может быть выполнен путем добавления ключевого слова всегда к команде default-information originate.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме.

/image/gif/paws/47868/ospfdb9a.gif

Конфигурации

В данном документе используются конфигурации, показанные ниже.

Маршрутизатор 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1

end

Маршрутизатор 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 default-information originate
 
ip route 0.0.0.0 0.0.0.0 6.0.0.3

end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show ip ospf database — Отображает список Объявлений о состоянии канала (LSA) и вводит их в базу данных состояния канала. Этот список показывает только информацию в заголовке LSA.

  • show ip ospf database external — Отображает информацию только о внешних LSA.

  • show ip route текущий статус таблицы маршрутизации.

Исследуйте базу данных OSPF

Эти выходные данные отображаются, как база данных OSPF выглядит данной эту сетевую среду, с помощью команды show ip ospf database .

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age     Seq#          Checksum   Link count 
2.2.2.2    2.2.2.2     600     0x80000001    0x9583          1 

                Summary Net Link States (Area 0) 

Link ID    ADV Router   Age     Seq#          Checksum 
5.0.0.0     2.2.2.2     600     0x80000001    0x8E61 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#           Checksum   Link count 
1.1.1.1    1.1.1.1     864     0x8000005E     0xD350         2 
2.2.2.2    2.2.2.2     584     0x8000001E     0xF667         2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#          Checksum 
6.0.0.0    2.2.2.2     585     0x80000004    0xA87C 

                Type-5 AS External Link States 

Link ID   ADV Router   Age     Seq#          Checksum    Tag 
0.0.0.0    2.2.2.2     601     0x80000001    0xD0D8       0 

Поскольку это имеет маршрут по умолчанию, Маршрутизатор 2.2.2.2 инициирует тип 5 LSA с идентификатором канала 0.0.0.0. Это результат команды default-information-originate в OSPF-конфигурации.

r2.2.2.2#show ip ospf database external 0.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-5 AS External Link States  

  LS age: 650 
  Options: (No TOS-capability, DC) 
  LS Type: AS External Link 
  Link State ID: 0.0.0.0 (External Network Number ) 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xD0D8 
  Length: 36 
  Network Mask: /0 
        Metric Type: 2 (Larger than any link state path) 
        TOS: 0 
        Metric: 1 
        Forward Address: 0.0.0.0 
        External Route Tag: 0 


r2.2.2.2#show ip route 0.0.0.0 
S* 0.0.0.0/0 [1/0] via 6.0.0.3, 00:28:00, ATM1/0.20  


r1.1.1.1#show ip route ospf 
O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:00:18, Serial2/1/0 
O*E2 0.0.0.0/0 [110/1] via 5.0.0.2, 00:00:18, Serial2/1/0 

Даже если маршрутизатор не имеет маршрута по умолчанию в своей таблице маршрутизации, можно также добавить всегда ключевое слово к команде default-information originate, чтобы заставить маршрутизатор инициировать 0.0.0.0 типа 5 LSA.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 47868