Протокол IP : Протокол OSPF

Виртуальный канал OSPF

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Все зоны в автономной системе OSPF должны быть физически подключены к магистральной зоне (зоне 0). В некоторых случаях, где такой вариант невозможен, можно использовать виртуальное соединение для подключения магистральной зоны через немагистральную зону. Можно также использовать виртуальные соединения для соединения двух частей разделенного магистрального канала через немагистральную зону. Зона, через которую настраивается виртуальный канал, известная как транзитная зона, должна иметь полную маршрутную информацию. Транзитная зона не может быть шлейфной. В этом документе рассматривается база данных OSPF в среде виртуального соединения. Подробнее о виртуальных соединениях можно узнать в руководстве по проектированию OSPF.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

Используемые компоненты

Данный документ не ограничен отдельными версиями программного или аппаратного обеспечения.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/47866/ospfdb7.gif

Конфигурации

Эти конфигурации используются в данном документе:

Маршрутизатор 1.1.1.1
Current configuration:

hostname Router1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0

router ospf 2
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 1
 area 1 virtual-link 3.3.3.3

!--- Area 1 is the transit area.
!--- IP address 3.3.3.3 is the router
!--- ID of the router between Area 1
!--- and Area 2 (Router3.3.3.3). See
!--- the next Note.

end

Примечание: ID маршрутизатора OSPF обычно является самый высокий IP-адрес на коробке или адресе наибольшей петли обратной связи, если вы существуете. Идентификатор маршрутизатора только вычислен во время начальной загрузки или в любое время что перезапущен процесс OSPF. Выполните команду show ip ospf interface для обнаружения идентификатора маршрутизатора.

Маршрутизатор 2.2.2.2
Current configuration:

hostname Router2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0

interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20 point-to-point
 ip address 6.0.0.2 255.0.0.0

router ospf 2
 network 6.0.0.0 0.255.255.255 area 1
 network 5.0.0.0 0.255.255.255 area 1

end

Маршрутизатор 3.3.3.3
Current configuration:

hostname Router3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface Ethernet0/0
 ip address 12.0.0.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 6.0.0.3 255.0.0.0

router ospf 2
 network 12.0.0.0 0.255.255.255 area 2
 network 6.0.0.0 0.255.255.255 area 1
 area 1 virtual-link 1.1.1.1

!--- Area 1 is the transit area.
!--- IP address 1.1.1.1 is the router
!--- ID of the router between Area 1
!--- and Area 0 (Router1.1.1.1).

end

Как работает виртуальное соединение

Первоначально, виртуальное соединение не работает, потому что Router1 1.1.1 не знает, как достигнуть Router3 3.3.3 (другой конец виртуального соединения). Все описания локального состояния соединениий (LSA) в области, которую 1 потребность, которая будет лавинно рассылаться, и алгоритм кратчайшего пути сначала (SPF), должна быть выполнена в области 1 всеми тремя маршрутизаторами для Router1 1.1.1, чтобы знать, как достигнуть Router3 3.3.3 через область 1.

После того, как маршрутизаторы знают, как достигнуть друг друга через транзитную область, они пытаются сформировать смежность через виртуальное соединение. Пакеты OSPF между двумя концами виртуального соединения не являются пакетами групповой адресации. Они - туннелировавшие пакеты из источника 5.0.0.1 назначению 6.0.0.3, потому что они туннелированы к другому концу виртуального соединения. Следует отметить, что, если существует межсетевой экран, промежуточный маршрутизаторы virtual-link, необходимо включить OSPF (Протокол "IP" 89) порт между туннельными IPs исходящего интерфейса virtual-link, которые являются между 5.0.0.1 и 6.0.0.3.

Как только маршрутизаторы становятся смежными на виртуальном соединении, Router3 3.3.3 считает себя пограничным маршрутизатором области (ABR), потому что это теперь имеет ссылку в области 0. В результате Router3 3.3.3 создает суммарное объявление о состоянии каналов для 12.0.0.0/8 в области 0 и в области 1.

Если виртуальное соединение неправильно сконфигурировано по некоторым причинам, то Router3 3.3.3 не считает себя ABR, потому что это не имеет никаких интерфейсов в области 0. Если это верно, это не создает суммарные объявления о состоянии каналов или объявляет 12.0.0.0/8 в область 1.

Примечание: OSPF выполняется поверх IP и количества по протоколу использования 89. OSPF не полагается ни на какие другие транспортные протоколы, такие как TCP и UDP.

Вычислите кратчайший путь

Этот раздел вычисляет кратчайший путь с точки зрения Router2 2.2.2.

Router-2. 2.2.2 взгляда в его собственном LSA и видят, что Router3 3.3.3 является соседним узлом. Это тогда посмотрело на LSA Router3 3.3.3, чтобы проверить, что Router3 3.3.3 рассматривает Router2 2.2.2 как соседний узел. Если оба маршрутизатора рассматривают друг друга как соседние узлы, то их считают достижимыми.

Каждый маршрутизатор также проверяет свою локальную таблицу соседей (который вы видите с командой show ip ospf neighbor ) проверить, что его интерфейс и интерфейс соседнего узла находятся на общей IP-подсети.

Примечание: Эта проверка не выполнена на ненумерованном интерфейсе.

Если они находятся на общей подсети, маршрутах установки маршрутизаторов для каких-либо тупиковых сетей, перечисленных в LSA маршрутизатора (локальный администратор безопасности) их соседнего узла. В данном примере 6.0.0.0/8 является единственной тупиковой сетью, перечисленной в LSA Router3 3.3.3 в области 1, с которым уже непосредственно связан Router2 2.2.2.

Маршрутизатор 3. 3.3.3 делает то же исследование для LSA Router1 1.1.1, но нет никаких полезных тупиковых сетей в LSA Router1 1.1.1.

После того, как все LSA для доступного маршрутизатора в области 1 исследованы, Router2 2.2.2 посмотрел на суммарные объявления о состоянии каналов в базе данных. Это находит два суммарных объявления о состоянии каналов для 12.0.0.0/8 в области 1 и выбирает ту с самыми низкими общими затратами, которые являются метрикой для достижения объявляющего маршрутизатора плюс метрика суммарного объявления о состоянии каналов.

  • Router-2. 2.2.2 может достигнуть 12.0.0.0 через Router1 1.1.1 со стоимостью 64 + 75 = 139.

  • Router-2. 2.2.2 может достигнуть 12.0.0.0 через Router3 3.3.3 со стоимостью 1 + 10 = 11.

Router-2. 2.2.2 установки маршрут в его таблице маршрутизации через Router3 3.3.3 с метрикой 11.

Эти выходные данные показывают, что маршруты OSPF в таблице маршрутизации каждого маршрутизатора ранее описали:

Router1.1.1.1#show ip route ospf

!--- Output suppressed.

O    6.0.0.0/8 [110/65] via 5.0.0.2, 00:38:12, Serial2/1/0
O IA 12.0.0.0/8 [110/75] via 5.0.0.2, 00:38:02, Serial2/1/0

Router2.2.2.2#show ip route ospf

!--- Output suppressed.

O IA 4.0.0.0/8 [110/74] via 5.0.0.1, 00:38:08, Serial0/1/0
O IA 12.0.0.0/8 [110/11] via 6.0.0.3, 00:38:12, ATM1/0.20

!--- This is the route in this example.

Router3.3.3.3#show ip route ospf

!--- Output suppressed.

O    4.0.0.0/8 [110/75] via 6.0.0.2, 00:38:18, ATM2/0.20
O    5.0.0.0/8 [110/65] via 6.0.0.2, 00:38:28, ATM2/0.20

Использование туннеля GRE вместо виртуального соединения

Можно также создать туннель универсальной инкапсуляции маршрутизации (GRE) между Router1 1.1.1 и Router3 3.3.3 и поместить туннель в область 0. Основные различия между Туннелем GRE и виртуальным соединением описаны в этой таблице:

Туннель GRE Виртуальный канал
Весь трафик в туннеле инкапсулируется и декапсулируется оконечными точками туннеля. Обновления маршрута туннелированы, но трафик данных передается исходно.
Заголовки туннеля в каждых пакетных служебных данных причины. Трафик данных не подвергается никаким туннельным издержкам.
Туннель может пройти изолированную область. Транзитная область не может быть изолированной областью, потому что маршрутизаторы в изолированной области не имеют маршрутов для внешних назначений. Поскольку данные передаются исходно, если пакет, предназначенный для внешнего назначения, передан в изолированную область, которая является также транзитной областью, тогда пакет не маршрутизируется правильно. Маршрутизаторы в изолированной области не имеют маршрутов для определенных внешних назначений.

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Исследуйте базу данных OSPF

Это - то, как база данных OSPF смотрит, учитывая эту сетевую среду при запуске команды show ip ospf database.

Router1.1.1.1#show ip ospf database

       OSPF Router with ID (1.1.1.1) (Process ID 2)

                Router Link States (Area 0)

Link ID   ADV Router    Age             Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       919             0x80000003    0xD5DF         2
3.3.3.3   3.3.3.3       5     (DNA)     0x80000002    0x3990         1

                Summary Net Link States (Area 0)

Link ID   ADV Router    Age                 Seq#         Checksum
5.0.0.0   1.1.1.1       1945                0x80000002   0xAA48
5.0.0.0   3.3.3.3       9     (DNA)         0x80000001   0x7A70
6.0.0.0   1.1.1.1       1946                0x80000002   0xA749
6.0.0.0   3.3.3.3       9     (DNA)         0x80000001   0xEA3F
12.0.0.0  3.3.3.3       9     (DNA)         0x80000001   0xF624

                Router Link States (Area 1)

Link ID   ADV Router    Age             Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       1946            0x80000005    0xDDA6         2
2.2.2.2   2.2.2.2       10              0x80000009    0x64DD         4
3.3.3.3   3.3.3.3       930             0x80000006    0xA14C         2

                Summary Net Link States (Area 1)

Link ID   ADV Router    Age             Seq#           Checksum
4.0.0.0   1.1.1.1       1947            0x80000002     0x9990
4.0.0.0   3.3.3.3       911             0x80000001     0xEBF5
12.0.0.0  1.1.1.1       913             0x80000001     0xBF22
12.0.0.0  3.3.3.3       931             0x80000001     0xF624

Router2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2)

                Router Link States (Area 1)

Link ID   ADV Router    Age     Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       1988    0x80000005    0xDDA6        2
2.2.2.2   2.2.2.2       50      0x80000009    0x64DD        4
3.3.3.3   3.3.3.3       969     0x80000006    0xA14C        2

                Summary Net Link States (Area 1)

Link ID   ADV Router    Age      Seq#          Checksum
4.0.0.0   1.1.1.1       1988     0x80000002    0x9990
4.0.0.0   3.3.3.3       950      0x80000001    0xEBF5
12.0.0.0  1.1.1.1       955      0x80000001    0xBF22
12.0.0.0  3.3.3.3       970      0x80000001    0xF624

Router3.3.3.3#show ip ospf database

       OSPF Router with ID (3.3.3.3) (Process ID 2)

                Router Link States (Area 0)

Link ID   ADV Router    Age          Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       6   (DNA)    0x80000003    0xD5DF         2
3.3.3.3   3.3.3.3       977          0x80000002    0x3990         1

                Summary Net Link States (Area 0)

Link ID   ADV Router    Age            Seq#          Checksum
5.0.0.0   1.1.1.1       1027  (DNA)    0x80000002    0xAA48
5.0.0.0   3.3.3.3       986            0x80000001    0x7A70
6.0.0.0   1.1.1.1       1027  (DNA)    0x80000002    0xA749
6.0.0.0   3.3.3.3       987            0x80000001    0xEA3F
12.0.0.0  3.3.3.3       987            0x80000001    0xF624

                Router Link States (Area 1)

Link ID   ADV Router    Age    Seq#          Checksum   Link count
1.1.1.1   1.1.1.1       2007   0x80000005    0xDDA6         2
2.2.2.2   2.2.2.2       68     0x80000009    0x64DD         4
3.3.3.3   3.3.3.3       987    0x80000006    0xA14C         2

                Summary Net Link States (Area 1)

Link ID   ADV Router    Age      Seq#         Checksum
4.0.0.0   1.1.1.1       2007    0x80000002    0x9990
4.0.0.0   3.3.3.3       967     0x80000001    0xEBF5
12.0.0.0  1.1.1.1       973     0x80000001    0xBF22
12.0.0.0  3.3.3.3       987     0x80000001    0xF624

                Router Link States (Area 2)

Link ID   ADV Router    Age    Seq#          Checksum   Link count
3.3.3.3   3.3.3.3       987    0x80000003    0xCF5          1

                Summary Net Link States (Area 2)

Link ID   ADV Router    Age    Seq#        Checksum
4.0.0.0   3.3.3.3       968    0x80000001  0xEBF5
5.0.0.0   3.3.3.3       988    0x80000001  0x7A70
6.0.0.0   3.3.3.3       988    0x80000001  0xEA3F

Заметьте, что LSA, изученные через виртуальное соединение, имеют опцию DoNotAge. Виртуальное соединение рассматривается как канал требования.

Router1.1.1.1#show ip ospf database router 1.1.1.1

       OSPF Router with ID (1.1.1.1) (Process ID 2)

                Router Link States (Area 0)

  LS age: 1100
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 1.1.1.1

!--- For router links, Link State ID is always the same as the Advertising Router.

  Advertising Router: 1.1.1.1

!--- This is the router ID of the router that created this LSA.

  LS Seq Number: 80000003
  Checksum: 0xD5DF
  Length: 48
  Area Border Router

!--- Bit B in the router LSA indicates that this router is an ABR.

   Number of Links: 2

!--- There are two links in Area 0.

    Link connected to: a Virtual Link
     (Link ID) Neighboring Router ID: 3.3.3.3

!--- Router ID of the neighbor on the other end of the virtual link.

     (Link Data) Router Interface address: 5.0.0.1

!--- The interface that this router uses to send packets to the neighbor.

      Number of TOS metrics: 0
       TOS 0 Metrics: 65

!--- The metric comes from the cost for this router to reach the neighboring router:
!--- the ATM link has a cost of 1 and the serial link has a cost of 64.

    Link connected to: a Stub Network

!--- This represents the Ethernet segment 4.0.0.0/8.

     (Link ID) Network/subnet number: 4.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 10

                Router Link States (Area 1)

  LS age: 122
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 1.1.1.1
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000006
  Checksum: 0xDBA7
  Length: 48
  Area Border Router
   Number of Links: 2

!--- There are two links in Area 1.

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 2.2.2.2
     (Link Data) Router Interface address: 5.0.0.1
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 5.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

Router1.1.1.1#show ip ospf database router 2.2.2.2

       OSPF Router with ID (1.1.1.1) (Process ID 2)

                Router Link States (Area 1)

  LS age: 245
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 2.2.2.2
  Advertising Router: 2.2.2.2
  LS Seq Number: 80000009
  Checksum: 0x64DD
  Length: 72
   Number of Links: 4

!--- There are four links in Area 1.


    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 3.3.3.3
     (Link Data) Router Interface address: 6.0.0.2
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 6.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 1.1.1.1
     (Link Data) Router Interface address: 5.0.0.2
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 5.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

Router1.1.1.1#show ip ospf database router 3.3.3.3

       OSPF Router with ID (1.1.1.1) (Process ID 2)

                Router Link States (Area 0)

  Routing Bit Set on this LSA
  LS age: 5 (DoNotAge)
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 3.3.3.3
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0x3990
  Length: 36
  Area Border Router
   Number of Links: 1

!--- There is one link in Area 0.


    Link connected to: a Virtual Link
     (Link ID) Neighboring Router ID: 1.1.1.1
     (Link Data) Router Interface address: 6.0.0.3
      Number of TOS metrics: 0
       TOS 0 Metrics: 65

                Router Link States (Area 1)

  Routing Bit Set on this LSA
  LS age: 1137
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 3.3.3.3
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000006
  Checksum: 0xA14C
  Length: 48
  Area Border Router
   Number of Links: 2

!--- There are two links in Area 1.


    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 2.2.2.2
     (Link Data) Router Interface address: 6.0.0.3
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 6.0.0.0
     (Link Data) Network Mask: 255.0.0.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

Маршрутизатор 3. 3.3.3 считает себя ABR, потому что он имеет ссылку на область 0 (виртуальное соединение). В результате это генерирует суммарное объявление о состоянии каналов для 12.0.0.0 в область 1 и область 0, который вы видите при выдаче команды сводки show ip ospf database.

Router3.3.3.3#show ip ospf database summary 12.0.0.0

       OSPF Router with ID (3.3.3.3) (Process ID 2)

                Summary Net Link States (Area 0)

  LS age: 1779
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000001
  Checksum: 0xF624
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 10

                Summary Net Link States (Area 1)

  LS age: 1766
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000001
  Checksum: 0xBF22
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 75

  LS age: 1781
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000001
  Checksum: 0xF624
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 10

Кроме того, заметьте, что Router3 3.3.3 создает суммарные объявления о состоянии каналов в области 2 для всей информации, которую это изучило из области 0 и области 1.

Router3.3.3.3#show ip ospf database summary self-originate

       OSPF Router with ID (3.3.3.3) (Process ID 2)

                Summary Net Link States (Area 0)

  LS age: 155
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 5.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0x7871
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 65

  LS age: 155
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 6.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xE840
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 1

  LS age: 156
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xF425
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 10

                Summary Net Link States (Area 1)

  LS age: 157
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 4.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xE9F6
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 75

  LS age: 165
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 12.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xF425
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 10

                Summary Net Link States (Area 2)

  LS age: 167
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 4.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xE9F6
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 75

  LS age: 168
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 5.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0x7871
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 65

  LS age: 168
  Options: (No TOS-capability, DC)
  LS Type: Summary Links(Network)
  Link State ID: 6.0.0.0 (summary Network Number)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000002
  Checksum: 0xE840
  Length: 28
  Network Mask: /8
        TOS: 0  Metric: 1

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Команды устранения неполадок

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

  • debug ip ospf adj — Отображает события, включенные, чтобы создать или сломать соседство OSPF.

Маршрутизаторы становятся смежными и обменными LSA через виртуальное соединение, подобное физическому соединению. Вы видите смежность при исследовании LSA маршрутизатора (локальный администратор безопасности) или выходных данных команды debug ip ospf adj:

Router3.3.3.3#
May 26 17:25:03.089: OSPF: Rcv hello from 1.1.1.1 area 0 from OSPF_VL3 5.0.0.1
May 26 17:25:03.091: OSPF: 2 Way Communication to 1.1.1.1 on OSPF_VL3, state 2WAY
May 26 17:25:03.091: OSPF: Send DBD to 1.1.1.1 on OSPF_VL3
                           seq 0xD1C opt 0x62 flag 0x7 len 32
May 26 17:25:03.135: OSPF: End of hello processing
May 26 17:25:03.139: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3
                           seq 0x1617 opt 0x22 flag 0x7 len 32
                           mtu 0 state EXSTART
May 26 17:25:03.175: OSPF: First DBD and we are not SLAVE
May 26 17:25:03.179: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3
                           seq 0xD1C opt 0x22 flag 0x2 len 172
                           mtu 0 state EXSTART
May 26 17:25:03.183: OSPF: NBR Negotiation Done. We are the MASTER
May 26 17:25:03.189: OSPF: Send DBD to 1.1.1.1 on OSPF_VL3
                           seq 0xD1D opt 0x62 flag 0x3 len 172
May 26 17:25:03.191: OSPF: Database request to 1.1.1.1
May 26 17:25:03.191: OSPF: sent LS REQ packet to 5.0.0.1, length 36
May 26 17:25:03.263: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3
                           seq 0xD1D opt 0x22 flag 0x0 len 32
                           mtu 0 state EXCHANGE
May 26 17:25:03.267: OSPF: Send DBD to 1.1.1.1 on OSPF_VL3
                           seq 0xD1E opt 0x62 flag 0x1 len 32
May 26 17:25:03.311: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3
                           seq 0xD1E opt 0x22 flag 0x0 len 32
                           mtu 0 state EXCHANGE
May 26 17:25:03.311: OSPF: Exchange Done with 1.1.1.1 on OSPF_VL3
May 26 17:25:03.315: OSPF: Synchronized with 1.1.1.1 on OSPF_VL3, state FULL
May 26 17:25:03.823: OSPF: Build router LSA for area 0,
                           router ID 3.3.3.3, seq 0x80000029
May 26 17:25:03.854: OSPF: Dead event ignored for 1.1.1.1 on demand circuit OSPF_VL3

Router3.3.3.3#show ip ospf neighbor

Neighbor ID       Pri       State        Dead Time       Address         Interface
2.2.2.2           1         FULL/  -     00:00:38        6.0.0.2         ATM2/0.20

Router3.3.3.3#show ip ospf virtual-links

Virtual Link OSPF_VL3 to router 1.1.1.1 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 1, via interface ATM2/0.20, Cost of using 65
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:01
    Adjacency State FULL (Hello suppressed)
    Index 1/2, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec

Заметьте, что смежности по виртуальным соединениям не отображены в выходных данных команды show ip ospf neighbor. Единственный способ видеть их состоит в том, чтобы посмотреть на LSA маршрутизатора (локальный администратор безопасности) и наблюдать команды отладки, поскольку смежность подходит, или выполните команду show ip ospf virtual-links .


Дополнительные сведения


Document ID: 47866