Протокол IP : Протокол OSPF

Межобластная маршрутизация OSPF

21 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этом документе рассматриваются база данных OSPF и таблица маршрутизации при работе OSPF с двумя зонами, .

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сетевая установка, показанная на следующей схеме.

/image/gif/paws/47864/ospfdb5a.gif

Конфигурации

Эти конфигурации используются в данном документе.

Маршрутизатор 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet2/0/0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0

end

Маршрутизатор 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial0/1/0
 ip unnumbered Ethernet0/0/4

interface ATM1/0.20 point-to-point
 ip address 200.0.0.2 255.255.255.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 200.0.0.0 0.255.255.255 area 1

end

Маршрутизатор 3.3.3.3
Current configuration:

hostname r3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 200.0.0.3 255.255.255.0
 
router ospf 2
 network 200.0.0.0 0.255.255.255 area 1

end

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show ip ospf database — Отображает список Объявлений о состоянии канала (LSA) в базе данных состояния канала. Этот список показывает только информацию в заголовке LSA.

  • show ip ospf database [router] [link-state-id] — Отображает содержание LSA маршрутизатора (локальный администратор безопасности) (LSA Type1) в базе данных. LSA маршрутизатора (локальный администратор безопасности) произведены каждым маршрутизатором, и эти фундаментальные LSA перечисляют весь ссылок маршрутизатора или интерфейсов, наряду с состояниями и исходящими затратами ссылок. Они лавинно рассылаются только в области, в которой они происходят.

  • сводка show ip ospf database <идентификатор состояния канала> — Отображает суммарные каналы пограничного маршрутизатора области (ABR).

Исследуйте базу данных OSPF

Так как маршрутизатор 2.2.2.2 является ABR, он имеет базу данных для обеих областей, с которыми он связан. Поэтому он находится в наилучшем положении для просмотра базы данных протокола OSPF при помощи команды "show ip ospf database".

r2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#          Checksum   Link count 
1.1.1.1   1.1.1.1      697    0x80000040    0x5A21         2 
2.2.2.2   2.2.2.2      696    0x80000045    0xEE82         2 

                Summary Net Link States (Area 0) 

Link ID     ADV Router   Age  Seq#          Checksum 
200.0.0.0   2.2.2.2      352  0x80000001    0x2546 

                Router Link States (Area 1) 

Link ID   ADV Router Age    Seq#          Checksum   Link count 
2.2.2.2   2.2.2.2    351    0x8000000B    0xCA9D         2 
3.3.3.3   3.3.3.3    354    0x80000006    0x71F7         2 

                Summary Net Link States (Area 1) 

Link ID    ADV Router   Age   Seq#         Checksum 
4.0.0.0    2.2.2.2      689   0x80000001   0xFFE6 
6.0.0.0    2.2.2.2      700   0x80000001   0x63C1 

 r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 773 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, Link State Id is always the same as the 
  !--- Advertising Router (next line).

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created this LSA.

  LS Seq Number: 80000040 
  Checksum: 0x5A21 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point)
	
!--- This line shows that Router 1.1.1.1 is a neighbor 
    !--- with Router 2.2.2.2. 

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 0.0.0.12
    
 !--- The link is unnumbered, so the address starts with 
	 !--- zero. In the case of unnumbered links, the interface address 
     !--- displays the MIB II IfIndex value that usually starts with 0.
 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
	   
!--- This is the OSPF cost of the link that connects 
       !--- the two routers.
 

    Link connected to: a Stub Network

	!--- This line represents the Ethernet segment 4.0.0.0/8.
 
     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

        Router Link States (Area 0) 

!--- This is the router LSA for 2.2.2.2 in area 0. 


  LS age: 789 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000045 
  Checksum: 0xEE82 
  Length: 48 
  Area Border Router
  
!--- Bit B is set in the router LSA. 
  !--- It indicates that this router is an ABR.
 
   Number of Links: 2
   
!--- There are two links in area 0. 


    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 0.0.0.10 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

                Router Link States (Area 1)    
				
!--- This is the router LSA for 
    			!--- Router 2.2.2.2 in area 1. 


  LS age: 445 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000000B 
  Checksum: 0xCA9D 
  Length: 48 
  Area Border Router
   Number of Links: 2

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 3.3.3.3 
     (Link Data) Router Interface address: 200.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 200.0.0.0 
     (Link Data) Network Mask: 255.255.255.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

r2.2.2.2#show ip ospf database router 3.3.3.3 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 1) 

  LS age: 465 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 3.3.3.3 
  Advertising Router: 3.3.3.3 
  LS Seq Number: 80000006 
  Checksum: 0x71F7 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 200.0.0.3 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 200.0.0.0 
     (Link Data) Network Mask: 255.255.255.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

Для объявления маршрутов от одной области в другого ABR создает суммарные каналы, которые вы видите использование сводки show ip ospf database команда <link-state id>.

r2.2.2.2#show ip ospf database summary 200.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 0) 

  LS age: 487 
  Options: (No TOS-capability, DC, Upward) 

  !--- The Upward keyword indicates that this is not an LSA imported 
  !--- from a VPN backbone (from a PE to a CE).

  LS Type: Summary Links(Network) 
  Link State ID: 200.0.0.0 (summary Network Number)
  
!--- 200.0.0.0/24 is advertised into area 0 by the 
  !--- ABR (Router 2.2.2.2). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x2546 
  Length: 28 
  Network Mask: /24 
        TOS: 0  Metric: 1 

r2.2.2.2#show ip ospf database summary 4.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 1) 

  LS age: 840 
  Options: (No TOS-capability, DC, Upward) 
  LS Type: Summary Links(Network) 
  Link State ID: 4.0.0.0 (summary Network Number)
  
!--- 4.0.0.0/8 is advertised into area 1 by 
  !--- the ABR (Router 2.2.2.2).
 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xFFE6 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 74 

r2.2.2.2#show ip ospf database summary 6.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 1) 

  LS age: 861 
  Options: (No TOS-capability, DC, Upward) 
  LS Type: Summary Links(Network) 
  Link State ID: 6.0.0.0 (summary Network Number)
  
!--- 6.0.0.0/8 is advertised into area 1 by the 
  !--- ABR (Router 2.2.2.2). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x63C1 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 10 

Вычислите кратчайший путь

Этот раздел вычисляет кратчайший путь с точки зрения маршрутизатора 3.3.3.3.

Маршрутизатор 3.3.3.3 проверяет свою собственную информацию LSA, из которой следует, что маршрутизатор 2.2.2.2 – соседний. Маршрутизатор 3. 3.3.3 тогда взгляды на LSA маршрутизатора 2.2.2.2's, чтобы проверить, что маршрутизатор 2.2.2.2 рассматривает маршрутизатор 3.3.3.3 как соседний узел. Если оба маршрутизатора рассматривают друг друга как соседние узлы, их считают достижимыми.

Каждый маршрутизатор также проверяет свою локальную таблицу соседей (для просмотра этой таблицы используйте команду show ip ospf neighbor), чтобы удостовериться, что его интерфейс и интерфейс соседа принадлежат общей IP-подсети.

Примечание: Эта проверка не выполнена на ненумерованном интерфейсе.

Если интерфейсы находятся на общей подсети, маршрутах установки маршрутизаторов для каких-либо тупиковых сетей, перечисленных в LSA их соседнего узла. В данном примере 200.0.0.0/24 является единственной тупиковой сетью, перечисленной в LSA маршрутизатора 2.2.2.2's, с которым уже непосредственно связан маршрутизатор 3.3.3.3.

После того, как все LSA для доступного маршрутизатора в области 1 исследованы, маршрутизатор 3.3.3.3 посмотрел на суммарные объявления о состоянии каналов в базе данных. Это находит суммарные объявления о состоянии каналов для 4.0.0.0/8 и 6.0.0.0/8. Если маршрутизатору 3.3.3.3 известен маршрут к объявляющему маршрутизатору, который создал сводное объявление LSA, этот маршрут включается в таблицу маршрутизации. В данном примере объявляющий маршрутизатор является маршрутизатором 2.2.2.2. Так как маршрутизатор 3.3.3.3 знает, как достигнуть маршрутизатора 2.2.2.2, он устанавливает маршруты для 4.0.0.0/8 и 6.0.0.0/8 в его таблице маршрутизации. Метрика для этих маршрутов -это метрика для достижения объявленного маршрутизатора плюс метрика сводного LSA. Метрика сводного LSA рассчитывается от затрат на достижение внутриобластного или межобластного маршрута, для которого генерируется сводный LSA.

Примечание: Маршрутизаторы используют LSA Type1 для объявления сетей и других маршрутизаторов, к которым они напрямую подключаются в области, которая лавинно рассылается в той же области. Так, все маршрутизаторы в той же области имеют завершенную информацию о топологии для своей собственной области. В результате ABR поддерживают завершенную информацию о топологии обо всех областях, к которым они непосредственно подключены. Однако, когда ABR объявляют сеть, которая принадлежит одной области во вторую область, они объявляют только префикс и маску сети при помощи LSA Type-3. Маршрутизаторы во второй области не знают об информации о топологии других областей, но у них есть информация о доступности для сетей в других областях.

Эти выходные данные показывают маршруты OSPF в таблице маршрутизации каждого маршрутизатора, описанного выше.

r1.1.1.1# show ip route ospf 
O IA 200.0.0.0/24 [110/65] via 6.0.0.2, 00:09:00, Serial2/1/0 
O    6.0.0.0/8 [110/74] via 6.0.0.2, 00:14:41, Serial2/1/0 

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 4.0.0.1, 00:09:16, Serial0/1/0 

r3.3.3.3#show ip route ospf
O IA 4.0.0.0/8 [110/75] via 200.0.0.2, 00:09:27, ATM2/0.20 
O IA 6.0.0.0/8 [110/11] via 200.0.0.2, 00:09:27, ATM2/0.20 

Устранение неполадок

Для получения информации об устранении проблем OSPF, когда информация в базе данных отсутствует в Таблице маршрутизации, обратитесь к тому, Почему Некоторые Маршруты OSPF в Базе данных, но Не в Таблице маршрутизации? Для получения общей информации об Устранении проблем для протокола OSPF обратитесь к Устранению проблем OSPF.


Дополнительные сведения


Document ID: 47864