Протокол IP : Протокол OSPF

Маршрутизаторы OSPF, подключенные через сеть множественного доступа

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этом документе показаны два маршрутизатора OSPF, объединенные в сеть множественного доступа.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме.

/image/gif/paws/47863/ospfdb4a.gif

Конфигурации

В данном документе используются конфигурации, показанные ниже.

Маршрутизатор 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Ethernet2/0/2
 ip address 5.0.0.1 255.0.0.0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Маршрутизатор 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Ethernet0/0/2
 ip address 5.0.0.2 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show ip ospf database — Отображает список Объявлений о состоянии канала (LSA) и вводит их в базу данных состояния канала. Этот список показывает только информацию в заголовке LSA.

  • show ip ospf database [router] [link-state-id] — Отображает список всех LSA маршрутизатора в базе данных. LSA произведены каждым маршрутизатором, и эти фундаментальные LSA перечисляют все ссылки маршрутизаторов или интерфейсы, вместе с состояниями и исходящими затратами ссылок. Они лавинно рассылаются только в области, в которой они происходят.

Исследуйте базу данных OSPF

Чтобы видеть, как база данных OSPF выглядит данной эту сетевую среду, посмотрите на выходные данные команды show ip ospf database .

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router  Age   Seq#         Checksum  Link count 
1.1.1.1   1.1.1.1     107   0x80000018   0x7966        2 
2.2.2.2   2.2.2.2     106   0x80000015   0x6770        2 

                Net Link States (Area 0) 

Link ID   ADV Router  Age   Seq#         Checksum 
5.0.0.2   2.2.2.2     102   0x80000004   0x7E9D 
  

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 147 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, the Link State Id is always the 
  !--- same as the Advertising Router. 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created 
  !--- this LSA.
 
  LS Seq Number: 80000018 
  Checksum: 0x7966 
  Length: 48 
   Number of Links: 2 

    Link connected to: a Transit Network
    
!--- This router (1.1.1.1) has a link connected to 
    !--- a transit network that has a designated router (DR)
    !--- and backup designated router (BDR) listed here.  

     (Link ID) Designated Router address: 5.0.0.2
	 
!--- The DR's interface IP address is 5.0.0.2.
 
     (Link Data) Router Interface address: 5.0.0.1
	 
!--- This router's (1.1.1.1) interface address 
     !--- connected to the DR is 5.0.0.1. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
       
!--- The OSPF cost of the link is 10.
 

    Link connected to: a Stub Network 
    
!--- This represents the subnet of the Ethernet segment
    !--- 4.0.0.0/8. 

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
       
!--- The cost of the link is 10. 


r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 162 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000015 
  Checksum: 0x6770 
  Length: 48 
   Number of Links: 2 

    Link connected to: a Transit Network 
     (Link ID) Designated Router address: 5.0.0.2
     
!--- The DR's interface IP address is 5.0.0.2.
 
     (Link Data) Router Interface address: 5.0.0.2
     
!--- Since these values are equal, router
     !--- (2.2.2.2) is the DR. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 
  

r2.2.2.2#show ip ospf database network 5.0.0.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Net Link States (Area 0) 

  Routing Bit Set on this LSA 
  LS age: 182 
  Options: (No TOS-capability, DC) 
  LS Type: Network Links 
  Link State ID: 5.0.0.2 (address of Designated Router)
  
!--- This is the IP address of the DR 
  !--- (not the router ID). 

  Advertising Router: 2.2.2.2
  
!--- This is the router ID of the router that 
  !--- created this LSA.

  LS Seq Number: 80000004 
  Checksum: 0x7E9D 
  Length: 32 
  Network Mask: /8
  
!--- Binary and the DR's interface address with the 
  !--- mask to get to network 5.0.0.0/8. 

        Attached Router: 2.2.2.2
	
!--- The DR's router ID, along with a list of routers 
    !--- adjacent on the transit network. 

        Attached Router: 1.1.1.1 

Вычислите кратчайший путь

Этот раздел вычисляет дерево кратчайших путей с точки зрения Маршрутизатора 1.1.1.1.

Маршрутизатор 1. 1.1.1 взгляда в его собственном LSA и видят, что это имеет ссылку на транзитную сеть, для которой 5.0.0.2 интерфейсный адрес DR. Это тогда ищет сеть LSA с идентификатором состояния канала 5.0.0.2. Он находит список присоединенных маршрутизаторов (маршрутизаторы 1.1.1.1 и 2.2.2.2) в сети LSA. Это означает, что все эти маршрутизаторы доступны через эту транзитную сеть. Маршрутизатор 1. 1.1.1 может проверить, что его собственный ID находится в списке. Это тогда может вычислить маршруты через любой из этих присоединенных маршрутизаторов.

Маршрутизатор 1.1.1.1 осуществляет поиск LSA маршрутизатора 2.2.2.2 для проверки наличия ссылки на ту же транзитную сеть 5.0.0.2. Маршрутизатор 1.1.1.1 может установить маршрутизаторы для любых тупиковых сетей в LSA маршрутизатора 2.2.2.2.

Маршрутизатор 1.1.1.1 устанавливает в своей таблице маршрутизации маршрут для сети 6.0.0.0/8, поскольку сеть 6.0.0.0/8 была обозначена в его объявлении о состоянии каналов как тупиковая.

r1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/20] via 5.0.0.2, 00:03:35, Ethernet2/0/2 

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/20] via 5.0.0.1, 00:03:18, Ethernet0/0/2 

База данных состояний каналов OSPF выглядит идентичной, если это - широковещательная сеть или нешироковещательная сеть. Основное отличие заключается в механизме обнаружения соседа. В широковещательной сети соседние узлы обнаружены через многоадресные пакеты запроса приветствия. Соседи в нешироковещательной сети настроены статически, и одноадресные пакеты hello отправляются с целью формирования смежности между соседями.

Следующий узел на нешироковещательных сетях с многократным доступом

Для исследования проблемы следующего перехода в сети (NBMA) нешироковещательный множественного доступа посмотрите на данный пример. Транзитная сеть содержит три маршрутизатора (маршрутизаторы non_DR_a, non_DR_b и DR). Это - топология звезды на Среды NBMA, такие как Frame Relay, Асинхронный режим передачи (ATM) или X.25.

/image/gif/paws/47863/ospfdb4b.gif

Если маршрутизатор non_DR_a рассчитывает маршрут через маршрутизатор non_DR_b, маршрутизатор non_DR_b становится следующим переходом. Однако non_DR_a Маршрутизатора не имеет виртуального канала (VC) к non_DR_b Маршрутизатора, что означает, что эти маршрутизаторы не могут пропинговать друг друга. OSPF устанавливает маршруты в таблицу маршрутизации со следующим переходом, который не может быть достигнут.

Способ решения этой проблемы заключается в добавлении второго правила набора Frame Relay, чтобы все соседи были доступными через VC, идущий к маршрутизатору DR. Например:

interface Serial0 
 frame-relay map ip 1.1.1.1 700 broadcast
 
!--- This is a map for the DR. 

 frame-relay map ip 1.1.1.2 700 broadcast
 
!--- This is a map on the same VC data-link connection 
 !--- identifier (DLCI) for a non-DR router. 

При сравнении этого поведения с тем из протокола Intermediate System-to-Intermediate System (ISIS) маршрутизатор не устанавливает Маршрут IS-IS через следующий переход, пока следующий переход не является соседним узлом. Это означает, что ISIS не работает на многоточечный интерфейс, пока маршрутизаторы полностью не пойманы в сети.

OSPF устанавливает маршруты даже при том, что следующий переход не является соседним узлом и не достижим через Уровень 2. Однако можно решить эту проблему путем настройки множественных операторов отображения.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 47863