Протокол IP : Протокол OSPF

Маршрутизаторы OSPF, соединенные многоточечным каналом

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ показывает два маршрутизатора Протокола OSPF, связанные ссылкой точка - много точек.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/47862/ospfdb3a.gif

Конфигурации

Эти конфигурации используются в данном документе:

Маршрутизатор 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 ip ospf network point-to-multipoint
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Маршрутизатор 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.2 255.0.0.0
 ip ospf network point-to-multipoint
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • show ip ospf database — Отображает список Объявлений о состоянии канала (LSA) и вводит их в базу данных состояния канала. Этот список показывает только информацию в заголовке LSA.

  • show ip ospf database [router] [link-state-id] — Отображает список всех LSA маршрутизатора в базе данных. LSA произведены каждым маршрутизатором. Эти фундаментальные LSA перечисляют все ссылки или интерфейсы маршрутизаторов, наряду с состояниями и исходящими затратами ссылок. Они лавинно рассылаются только в области, в которой они происходят.

Исследуйте базу данных OSPF

Чтобы видеть, как база данных OSPF выглядит данной эту сетевую среду, посмотрите на выходные данные команды show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#           Checksum   Link count 
1.1.1.1  1.1.1.1       206    0x8000000A     0x158C       3 
2.2.2.2  2.2.2.2       206    0x8000000B     0x791        3 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 224 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, Link State Id is always the same 
  !--- as the Advertising Router (next line).

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created 
  !--- this LSA.

  LS Seq Number: 8000000A 
  Checksum: 0x158C 
  Length: 60 
   Number of Links: 3 

    Link connected to: another Router (point-to-point) 
   
 !--- This line shows that this router(1.1.1.1) is a 
	   !--- neighbor with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1 
     
!--- This line shows the interface on this router 
	    !--- (1.1.1.1) that connects the neighbor (2.2.2.2).

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64  
       
!--- The OSPF cost of the link is 64.


    Link connected to: a Stub Network 
    
!--- This router's (1.1.1.1) interface on the 
    !--- point-to-multipoint network. 

     (Link ID) Network/subnet number: 5.0.0.1 
     (Link Data) Network Mask: 255.255.255.255
     
!--- Notice the mask. Only the interface is advertised,
     !--- not the whole subnet. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 0
      
 !--- The OSPF cost for this router to reach its 
       !--- own interface is zero. 


    Link connected to: a Stub Network
	
!--- Represents the subnet of the Ethernet segment 4.0.0.0/8. 

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
	   
!--- The cost of the link is 10.


r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 253 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000000B 
  Checksum: 0x791 
  Length: 60 
   Number of Links: 3 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.2 
     (Link Data) Network Mask: 255.255.255.255 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 0 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10

Вычислите кратчайший путь

Этот раздел вычисляет дерево кратчайших путей с точки зрения маршрутизатора 2.2.2.2.

Маршрутизатор 2.2.2.2 просматривает свое объявление LSA и видит, что Маршрутизатор 1.1.1.1 является соседом. Маршрутизатор 2.2.2.2 смотрит на LSA маршрутизатора 1.1.1.1, чтобы подтвердить, что 1.1.1.1 видит 2.2.2.2 в качестве соседа. Если оба маршрутизатора рассматривают друг друга как соседние узлы, то их считают достижимыми.

Каждый маршрутизатор также проверяет локальную таблицу соседа (ее можно увидеть, используя команду show ip ospf neighbor) для подтверждения, что его интерфейсы и соседский интерфейс находятся в общей IP-подсети. Если это так, маршрутизаторы устанавливают маршруты для всех тупиковых сетей, перечисленных в LSA соседнего маршрутизатора.

В этом примере маршрутизатор 2.2.2.2 устанавливает маршрут для 4.0.0.0/8 в своей таблице маршрутизации, так как маршрутизатор 1.1.1.1 занес 4.0.0.0/8 как сеть-заглушку в его собственном маршрутизаторе LSA. Маршрутизатор 1.1.1.1 также считает 5.0.0.1/32 шлейфом, который является его интерфейсом в сети "точка-многие точки". Поэтому маршрутизатор 2.2.2.2 устанавливает маршрут OSPF для 5.0.0.1/32 в его таблице маршрутизации.

Router 2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:09:26, Serial0/1/0 
O    5.0.0.1/32 [110/64] via 5.0.0.1, 00:09:26, Serial0/1/0
  
Router 1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 5.0.0.2, 00:00:49, Serial2/1/0 
O    5.0.0.2/32 [110/64] via 5.0.0.2, 00:00:49, Serial2/1/0

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 47862