Протокол IP : Протокол OSPF

Маршрутизаторы OSPF, соединенные по ненумерованному последовательному каналу

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв



Содержание


Введение

Команда ip unnumbered configuration позволяет включить IP-обработку на последовательном интерфейсе, не назначая явный IP-адрес. Интерфейс Ненумерованного ip может "одолжить" IP-адрес другого интерфейса, который уже настроен на маршрутизаторе. Это сохраняет сетевое и адресное пространство. Для получения дополнительной информации о команде ip unnumbered обратитесь к Пониманию и Настройке команду ip unnumbered. Этот документ иллюстрирует два маршрутизатора Протокола OSPF, связанные ненумерованным последовательным соединением.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме:

/image/gif/paws/47860/ospfdb1.gif

Конфигурации

Эти конфигурации используются в данном документе:

Маршрутизатор 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet2/0/0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0

end

Маршрутизатор 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet0/0/4
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0

end

Проверка.

Этот раздел предоставляет сведения, чтобы подтвердить, что конфигурация работает должным образом.

Некоторые команды show поддерживаются интерпретатором выходных данных (только для зарегистрированных пользователей). Это позволяет просмотреть анализ выходных данных команды show.

  • show ip ospf database — Отображает список Объявлений о состоянии канала (LSA) в базе данных состояния канала. Этот список показывает только информацию в заголовке LSA.

  • show ip ospf database [router] [link-state-id] — Отображает содержание LSA маршрутизатора (локальный администратор безопасности) (LSA Type1) в базе данных. LSA маршрутизатора (локальный администратор безопасности) произведены каждым маршрутизатором. Эти фундаментальные LSA перечисляют все ссылки маршрутизаторов или интерфейсы, вместе с состояниями и исходящими затратами ссылок. Они лавинно рассылаются только в области, в которой они происходят.

Исследуйте базу данных OSPF

Чтобы видеть, как база данных OSPF смотрит, когда ей дают эту сетевую среду, посмотрите на выходные данные команды show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router  Age   Seq#           Checksum     Link count 
1.1.1.1   1.1.1.1     254   0x8000001A     0xA6FA           2 
2.2.2.2   2.2.2.2     253   0x80000017     0x4858           2 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Router Link States (Area 0) 

  LS age: 279 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1   
  
!--- For router links, Link State Id is always the same as the 
  !--- Advertising Router (next line). 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router which created 
  !--- this LSA.

  LS Seq Number: 8000001A 
  Checksum: 0xA6FA 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point)
	
!--- This line shows that this router (1.1.1.1) is a neighbor 
 !--- with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 0.0.0.12
		
!--- In the case of unnumbered link, use the MIB II IfIndex  
  !--- value. This value usually starts with 0. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
	   
!--- This is the OSPF cost of the link that connects 
!--- the two routers.


    Link connected to: a Stub Network 
	
!--- This entry represents the Ethernet segment 4.0.0.0/8.

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10  
	   
!--- This is the OSPF cost of the Ethernet segment. 



r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Router Link States (Area 0) 

  LS age: 295 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000017 
  Checksum: 0x4858 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 0.0.0.10 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

Вычислите кратчайший путь

Этот раздел вычисляет дерево кратчайших путей с точки зрения Маршрутизатора 2.2.2.2.

Маршрутизатор 2.2.2.2 просматривает свое объявление LSA и видит, что Маршрутизатор 1.1.1.1 является соседом. Это тогда посмотрело на LSA Маршрутизатора 1.1.1.1's, чтобы проверить, что 1.1.1.1 видит 2.2.2.2 как соседний узел. Если оба маршрутизатора рассматривают друг друга как соседние узлы, их считают достижимыми. Маршрутизаторы тогда устанавливают маршруты для любых тупиковых сетей, перечисленных в LSA их соседнего узла.

В данном примере Маршрутизатор 2.2.2.2 устанавливает маршрут для 4.0.0.0/8 в его таблице маршрутизации, потому что Маршрутизатор 1.1.1.1 перечисляет 4.0.0.0/8 как тупиковую сеть в его LSA. Это замечено с помощью команды show ip route ospf.

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 4.0.0.1, 00:06:01, Serial0/1/0 

r1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 6.0.0.2, 00:06:16, Serial2/1/0 

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 47860