Протокол IP : Протокол IS-IS

Проблема несоответствия MTU в IS-IS

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Приветствия промежуточных систем (IS-IS) заполняются пустыми байтами до размера полного максимального блока передачи (MTU). Преимущество заполнения приветствий IS-IS (IIH) до полного размера MTU состоит в том, что это позволяет заблаговременно обнаруживать ошибки, связанные с проблемами передачи крупных кадров или несоответствием максимальных размеров блока MTU на смежных интерфейсах.

Заполнение IIH может быть выключено (в Cisco Выпуски ПО IOS� 12.0 (5) T и 12.0 (5) S) для всех интерфейсов на маршрутизаторе с командой no hello padding в режиме конфигурации маршрутизатора для Процесса маршрутизации IS-IS. Заполнение данными IIH можно выборочно отключить для интерфейсов "точка-точка" или многоточечных интерфейсов с помощью команды no hello padding multi-point или no hello padding point-to-point в режиме настройки маршрутизатора для процесса маршрутизации IS-IS. Заполнение приветствий также можно отключить индивидуально с помощью команды настройки интерфейса no isis hello padding.

Пользователь отключил бы заполнение приветствия в заказе, избегают тратить впустую пропускную способность сети в случае, если MTU обоих интерфейсов является тем же или, в случае трансляционного объединения с помощью мостов. В то время как заполнение приветствия отключено, маршрутизаторы Cisco все еще передают первые пять hellos IS-IS, дополненных к полному максимальному размеру передаваемого блока данных. Это должно поддержать преимущества обнаружения несоответствий MTU. Последовательные hellos больше не дополняются.

Данный документ показывает, что произойдет при несовпадении MTU на интерфейсах двух соединенных маршрутизаторов в режиме IS-IS. MTU на маршрутизаторе F изменил свое значение со стандартного 1500 байт на 2000 байт с помощью команды mtu 2000 interface configuration. Последовательным интерфейсом "махали". Поэтому для нового значения MTU для вступления в силу необходимо отключить Serial 0 с командой shutdown, и затем включить его с командой no shutdown.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Проблема

Схему сети и конфигурации, используемые для описания этой проблемы, показывают здесь:

/image/gif/paws/47201/isis_mtu_01.gif

Маршрутизатор H Маршрутизатор F
clns routing
 !

 interface Serial0
  no ip address
  no ip directed-broadcast
  no ip mroute-cache
  encapsulation frame-relay
  frame-relay lmi-type ansi
 !
 interface Serial0.1 

  ip address 10.10.10.4 255.255.255.0
  no ip directed-broadcast
  ip router isis  
  clns router isis 
  frame-relay map clns 132 broadcast
  frame-relay map clns 131 broadcast
  frame-relay map ip 10.10.10.1 132 broadcast
  frame-relay map ip 10.10.10.3 131 broadcast
 !
 interface Serial0.2 point-to-point
  ip address 10.20.20.4 255.255.255.0
  no ip directed-broadcast
  ip router isis 
  clns router isis 
  frame-relay interface-dlci 130   
 !
 router isis 
  passive-interface Ethernet0
  net 49.0001.4444.4444.4444.00
  is-type level-1
clns routing

!
interface Serial2
mtu 2000
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial2.1 point-to-point
 ip address 10.20.20.2 255.255.255.0
 no ip directed-broadcast
 ip router isis 
 clns router isis 
 frame-relay interface-dlci 103   
!
router isis 
 net 49.0001.2222.2222.2222.00
 is-type level-1

На обоих маршрутизаторах вы видите состояние смежности между маршрутизатором F и маршрутизатором H с командой show clns neighbors. В выходных данных маршрутизатора F помните, что смежное соединение с маршрутизатором H находится в состоянии INIT. В выходных данных от маршрутизатора H вы видите, что смежность с маршрутизатором F является типом IS, и протокол является конечной системой - к Промежуточной системе (ES-IS). Эти выходные данные указывают на проблемы с определением смежности для сетевого обслуживания без установления соединений (CLNS).

Router_H# show clns neighbors

System Id      SNPA                Interface   State  Holdtime  Type Protocol
Router_F       DLCI 130            Se0.2       Up     294       IS   ES-IS
Router_G       DLCI 131            Se0.1       Up     7         L1   IS-IS
Router_E       DLCI 132            Se0.1       Up     27        L1   IS-IS


Router_F# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_H       Se2.1       DLCI 103            Init   26        L1   IS-IS

При включении отладки пакета смежности IS-IS с командой debug isis adj-packets вы видите, что маршрутизатор F и передает и получает последовательные IIH на Последовательных 2.1 подинтерфейсах.

Router_F# debug isis adj-packets
IS-IS Adjacency related packets debugging is on
ISIS-Adj: Sending serial IIH on Serial2.1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Sending serial IIH on Serial2.1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Sending serial IIH on Serial2.1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1,cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Sending serial IIH on Serial2.1

Эти выходные данные показывают, что маршрутизатор H не получает IIH на Последовательных 0.2 от маршрутизатора F. Поэтому никакая смежность IS-IS не сформирована. Вместо этого формируется смежность "конечная система" (ES).

Router_H# debug isis adj-packets
IS-IS Adjacency related packets debugging is on
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Sending L1 IIH on Serial0.1
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Sending serial IIH on Serial0.2
ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01 
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Sending L1 IIH on Serial0.1
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01 
ISIS-Adj: Sending serial IIH on Serial0.2
ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01 
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

Причина проблемы

Маршрутизатор H не получает hellos от маршрутизатора F, потому что IIH дополнены к полному MTU ссылки, тогда как hellos ES не дополнены к полному максимальному размеру передаваемого блока данных. Это происходит, потому что маршрутизатор F думает, что MTU является 2000, и это передает 2000 байтов приветствия, которые проигнорированы маршрутизатором H.

Решение

Решение состоит в том, чтобы удостовериться, что обе стороны ссылки имеют тот же MTU. Один способ сделать это должно использовать команду mtu как показано здесь:

Router_F# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router_F(config)# interface serial 2
Router_F(config-if)# mtu 1500
Router_F(config-if)# shutdown
Router_F(config-if)# no shutdown
Router_F(config-if)# ^Z
Router_F#

Теперь маршрутизаторы H и F могут стать соседями и направлять трафик друг друга.

Router_H# show clns neighbors

System Id      SNPA                Interface   State  Holdtime  Type Protocol
Router_F       DLCI 130            Se0.2       Up     28        L1   IS-IS
Router_G       DLCI 131            Se0.1       Up     8         L1   IS-IS
Router_E       DLCI 132            Se0.1       Up     29        L1   IS-IS


Router_F# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_H       Se2.1       DLCI 103            Up     24        L1   IS-IS

Проблема вследствие смежности CLNS к несоответствию MTU может также быть решена с помощью команды clns mtu как показано здесь:

Router_F#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router_F(config)#interface serial2
Router_F(config-if)#clns mtu 1500
Router_F(config-if)#^Z
Router_F#

Дополнительные сведения


Document ID: 47201