Протокол IP : IP версии 6 (IPv6)

Соединение с сетью 6bone с помощью туннелей 6to4 для протокола IPv6

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает, как клиент кампуса предприятия (например, образовательное учреждение, маленькая фирма по разработке и продаже программного обеспечения или маленькая производственная компания) может соединиться с 6bone при помощи 6to4 туннели. 6bone — это испытательная сеть IP версии 6 (IPv6), которая была создана для развития и внедрения протокола IPv6 в Интернете.

Этот документ является одним из ряда документов, которые поддерживают и дополняют публикацию Стратегий развертывания IPv6, которая доступна в Руководствах по дизайну IPv6.

Этот документ следует изучить в комплекте с публикацией Стратегии внедрения IPv6, чтобы лучше понять действия, выполняемые перед внедрением протокола IPv6.

Предварительные условия

Требования

Прежде чем приступить к созданию туннеля 6to4 к сети 6bone, вам нужно выполнить следующие задачи:

  • Определите пограничный маршрутизатор на данном узле, который будет использовать два стека. Этот пограничный маршрутизатор должен иметь статический, глобально маршрутизируемый адрес IPv4.

  • Лицензия данных требуется, чтобы активировать все опции IPv6. Для подтверждения, какая лицензия включена на маршрутизаторе, используйте команду show license .

  • Получите от поставщика интернет-услуг сети 6bone адрес IPv4 передающего маршрутизатора 6to4, который будет использоваться для доступа к сети 6bone.

    Примечание: При настройке туннелей для корпоративных пограничных маршрутизаторов необходимо использовать глобально маршрутизуемого Ipv4 address. Адреса IPv4, использованные в примере конфигурации в этом документе, не являются глобально маршрутизируемыми и даны для иллюстрации.

  • Убедитесь, что сервер DNS использует службу BIND версии 9 (или ее эквивалент), которая обеспечивает реализацию основных компонентов DNS для протокола IPv6. Конфигурация DNS не описывается в этом документе.

  • Распознайте, что текущая реализация двойного стека в программном обеспечении Cisco IOS разрешает промежуточное решение для управления сетью, которое позволяет приложениям, таким как TFTP, эхо-запрос, Telnet и traceroute быть выполненными или по IPv4 или по транспорту IPv6.

  • Выберите протокол внутренней маршрутизации IPv6 — например, RIPng — соответствующий конфигурации сети. Для упрощения понимания решение, описанное в этом документе, использует статический маршрут. Соответствующий внешний протокол маршрутизации IPv4 оперирует внешней маршрутизацией.

  • Настройте маршрутизаторы с двумя стеками для использования протокола RIP.

Дополнительные сведения о настройке сети для IPv6 см. в библиотеке по конфигурации IPv6 в Cisco IOS.

Используемые компоненты

Сведения, содержащиеся в данном документе, основаны на образах Cisco IOS с поддержкой IPv6.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

На следующем рисунке приведена исходная топология сети IPv4 для клиента корпоративного кампуса. В этой сети для обеспечения IP-соединения между локальными пользователями используется несколько маршрутизаторов. Постоянное подключение IPv4 к поставщику Интернет-услуг (ISP) предоставляет возможность внешнего подключения

/image/gif/paws/45741/6bone_tc_1-01.gif

В следующей таблице перечислены устройства, использующие это решение.

Устройство Корпоративный пограничный маршрутизатор ISP-маршрутизатор 6bone
Имя узла 6bone-gw ipv6-маршрутизатор
Тип корпуса Маршрутизатор Cisco 3660 Маршрутизатор Cisco 7206
Физические интерфейсы 2 Fast Ethernet Ethernet 2 4 сериала 4 Fast Ethernet Ethernet 2 4 сериала
Загруженное программное обеспечение Cisco IOS выпуск 12.2(4)T Cisco IOS выпуск 12.2(4)T
Память ОЗУ на 64 мВ; Флэш на 16 МБ 128 Мбайт ОЗУ; 20 Мбайт флэш-памяти
IP-адреса !--- Ethernet 0: IPv4 192.168.99.1 Tunnel2002: IPv6 2002:C0A8:: 1/128 Ethernet0/0: IPv4 192.168.33.1 Tunnel2002: IPv6 2002:C0A8:2102:: 1/128

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Принципы работы туннелей 6to4

Туннель 6to4 настроен на корпоративном пограничном маршрутизаторе с двойным стеком. Весь корпоративный трафик IPv6, предназначенный для 6bone, направляется через IPv4 по туннелю к передающему маршрутизатору 6bone ISP 6to4. Трафик с 6bone к корпоративному узлу направляется при помощи IPv4 через туннель к корпоративному пограничному маршрутизатору с двумя стеками, а затем к узлу назначения IPv6.

Использование туннелей 6to4 дает следующие преимущества корпоративным пользователям:

  • Программное обеспечение Cisco IOS поддерживает туннели 6to4.

  • Конфигурация узла конечного пользователя проста – для нее требуется минимальное количество информации управления.

  • Туннельное соединение является автоматическим; на передающем узле 6to4 не требуется никакой специальной конфигурации для корпоративной сети. Туннели 6to4 хорошо масштабируются.

  • Это решение согласовывает динамические IP-адреса корпоративной сети.

  • Туннельное соединение существует только во время сеанса.

  • 6to4 туннель требует только одноразовой конфигурации в интернет-провайдере, который делает 6to4 релейный сервис доступный одновременно многим предприятиям.

Ограничения туннелей 6to4

Использование туннеля 6to4 сопряжено со следующими ограничениями:

  • Независимо управляемое преобразование сетевых адресов (NAT) не разрешается на участке туннеля.

  • Вы не можете легко внедрить множественную адресацию.

  • Механизм туннеля 6to4 использует адресный блок /48; другие адреса недоступны.

  • Поскольку туннели 6to4 настроены для работы в режиме "многие-к-одному" и трафик туннеля может исходить из нескольких конечных точек, туннели 6to4 могут предоставлять провайдеру услуг Интернета только общие сведения о трафике.

  • Базовый IPv4 address определяет предприятие 6to4 префикс IPv6 address, таким образом, миграция к собственному IPv6 требует изменения нумерации сети.

  • Это решение подходит только для для статической маршрутизации или марштрутизации на основе протокола BGP4+.

Сценарий туннелирования

Обсуждается слияние маленькой компании по разработке ПО (считаем ее типичной средой кампуса), имеющей сеть IPv4, с другой компанией, в сети которой используется протокол IPv6. Чтобы оценить влияние, которое окажет слияние компаний на возможности подключения, клиенту нужно расширить свои знания о IPv6, подключившись к сети 6bone. В настоящем документе рассматриваются следующие цели клиентов компоративного кампуса:

  • IPv6 усиления испытывает на установленной магистрали IPv6 использование ее существующей топологии IPv4 с минимальным вложением.

  • Перед развертыванием протокола IPv6 необходимо выполнить проверку переходных и рабочих процедур в реальном окружении с протоколом IPv6.

    Переходные процедуры — это процедуры, необходимые для перехода с протокола IPv4 на IPv6. Эти процедуры включают настройку маршрутизаторов с двумя стеками и конечных систем, механизмы туннелирования, серверы DNS, а в будущем планируется тестирование преобразования NAT-PT.

    К рабочим процедурам относится управление сетью, управление элементами узлов с двумя стеками и конечных систем, а также другими сходными функциями.

  • Проверить использование и реализацию протокола IPv6 на локальных рабочих станциях.

  • Минимизировать служебную информацию для управления, связанную с подключением сети 6bone.

    Примечание: Хотя соединение 6bone включает многие типы организаций (например, учебные и правительственные организации, производителей технического и аппаратного обеспечения, поставщиков услуг), в данной документации используется термин 6bone ISP, если речь идет об организации, которая находится в конце туннеля 6bone.

Настройка

Адрес IPv6 пограничного маршрутизатора — 192.168.99.1. Выделите префикс 6to4 из адреса IPv4, преобразовав десятичные компоненты адреса IPv4 в шестнадцатеричные значения и добавив перед ними цифры «2002». Поэтому префикс 6to4 для узлов IPv6 в сети имеет вид 2002:C0A8:6301::/128.

Часть C0A8:6301 предыдущего IPv6 address сформирована от IPv4 address путем преобразования каждого октета десятичного представления с разделением точками к его шестнадцатеричному эквиваленту, как показано в Таблице 6.

Десятичное число Шестнадцатеричный
192 C0
168 A8
99 63
1 01

В этом разделе представлены сведения по настройке функций, описанных в данном документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

На этом рисунке изображена топология стандартного туннеля 6to4 к 6bone.

/image/gif/paws/45741/6bone_tc_1-02.gif

Конфигурации

Поставщик интернет-услуг сети 6bone указал адрес IPv4 своего пограничного маршрутизатора 6bone: 192.168.33.1. Используйте предыдущие сведения об адресе для настройки туннеля 6to4 на своем идентифицированном граничном маршрутизаторе с двойным стеком, введя следующие команды:

Корпоративный маршрутизатор
ipv6 unicast-routing

interface Ethernet0
 description connection to 6bone ISP
 ip address 192.168.99.1 255.255.255.0

interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode ipv6ip 6to4


!--- In some cases, a user will require a data license 
!-- in order to issue the tunnel mode ipv6ip command.

 ipv6 route 2002::/16 Tunnel2002
 ipv6 route ::/0 2002:C0A8:2101::1

Запись 2002:C0A8:2101::1 во второй команде ipv6 route соответствует адресу IPv6 маршрутизатора ответвления ISP 6to4, который обеспечивает доступ к 6bone. Часть адреса C0A8:2101 была получена из адреса IPv4 (192.168.33.1) маршрутизатора ответвления 6to4 тем же методом, который показан в таблице 6.

На другом конце туннеля у пограничного маршрутизатора 6bone ISP будет такая же конфигурация, как в следующем примере одноадресной маршрутизации IPv6:

Маршрутизатор ISP 6to4 Relay Router
ipv6 unicast-routing

interface ethernet0/0
 description connection to enterprise
 ip address 192.168.33.1 255.255.255.0

interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode ipv6ip 6to4

ipv6 route 2002::/16 tunnel2002

Корпоративный маршрутизатор 6bon2-gw
maui-soho-01# show running-config 
 Building configuration...
 .
 .
 .
 username maui-nas-05 password cisco

 ! Identify the version of Cisco IOS software running on the router
!
version 12.2
!
! Include timestamps on log and debug entries that are useful for
! troubleshooting and optimizing the network.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Specify that passwords will be encrypted in configuration output.
!
service password-encryption
!
! Configure the router name
!
hostname 6bone-gw
!
! Configure boot options
!
boot system flash slot0:
boot system flash bootflash:
!
! Configure logging
!logging buffered 10000 debugging
!
! Configure secret password
!
enable secret 5 [removed]
!
! Configure clock timezone and summertime rule
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Configure router domain name
!
ip domain-name EnterpriseDomain.com
!
! Configure DNS name servers
!
ip name-server 192.168.1.10
ip name-server 192.168.2.21
ip name-server 2002:C0A8:6301:1::21
!
! Enable IPv6 routing
!
ipv6 unicast-routing
!
! Configure Tunnel interface
!
interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode ipv6ip 6to4
!
! Configure physical interface
!
interface Ethernet0
 description connection to 6bone ISP
 ip address 192.168.99.1 255.255.255.0
!
interface Ethernet1
 description connection to Lab interface router
 ip address 192.168.99.40 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:100::1/64
 ipv6 rip v6rip enable
!
interface FastEthernet2/0
 description connection to core router
 ip address 192.168.99.41 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:200::1/64
 ipv6 rip v6rip enable
!
interface FastEthernet3/0
 description connection to IPv4-only core router
 ip address 192.168.99.42 255.255.255.0
!
! Other interfaces are all unused
!

interface Serial4/0
 no ip address
 shutdown
!
interface Serial4/1
 no ip address
 shutdown
!
interface Serial4/2
 no ip address
 shutdown
!
interface Serial4/3
 no ip address
 shutdown
!
! Configure basic IP routing
!
ip default-gateway 192.168.33.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.33.1
!
! Configure IPv6 static route
!
ipv6 route 2002::/16 tunnel2002
ipv6 route ::/0 2002:C0A8:2101::1
ipv6 router rip v6rip
!
end
 end

Маршрутизатор 6bone IPv6 ISP
maui-soho-01# show running-config 
 Building configuration...
 .
 .
 .
 username maui-nas-05 password cisco

 ! Identify the version of Cisco IOS software running on the router
!
version 12.2
!
! Include timestamps on log and debug entries that are useful for
! troubleshooting and optimizing the network.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Specify that passwords will be encrypted in configuration output.
!
service password-encryption
!
! Configure the router name
!
hostname ipv6-router
!
! Configure boot options
!
boot system flash slot0:
boot system flash bootflash:
!
! Configure logging
!
logging buffered 10000 debugging
!
! Configure secret password
!
enable secret 5 [removed]
!
! Configure clock timezone and summertime rule
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Configure router's domain name
!
ip domain-name 6boneISP.com
!
! Configure DNS name servers
!
ip name-server 192.168.33.4
ip name-server 192.168.33.5
ip name-server 3FFE:FFFF:8001::4
!
! Enable IPv6 routing
!
ipv6 unicast-routing
!
! Configure Tunnel interface
!
interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode ipv6ip 6to4
!
! Configure physical interface
!
interface Ethernet0/0
 description connection to enterprise
 ip address 192.168.33.1 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface FastEthernet1/0
 description connection to ISP-core-A
 ip address 192.168.34.10 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:2::6/64
 duplex auto
 speed auto
!
interface FastEthernet2/0
 description connection to ISP-core-B
 ip address 192.168.35.22 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:2::8/64
 duplex auto
 speed auto
!
! Other interfaces are all unused
!

interface Serial4/0
 no ip address
 shutdown
!
interface Serial4/1
 no ip address
 shutdown
!
interface Serial4/2
 no ip address
 shutdown
!
interface Serial4/3
 no ip address
 shutdown
!
! Configure basic IP routing
!
ip default-gateway 192.168.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.30.1
!
! Configure IPv6 static route
!
ipv6 route 2002::/16 tunnel2002
!
end

Проверка.

В этой дополнительной задаче объясняется, как убедиться в том, что туннель настроен и работает правильно. Команды, содержащиеся в процедурах, можно применять в любой последовательности и повторять

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • enable

  • show interfaces tunnel number [accounting]

  • эхо-запрос [протокол] назначение

  • show ip route [адрес [маска]]

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 45741