Протокол IP : Протокол OSPF

Проектирование крупных сетей вызова поставщиков услуг с помощью OSPF

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Разработать коммутируемую сеть - непростая задача для интернет-провайдеров (интернет-провайдеры). Каждый интернет-провайдер использует уникальный метод для разработки коммутируемых сетей. Однако все интернет-провайдеры совместно используют те же области интереса, когда они разрабатывают коммутируемые сети, как перечислено здесь:

  • Как маршруты пула должны распространиться в ядро интернет-провайдера?

  • Какой протокол маршрутизации должен использоваться для переноса тех маршрутов в ядро?

  • Те маршруты модемного соединения должны быть суммированы прежде, чем передать в ядро?

  • Когда пулы распределены, что должно быть принято во внимание?

  • Что происходит, если пулы статические?

В этом документе даны ответы на большую часть заданных выше вопросов и рассмотрены практические примеры проектирования с использованием протокола IGP и OSPF в среде вызова ISP. OSPF часто используется в базовой сети ISP. В этом документе мы избегаем представлять отдельный протокол для переноса набираемых маршрутов пула — мы используем OSPF для размножения набираемых маршрутов пула в ядро.

Топология сети

Топология, показанная здесь, является типичной топологией коммутируемой сети интернет-провайдера. Интернет-провайдеры, которые предоставляют услуги коммутируемого доступа, обычно располагают несколькими серверами сетевого доступа (NAS), которые обычно представлены моделями AS5300 или AS5800. Серверы ответственны за условие IP-адреса всем пользователям, которые набирают в интернет-провайдера и хотят использовать интернет-сервисы. Серверы NAS тогда связаны с устройством агрегации, которое, как правило, является маршрутизатором Cisco 6500. Маршрутизатор 6500 передает маршруты модемного соединения на центральный коммутатор, который позволяет опорным маршрутизаторам предоставлять службы Интернета конечным пользователям. Рисунок 1 показывает типичный сценарий Point of Presence (POP).

Рисунок 1 – Типичный сценарий POP

ispdial.jpg

Пулы удаленных вызовов ISP

Интернет-провайдер, как правило, имеет дело с двумя типами IP-адресов пула:

  • Статичный

  • Центральный

Статический пул

Со статическими пулами интернет-провайдеры имеют определенный набор IP-адресов, выделенных каждому серверу NAS. Пользователь, который встречается с NAS, получает один из специализированных IP-адресов от пула. Например, если NAS1 существует приблизительно 1023 IP-адреса, статический диапазон адреса пула является 192.168.0.0/22. Пользователь, который встречается с NAS1, получает один из адресов в диапазоне от 192.168.0.0 до 192.168.3.254.

Центральный пул

Центральные пулы предоставляют ISPs более широкий диапазон IP-адресов, распространяемых по всем NASs в едином POP. Пользователь, который встречается с NAS, получает IP-адрес от центрального пула, который является очень большим спектром. Например, если диапазон центрального пула адресов - 192.168.0.0/18, и они распределяются между четырнадцатью серверами NAS, существует примерно 14000 IP адресов.

Коммутируемый дизайн со статическим пулом

Статическими пулами легче управлять с точки зрения маршрутизации. Когда статический пул определен на NAS, пул должен распространиться к ядру для назначений маршрутизации.

Используйте эти методы для размножения маршрутов модемного соединения от NAS:

  • Создайте статический маршрут к Диапазону IP-адресов пула, указывая на пустой 0, с адресом пула, перераспределенным на NAS.

  • Назначьте IP-адрес пула на loopback, на NAS с двухточечным типом сети OSPF, включая loopback в области OSPF.

  • Настройте статический маршрут на пограничном маршрутизаторе области (ABR) для IP-адреса пула, указывающего к граничному маршрутизатору автономной системы (ASBR) NAS — это - предпочтительный способ, потому что суммирование может быть выполнено в ABR.

Создайте Статический маршрут к Диапазону Адреса пула, Указывающему на пустой 0

При использовании этого метода статический маршрут должен быть создан для каждого NAS. Тот статический маршрут должен покрыть точный статический адрес диапазона пула, указывающий на пустой 0. Например, если статический адрес пула является 192.168.0.0/22, конфигурирование статических маршрутов на NAS:

NAS1(config)# ip route 192.168.0.0 255.255.252.0 null0
NAS1(config)# router ospf 1
NAS1(config-router)# redistribute static subnets
NAS1(config-router)# end

Адрес пула перераспределен в OSPF, который распространяется эту информацию в ядро в типе 5 внешних объявлений о состоянии канала (LSA) форма.

Назначьте адрес пула на Loopback на NAS с двухточечным типом сети OSPF

При использовании этого метода статический маршрут не требуется. Адрес пула назначается как адрес подсети в петлевом интерфейсе. Тип сети по умолчанию на интерфейсе обратной связи является LOOPBACK, который, согласно RFC 2328 leavingcisco.com должен быть объявлен в OSPF как/32 — это - то, почему необходимо изменить тип сети на loopback к точка-точка. Двухточечный тип сети вынуждает OSPF объявить адрес подсети loopback, который в этом случае является 192.168.0.0/22. Вот настройка:

NAS1(config)# interface loopback 1
NAS1(config-if)# ip addreess 192.168.0.1 255.255.252.0
NAS1(config-if)# ip ospf network-type point-to-point
NAS1(config-if)# router ospf 1
NAS1(config-router)# network 192.168.0.0 0.0.3.255 area 1
NAS1(config-router)# end

Эта конфигурация создает ссылку фиктивного модуля маршрутизатора в LSA маршрутизатора (локальный администратор безопасности) и распространяется как внутренний маршрут OSPF, а не внешний маршрут OSPF.

Настройте статический маршрут на ABR для адреса пула, указывая на NAS (ASBR)

Если вы используете этот метод, вам не нужно настраивать любую конфигурацию на NAS. Все конфигурации встречаются в ABR или устройстве агрегации. Пулы адресов статичны. Поэтому статический маршрут легко генерируется, и маршрутизатор может указать следующий переход к соответствующему NAS, граничному маршрутизатору автономной системы (ASBR). Данные статические маршруты необходимо перераспределить в OSPF путем перераспределения статических подсетей под управлением OSPF. Например: :

ABR(config)# ip route 192.168.0.0 255.255.252.0 <next-hop ip address (NAS1)>
ABR(config)# ip route 192.168.4.0 255.255.252.0 <next-hop ip address (NAS2)>

! --- and so on for the remaining 12 NAS boxes.

ABR(config)# router ospf 1
ABR(config-router)# redistribute static subnets
ABR(config-router)# end

Это предпочтительный метод, так как на ABR можно провести подведение итогов. Суммирование может также произойти в первых двух методах, но конфигурации объединения необходимы на каждом NAS по сравнению с этим методом, где конфигурация объединения необходима только в этом маршрутизаторе.

Если статические пулы находятся в последовательном блоке, суммирование может быть выполнено на ABR, потому что все статические маршруты находятся на ABR. Например: :

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

Коммутируемый дизайн с присвоением динамического IP от центрального пула адресов

Для этого коммутируемого дизайна предположите, что центральный пул IP-адреса настроен на сервере Cервиса RADIUS. У каждой точки присутствия POP есть свой номер службы определения набранного номера DNIS, и для каждого DNIS у сервера RADIUS есть отдельный пул IP-адресов., Кроме того, все NAS, которые завершают призывы к DNIS, находятся в той же области и говорят с тем же маршрутизатором с поддержкой агрегирования.

Центральные пулы IP-адреса приносят некоторую сложность в дизайне протокола маршрутизации. При вызове номера Набранного номера для POP нет никакой гарантии о NAS, с которым вы соединяетесь и IP-адрес, который будет назначен на вас от центрального пула IP-адреса для того DNIS. В результате суммирование на каждом NAS невозможно для адресов, назначенных из пула DNIS. Перераспределенная связанная подсеть необходима в каждом NAS, таким образом, это может распространиться всю информацию к ABR или устройству агрегации. Существует одна проблема с этим дизайном — потому что внешние LSA могут только быть суммированы на ASBR и в этом дизайне, ASBR являются серверами NAS, как ABR выполнит суммирование для внешних маршрутов, прибывающих из NAS?

Для решения этой проблемы проектирования Cisco рекомендует, что область, к которой серверы NAS принадлежат быть настроенными в Не так плотной области (NSSA) (см. рисунок 2):

Рисунок 2 – конфигурация в не так плотная область

/image/gif/paws/44944/ispdial2.jpg

Обратитесь к OSPF Not-So-Stubby Area (NSSA) для более подробной информации по OSPF NSSAs.

Вот преимущества при определении области как NSSA:

  • Все маршруты NAS можно суммировать на ABR, потому что ABR регенерирует/транслирует LSA типа 7 в LSA типа 5.

  • Точка присутствия не передает маршруты, принадлежащие другим POP, поскольку в NSSA запрещены внешние LSA.

Конфигурация перераспределенных, связанные подсети необходимы во всех NAS, потому что пулы IP-адреса по всем NAS не статичны — любой NAS может перенести любой IP-адрес в том центральном Диапазоне IP-адресов.

NAS1(config)# router ospf 1
NAS1(config-router)# redistribute connected subnets
NAS1(config-router)# end

При выполнении этой конфигурации на всех NAS конфигурация объединения выполнена на ABR, потому что весь тип LSA 7 с восстановлен на ABR и преобразован в тип LSA 5 с. Поскольку ABR генерирует абсолютно новый тип LSA 5, и ID объявляющего маршрутизатора является ID маршрутизатора ABR, действиями ABR как ASBR и позволяет суммирование маршрутов, которые были ранее типом LSA 7 с (инициируемый NAS).

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

Заметьте, что областью между ABR и NAS является NSSA, который может быть настроен следующим образом:

ABR(config)# router ospf 1
ABR(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa
ABR(config-router)# end

Вопрос масштабируемости области

Если у вас есть много серверов NAS в одной области, и каждый NAS перераспределяет 1000 или больше маршрутов в область, вопрос возникает — сколько серверов NAS каждая область должна включить? Если все серверы NAS находятся в той же области, область может стать нестабильной, потому что область должна перенести 1000 или больше маршрутов от всех серверов NAS. В данном примере 14 серверов NAS это может потенциально перераспределить 14000 маршрутов, который является очень большим номером. Для обеспечения большего количества масштабируемости к области Cisco рекомендует разделить область на несколько подобластей, чтобы гарантировать, что каждая область не влияет на другие области, если некоторая нестабильность происходит в одной области (см. рисунок 3):

Рисунок 3 – делит область

ispdial3.jpg

Для определения количества серверов NAS для хранения в одной области, необходимо установить количество маршрутов, которые вводит каждый NAS. Если каждый NAS вводит 3000 или больше маршрутов, три сервера NAS в одной области могут быть достаточно. Не помещайте слишком мало серверов NAS в каждую область, потому что, если у вас есть слишком много областей, ABR может стать перегруженным из-за создания суммирования в каждую область. Однако можно решить эту проблему, если вы области make all полностью тупиковый NSSA, который не позволяет перераспределение никаких объединенных маршрутов в область. Это действие уменьшает количество данных каждый NAS переносы в дополнение к его собственным 1000 или больше маршрутов и уменьшает величину нагрузки, ABR осуществляет перераспределение суммарных объявлений о состоянии каналов в каждую область. Добавьте ключевое слово no-summary на ABR для выполнения конфигурации, как показано здесь:

ABR#(config)# router ospf 1
ABR#(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa no-summary
ABR#(config-router)# end

У канала между серверами ABR и NAS нет необходимости выходить в каждую область, поэтому ABR не необходимости собирать сводные сведения в каждой области для этих подключенных маршрутов. Главное преимущество NSSA состоит в том, что 3000 или более маршрутов одной области не переходят в другие области, поскольку NSSA не содержит внешние объявления LSA. Когда ABR транслирует все NSSA LSA типа 7s в область 0, он не посылает LSA типа 5s в другие области вследствие характеристик NSSA.

Заключение

Разработка коммутируемой сети интернет-провайдера может быть непростой задачей, но с несколькими факторами это может быть улучшено и предоставить больше масштабируемого решения. Внедрение NSSA может дать видимые результаты в управлении масштабируемостью, поскольку обеспечивает значительное уменьшение числа маршрутов NAS по сравнению с ситуацией, когда NSSA не используется. Суммирование также помогает уменьшить размер таблицы маршрутизации, особенно в случае центрального пула IP-адресов, потому что на серверах NAS требуется команда redistribute connected configuration. При объединении рекомендуется выполнять назначение смежных блоков IP-адресов для каждого сервера NAS, так как при этом все точки POP могут быть объединены в один большой блок, за счет чего значительно сокращается число маршрутов, хранящихся в ядре.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 44944