Голосовая связь : Протокол MGCP

Пример конфигурации MGCP с Digital CAS и Cisco CallManager

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ объясняет, как использовать Протокол MGCP между Cisco IOS� шлюз (например, VG200, 2600, 3600, IAD2400) и Сisco CallManager 3.x Сервер медиа-конвергенции (MCS). Это покрывает конфигурацию одного соединения сигнализации по выделенному каналу (CAS) T1 с Открытой коммутируемой телефонной сетью (PSTN). Удаленный сайт является шлюзом H.323. Подключение VoIP к IP-телефонам Cisco 7960 также показывают. После настройки этой конфигурации становится возможно выполнять вызовы между всеми телефонами, используемыми в этой конфигурации., Кроме того, будет возможно направить переклички PSTN с любого из телефонов, используемых в этой конфигурации.

Этот документ предполагает, что читатель уже знаком с тем, как настроить Cisco IP Phone в Сisco CallManager. Это также предполагает, что существует по крайней мере один IP-телефон, уже активный на Cisco CallManager server.

Признаки:

Это - список возможных симптомов, с которыми вы могли бы встретиться со шлюзами MGCP и что проверить для:

  • Исходящий или исходящие вызовы не работают. Гарантируйте привязку корректного исходного интерфейса MGCP для сред и сигнализации.

  • Исходящие вызовы получают сигнал занятости после того, как будет набрана последняя цифра. Гарантируйте привязку корректного исходного интерфейса MGCP для сред и сигнализации.

  • Шлюз MGCP не регистрируется с Cisco CallManager. При использовании доменное имя на шлюзе MGCP, гарантируете, что он совпадает с доменным именем в Сisco CallManager под Конфигурацией шлюза.

Предварительные условия

Требования

Рассматриваемая процедура настройки предполагает выполнение следующих условий:

  • Шлюз Cisco IOS, выполняющий Cisco IOS Software Release, который поддерживает MGCP с Сisco CallManager.

  • Этот документ создан с помощью Cisco 2611.

Примечание: Существуют другие Cisco IOS Software Release Train, которые поддерживают MGCP на маршрутизаторах Cisco. Одним из примеров является выпуск ПО Cisco IOS 12.1XM.

caution  Внимание! Синтаксис некоторых команд MGCP отличается в других выпусках ПО Cisco IOS. Чтобы определить требуемый синтаксис, см. документацию по данной конфигурации.

Используемые компоненты

Эта конфигурация была протестирована с Сisco CallManager 3.3 (2) и образ Cisco IOS Software Release 12.2 (13). Снимки экрана и конфигурация IOS были перехвачены с помощью программного обеспечения, аппаратных средств и другого оборудования здесь.

  • Cisco 2600 / 1 MFT-T1 / 1 FastEthernet 10/100 порт с Cisco IOS Software Release 12.2 (13)

  • Сisco CallManager 3.3 (2) работа MCS7835

  • Аналоговая телефонная трубка

  • IP-телефон Cisco 7960

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Схема сети

Схема сети ниже описывает настройку, используемую в целях конфигурации и устранения проблем этого документа.

/image/gif/paws/43802/mgcp_12_2_xn5.gif

Для рекомендуемых версий программного обеспечения совместимости между Сisco CallManager и шлюзом Cisco IOS, обратитесь к Матрице совместимости Сisco CallManager leavingcisco.com.

Примечание: Рекомендуется выпуск ПО Cisco IOS 12.2(11)T и позднее на основе усовершенствований команды ccm-manager. Команда ccm-manager требует программного обеспечения Cisco IOS версии 12.1(5)XM или позже всех маршрутизаторов Cisco (2600, 3600) и VG200.

Cisco 2600 и 3600 маршрутизаторов поддерживают MGCP, если они выполняют программное обеспечение Cisco IOS версии 12.1(3)T или позже. Выпуск и версия, которой вы требуете, основываются на опциях, которые необходимо активировать. Cisco CallManager server должен выполнить версию 3.0 (5) a или позже. Конфигурация маршрутизатора одинакова для всех типов маршрутизаторов. Конфигурация Cisco CallManager также одинакова для всех типов маршрутизаторов.

Cisco IOS Software Release 12.1 (5) XM1 и позднее поддерживает VG200. Выпуск и версия, которой вы требуете, основываются на опциях, которые необходимо активировать. Хотя VG200 поддерживается в ранних версиях Cisco CallManager, рекомендуется использование версии 3.0(5)a или более поздних.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройте шлюз MGCP Cisco IOS

Этот документ ведет вас через простую конфигурацию Протокола MGCP. Только минимальные команды требуются, чтобы создавать действующую конфигурацию для маршрутизатора с одним T1.

Примечание: Конфигурация в этом документе работает для Cisco VG200, 2600, или маршрутизатор серии "3600", который выполняет Cisco Выпуск ПО IOS� 12.1 (5) T или позже. Для других шлюзов IOS MGCP проверьте документацию IOS для поддерживаемых версий.

Пошаговые инструкции

Выполните эту процедуру для настройки Шлюза MGCP Cisco IOS.

Примечание: Оставшаяся часть этого документа обращается к Cisco 2600. Cisco 2600 запускается с конфигурации по умолчанию (как это прибывает поставленное).

  1. Настройте IP-адрес на Интерфейсе Ethernet Cisco 2600 и включите интерфейс.

    router(config)#interface fastether 0/0               
    router(config-if)#ip address 172.16.13.35 255.255.255.224 
    router(config-if)#no shut
    
  2. Назначьте уникальное имя на Cisco 2600 так, чтобы Cisco CallManager server мог определить его.

     router(config)#hostname 2611-4
    
    !--- This is how Cisco CallManager keeps track of the MGCP network
    !--- devices it is communicating with. This name  must be unique.
    
    
  3. Настройте Cisco 2600 для выполнения MGCP как протокола сигнализации.

    2611-7 (config)#mgcp
    
  4. Настройте IP-адрес или DNS-имя для сервера Cisco CallManager.

    2611-7 (config)#mgcp call-agent 171.69.85.171
    

    Примечание: Для настройки избыточных Сisco CallManager в Кластере CallManager используют эти команды.

    2611-7 (config)#ccm-manager redundant-host [ip address |
      DNS-name] [ip-address | DNS-name]
    2611-7 (config)#ccm-manager switchback {graceful|imm[ediate]
      |sch[edule-time] hh:mmm|uptime[-delay] minutes}
  5. Выберите тип codec и функцию передачи DTMF (двухтональная многочастотная сигнализация).

    VG200A(config)#mgcp dtmf-relay voip codec all mode out-of-band
    
  6. Для включения поддержки Сisco CallManager в MGCP введите эту команду.

    VG200A(config)#ccm-manager mgcp
    
  7. Установите связь приложения MGCP с голосовыми портами.

    Примечание: Используйте команду show voice port для определения типа портов, которые Cisco 2611 имеет и заказ, они установлены.

    dial-peer voice 999101 pots
     application mgcpapp
     port 1/0:1
    /* T1 digital port */

    Примечание: В некоторых Cisco IOS Software Release учитывает регистр команда application MGCPAPP. Пока вы не знаете, что версия не чувствительна к регистру, всегда вводите эту команду в верхний регистр. Можно проверить, учитывает ли версия регистр после настройки этой команды при рассмотрении выходных данных команды show running-config. Выпуск ПО Cisco IOS 12.1(5)T не является чувствительным к регистру.

  8. Убедитесь, что голосовые порты включены.

    Примечание: Завершение и команды no shutdown влияют на оба порта на голосовой интерфейсной карте (VIC). Только необходимо ввести команду в один из этих портов.

  9. Установите IP-подключение.

    Если какой-либо из VoIP - устройств, с которыми связывается Cisco 2600, расположен на других ПОДСЕТЯХ/VLAN, включает IP routing и создает шлюз последней очереди (сеть по умолчанию). Этот шаг объясняет, как выполнить обе задачи.

    VG200A(config)#ip routing
    VG200A(config)#ip route 0.0.0.0 0.0.0.0 
    <ip_address_of_gateway>

    Примечание: На шлюзах Cisco IOS (которые являются по существу маршрутизаторами с голосовыми интерфейсами), можно настроить протокол маршрутизации вместо статических маршрутов. Важно обеспечить IP-подключение между устройствами VoIP.

    Примечание: Для VG200 при включении IP routing команда ip routing не появляется в конфигурации, потому что это обычно включено командами по умолчанию и по умолчанию, обычно не появляются в Конфигурации маршрутизатора Cisco. Образы Cisco IOS VG200 отвергают поведение по умолчанию включения IP routing трудным кодированием команды no ip routing в начальную конфигурацию. Начальная конфигурация создана, когда образ загружен на платформе, которой очистила ее конфигурацию команда write erase или когда это загружено VG200, который никогда не настраивался.

    Команда ip route 0.0.0.0 0.0.0.0 <ip_address_of_gateway> заставляет VG200 устанавливать шлюз последней очереди в свою таблицу маршрутизации. Команда show ip route подтверждает это. В примере ниже, IP-адрес шлюза 172.16.13.35.

    Примечание: Команда ip classless также требуется для этого шлюза последней очереди быть эффективной. Команда ip classless включена по умолчанию. Это - одна из нескольких команд Cisco IOS по умолчанию, которая появляется в конфигурации, когда это включено и также не появляется в " никакая" форма, когда это отключено. Если конфигурация имеет никакой ip classless линии, введите команду ip classless для включения ip classless.

    caution Внимание.  : Все элементы связанной конфигурации схемы набора номеров управляются Сisco CallManager и не должны быть настроены в шлюзе MGCP для управляемых MGCP оконечных точек (те с командой application MGCPAPP в их операторе точки вызова). Вы не должны настраивать ни одну из этих функций:

    • Для адресуемых точек вызова:

      • destination-pattern
      • session-target
    • Для голосовых портов:

      • connection { plar | tie line | trunk }

    Cisco 2600 теперь готов связаться с Cisco CallManager server. Это периодически отсылает сообщения в попытке установить соединение. Когда конфигурация Cisco CallManager server завершена, соединение должно автоматически установить себя. Вам не придется внести дальнейшие изменения на Cisco 2600.

    Примечание: Это - полезный прием для сброса портов шлюза после завершения конфигурации, как показано в данном примере.

    router(config)#voice-port 1/0:1
    router(config-voiceport)#shutdown
    router(config-voiceport)#no shutdown
    

Конфигурация

2611-4#show run

Building configuration...
Current configuration : 1480 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname 2611-4
enable secret 5 $1$Mg6h$ewJl8p0VQlKWg0zYasUh91
!
memory-size iomem 10
voice-card 1
!
ip subnet-zero
!
isdn switch-type primary-ni
!
ccm-manager mgcp
mta receive maximum-recipients 0
!
controller T1 1/0
 framing sf
 linecode b8zs
 no yellow generation
 no yellow detection
 ds0-group 1 timeslots 1-24 type e&m-wink-start
!
interface Ethernet0/0
 ip address 172.16.13.35 255.255.255.224
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.13.33
no ip http server
!
call rsvp-sync
!
voice-port 1/0:0
!
mgcp
mgcp call-agent 171.69.85.171 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
no mgcp timer receive-rtcp
mgcp sdp simple

!--- This binds the correct MGCP source interface.

mgcp bind control source-interface Ethernet0/0
mgcp bind media source-interface Ethernet0/0
mgcp profile default
!
dial-peer cor custom
dial-peer voice 99 pots
 application mgcpapp
 incoming called-number .
 port 1/0:1
!
dial-peer voice 88 voip
 destination-pattern 1010
 session target ipv4:172.16.13.42
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
login
line vty 5 15
 login
!

Проверьте шлюз MGCP Cisco IOS

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • покажите, что ccm — Предоставляет состояние регистрации Сisco CallManager.

  • show mgcp endpoint состояние порта.

mgcp-t1-cas-ccm-a.gif

2611-4#show mgcp endpoint 

Interface T1 1/0

             ENDPOINT-NAME    V-PORT   SIG-TYPE   ADMIN
         S1/ds1-0/1@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/2@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/3@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/4@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/5@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/6@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/7@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/8@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/9@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/10@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/11@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/12@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/13@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/14@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/15@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/16@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/17@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/18@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/19@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/20@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/21@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/22@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/23@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/24@2611-4    1/0:0    e&m-wnk    up    

Настройка Cisco CallManager

В этом разделе рассматриваются подробно конфигурацию Сisco CallManager во взаимодействии со шлюзом MGCP и интерфейсом CAS к PSTN.

Задача 1: Создание шлюза MGCP

В этой задаче создан основанный на Cisco 2611 шлюз MGCP. Материал в данном разделе также можно применять к другим маршрутизаторам Cisco IOS MGCP. Единственная разница заключена в выборе платформы в шаге 3. .

  1. Выберите Device> Gateway для использования Аппаратного мастера для создания шлюза MGCP.

    mgcp-t1-cas-ccm-2.gif

  2. Нажмите Add новый шлюз.

    mgcp-t1-cas-ccm-3.gif

  3. Выберите Gateway Type (в этом случае, это - Cisco26xx).

    Примечание: В поле Device Protocol заметьте, что единственная опция "Не Требуется для MGCP". Это означает, что никакой протокол не должен быть выбран, если шлюз является шлюзом MGCP.

    Примечание: При использовании другого маршрутизатора Cisco IOS выберите соответствующий тип шлюза (такой как Cisco 26XX или 36xx). Это единственный шаг, который отличается от других. Оставшиеся задачи применяются к Cisco VG200, а также Cisco 2600 или маршрутизаторам серии "3600".

  4. Нажмите кнопку Next.

  5. Для Доменного имени MGCP используйте фактическое имя хоста, которое вы назначили на Cisco 2600 (в этом случае, 2611-4), и задайте модуль несущей звукового сопровождения Carrier Module, который установили эти 2600 (в этом случае, это - NM-HDV).

    Примечание: Модули звуковой несущей для IAD2400 являются другими, чем те из Серии cisco vg200, 2600 и 3600.

    Примечание: Параметр MGCP Domain Name чувствителен к регистру.

    /image/gif/paws/43802/mgcp-t1-cas-ccm-4.gif

  6. Щелкните Insert (Вставить).

    Примечание: Если маршрутизатор Cisco IOS / шлюз настроен со словом ip domain name доменного имени, поле Domain Name MGCP должно включать его. Например, 2600.company.com.

    Перейдите к Задача 2. : Настройте порты MFT-T1.

Задача 2: Настройте порты MFT-T1

В этой задаче настроены порты MFT-T1. Данные порты соединяются с PSTN. В этой процедуре вы определяете тип порта и назначаете телефонный номер оператора (DN).

  1. Определите модули Карты голосового интерфейса (VIC), установленные в позициях слота 1 0 и 1. В этом случае они находятся в 1 порту T1.

  2. Чтобы активировать изменения, нажмите Update.

    Порты T1 появляются в нижнем правом углу следующего экрана. Они также называются идентификаторами конечных точек.

    mgcp-t1-cas-ccm-5.gif

  3. Выберите маркированный 1/0/0 порта T1.

  4. Выберите корректный тип порта T1.

    mgcp-t1-cas-ccm-6.gif

  5. Настройте параметры на этом Окне конфигурации Члена MGCP как требуется и нажмите Insert.

    Примечание: Ищите название S1/DS1-0@2611-4 в образе выше для определения устройства MGCP, которое вы настраиваете (2611-4), а также порт S1/DS1-0 = Слот 1/Port0.

    /image/gif/paws/43802/mgcp-t1-cas-ccm-7.gif

  6. Нажмите Параметр Сброс шлюза и настройте каждый порт следующим образом:

    Щелкните по Add a New Port и настройте эти параметры настройки.

    Сisco CallManager 3.3 (2):

    • Тип порта: Только E& M поддерживается на Сisco CallManager 3.3 (2).

    • Начало Номера порта: первый порт настроен.

    • Количество Конечного порта: последний порт настроен.

    • Направление портов: Оба пути к двум вызовам. Входящий для входящих вызовов. Исходящий для исходящих вызовов.

    • Сигнальный Type*: Только два типа сигнализации поддерживаются с Сisco CallManager 3.3 (2). Они - Набор номера с задержкой и Быстрый старт.

    mgcp-t1-cas-ccm-8.gif

  7. Нажмите Insert и настройте порт определенные параметры как показано в оставшихся действиях.

  8. Нажмите Port, настройте параметры и нажмите Update.

    mgcp-t1-cas-ccm-9.gif

    Перейдите к Задача 4. : Проверка возможности локальных телефонных соединений.

Задача 4: Проверка возможности локальных телефонных соединений

Если вы уже выполнили задачи для настройки Cisco 2600, он передавал сообщения MGCP к Cisco CallManager server, пытающемуся установить отношения MGCP. Если Задачи 1 - 4 имеют успех, Cisco CallManager server и Cisco 2600 теперь готовы направить локальные вызовы между любыми IP-телефонами, зарегистрированными к Cisco CallManager server и PSTN.

Необходимо также быть в состоянии набрать IP-телефоны, которые настроены, а также вызывают аналоговые телефоны от IP-телефонов. Попытайтесь завершить вызовы к и со всех телефонов в конфигурации.

Примечание: Если некоторые телефоны не могут разместить или получить вызовы, посмотреть на разделение, Пространство поиска вызова (CSS), аппаратный пул и конфигурации расположения. У вас может быть конфигурация, которая не позволяет всем местным телефонам вызывать друг друга. Если это верно, временно разместите один IP-телефон и один аналоговый телефон (порт FXS) в том же разделении, аппаратном пуле, местоположении и CSS и попробуйте тест снова.

Примечание: При обнаружении с проблемами с регистрацией шлюза Cisco IOS или работой шлюза попытайтесь перезагрузить голосовые порты шлюза, как показано в данном примере.

router(config)#voice-port 1/0:1
router(config-voiceport)#shutdown
Both ports are out of service
router(config-voiceport)#no shutdown

Примечание: Если вы продолжаете иметь проблемы, отнеситесь, чтобы Контролировать, Перезагрузить, и Удалить Шлюзы MGCP для Сisco CallManager и Проверить Шлюз MGCP для задач дополнительного устранения проблем.

Перейдите к Задача 5. : Настройка шаблона маршрута.

Задача 5. : Настройка шаблона маршрута

В этой задаче простой шаблон маршрута создан, чтобы позволить телефонам выполнить вызовы через PSTN. В качестве стандартного шаблона североамериканского плана нумерации (NANP) используется "9.@".

  1. В главном меню Cisco CallManager выберите Route Plan > Route Pattern.

    /image/gif/paws/43802/mgcp-t1-cas-ccm-10.gif

    В дополнение к настройкам по умолчанию были настроены эти параметры:

    Поле имени Значение Значение
    Route Pattern 9. Стандартный шаблон маршрута для Схем набора номеров с помощью NANP. Этот шаблон маршрута настроен для обеспечения тонального сигнала готовности к набору номера (или по умолчанию).
    Список маршрутизатор/шлюза S1/DS1-0@2611-4 T1 1/0:1 на 2611-4
    Discard Digits PreDot Отбросить все до точки, включая "." в шаблоне маршрута.

    Примечание: Шаблон маршрута "9.@" часто используется для установки вне Соединенных Штатов, где невозможно использовать NANP.

    /image/gif/paws/43802/mgcp-t1-cas-ccm-11.gif

  2. Нажмите Insert и продолжите Задавать работу 6: Тестовые вызовы по сети PSTN.

Задача 6: Тестовые вызовы по сети PSTN

Необходимо теперь быть в состоянии направить переклички PSTN с любого телефона в системе, когда вы набираете 9, и затем набираете вызываемый номер после того, как возвращается тональный сигнал готовности к набору номера. В следах ниже, вызов выполнен от IP-телефона и перехватывает следы пакета MGCP.

Примечание: Если у вас есть какие-либо проблемы, отнеситесь, чтобы Контролировать, Перезагрузить, и Удалить Шлюзы MGCP для Сisco CallManager и Проверить и Устранение неполадок Шлюз MGCP Cisco IOS для получения дополнительной информации о задачах по устранению проблем. Для любого устранения проблем CAS посмотрите, Настраивают и Сигнализация T1 CAS Устранения неполадок.

Mar  9 06:34:21.523: NTFY 27862 *@2611-4 MGCP 0.1
X: 0
O: 
<---
*Mar  9 06:34:21.567: MGCP Packet received from 171.69.85.171-
200 27862 
*Mar  9 06:34:23.110: MGCP Packet received from 171.69.85.171-

!--- Keepalives sent to and received from the Cisco CallManager.

CRCX 122 S1/DS1-0/1@2611-4 MGCP 0.1
C: A00000000100001a
X: 0
L: p:20, a:PCMU, s:off
M: recvonly
R: DT/oc
S: DT/sup(addr(1,0,1,0))
Q: process,loop

!--- CRCX: CreateConnection 
!--- C: CallId
!--- L: LocalCXOptions   p: packetize period(ms)   a: Compression Algo.
!--- M: Mode
!--- X: RequestIdentifier for the notification request
!--- R: RequestEvents
!--- I: ConnectionId

*Mar  9 06:34:23.146: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:23.146: 200 122 OK
I: 6
v=0
 c=IN IP4 172.16.13.35
m=audio 18546 RTP/AVP 0 100
 a=rtpmap:100 X-NSE/8000
 a=fmtp:100 192-194,200-202
 a=X-sqn:0
 a=X-cap: 1 audio RTP/AVP 100
 a=X-cpar: a=rtpmap:100 X-NSE/8000
 a=X-cpar: a=fmtp:100 192-194,200-202
 a=X-cap: 2 image udptl t38
<---
*Mar  9 06:34:24.885: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:24.885: NTFY 27863 S1/DS1-0/1@2611-4 MGCP 0.1
X: 0
O: DT/oc(dt/sup)
<---
*Mar  9 06:34:24.925: MGCP Packet received from 171.69.85.171-
200 27863 
*Mar  9 06:34:26.271: MGCP Packet received from 171.69.85.171-
MDCX 123 S1/DS1-0/1@2611-4 MGCP 0.1
C: A00000000100001a
I: 6
X: 0
L: p:20, a:PCMU, s:off
M: sendrecv
S: 
v=0
o=- 6 0 IN EPN S1/DS1-0/1@2611-4
s=Cisco SDP 0
t=0 0
c=IN IP4 172.16.240.41
m=audio 32112 RTP/AVP 0

!---  MDCX= ModifyConnection
!--- C: CallId
!--- I: ConnectionId 
!--- M: Mode

*Mar  9 06:34:26.287: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:26.287: 200 123 OK
<---
*Mar  9 06:34:34.340: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:34.340: NTFY 27864 S1/DS1-0/1@2611-4 MGCP 0.1
X: 0
O: DT/ans
<---
*Mar  9 06:34:34.368: MGCP Packet received from 171.69.85.171-
200 27864 
*Mar  9 06:34:34.597: MGCP Packet received from 171.69.85.171-
RQNT 124 S1/DS1-0/1@2611-4 MGCP 0.1
X: 0
R: D/[0-9ABCD*#], DT/rel
S: 
Q: process,loop
*Mar  9 06:34:34.609: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:34.609: 200 124 OK
<---
*Mar  9 06:34:42.954: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:42.954: NTFY 27865 S1/DS1-0/1@2611-4 MGCP 0.1
X: 0
O: DT/sus
<---
*Mar  9 06:34:42.958: MGCP Packet received from 171.69.85.171-
200 27865 
*Mar  9 06:34:42.962: MGCP Packet received from 171.69.85.171-
DLCX 125 S1/DS1-0/1@2611-4 MGCP 0.1
C: A00000000100001a
I: 6
X: 0
R: DT/rlc
S: DT/rel
Q: process,loop
*Mar  9 06:34:42.970: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:42.974: 250 125 OK
P: PS=833, OS=133280, PR=875, OR=140000, PL=0, JI=24, LA=0
<---
*Mar  9 06:34:43.395: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->

Проверка.

Посмотрите Сверение раздела Шлюза MGCP Cisco IOS.

Устранение неполадок

Отнеситесь, чтобы Проверить и Устранить неполадки Шлюза MGCP Cisco IOS для дополнительных сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 43802