Протокол IP : Групповая IP-адресация

Многоадресность через туннель GRE

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ содержит пример конфигурации для передачи в многоадресном режиме по туннелю общей маршрутной инкапсуляции (GRE).

Во многих сетевых сценариях вы хотите настроить сеть для использования Туннелей GRE для передачи независимой от протокола многоадресной передачи (PIM) и многоадресного трафика между маршрутизаторами. Как правило, это происходит, когда источник групповой адресации и получатель разделены облаком IP, которое не настроено для маршрутизации групповой IP-адресации. В таких сетевых сценариях, настраивая туннель по облаку IP с PIM включил пакеты групповой адресации транспортов к получателю. Этот документ описывает конфигурацию, проверку и связанные проблемы, имеющие отношение к групповой адресации по Туннелю GRE.

Предварительные условия

Требования

Рассматриваемая процедура настройки предполагает выполнение следующих условий:

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Поскольку схема сети показывает, источник групповой адресации (10.1.1.1) связан с R102 и настроен для группы многоадресной рассылки 239.1.1.20. Получатель групповой адресации (10.2.2.3) связан с R104 и настроен для получения пакетов групповой адресации для группы 239.1.1.20. Разделение R102 и R104 является облаком IP, которое не настроено для многоадресной маршрутизации.

Туннель настроен между R102 к R104, полученному с их интерфейсами обратной связи. Команда ip pim sparse-dense mode настроена на туннельных интерфейсах, и multicast-routing включен на R102 и R104. Конфигурация редкого плотного режима на туннельных интерфейсах позволяет разреженному режиму или пакетам режима уплотнения быть переданным по туннелю в зависимости от конфигурации точки встречи (RP) для группы.

Примечание:  Для плотного режима — С разреженным режимом PIM (многоадресная рассылка, независящая от протокола), настроенным через туннель, команда ip mroute 10.1.1.0 255.255.255.0 tunnel 0 настроена на R104 для обеспечения успешного RPF для адреса источника для групповой адресации 10.1.1.1. При поступлении (10.1.1.1, 239.1.1.20) пакеты групповой адресации по Tunnel0 (Tu0) проверены для Пересылки по обратному пути (RPF) с помощью этой инструкции mroute. После успешной проверки пакеты групповой адресации переданы интерфейсам списка исходящих интерфейсов (OIL).

Примечание:  Для разреженного режима — С разреженным режимом многоадресной рассылки (PIM sparse), настроенным через туннель, гарантируйте, что обращены эти точки:

  • Для успешной проверки RPF многоадресного трафика, текущего по совместно используемой древовидной схеме (*, G) от RP, команда ip mroute rp-address nexthop должна быть настроена для адреса RP, который указывает к туннельному интерфейсу.

    Учитывая, что R102 является RP (адрес RP 2.2.2.2) в этом случае, тогда mroute является командой ip mroute 2.2.2.2 255.255.255.255 tunnel 0, которая гарантирует успешную Проверку переадресации по обратному пути для трафика, который течет по совместно используемой древовидной схеме.

  • Для успешной проверки RPF групповой адресации (S, G) поток трафика по Дереву кратчайших путей (SPT), команда ip mroute source-address nexthop должна быть настроена для источника групповой адресации, указывая на туннельный интерфейс.

    В этом случае, когда трафик SPT течет по туннельному интерфейсу, команда ip mroute 10.1.1.0 255.255.255.0 tunnel 0 настроена на R104 для обеспечения успешной проверки RPF для входящих (10.1.1.1, 239.1.1.20) пакеты групповой адресации по интерфейсу Tu0.

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/43584/mcast-gre2.gif

Конфигурации

Эти конфигурации используются в данном документе:

Настройте Маршрутизатор 102 согласно этому файлу рабочей конфигурации:

R102
version 12.2
!hostname r102
!
!ip subnet-zero
no ip domain-lookup

!--- It stops IP domain lookup, which improves 
!--- the show command response time.

!
ip multicast-routing

!--- Enables IP multicast routing.

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 
!--- Tunnel Source interface.

!
interface Tunnel0

!--- Tunnel interface configured for PIM and carrying 
!--- multicast packets to R104.

 ip address 192.168.24.1 255.255.255.252
 ip pim sparse-dense-mode
 tunnel source Loopback0
 tunnel destination 4.4.4.4
!
interface Ethernet0/0

!--- Interface connected to Source.

 ip address 10.1.1.2 255.255.255.0
 ip pim sparse-dense-mode
!
!
interface Serial8/0
 ip address 192.168.23.1 255.255.255.252

!--- Note IP PIM sparse-dense mode is 
!--- not configured on Serial interface.

!router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 10.1.1.0 0.0.0.255 area 0
 network 192.168.23.0 0.0.0.255 area 0
!
ip classless
ip pim bidir-enable
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Настройте Маршрутизатор 104 согласно этому файлу рабочей конфигурации:

R104
r104#
version 12.2
!
hostname r104
!
!
ip subnet-zero
no ip domain-lookup

!--- It stops IP domain lookup, which improves 
!--- the show command response time.

!
ip multicast-routing

!--- Enables IP multicast routing.

!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255

!--- Tunnel Source interface.

!
interface Tunnel0
 ip address 192.168.24.2 255.255.255.252

!--- Tunnel interface configured for PIM 
!--- and carrying multicast packets.

 ip pim sparse-dense-mode
 tunnel source Loopback0
 tunnel destination 2.2.2.2
!
interface Ethernet0/0
 ip address 10.2.2.2 255.255.255.0
 ip pim sparse-dense-mode
!
interface Serial9/0
 ip address 192.168.34.1 255.255.255.252

!--- Note IP PIM sparse-dense mode is not 
!--- configured on Serial interface.

!
!
router ospf 1
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 10.2.2.0 0.0.0.255 area 0
 network 192.168.34.0 0.0.0.255 area 0
!
ip classless
no ip http server
ip pim bidir-enable
ip mroute 10.1.1.0 255.255.255.0 Tunnel0


!--- This mroute ensures a successful RPF check 
!--- for packets flowing from the source.
!--- 10.1.1.1 over Shared tree in case of Dense 
!--- more and SPT in case of Sparse mode.

!
ip mroute 2.2.2.2 255.255.255.255 tunnel 0


!--- This mroute is required for RPF check when 
!--- Sparse mode multicast traffic is 
!--- flowing from RP (assuming R102 with 2.2.2.2 as RP)
!--- towards receiver via tunnel  
!--- before the SPT switchover.

line con 0
line aux 0
line vty 0 4
 login
!
end

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • show ip igmp group — Проверяет, что получатель отправил свой запрос членства в соединении IGMP для группы 239.1.1.20 к R104.

    r104#show ip igmp groups 
    IGMP Connected Group Membership
    Group Address    Interface          Uptime    Expires   Last Reporter
    239.1.1.20       Ethernet0/0        00:00:04  00:02:55  10.2.2.3
  • групповой адрес show ip mroute — Проверяет, что, когда источник 10.1.1.1 начинает передавать пакеты в многоадресном режиме для группы 239.1.1.20, R102 устанавливает (*, 239.1.1.20) и (10.1.1.1, 239.1.1.20) записи в таблице mroute R102.

    Примечание: В (10.1.1.1, 239.1.1.20) запись, НЕФТЬ является Tunnel0.

    r102#show ip mroute 239.1.1.20
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report
    Outgoing interface flags: H - Hardware switched
    Timers: Uptime/Expires
    Interface state: Interface, Next-Hop or VCD, State/Mode
    
    (*, 239.1.1.20), 00:00:09/00:02:59, RP 0.0.0.0, flags: D
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Tunnel0, Forward/Sparse-Dense, 00:00:09/00:00:00
        Ethernet0/0, Forward/Sparse-Dense, 00:00:09/00:00:00
    
    (10.1.1.1, 239.1.1.20), 00:00:09/00:02:58, flags: T
      Incoming interface: Ethernet0/0, RPF nbr 0.0.0.0
      Outgoing interface list:
        Tunnel0, Forward/Sparse-Dense, 00:00:09/00:00:00
  • групповой адрес show ip mroute — Проверяет, что R104 имеет (*, 239.1.1.20) и (10.1.1.1, 239.1.1.20) записи, в то время как это - пересылки многоадресного пакета для группы 239.1.1.20 полученных от 10.1.1.1.

    Примечание: В (10.1.1.1, 239.1.1.20), входящий интерфейс является Tunnel0, и сосед RPF 192.168.24.1 — Туннельный головной узел на R102. Проверка RPF сделана на основе mroute, настроенного на R104, и пакеты групповой адресации выставлены к НЕФТИ к получателю, связанному на Ethernet 0/0 интерфейс.

    r104#show ip mroute 239.1.1.20
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report
    Outgoing interface flags: H - Hardware switched
    Timers: Uptime/Expires
    Interface state: Interface, Next-Hop or VCD, State/Mode
    
    (*, 239.1.1.20), 00:07:10/00:00:00, RP 0.0.0.0, flags: DCL
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Tunnel0, Forward/Sparse-Dense, 00:07:10/00:00:00
        Ethernet0/0, Forward/Sparse-Dense, 00:07:10/00:00:00
    
    (10.1.1.1, 239.1.1.20), 00:01:13/00:02:24, flags: CLT
      Incoming interface: Tunnel0, RPF nbr 192.168.24.1, Mroute
      Outgoing interface list:
        Ethernet0/0, Forward/Sparse-Dense, 00:01:13/00:00:00
  • IP-адрес show ip rpf — Выполняет проверку RPF для пакетов от источника от 10.1.1.1. Следующий пример подтверждает, что RPF для 10.1.1.1 через Туннель 0, на котором мы получаем групповую адресацию (S, G) пакеты.

    r104>show ip rpf 10.1.1.1
    RPF information for ? (10.1.1.1)
      RPF interface: Tunnel0
      RPF neighbor: ? (192.168.24.1)
      RPF route/mask: 10.1.1.1/24
      RPF type: static
      RPF recursion count: 0
      Doing distance-preferred lookups across tables

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Прежде чем выполнять какие-либо команды отладки , ознакомьтесь с документом "Важные сведения о командах отладки".

Если групповая адресация по Туннелю GRE не работает, один из них может быть причиной:

  • Туннель не UP/UP — источник и место назначения туннеля не совпадает на каждом конце туннеля. Например, если бы назначение туннеля на R102 было изменено на IP-адрес 10.2.2.2 вместо 2.2.2.2, в то время как конфигурация на R104 осталась тем же, то туннель не подошел бы.

    Выполните команду show interface tunnel 0 для подтверждения статуса туннеля.

  • Пакеты групповой адресации отброшены из-за Ошибки переадресации по обратному пути.

    Выполните команду show ip mroute count. Пример выходных данных этой команды и ее увеличивающихся счетчиков для Ошибки переадресации по обратному пути показывают в этих выходных данных:

    r104#show ip mroute count
    IP Multicast Statistics
    3 routes using 1642 bytes of memory
    2 groups, 0.50 average sources per group
    Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
    Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
    
    Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
    
    Group: 239.1.1.20, Source count: 1, Packets forwarded: 11, Packets received: 45
      Source: 10.1.1.1/32, Forwarding: 11/0/100/0, Other: 25/14/0
    
    
    !--- After some time, the show ip mroute count command 
    !--- is issued again. You can see the RPF failed counter increasing:
    
    r104#show ip mroute count
    IP Multicast Statistics
    3 routes using 1642 bytes of memory
    2 groups, 0.50 average sources per group
    Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
    Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
    
    Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
    
    Group: 239.1.1.20, Source count: 1, Packets forwarded: 11, Packets received: 50
      Source: 10.1.1.1/32, Forwarding: 11/0/100/0, Other: 30/19/0
    r104#

    Можно также выполнить команду show ip rpf source. Гарантируйте, что интерфейс RPF совпадает с этим, на котором исходные пакеты групповой адресации получены — Туннель 0 в данном примере. Обратитесь к Руководству по поиску и устранению проблем многоадресного IP-вещания для получения дополнительной информации об Ошибках переадресации по обратному пути.

  • Соседи PIM — Маршрутизатор R102 не передает по интерфейсу Tunnel0, потому что это не видит, что премьер-министр граничит с R104.

    Введите следующие команды:

    • show ip pim neighbor Можно использовать команду show ip pim neighbor на R102 для показа соседнего R104 по туннелю.

    • show ip pim int — Можно также использовать команду show ip pim int, чтобы показать, что существует соседний узел.

    • ip pim sparse-dense-mode , что команда ip pim sparse-dense-mode уровня интерфейса настроена на обоих концах туннеля и что включен IP multicast-routing.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 43584