Безопасность и VPN : Протоколы IPSec Negotiation/IKE

Настройка протокола IPSec между двумя системами IOS с использованием шифрования AES

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (12 ноября 2015) | Отзыв


Содержание


Введение

В документе содержится пример конфигурации IPSec-туннеля IOS-to-IOS с использованием шифрования стандарта AES.

Предварительные условия

Требования

Поддержка шифрования AES была представлена в Cisco IOS� 12.2 (13) T.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Программное обеспечение Cisco IOS версии 12.3(10)

  • Маршрутизаторы Cisco 1721

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Конфигурации

В данном документе используются конфигурации, показанные ниже.

Маршрутизатор 1721-A
R-1721-A#show run
Building configuration...

Current configuration : 1706 bytes
!
! Last configuration change at 00:46:32 UTC Fri Sep 10 2004
! NVRAM config last updated at 00:45:48 UTC Fri Sep 10 2004
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R-1721-A
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 15
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!
!
!
ip audit po max-events 100
no ip domain lookup
no ftp-server write-enable
!
!
! 
!


!--- Define Internet Key Exchange (IKE) policy.

crypto isakmp policy 10

!--- Specify the 256-bit AES as the
!--- encryption algorithm within an IKE policy.

 encr aes 256

!--- Specify that pre-shared key authentication is used.

 authentication pre-share


!--- Specify the shared secret.

crypto isakmp key cisco123 address 10.48.66.146
!
!

!--- Define the IPSec transform set.

crypto ipsec transform-set aesset esp-aes 256 esp-sha-hmac 
!

!--- Define crypto map entry name "aesmap" that will use 
!--- IKE to establish the security associations (SA).

crypto map aesmap 10 ipsec-isakmp 

!--- Specify remote IPSec peer.

 set peer 10.48.66.146

!--- Specify which transform sets
!--- are allowed for this crypto map entry.

 set transform-set aesset 

!--- Name the access list that determines which traffic 
!--- should be protected by IPSec.

 match address acl_vpn
!
!
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Ethernet0
 ip address 192.168.100.1 255.255.255.0
 ip nat inside
 half-duplex
!
interface FastEthernet0
 ip address 10.48.66.147 255.255.254.0
 ip nat outside
 speed auto

!--- Apply crypto map to the interface.

 crypto map aesmap
!
ip nat inside source list acl_nat interface FastEthernet0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 10.48.66.1
ip route 192.168.200.0 255.255.255.0 FastEthernet0
no ip http server
no ip http secure-server
!


ip access-list extended acl_nat

!--- Exclude protected traffic from being NAT'ed.

 deny   ip 192.168.100.0 0.0.0.255 192.168.200.0 0.0.0.255
 permit ip 192.168.100.0 0.0.0.255 any


!--- Access list that defines traffic protected by IPSec.

ip access-list extended acl_vpn
 permit ip 192.168.100.0 0.0.0.255 192.168.200.0 0.0.0.255
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
!
end

R-1721-A#

Маршрутизатор 1721-B
R-1721-B#show run
Building configuration...

Current configuration : 1492 bytes
!
! Last configuration change at 14:11:41 UTC Wed Sep 8 2004
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R-1721-B
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 15
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!
!
!
ip audit po max-events 100
no ip domain lookup
no ftp-server write-enable
!
!
!
! 
!

!--- Define IKE policy.

crypto isakmp policy 10

!--- Specify the 256-bit AES as the
!--- encryption algorithm within an IKE policy.

 encr aes 256

!--- Specify that pre-shared key authentication is used.

 authentication pre-share


!--- Specify the shared secret.

crypto isakmp key cisco123 address 10.48.66.147
!
!

!--- Define the IPSec transform set.

crypto ipsec transform-set aesset esp-aes 256 esp-sha-hmac 
!

!--- Define crypto map entry name "aesmap" that uses 
!--- IKE to establish the SA.

crypto map aesmap 10 ipsec-isakmp 

!--- Specify remote IPSec peer.

 set peer 10.48.66.147

!--- Specify which transform sets
!--- are allowed for this crypto map entry.

 set transform-set aesset 

!--- Name the access list that determines which traffic 
!--- should be protected by IPSec.

 match address acl_vpn
!
!
!
interface Ethernet0
 ip address 192.168.200.1 255.255.255.0
 ip nat inside
 half-duplex
!
interface FastEthernet0
 ip address 10.48.66.146 255.255.254.0
 ip nat outside
 speed auto

!--- Apply crypto map to the interface.

 crypto map aesmap
!
ip nat inside source list acl_nat interface FastEthernet0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 10.48.66.1
ip route 192.168.100.0 255.255.255.0 FastEthernet0
no ip http server
no ip http secure-server
!
ip access-list extended acl_nat

!--- Exclude protected traffic from being NAT'ed.

 deny   ip 192.168.200.0 0.0.0.255 192.168.100.0 0.0.0.255
 permit ip 192.168.200.0 0.0.0.255 any



!--- Access list that defines traffic protected by IPSec.

ip access-list extended acl_vpn
 permit ip 192.168.200.0 0.0.0.255 192.168.100.0 0.0.0.255
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
!
end

R-1721-B#

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show crypto isakmp sa - отображает состояние для ISAKMP (Internet Security Association and Key Management Protocol) SA.

    Маршрутизатор 1721-A
    R-1721-A#show crypto isakmp sa     
    dst             src             state          conn-id slot
    10.48.66.147    10.48.66.146    QM_IDLE              1    0

    Маршрутизатор 1721-B
    R-1721-B#show crypto isakmp sa     
    dst             src             state          conn-id slot
    10.48.66.147    10.48.66.146    QM_IDLE              1    0

  • {\f3 show crypto ipsec sa}–{\f3 показывает статистику по активным туннелям.}

    Маршрутизатор 1721-A
    R-1721-A#show crypto ipsec sa
    
    interface: FastEthernet0
        Crypto map tag: aesmap, local addr. 10.48.66.147
    
       protected vrf: 
       local  ident (addr/mask/prot/port): (192.168.100.0/255.255.255.0/0/0)
       remote ident (addr/mask/prot/port): (192.168.200.0/255.255.255.0/0/0)
       current_peer: 10.48.66.146:500
         PERMIT, flags={origin_is_acl,}
        #pkts encaps: 30, #pkts encrypt: 30, #pkts digest 30
        #pkts decaps: 30, #pkts decrypt: 30, #pkts verify 30
        #pkts compressed: 0, #pkts decompressed: 0
        #pkts not compressed: 0, #pkts compr. failed: 0
        #pkts not decompressed: 0, #pkts decompress failed: 0
        #send errors 0, #recv errors 0
    
         local crypto endpt.: 10.48.66.147, remote crypto endpt.: 10.48.66.146
         path mtu 1500, ip mtu 1500, ip mtu idb FastEthernet0
         current outbound spi: 2EB0BA1A
    
         inbound esp sas:
          spi: 0xFECA28BC(4274661564)
            transform: esp-256-aes esp-sha-hmac ,
            in use settings ={Tunnel, }
            slot: 0, conn id: 2000, flow_id: 1, crypto map: aesmap
            sa timing: remaining key lifetime (k/sec): (4554237/2895)
            IV size: 16 bytes
            replay detection support: Y
    
         inbound ah sas:
    
         inbound pcp sas:
    
         outbound esp sas:
          spi: 0x2EB0BA1A(783333914)
            transform: esp-256-aes esp-sha-hmac ,
            in use settings ={Tunnel, }
            slot: 0, conn id: 2001, flow_id: 2, crypto map: aesmap
            sa timing: remaining key lifetime (k/sec): (4554237/2894)
            IV size: 16 bytes
            replay detection support: Y
    
         outbound ah sas:
    
         outbound pcp sas:
    R-1721-A#

    Маршрутизатор 1721-B
    R-1721-B#show crypto ipsec sa
    
    interface: FastEthernet0
        Crypto map tag: aesmap, local addr. 10.48.66.146
    
       protected vrf: 
       local  ident (addr/mask/prot/port): (192.168.200.0/255.255.255.0/0/0)
       remote ident (addr/mask/prot/port): (192.168.100.0/255.255.255.0/0/0)
       current_peer: 10.48.66.147:500
         PERMIT, flags={origin_is_acl,}
        #pkts encaps: 30, #pkts encrypt: 30, #pkts digest 30
        #pkts decaps: 30, #pkts decrypt: 30, #pkts verify 30
        #pkts compressed: 0, #pkts decompressed: 0
        #pkts not compressed: 0, #pkts compr. failed: 0
        #pkts not decompressed: 0, #pkts decompress failed: 0
        #send errors 5, #recv errors 0
    
         local crypto endpt.: 10.48.66.146, remote crypto endpt.: 10.48.66.147
         path mtu 1500, ip mtu 1500, ip mtu idb FastEthernet0
         current outbound spi: FECA28BC
    
         inbound esp sas:
          spi: 0x2EB0BA1A(783333914)
            transform: esp-256-aes esp-sha-hmac ,
            in use settings ={Tunnel, }
            slot: 0, conn id: 2000, flow_id: 1, crypto map: aesmap
            sa timing: remaining key lifetime (k/sec): (4583188/2762)
            IV size: 16 bytes
            replay detection support: Y
    
         inbound ah sas:
    
         inbound pcp sas:
    
         outbound esp sas:
          spi: 0xFECA28BC(4274661564)
            transform: esp-256-aes esp-sha-hmac ,
            in use settings ={Tunnel, }
            slot: 0, conn id: 2001, flow_id: 2, crypto map: aesmap
            sa timing: remaining key lifetime (k/sec): (4583188/2761)
            IV size: 16 bytes
            replay detection support: Y
    
         outbound ah sas:
    
         outbound pcp sas:
    R-1721-B#

  • {\f3 show crypto engine connections active}–{\f3 показывает число активных соединений с ядром шифрования.}

    Маршрутизатор 1721-A
    R-1721-A#show crypto engine connections active 
    
      ID Interface       IP-Address      State  Algorithm           Encrypt  Decrypt
       1 FastEthernet0   10.48.66.147    set    HMAC_SHA+AES_256_C        0        0
    2000 FastEthernet0   10.48.66.147    set    HMAC_SHA+AES_256_C        0       30
    2001 FastEthernet0   10.48.66.147    set    HMAC_SHA+AES_256_C       30        0

    Маршрутизатор 1721-B
    R-1721-B#show crypto engine connections active 
    
      ID Interface       IP-Address      State  Algorithm           Encrypt  Decrypt
       1 FastEthernet0   10.48.66.146    set    HMAC_SHA+AES_256_C        0        0
    2000 FastEthernet0   10.48.66.146    set    HMAC_SHA+AES_256_C        0       30
    2001 FastEthernet0   10.48.66.146    set    HMAC_SHA+AES_256_C       30        0

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • {\f3 debug crypto ipsec}–{\f3 показывает события IPSec.}

  • {\f3 debug crypto isakmp}–{\f3 показывает сообщения, касающиеся событий IKE.}

  • {\f3 debug crypto engine}–{\f3 выводит информацию о криптографическом модуле.}

Дополнительные сведения об устранении неисправностей протокола IPSec см. в документе Основные сведения об устранении неполадок протокола IP Security и использовании команд отладки debug.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 43069