Протокол IP : Групповая IP-адресация

Внедрение политики фильтрации для точек синхронизации

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (27 апреля 2015) | Отзыв


Содержание


Введение

Этот документ объясняет, как внедрить политику фильтрации для точек встречи (RP) в агенте сопоставления RP в среде групповой адресации, где динамическая Настройка протокола маршрутизации применена (Auto-RP).

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Основное понимание независимой от протокола многоадресной передачи (PIM)

Используемые компоненты

Используйте эту схему в качестве ссылки всюду по этому документу:

/image/gif/paws/41680/rp_announce_02.gif

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Auto-RP

Auto-RP является динамическим способом для обучения информации о RP для каждого маршрутизатора в сети. Это достигнуто при распределении всей информации о группе - к-RP через групповую IP-адресацию.

Все поддерживающие PIM маршрутизаторы автоматически присоединяются к группе обнаружения RP Cisco (224.0.1.40), который позволяет им получать все данные сопоставления группы - к-RP. Эта информация распределена объектом, названным агентом сопоставления RP. Сами агенты сопоставления присоединяются к другой группе — RP Cisco объявляет о группе (224.0.1.39). Все RP кандидата объявляют себя в периодических многоадресных сообщениях, нацеленных на RP, объявляют о групповом адресе.

Агент сопоставления слушает все объявления кандидата RP и создает таблицу с информацией. Если несколько RP объявляют о себе для диапазона групповой адресации, агент сопоставления выбирает только один — RP с самым высоким IP-адресом. Это тогда объявляет RP ко всем маршрутизаторам PIM в сети с помощью сообщения об обнаружении RP. Агенты сопоставления передают эту информацию каждые 60 секунд (настройка по умолчанию).

Адреса RP фильтрации

Можно использовать команду ip pim rp-announce-filter rp-list access-list group-list access-list для фильтрации определенных RP для определенных групп многоадресной рассылки.

Команда ip pim rp-announce-filter rp-list access-list group-list access-list только имеет значение, если это настроено в агенте сопоставления. Access-list rp-list определяет access-list RP кандидата, которые, если разрешено, приняты для диапазонов групповой адресации, заданных в команде access-list group-list .

Примечание: Используйте эту команду с осторожностью. RP, с которыми совпадает rp-list (позволенный оператором permit) фильтровал их группы многоадресной рассылки group-list. RP, которые запрещены (или явным или неявным запрещают) не подвергаются фильтрации своих групп многоадресной рассылки и "вслепую" приняты как RP кандидата для всех их групп. Другими словами, только RP, которые разрешены rp-list, фильтровал их группы многоадресной рассылки group-list. Все другие RP приняты без исследования.

Дополнительный RP объявляет, что фильтр необходим для эффективной фильтрации RP, которые приняты без исследования. Раздел фильтрации В качестве примера разъясняет эту процедуру.

Пример фильтрации

В схеме в разделе Используемых компонентов R2 и R4 объявляют о себе как RP кандидата для этих групп (которые объявляют эту информацию с помощью сообщений об обнаружении RP):

  • 224.1.0.1

  • 224.1.0.2

  • 224.1.0.3

R3 настроен как агент сопоставления и собирает эту информацию, создает свою таблицу и передает только один адрес RP к R6, который является только поддерживающим PIM маршрутизатором. Обмен информацией между промежуточными системами (IS-IS) используется в данном примере в качестве протокола одноадресной маршрутизации, но любой другой протокол работал бы также. Режим PIM sparseDense необходим для получения информации о групповой адресации для групп 224.0.1.39 и 224.0.1.40, не настраивая RP для тех групп. Другими словами, если нет никакого известного RP, режим SparseDense работает как плотный режим. Когда RP известен, режим SparseDense используется для групп, для которых RP объявляет себя.

Конфигурация R2

hostname R2

ip multicast-routing

interface Loopback0
 ip address 50.0.0.2 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Serial3/0
 ip address 10.2.0.2 255.255.255.0
 ip router isis
 ip pim sparse-dense mode

router isis 
 net 49.0002.0000.0000.0002.00

ip pim send-rp-announce Loopback0 scope 16 group-list groupB
!         
!         
ip access-list standard groupB
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

Конфигурация R4

hostname R4

ip multicast-routing

interface Loopback0
 ip address 50.0.0.4 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Serial3/0
 ip address 10.3.0.4 255.255.255.0
 ip router isis
 ip pim sparse-dense mode

router isis 
 net 49.0002.0000.0000.0004.00

ip pim send-rp-announce Loopback0 scope 16 group-list groupA
!         
!         
ip access-list standard groupA
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

Конфигурация R3

hostname R3

ip multicast-routing

interface Loopback0
 ip address 50.0.0.3 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

interface Serial2/0
 ip address 10.2.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

interface Serial3/0
 ip address 10.3.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

router isis 
 net 49.0002.0000.0000.0003.00

Конфигурация R6

hostname R6

ip multicast-routing

interface Loopback0
 ip address 50.0.0.6 255.255.255.255
 ip router isis
 
interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.6 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

router isis 
 net 49.0002.0000.0000.0006.00

Если вы хотите фильтровать R4 как возможный RP для какой-либо из тех групп и только иметь R2 как рабочий RP, настроить RP, объявляют, просачиваются R3:

ip pim rp-announce-filter rp-list filtering-RP group-list filtering-group
!         
!         
ip access-list standard filtering-RP
 permit 50.0.0.2
 deny    50.0.0.4


!--- ACL "filtering-RP" specifically allows R2 and explicitly denies R4.


ip access-list standard filtering-group
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

Затем для очистки текущих ассоциаций группы - к-RP выполните команду clear ip pim rp-mapping и в R3 и в R6.

Однако при просмотре R6 вы видите, что информация не то, что вы ожидаете:

R6#show ip pim rp mapping 
PIM Group-to-RP Mappings

Group(s) 224.1.0.1/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55
Group(s) 224.1.0.2/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55
Group(s) 224.1.0.3/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55

При просмотре R3 вы видите, что фактически не выполняется никакая фильтрация:

R3# show ip pim rp mapping
PIM Group-to-RP Mappings
This system is an RP-mapping agent

!--- This line confirms that R3 is configured as the mapping agent.


Group(s) 224.1.0.1/32
  RP 50.0.0.4 (?), v2v1

!--- No filtering has taken effect.

    Info source: 50.0.0.4 (?), elected via Auto-RP

!--- R4 is elected because it has a higher IP address.

         Uptime: 00:09:06, expires: 00:02:53
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:27
Group(s) 224.1.0.2/32
  RP 50.0.0.4 (?), v2v1
    Info source: 50.0.0.4 (?), elected via Auto-RP
         Uptime: 00:09:06, expires: 00:02:51
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:27
Group(s) 224.1.0.3/32
  RP 50.0.0.4 (?), v2v1
    Info source: 50.0.0.4 (?), elected via Auto-RP
         Uptime: 00:09:06, expires: 00:02:51
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:28

Адрес R4 в частности запрещен и не подвергается никакой фильтрации своих групп многоадресной рассылки — это "вслепую" принято агентом сопоставления. Агент сопоставления выбирает один RP на основе самого высокого IP-адреса (в данном примере, 50.0.0.4) и затем передает эту информацию к R6.

Настройте другой RP, объявляют о фильтре, который разрешает R4 и запрещает все его группы для эффективной фильтрации адреса R4:

ip pim rp-announce-filter rp-list filtering-R4 group-list filtering-groupR4

ip access-list standard filtering-R4
 permit 50.0.0.4
ip access-list standard filtering-groupR4
 deny   any

Если вы просматриваете R3 и выполняете команду debug ip pim auto-rp, как только вы получаете RP, объявляют о сообщении от R4, вы видите эти сообщения:

R3#
*Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4

Затем при просмотре таблицы группы - к-RP можно только видеть R2:

R3#show ip pim rp mapping 
PIM Group-to-RP Mappings
This system is an RP-mapping agent

Group(s) 224.1.0.1/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:52
Group(s) 224.1.0.2/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:54
Group(s) 224.1.0.3/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:55

Наконец, если вы хотите иметь R2 как RP для 224.1.0.1, и R4 как RP для 224.1.0.2 и 224.1.0.3, у вас есть эта конфигурация в R3:

hostname R3

ip multicast-routing

interface Loopback0
 ip address 50.0.0.3 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

interface Serial2/0
 ip address 10.2.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

interface Serial3/0
 ip address 10.3.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

router isis
 net 49.0002.0000.0000.0003.00

ip pim rp-announce-filter rp-list filtering-RP2 group-list filtering-group2
ip pim rp-announce-filter rp-list filtering-RP4 group-list filtering-group4
!        
!        
ip access-list standard filtering-RP2
 permit 50.0.0.2

ip access-list standard filtering-RP4
 permit 50.0.0.4

ip access-list standard filtering-group2
 permit 224.1.0.1

ip access-list standard filtering-group4
 permit 224.1.0.2
 permit 224.1.0.3

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 41680