Многопротокольная коммутация по меткам (MPLS) : MPLS

Пример конфигурации поддержки многоадресности для VPN-сетей MPLS

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Данный документ содержит пример конфигурации и общие указания для настройки многоадресной поддержки в виртуальных частных сетях с многопротокольной коммутацией по меткам (MPLS). Эта функция была представлена в Cisco Выпуск ПО IOS� 12.0 (23) S and�12.2 (13) T.

Предварительные условия

Требования

Прежде чем использовать эту конфигурацию, убедитесь, что выполняются эти требования:

  • У поставщиков услуг должно быть поддерживающее групповую адресацию ядро для использования функции Multicast VPN Cisco.

Используемые компоненты

Сведения, содержащиеся в данном документе, относятся к Cisco IOS Software Release 12.2(13)T

Примечание: Для получения обновленной информации о платформенной поддержке этой функции используйте программу Software Advisor (только для зарегистрированных пользователей). Software Advisor динамично обновляет список поддерживаемых платформ, поскольку новая поддержка платформ добавлена для функции.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Общие сведения

Для общих сведений сошлитесь на документацию новой характеристики программного обеспечения Cisco IOS версии 12.2(13)T для Поддержки Групповой IP-адресации MPLS VPN.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме.

/image/gif/paws/29220/config_mpls_vpn1.gif

Конфигурации

Схема сети представляет магистраль поставщика услуг. Это состоит из маршрутизаторов R2, R3 и R4. Магистраль настроена на поддержку MPLS VPN. Маршрутизаторы R2 и R4 находятся на стороне провайдера (PE), в то время как R3 является маршрутизатором провайдера (P). R1 и R5 представляют маршрутизаторы на стороне абонента (CE), которые относятся к тождественной маршрутизации виртуальной частной сети и экземпляра VRF, желтый.

Для обеспечения сервисов групповой адресации магистраль должна быть настроена для выполнения многоадресной маршрутизации. Для этой цели выбран протокол многоадресной передачи PIM (многоадресная передача, независимая от протокола), а маршрутизатор 3 настроен как точка встречи (RP). R2 и R4 также настроены для выполнения многоадресной маршрутизации в желтый VRF. Редкий плотный режим PIM настроен как протокол многоадресной маршрутизации между PE и CEs. R2 был настроен так, чтобы быть RP для желтого VRF.

Для тестирования подключения групповой адресации s0/0 интерфейс R5 настроен для присоединения к группе многоадресной рассылки 224.2.2.2. Пакеты проверки соединения отправляются с адреса обратной связи R1 на адрес 224.2.2.2. Эхо протокола управляющих сообщений в сети Internet (ICMP) – многоадресный пакет, тогда как ICMP ответ – это одноадресный пакет, так как IP-адрес назначения – это адрес обратной связи R1.

Конфигурации, представленные в этом документе, включают их:

R1-(CE)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
!
clock timezone CET 1
ip subnet-zero
no ip domain lookup
!
ip multicast-routing 

!--- Enable multicast routing.

!
!
interface Loopback0
 ip address 100.0.0.1 255.255.255.255
!
interface Serial0/0
 ip address 10.1.0.1 255.255.255.0
 ip pim sparse-dense-mode

!--- PIM sparce-dense mode is used between the PE and CE.
!--- PIM sparce-dense mode is the multicast routing protocol.

 
!
router rip
 version 2
 network 10.0.0.0
 network 100.0.0.0
 no auto-summary
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!         
end

R2-(PE)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
!
clock timezone CET 1
ip subnet-zero
no ip domain lookup
!
ip vrf yellow
 rd 2:200
 route-target export 2:200
 route-target import 2:200
 mdt default 239.1.1.1

!--- Configure the default Multicast Distribution Tree (MDT) 
!--- for VRF yellow.

 mdt data 239.2.2.0 0.0.0.255 threshold 1

!--- Configure the range global addresses for 
!--- data MDTs and the threshold.

ip multicast-routing 

!--- Enable global multicast routing.

ip multicast-routing vrf yellow 

!--- Enable multicast routing in VRF yellow.

ip cef
mpls label protocol ldp
tag-switching tdp router-id Loopback0
!
!
!
interface Loopback0
 ip address 50.0.0.2 255.255.255.255
 ip pim sparse-dense-mode


!--- Multicast needs to be enabled on loopback 
!--- interface. This is used as a source  
!--- for MPBGP sessions between PE routers that participate in MVPN.


!
interface Loopback100
 ip vrf forwarding yellow
 ip address 100.0.0.2 255.255.255.255
 ip pim sparse-dense-mode
!

!--- This router needs to be RP for 
!--- multicast in VRF yellow. Therefore, multicast
!--- needs to be enabled on the interface which is used as RP.


!
interface Serial1/0
 ip vrf forwarding yellow
 ip address 10.1.0.2 255.255.255.0
 ip pim sparse-dense-mode

!--- Multicast is enabled on PE-CE interfaces in VRF.


!         
interface Serial2/0
 ip address 10.2.0.2 255.255.255.0
 ip pim sparse-dense-mode

!--- Service provider core needs to run multicast
!--- to support MVPN services,
!--- so multicast is enabled on PE-P links.


 tag-switching ip        
!         
router ospf 1
 router-id 50.0.0.2
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.0.0.255 area 0
!
router rip
 version 2
 no auto-summary
 !
 address-family ipv4 vrf yellow
 version 2
 redistribute bgp 1
 network 10.0.0.0
 network 100.0.0.0
 default-metric 5
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 redistribute rip
 neighbor 50.0.0.4 remote-as 1
 neighbor 50.0.0.4 update-source Loopback0
 neighbor 50.0.0.4 activate
 neighbor 50.0.0.6 remote-as 1
 neighbor 50.0.0.6 update-source Loopback0
 neighbor 50.0.0.6 activate
 no auto-summary
 !
 address-family ipv4 vrf yellow
 redistribute connected
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 50.0.0.4 activate
 neighbor 50.0.0.4 send-community extended
 neighbor 50.0.0.6 activate
 neighbor 50.0.0.6 send-community extended
 no auto-summary
 exit-address-family
!         
ip classless
no ip http server
ip pim bidir-enable
ip pim vrf yellow send-rp-announce Loopback100 scope 100
ip pim vrf yellow send-rp-discovery Loopback100 scope 100

!--- Configure auto-RP. The R2's loopback 
!--- 100 is the RP in VRF yellow.

!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

R3 - (P)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R3 
! 
! 
clock timezone CET 1 
ip subnet-zero 
! 
ip multicast-routing  

!--- Enable global multicast routing.
 
ip cef 
mpls label protocol ldp 
tag-switching tdp router-id Loopback0 
! 
! 
! 
interface Loopback0 
 ip address 50.0.0.3 255.255.255.255 
 ip pim sparse-dense-mode 
! 
! 
interface Serial1/0 
 ip address 10.2.0.3 255.255.255.0 
 ip pim sparse-dense-mode

!--- Enable multicast on links to PE routers 
!--- which have MVPNs configured.

 
 tag-switching ip 
! 
interface Serial2/0 
 ip address 10.3.0.3 255.255.255.0 
 ip pim sparse-dense-mode 
 tag-switching ip 
! 
router ospf 1 
 router-id 50.0.0.3 
 log-adjacency-changes 
 network 10.0.0.0 0.255.255.255 area 0 
 network 50.0.0.0 0.0.0.255 area 0 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
ip pim send-rp-announce Loopback0 scope 100 
ip pim send-rp-discovery Loopback0 scope 100 

!--- R3 is configured to announce itself as 
!--- the RP through auto-RP.
 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login  
! 
end

R4-(PE)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R4 
! 
! 
clock timezone CET 1 
ip subnet-zero 
no ip domain lookup 
! 
ip vrf yellow 
 rd 2:200 
 route-target export 2:200 
 route-target import 2:200 
 mdt default 239.1.1.1 

!--- Configure the default MDT address.
 
 mdt data 238.2.2.0 0.0.0.255 threshold 1 

!--- Configure the data MDT range and threshold.
 
! 
ip multicast-routing  

!--- Enable global multicast routing.
 
ip multicast-routing vrf yellow  

!--- Enable multicast routing in VRF yellow.
 
ip cef 
mpls label protocol ldp 
tag-switching tdp router-id Loopback0 
! 
! 
! 
interface Loopback0 
 ip address 50.0.0.4 255.255.255.255 
 ip pim sparse-dense-mode 
! 
interface Loopback100 
 ip vrf forwarding yellow 
 ip address 100.0.0.4 255.255.255.255 
 ip pim sparse-dense-mode 
! 
interface Serial1/0 
 ip address 10.3.0.4 255.255.255.0 
 ip pim sparse-dense-mode 
 tag-switching ip 
! 
interface Serial2/0 
 ip vrf forwarding yellow 
 ip address 10.4.0.4 255.255.255.0 
 ip pim sparse-dense-mode 

!--- Enable the PIM toward the CE.
 
! 
router ospf 1 
 router-id 50.0.0.4 
 log-adjacency-changes 
 network 10.0.0.0 0.255.255.255 area 0 
 network 50.0.0.0 0.0.0.255 area 0 
! 
router rip 
 version 2 
 no auto-summary 
 ! 
 address-family ipv4 vrf yellow 
 version 2 
 redistribute bgp 1 
 network 10.0.0.0 
 network 100.0.0.0 
 default-metric 5 
 no auto-summary 
 exit-address-family 
! 
router bgp 1 
 no synchronization 
 no bgp default ipv4-unicast 
 bgp log-neighbor-changes 
 redistribute rip 
 neighbor 50.0.0.2 remote-as 1 
 neighbor 50.0.0.2 update-source Loopback0 
 neighbor 50.0.0.2 activate 
 no auto-summary 
 ! 
 address-family ipv4 vrf yellow 
 redistribute connected 
 redistribute rip 
 no auto-summary 
 no synchronization 
 exit-address-family 
 ! 
 address-family vpnv4 
 neighbor 50.0.0.2 activate 
 neighbor 50.0.0.2 send-community extended 
 no auto-summary 
 exit-address-family 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
! 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login 
! 
end

R5-(CE)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R5 
! 
! 
clock timezone CET 1 
ip subnet-zero 
no ip domain lookup 
! 
ip multicast-routing  

!--- Enable global multicast routing in the CE.
 
! 
! 
interface Loopback0 
 ip address 100.0.0.5 255.255.255.255 
! 
interface Serial0/0 
 ip address 10.4.0.5 255.255.255.0 
 ip pim sparse-dense-mode 
 ip igmp join-group 224.2.2.2 
! 
router rip 
 version 2 
 network 10.0.0.0 
 network 100.0.0.0 
 no auto-summary 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
! 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login 
!          
end

Советы по разработке

  • Групповая адресация для MPLS VPN (MVPN) настроена поверх конфигурации VPN. Сеть MPLS VPN должна быть тщательно разработана, для наблюдения всех рекомендаций для сетей MPLS VPN сначала.

  • Ядро поставщика услуг следует настроить для собственной многоадресной службы. Ядро необходимо настроить на разреженный режим PIM, многоадресную PIM, определяемую источником, или двустороннюю PIM. Разреженный режим PIM (PIM-DM) не поддерживается как протокол ядра в конфигурациях MVPN. Возможно настроить соединение поддерживаемых протоколов в ядре поставщика. Это может быть сделано, когда некоторые группы многоадресной рассылки обрабатываются одним режимом PIM, и некоторые другие группы обрабатываются другим поддерживаемым режимом PIM.

  • Все протоколы групповой адресации поддерживаются в VRF групповой адресации. То есть внутри многоадресной рассылки VRF можно использовать MSDP и PIM-DM в дополнение к PIM-SM, PIM-SSM и PIM-BIDIR

  • Служба MVPN может быть добавлена отдельно для каждого экземпляра VRF. То есть для одного маршрутизатора PE могут конфигурироваться как VRF, поддерживающие многоадресную рассылку, так и VRF, поддерживающие только одноадресную рассылку.

  • Не все сайты одиночного VRF индивидуальной рассылки должны быть настроены для групповой адресации. Возможно иметь некоторые сайты (и даже интерфейсы Периферийного маршрутизатора MVPN), где переданный в многоадресном режиме не включен. Необходимо гарантировать, что маршруты никогда не вычисляются для обращения для непередавания включенных интерфейсов в многоадресном режиме. Иначе многоадресная пересылка будет остановлена.

  • Несколько VRF могут принадлежать тому же многоадресному домену MVPN. IP-адресация должна быть уникальной в домене групповой адресации. Утечка маршрутов и/или пакетов между доменами групповой адресации или в глобальную таблицу многоадресной маршрутизации в настоящее время не возможна.

  • Конфигурация MDT default является обязательной для MVPN для работы. Данные Настройки MDT являются дополнительными. Если вы принимаете решение настроить тот, это настоятельно рекомендовано для установки порогового значения для данных MDT.

  • IP-адрес MDT по умолчанию определяет, к какому многоадресному домену принадлежит VRF. Таким образом, существует возможность установить один адрес MDT по умолчанию для нескольких VRF. Однако они совместно используют пакеты групповой адресации между ними и должны наблюдать другие требования относительно доменов групповой адресации (таких как уникальная схема IP-адресации).

  • Данные MDT мог бы или не мог бы быть настроен с тем же диапазоном IP-адресов на других Периферийных маршрутизаторах. Это зависит от того, какой режим PIM используется в центральном узле провайдера. Если ядро поставщика услуг использует Разреженный режим PIM многоадресной рассылки, независимой от протокола, то каждый Периферийный маршрутизатор должен использовать уникальный диапазон IP-адресов для Данных группы MDT. Если ядро поставщика услуг использует Source-Specific Multicast, то все Периферийные маршрутизаторы могли бы быть настроены с тем же диапазоном IP-адресов для Данных MDT каждого домена групповой адресации.

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show ip igmp groups группы многоадресной рассылки с приемниками, которые напрямую подключаются к маршрутизатору и которые были изучены через Протокол IGMP.

  • show ip pim mdt bgp детализировали рекламу Протокола BGP Признака маршрута (RD) для группы MDT default.

  • show ip pim vrf <vrf-name>, который mdt передает — Отображает объявления данных MDT, которые маршрутизатор сделал в указанном VRF.

  • show ip pim vrf <vrf-name>, который mdt получает — Отображает объявления данных MDT, полученные маршрутизатором в указанном VRF.

  • show ip mroute - вывод содержимого таблицы многоадресной IP-маршрутизации ядра сети провайдера.

  • vrf show ip mroute <vrf-name> — Отображает таблицу многоадресной маршрутизации в VRF клиента.

Выполните эти шаги, чтобы проверить, что конфигурация работает должным образом.

  1. Проверьте, что PE присоединились к Группе IGMP для туннеля MDT по умолчанию.

    Если это настроено после того, как команда default-mdt выполнена под конфигурацией VRF, PE мог бы быть не в состоянии присоединяться к группе MDT по умолчанию. После настройки петли удалите команду mdt из VRF, а потом верните ее назад, чтобы устранить проблему.

    • Для PE-R2, проблема команда show ip igmp groups.

      IGMP Connected Group Membership
      Group Address  Interface   Uptime     Expires   Last Reporter
      224.0.1.40     Serial2/0   02:21:23   stopped   10.2.0.2
      239.1.1.1      Loopback0   02:36:59   stopped   0.0.0.0
    • Для PE-R4, проблема команда show ip igmp groups.

      IGMP Connected Group Membership 
      Group Address  Interface    Uptime    Expires   Last Reporter
      224.0.1.40     Loopback0    02:51:48  00:02:39  50.0.0.4
      239.1.1.2      Loopback0    02:51:45  stopped   0.0.0.0
      239.1.1.1      Loopback0    02:51:45  stopped   0.0.0.0
      239.2.2.0      Loopback0    01:40:03  stopped   0.0.0.0 
  2. Проверьте объявление BGP, полученное для каждого PE.

    Примечание: Для данного примера проверьте MDTs, полученный от однорангового PE-R2 PE и PE-R4.

    • Для PE-R2, проблема команда show ip pim mdt bgp.

      MDT-default group 239.1.1.1 
      rid: 50.0.0.4 next_hop: 50.0.0.4 
       
      WAVL tree nodes
      
      MDT-default: 239.1.1.1  Tunnel0     source-interface: Loopback0
    • Поскольку PE-R4 выполняет команду show ip pim mdt bgp

      MDT-default group 239.1.1.1 
      rid: 50.0.0.2 next_hop: 50.0.0.2 
       
      WAVL tree nodes
      
      MDT-default: 239.1.1.1  Tunnel0     source-interface: Loopback0 
      MDT-data   : 239.2.2.0  Tunnel0     source-interface: Loopback0 
  3. Проверьте данные MDTs.

    Примечание: Для данного примера проверьте полученные данные MDT или присоединенный PE-R2 и PE-R4.

    • Для PE-R2, проблема команда show ip pim vrf yellow mdt send.

      MDT-data send list for VRF: yellow 
        (source, group)                     MDT-data group      ref_count 
        (100.0.0.1, 224.2.2.2)              239.2.2.0           1 
    • Для PE-R2, проблема команда show ip pim vrf yellow mdt receive.

      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group
      Joined MDT-data groups for VRF: yellow 
        group: 239.2.2.0 source: 0.0.0.0 ref_count: 1 
    • Проверьте глобальную таблицу многоадресной маршрутизации для MDT по умолчанию.

      Примечание: Заметьте эту информацию:

      1. Списком исходящих интерфейсов является MVRF yellow на PE.

      2. Маршрутизатор P рассматривает группу как обычную Группу многоадресной рассылки.

      3. Каждый PE является источником для MDT по умолчанию и находится только в Периферийных маршрутизаторах.

      4. Новый флаг, Z, указывает, что это - туннель групповой адресации.

    • Для PE-R2, проблема команда show ip mroute 239.1.1.1.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:37:16/stopped, RP 50.0.0.3, flags: SJCFZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:21:26/00:00:28 
      
      (50.0.0.2, 239.1.1.1), 02:37:12/00:03:29, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:36:09/00:02:33 
      (
      50.0.0.4, 239.1.1.1), 02:36:02/00:02:59, flags: JTZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:21:26/00:00:28
    • Для P-R3, проблема команда show ip mroute 239.1.1.1.

       
      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:50:24/stopped, RP 50.0.0.3, flags: S 
        Incoming interface: Null, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:34:41/00:03:16 
          Serial2/0, Forward/Sparse-Dense, 02:49:24/00:02:37 
      
      (50.0.0.2, 239.1.1.1), 02:49:56/00:03:23, flags: T 
        Incoming interface: Serial1/0, RPF nbr 10.2.0.2 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:49:24/00:02:37 
      
      (50.0.0.4, 239.1.1.1), 02:49:47/00:03:23, flags: T 
        Incoming interface: Serial2/0, RPF nbr 10.3.0.4 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:34:41/00:03:16 
    • Для PE-R4, проблема команда show ip mroute 239.1.1.1.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:51:06/stopped, RP 50.0.0.3, flags: SJCFZ 
        Incoming interface: Serial1/0, RPF nbr 10.3.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:51:06/00:00:48 
      
      (50.0.0.2, 239.1.1.1), 02:50:06/00:02:58, flags: JTZ 
        Incoming interface: Serial1/0, RPF nbr 10.3.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:50:06/00:00:48 
      
      (50.0.0.4, 239.1.1.1), 02:51:00/00:03:10, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:35:24/00:03:00 
  4. Проверьте глобальную таблицу многоадресной маршрутизации для данных MDTs.

    Примечание: Для PE-R2 заметьте, что исходящий интерфейс является tunnel0.

    • Для PE-R2, где источник расположен (сторона VRF), выполняют vrf show ip mroute желтые 224.2.2.2 команды.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 224.2.2.2), 2d01h/stopped, RP 100.0.0.2, flags: S 
        Incoming interface: Null, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Tunnel0, Forward/Sparse-Dense, 2d01h/00:02:34 
      
      (100.0.0.1, 224.2.2.2), 00:05:32/00:03:26, flags: Ty 
        Incoming interface: Serial1/0, RPF nbr 10.1.0.1 
        Outgoing interface list: 
          Tunnel0, Forward/Sparse-Dense, 00:05:37/00:02:34
    • Для PE-R2, где источник расположен (глобальный многоадресный маршрут), выполняют show ip mroute 239.2.2.0 команды.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.2.2.0), 02:13:27/stopped, RP 50.0.0.3, flags: SJPFZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: Null 
      
      (50.0.0.2, 239.2.2.0), 02:13:27/00:03:22, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:13:27/00:03:26

    Примечание: Только маршрутизатор PE с подключенным к нему многоадресным источником отображается в качестве источника для многоадресного трафика группового адреса данных MDT.

Устранение неполадок

  • Выполните команду show ip pim vrf neighbor, чтобы проверить, что Периферийные маршрутизаторы установили отношение соседа PIM через интерфейс динамического туннеля. Если они сделали, то По умолчанию MDT работает должным образом.

  • Если По умолчанию, MDT не функционирует, выполняют команду show ip pim mdt bgp, чтобы проверить, что loopback удаленных маршрутизаторов PE, участвующих в MVPN, известны локальным маршрутизатором. Если они не, проверяют, что PIM включен на интерфейсах обратной связи, используемых в качестве источника сеансов BGP MP

  • Проверьте, что ядро SP должным образом настроено для отправки групповой адресации между Периферийными маршрутизаторами. Для целей тестирования вы могли бы настроить ip igmp join-group на интерфейсе обратной связи одного Периферийного маршрутизатора и действительно передаете в многоадресном режиме эхо-запрос, полученный от loopback другого Периферийного маршрутизатора.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 29220