Широкополосные кабельные сети : Системы терминирования кабельных модемов (CMTS)

Настройка сервисов DHCP, ToD, TFTP на Cisco CMTS: Функционально законченная конфигурация

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ показывает конфигурацию Ciscos оконечная система для кабельного модема (CMTS), которая работает как протокол динамической конфигурации хоста (DHCP), ToD, и сервер TFTP. Также объясняется построение файла конфигурации DOCSIC с помощью интерфейса командной строки на CMTS. Эта конфигурация известна под именем "конфигурация все-в-одном для CMTS Cisco."."

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Предварительные условия

Читатель должен быть знаком с основами протокола DOCSIS и командной строки Cisco IOS на маршрутизаторах семейства uBR.

Используемые компоненты

Инструкции по использованию оборудования в данном документе относятся к кабельным модемам Cisco uBR7200, uBR7100 или uBR10k CMTS- и DOCSIS-совместимым кабельным модемам.

Описание

Кабельный модем, совместимый с DOCSIS, требует доступа к трем типам серверов для успешного подключения к сети.

  • Первый из них - это DHCP-сервер, который предоставляет кабельному модему IP-адрес, маску подсети и другие параметры, связанные с IP.

  • Второй - сервер текущего времени (ToD), совместимый с RFC868, с помощью которого модем определяет текущее время. Кабельному модему нужно знать время для того, чтобы правильно и аккуратно добавлять метки времени в журнал событий.

  • Третьим является сервер упрощенного протокола передачи файлов (TFTP), от которого кабельный модем в состоянии загрузить файл конфигурации DOCSIS, содержащий кабельный модем определенные рабочие параметры.

Большинство операторов кабельной связи используют Cisco Network Registrar (CNR) в качестве серверов DHCP, DNS и TFTP. Сервер ToD не является частью CNR. Сервер ToD, который используется, зависит от платформы в их системе. ToD должен быть совместимым RFC868. В системах UNIX он включен в Solaris, необходимо лишь убедиться, что файл inetd.conf каталога /etc содержит следующие строки:

# Time service is used for clock synchronization.
#
time��� stream� tcp���� nowait� root��� internal
time��� dgram�� udp���� wait��� root��� internal

Для Windows наиболее распространенным программным обеспечением, которое используется, является Greyware leavingcisco.com.

Следующая таблица показывает Cisco Версии релиза ПО IOS�, в которых другие возможности сервера были добавлены к CMTS.

Возможности сервера Cisco IOS Software Release
DHCP 12.0 (1) T
ToD 12.0 (4) XI�
TFTP 11.0 (для всех платформ)

Данный документ содержит сведения о каждом из этих средств. Конфигурация на CMTS, который содержит все эти возможности, - то, что мы вызываем "конфигурацией все в одном для cmts". В такой конфигурации можно обойтись без дополнительных серверов при тестировании кабельной системы с целью обеспечения высокоскоростного доступа в Интернет.

Также возможно настроить файл конфигурации DOCSIS таким образом, чтобы он постоянно находился на CMTS вместо сервера TFTP. Согласно комментариям к релизу, для использования этой возможности необходимо Cisco IOS Software Release 12.1(2)EC1.

Несмотря на то, что эта "конфигурация все в одном" очень удобна для лабораторной среды, начального тестирования, небольших развертываний и устранения проблем, это не является масштабируемым для поддержки очень большого числа кабельных модемов. Таким образом, НЕ рекомендуется использовать эту конфигурацию на в рабочем состоянии кабельных участках с большими развертываниями кабельных модемов.

Инженеры TAC очень часто используют эту конфигурацию для получения возможности удаления переменных во время устранения проблем с кабелями.

DHCP-сервис Cisco IOS на CMTS

Маршрутизаторы Cisco, работающие под управлением Cisco IOS Software Release of 12.0(1)T или выше, могут действовать в качестве серверов DHCP. Этот сервис DHCP может быть настроен для обеспечения аренды DHCP кабельным модемам и Оборудованию в помещении заказчика (CPE), таким как PC и рабочие станции.

Существует минимальный набор параметров DHCP, которые обычно необходимы кабельному модему для перехода в активный режим. Это команды:

  • IP-адрес (поле "yiaddr" в заголовке пакета DHCP)

  • Маска подсети (параметр DHCP 1)

  • Смещение местного времени относительно Гринвича (GMT) в секундах (DHCP Option 2)

  • Маршрутизатор по умолчанию (Параметр DHCP 3)

  • IP-адрес сервера ToD (DHCP, вариант 4)

  • Сервер журналов (DHCP, вариант 7)

  • IP-адрес сервера TFTP (поле siaddr в заголовке пакета DHCP)

  • Имя файла конфигурации DOCSIS (поле файла в заголовке пакета DHCP)

  • Время аренды DHCP в секундах (DHCP-параметр 51)

Это можно настроить в маршрутизаторе так:

!
ip dhcp pool cm-platinum
�� network 10.1.4.0 255.255.255.0
�� bootfile platinum.cm
�� next-server 10.1.4.1�
�� default-router 10.1.4.1�
�� option 7 ip 10.1.4.1�
�� option 4 ip 10.1.4.1�
�� option 2 hex ffff.8f80
�� lease 7 0 10
!

Пояснение каждой команды следующие:

  • С помощью команды dhcp pool определяется имя оконечного устройства (cm-platinum, т.е. "платиновое обслуживание" для кабельных модемов).

  • Со стороны сети предоставляются IP-адрес и маска подсети (параметр 1 DHCP).

  • Команда bootfile даст имя загрузочного файла, в данном случае – platinum.cm.

  • Команда next-server указывает IP-адрес TFTP-сервера (в данном случае, это основной IP-адрес в интерфейсе с4/40).

  • Default-router является шлюзом по умолчанию, который в этом случае является первичным IP - адресом интерфейса c4/0 (option3).

  • Опция 7 является Регистрационной опцией dhcp сервера.

  • Опция 4 – IP-адрес сервера ToD (основной IP-адрес интерфейса с4/0).

  • Параметр 2 - параметр смещения времени для GMT - 8 ч (-8 ч = -28800 с = ffff.8f80 в шестнадцатеричной системе счисления).

  • Время аренды составляет 7 дней 0 часов 10 минут.

Примечание: Для получения дополнительных сведений о том, как преобразовать десятичное значение времени сдвига в шестнадцатеричное см. "Практические указания по расчету шестнадцатеричного значения для DHCP варианта 2 (временной сдвиг)".

Для устройств CPE придерживающиеся опции являются минимумом, чтобы быть в состоянии действовать успешно.

  • IP-адрес (поле "yiaddr" в заголовке пакета DHCP)

  • Маска подсети (параметр DHCP 1)

  • Маршрутизатор по умолчанию (Параметр DHCP 3)

  • IP-адрес одного или нескольких серверов доменных имен (DHCP Option 6)

  • Имя домена (DHCP, параметр 15)

  • Время аренды DHCP в секундах (DHCP-параметр 51)

!
ip dhcp pool pcs-c4�

! -- the scope for the hosts

    network 172.16.29.0 255.255.255.224

! -- the ip address and mask for the hosts

��� next-server 172.16.29.1

! -- tftp server, in this case we put the secondary add.

��� default-router 172.16.29.1
��� dns-server 172.16.30.2

! -- dns server (which is not configured on the cmts)

��� domain-name cisco.com
��� lease 7 0 10
!

При настройке пулов DHCP важно включать giaddr policy dhcp управляющего кабеля в конфигурацию кабельного сопряжения. С помощью этой команды DHCP сервер назначает кабельным модемам аренду, соответствующую номеру основной сети на кабельном интерфейсе, а CPE – аренду, соответствующую номеру вторичной сети на кабельном интерфейсе. Если эта команда будет отсутствовать тогда, то вся аренда DHCP прибудет из пула, соответствующего номеру основной сети на кабельном сопряжении. Кроме того, как показано в приведенной ниже частичной конфигурации интерфейса, диапазон cm-platinum связан с основным адресом, определенным на кабеле интерфейса 4/0, а диапазон pcs-c4 находится в сети вспомогательного адреса.

!
interface Cable4/0
�� ip address 172.16.29.1 255.255.255.224 secondary

! -- CPE network

�� ip address 10.1.4.1 255.255.255.0

! -- Cable Modem Network

�� cable dhcp-giaddr policy
!

Имейте в виду, что для кабельного интерфейса не существует команды cable helper-address или ip helper-address. Это происходит, потому что запросы DHCP не требуют отправки к внешнему серверу, когда используется внутренний IOS DHCP сервер. Если добавить эту команду под интерфейсом при наличии настроенного внешнего сервера DHCP, кабельные модемы зарегистрируются с конфигурацией внешнего DHCP.

Дополнительные возможности сервера DHCP

Другие функции, которые могут быть использованы с помощью Cisco IOS DHCP-сервера включают в себя:

  • ip dhcp ping: Эхо-запрос перед функцией арендного договора, которая гарантирует, что DHCP server не выполняет арендные договоры для IP-адресов, которые уже находятся в использовании.

  • ip dhcp database: Хранение DHCP связывания во внешних базах данных для сохранения отношения MAC адреса и IP-адреса через цикл питания CMTS.

  • dhcp show ip: Набор команд, которые можно использовать для контроля функционирования сервера DHCP.

  • команда debug ip dhcp server: Набор команд, которые можно использовать для устранения неполадок DHCP-сервера.

Все эти дополнительные функции и функции описаны в Комментариях к выпуску характеристики сервера DHCP Cisco IOS, расположенных в документе сервера DHCP Cisco IOS.

Сервис ToD Cisco IOS

После получения кабельным модемом DHCP, он продолжает свои попытки связаться с сервером ToD. Программы Cisco CMTS, использующие Cisco IOS Software Release 12.0(4)XI или выше, могут обеспечить услуги RFC 868 ToD.

Согласно всеобщему заблуждению, служба ToD, необходимая кабельным модемам для перехода в оперативный режим, - это то же, что служба NTP (синхронизирующий сетевой протокол), обычно настраиваемая в маршрутизаторах Cisco. Сервис NTP и сервис ToD несовместимы. Кабельные модемы не могут общаться с NTP-сервером. В то время как кабельные модемы должны попытаться связаться с Сервером текущего времени как с частью процесса прибытия онлайн, совместимые модемы с последними пересмотрами спецификаций RFI DOCSIS 1.0 все еще продолжат прибывать онлайн, даже если не может быть достигнут сервер ToD.

В соответствии с последней версией данной спецификации, если кабельный модем не может подключиться к серверу ToD, он может продолжать процесс выхода в сеть. Тем не менее, ему следует периодически обращаться к серверу ToD, пока соединение не будет установлено. Согласно старым версиям спецификаций DOCSIS 1.0 RFI если кабельный модем не мог соединиться с сервером ToD, то он не мог установить подключение. Важно сознавать, что кабельные модемы с более старой микропрограммой, могут соответствовать этой более старой версии спецификации.

Примечание: Кабельные модемы некоторого поставщика не взаимодействуют с сервисом Cisco IOS Time of Day \(Истинное время Cisco IOS \). Если эти модемы совместимы с последними версиями спецификации радиопомех DOCSIS 1.0, они не должны прерывать соединение. Данную проблему совместимости отражает идентификатор ошибки Cisco CSCdt24107.

Примечание: Настройка ToD на CMTS Cisco требует только двух глобальных команд:

service udp-small-servers max-servers no-limit
!
cable time-server
!

TFTP-сервис Cisco IOS

После того как кабельный модем попытался установить связь с сервером ToD, он продолжает связываться с сервером TFTP для загрузки файла конфигурации DOCSIS. Если двоичный конфигурационный файл DOCSIS можно скопировать на флэш-устройство в Cisco CMTS, то маршрутизатор можно использовать как сервер TFTP для этого файла.

Загрузка файла конфигурации DOCSIS во флэш-память производится следующим образом:

Во-первых, удостоверьтесь, что CMTS может достигнуть сервера, где живет файл конфигурации DOCSIS:

7246VXR#ping 172.16.30.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.2, timeout is 2 seconds:
!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Далее, скопируйте файл, в этом случае он называется silver.cm, на flash память CMTS.

7246VXR#copy tftp flash
Address or name of remote host []? 172.16.30.2
Source filename []? silver.cm
Destination filename [silver.cm]?�

Accessing tftp://172.16.30.2/silver.cm...
Loading silver.cm from 172.16.30.2 (via Ethernet2/0): !
[OK - 76/4096 bytes]

76 bytes copied in 0.152 secs

В конечном итоге никогда не помешает проверить Flash-память и убедиться, что размер файла подходящий. Для этого выполните команду "show flash".

7246VXR#show flash
-#- ED --type-- --crc--- -seek-- nlen -length- -----date/time------ name
1�� .. unknown� 2D6C7818�� 200CC��� 9������ 74 Feb 28 2001 7:39:09 silver.cm
2�� .. unknown� 1CB785DC�� 20258��� 7������ 62 Feb 20 2001 15:44:11 test.cm
3�� .. image��� 4350A04F� 7A0CC8�� 24� 7866864 Feb 27 2001 09:36:40 ubr7200-ik1s-mz.121-4.EC
4�� .. unknown� 36E5D6D3� 7A0D94��� 7������ 76 Feb 28 2001 07:23:12 gold.cm

8516204 bytes available (7867796 bytes used)

Для включения Сервиса TFTP на CMTS там, мы только должны включать следующую команду в режим глобальной конфигурации.

tftp-server slot0:silver.cm alias silver.cm

Как только эта команда введена, после конфигурации будет показано следующее:

!
tftp-server slot0:silver.cm alias silver.cm
tftp-server server��
!

Дополнительные сведения о настройке сервера TFTP на маршрутизаторе см. в документе "Дополнительные команды передачи файлов".

Встроенная программа создания файла конфигурации DOCSIS

Продукты Cisco CMTS с ПО Cisco IOS выпуск 12.1(2)EC или выше (в серии выпуска EC), могут быть конфигурированы для создания или хранения во внутренней памяти конфигурационные файлы DOCSIS. Это удобно, так как нет необходимости обращаться к внешнему средству генерирования файла конфигурации DOCSIS. Когда файл конфигурации DOCSIS создается с использованием внешнего средства конфигурации, файл автоматически становится доступным через TFTP. Кроме того, только кабельные модемы, непосредственно подключенные через кабельные интерфейсы, могут загружать эти конфигурационные файлы.

Следующий пример конфигурации отображает создание двух конфигурационных файлов DOCSIS .

Первый называется disable.cm и позволяет кабельному модему подключиться к сети, но не дает подключенным устройствам CPE получить доступ к сети поставщика услуг. В этом случае мы видим команду access-denied. Обратите внимание на то, что скорость нисходящего и восходящего потока в данном случае составляет 1 Кбит/с, а максимальный размер пакета – 1600 байт.

cable config-file disable.cm
�access-denied
�service-class 1 max-upstream 1
�service-class 1 max-downstream 1600
�timestamp
!

Причина, по которой у оператора кабельной связи будет этот файл конфигурации DOCSIS "disable.cm" заключается в том, что он хочет запретить доступ к CPE за кабельными модемами, позволяя при этом кабельному модему подключаться к сети. Это более рациональный способ запретить службу CPE, чем использование параметра “exclude” в CNR, который не разрешит кабельному модему подключиться к сети и, таким образом, модем будет пытаться подключиться снова и снова, что приведет к расходованию пропускной способности впустую.

Получение этого файла конфигурации DOCSIS для кабельных модемов будет выглядеть также, как и в результате команды show cable modem:

Cable4/0/U0 10�� online(d)� 2287��� 0.50� 6�� 0�� 10.1.4.65������ 0010.7bed.9b45

(|| добавляют ссылку, когда доступный) ниже дает больше подробных данных об этом outupt. Статус "online(d)" означает, что кабельные модемы подключены, но доступ запрещен.

Во втором примере создается имя файла конфигурации DOCSIS platinum.cm. В этом случае максимальная скорость передачи в направлении оператора составляет 1 Мбит/с, гарантированная скорость передачи в направлении оператора - 100 Кбит/с, а максимальная скорость передачи в направлении абонента - 10 Мбит/с, что позволяет подключить до 30 CPE-устройств.

cable config-file platinum.cm
�service-class 1 max-upstream 1000
�service-class 1 guaranteed-upstream 100
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 30
�timestamp
!

Следует отметить, что при настройке файла конфигурации DOCSIS в CMTS не требуется оператор "tftp server slot0:platinum.cm alias platinum.cm", так как в памяти нет файла ".cm" - он содержится в конфигурации. Более подробную информацию об инструменте файла конфигурации Internal DOCSIS можно найти в документе Cable Modem Termination System Commands.

Пример диаграммы

Типичная топология установки лаборатории показана на данном рисунке.

/image/gif/paws/28990/all_in_one_config1.gif

Конфигурации

Эта конфигурация поддерживается на всех платформах CMTS Cisco. Это включает uBR7200, uBR7246 VXR, uBR7100, и uBR10000.

Cisco IOS Software Release, который поддерживает все в одной конфигурации, включая конфигурацию файла конфигурации DOCSIS, является программным обеспечением Cisco IOS версии 12.1(2)EC и последующими версиями Серии EC.

Следующие настройки были произведены в uBR7246 VXR при помощи Cisco IOS Software Release 12.1(4)EC с NPE300. Сначала будет продемонстрирована базовая конфигурация, затем более сложная.

Базовая конфигурация "все в одном"

Представленная ниже конфигурация включает все элементы, описанные в документе. В ней имеются две области DHCP: одну для кабельных модемов и другую для узлов за кабельными модемами.

Один файл конфигурации DOCSIS был создан названный platinum.cm. Этот файл применяется к пулу DHCP, называемому cm-platinum. Другой файл конфигурации DOCSIS с именем disabled.cm в данный момент не применяется.

В этом примере настроено два пула DHCP — один для кабельных модемов, а другой для ПК после кабельных модемов.

Примечание: Функционально законченные команды настройки выделены жирным шрифтом.

Простая "конфигурация все в одном" 7246VXR
7246VXR#show run

version 12.1
no service pad
service timestamps debug datetime msec localtime

! -- provides nice timestamps on all log messages

service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit

! -- supports a large number of modems / hosts attaching quickly

!
hostname 7246VXR
!
logging buffered 1000000 debugging
enable password cable
!
cable qos profile 8
cable qos profile 10
cable qos profile 10 grant-size 1500
cable qos profile 12 guaranteed-upstream 100000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server

! --� permits cable modems to obtain Time of Day (ToD) from uBR7246VXR

!
cable config-file disable.cm
�access-denied
�service-class 1 max-upstream 1
�service-class 1 max-downstream 1600
�cpe max 1
�timestamp
!
cable config-file platinum.cm
�service-class 1 max-upstream 128
�service-class 1 guaranteed-upstream 10
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 10
�timestamp
!
clock timezone PDT -8
clock summer-time PDT recurring
clock calendar-valid
ip subnet-zero
ip cef

! -- Turn on cef switching / routing, anything but process� switching (no ip route-cache)

ip cef accounting per-prefix�
no ip finger
ip tcp synwait-time 5
no ip domain-lookup

! -- Prevents cmts from looking up domain names / attempting�
! -- to connect to machines when mistyping commands

ip host vxr 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
no ip dhcp relay information check
!
!
!��
ip dhcp pool cm-platinum

! -- name of the dhcp pool. This scope is for the cable modems attached�
! -- to interface cable 4/0

�� network 10.1.4.0 255.255.255.0

! -- pool of addresses for scope modems-c4/0

�� bootfile platinum.cm

! -- DOCSIS config file name associated with this pool

�� next-server 10.1.4.1

! -- IP address of TFTP server which sends bootfile

�� default-router 10.1.4.1

! -- default gateway for cable modems, necessary to get DOCSIS files

�� option 7 ip 10.1.4.1

! -- Log Server DHCP option

�� option 4 ip 10.1.4.1

! -- ToD server IP address

�� option 2 hex ffff.8f80

! -- Time offset for ToD, in seconds, HEX, from GMT, -28,000 = PST = ffff.8f80

�� lease 7 0 10

! -- lease 7 days 0 hours 10 minutes

!�
ip dhcp pool pcs-c4

! -- name of the dhcp pool. This scope is for the CPEs� attached�
! -- the cable modems that are connected to interface cable 4/0

�� network 172.16.29.0 255.255.255.224

! -- pool of addresses for scope pcs-c4 (associated with the secondary address)

�� next-server 172.16.29.1�
�� default-router 172.16.29.1
�� dns-server 172.16.30.2�
�� domain-name cisco.com�
�� lease 7 0 10������
!
!
interface Ethernet2/0
�ip address 172.16.30.4 255.255.255.192
�no ip mroute-cache
�half-duplex
!
interface Cable4/0
�ip address 172.16.29.1 255.255.255.224 secondary

! -- used for the scope pcs-c4 so that PC's get an ip address on this network

�ip address 10.1.4.1 255.255.255.0

! -- used for the scope modems-c4/0 so that cable modems get an ip address from this network

�no ip route-cache cef
�no keepalive
�cable downstream rate-limit token-bucket shaping
�cable downstream annex B
�cable downstream modulation 64qam
�cable downstream interleave-depth 32
�cable downstream frequency 555000000
�cable upstream 0 frequency 40000000
�cable upstream 0 power-level 0
�no cable upstream 0 shutdown
�cable upstream 1 shutdown
�cable upstream 2 shutdown
�cable upstream 3 shutdown
�cable upstream 4 shutdown
�cable upstream 5 shutdown
�cable dhcp-giaddr policy

! -- Used to� modify the GIADDR field of DHCPDISCOVER and DHCPREQUEST packets with a
! -- Relay IP address before they are forwarded to the DHCP server

!���������
!���������
router eigrp 202
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
�no eigrp log-neighbor-changes
!���������
router rip
�version 2
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
!���������
ip default-gateway 172.16.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
ip route 172.16.30.0 255.255.255.0 Ethernet2/0
ip http server
ip http authentication local
!���������
snmp-server engineID local 00000009020000E01ED77E40
snmp-server community public RO
snmp-server community private RW
tftp-server server

! -- enable the cmts to act as a tftp server

tftp-server slot0:silver.cm alias silver.cm

! -- get the DOCSIS config file called silver.cm that is pre-downloaded to flash.
! -- this DOCSIS config file is built using DOCSIS CPE Configurator.��

!���������
line con 0
�exec-timeout 0 0
�transport input none
line aux 0
�speed 19200
line vty 0 4
�session-timeout 60�
�login
!
ntp clock-period 17179977
ntp server 172.16.135.51
end

Советы по проверке для базовой конфигурации

Сначала следует убедиться, что команды поддерживаются Cisco IOS Software Release. Для этого можно сделать демонстрационную версию.

7246VXR#show version
Cisco Internetwork Operating System Software�
IOS (tm) 7200 Software (UBR7200-IK1S-M), Version 12.1(4)EC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Fri 08-Dec-00 17:35 by ninahung
Image text-base: 0x60008950, data-base: 0x612AA000

ROM: System Bootstrap, Version 12.0(19990210:195103) [12.0XE 105], DEVELOPMENT SOFTWARE
BOOTFLASH: 7200 Software (UBR7200-BOOT-M), Version 12.0(7)T,� RELEASE SOFTWARE (fc2)

7246VXR uptime is 9 minutes
System returned to ROM by reload at 09:47:00 PDT Tue Feb 27 2001
System restarted at 09:48:26 PDT Tue Feb 27 2001
System image file is "slot0:ubr7200-ik1s-mz.121-4.EC"

cisco uBR7246VXR (NPE300) processor (revision C) with 253952K/40960K bytes of memory.
Processor board ID SAB03500058
R7000 CPU at 262Mhz, Implementation 39, Rev 1.0, 256KB L2, 2048KB L3 Cache
6 slot VXR midplane, Version 2.0

Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
4 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
5 Cable Modem network interface(s)
125K bytes of non-volatile configuration memory.

16384K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
4096K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

Мы должны проверить, что файл конфигурации DOCSIS находится во флэш-памяти.

7246VXR#show flash
-#- ED --type-- --crc--- -seek-- nlen -length- -----date/time------ name
1�� .. unknown� 2D6C7818�� 200CC��� 9������ 74 Feb 28 2001 7:39:09 silver.cm
2�� .. unknown� 1CB785DC�� 20258��� 7������ 62 Feb 20 2001 15:44:11 test.cm
3�� .. image��� 4350A04F� 7A0CC8�� 24� 7866864 Feb 27 2001 09:36:40 ubr7200-ik1s-mz.121-4.EC
4�� .. unknown� 36E5D6D3� 7A0D94��� 7������ 76 Feb 28 2001 07:23:12 gold.cm

8516204 bytes available (7867796 bytes used)

Обратите внимание, что файл silver.cm создан с помощью средства конфигурации DOCSIS CPE. Для файла platunum.cm, созданного в конфигурации CMTS, нет необходимости в выполнении инструкции "tftp server slot0:platinum.cm alias platinum.cm", поскольку нет файла с расширением "Cm", он существует в рамках конфигурации.

Следующий шаг должен проверить, что кабельные модемы являются онлайновыми. Этого можно достичь при помощи команды show cable modem.

7246VXR#show cable modem
Interface�� Prim Online���� Timing Rec��� QoS CPE IP address����� MAC address
����������� Sid� State����� Offset Power
Cable4/0/U0 75�� online���� 2290��� 0.00� 5�� 1�� 10.1.4.2������� 0010.7bed.9b23
Cable4/0/U0 76�� online���� 2809��� 0.00� 5�� 0�� 10.1.4.3������� 0002.fdfa.0a63
Cable4/0/U0 77�� online���� 2288��� 0.25� 5�� 1�� 10.1.4.5������� 0010.7bed.9b45
Cable4/0/U0 78�� online���� 2810��� 0.50� 5�� 0�� 10.1.4.4������� 0004.2752.ddd5
Cable4/0/U0 79�� online���� 2813��� 0.25� 5�� 0�� 10.1.4.6������� 0002.1685.b5db
Cable4/0/U0 80�� online���� 2812�� -0.50� 5�� 0�� 10.1.4.7������� 0001.64ff.e47d


Обратите внимание, что все кабельные модемы подключены. Подключенные к интерфейсному кабелю 4/0/U0 находятся в сети 10.1.4.0. Из конфигурации ясно, что их IP-адреса взяты из пула DNCP, который называется "cm-platinum".

Обратите также внимание на то, что за модемами с MAC-адресами 0010.7bed.9b23 и 0010.7bed.9b45 находится CPE. Эти кабельные модемы подключаются к сети со стандартной конфигурацией мостовой передачи. Данные PC настроены на использование DHCP, чтобы получать IP-адрес из сети.

7246VXR#show interface cable 4/0 modem 0
SID�� Priv bits� Type����� State���� IP address��� method��� MAC address
75��� 00�������� host����� unknown�� 172.16.29.2�� static��� 00c0.4f97.61c5
75��� 00�������� modem���� up������� 10.1.4.2����� dhcp����� 0010.7bed.9b23
76��� 00�������� modem���� up������� 10.1.4.3����� dhcp����� 0002.fdfa.0a63
77��� 00�������� host����� unknown�� 172.16.29.3�� dhcp����� 00a0.243c.eff5
77��� 00�������� modem���� up������� 10.1.4.5����� dhcp����� 0010.7bed.9b45
78��� 00�������� modem���� up������� 10.1.4.4����� dhcp����� 0004.2752.ddd5
79��� 00�������� modem���� up������� 10.1.4.6����� dhcp����� 0002.1685.b5db
80��� 00�������� modem���� up������� 10.1.4.7����� dhcp����� 0001.64ff.e47d

На следующих рисунках показано, что компьютеры получают IP-адрес из пулов с именем "pcs-c4"."

all_in_one_config2.gif

Здесь также можно увидеть, что протокол управления передачей/протокол Internet должен получать ip адрес автоматически.

all_in_one_config3.gif

Расширенная конфигурация "все в одном"

Этот раздел предоставляет более сложный пример конфигурации, который включает иерархическую функциональность пулов DHCP. Путем работы иерархии пула DHCP состоят в том, что любой пул DHCP с номером сети, который является подмножеством номера сети другого пула, наследовал все характеристики того другого пула. Это спасает повторения в конфигурации сервера DHCP. Однако, если та же спецификация будет сделана с другим параметром тогда, то параметр будет перезаписан. Этот пример покажет общий пул с загрузочным файлом platinum.cm, а у поднабора этого пула будет загрузочный файл disable.cm.

В дополнение к пулам DHCP, созданным в базовом примере, у нас есть специальные требования для двух кабельных модемов.

Кабельный модем 0010.7bed.9b45 будет запрещен доступа. Это означает, что кабельному модему предоставят IP-адрес, но он не прибудет онлайн. Для этого создается следующий пул:

ip dhcp pool cm-0010.7bed.9b45
�� host 10.1.4.65 255.255.255.0
�� client-identifier 0100.107b.ed9b.45
�� bootfile disable.cm

Наиболее основная функция этого примера конфигурации является разделом, где заданы специальные пулы DHCP, соответствующие MAC-адресам отдельного кабельного модема. Это делается для того, чтобы сервер DHCP мог посылать уникальные параметры DHCP этим модемам. Для указания конкретного кабельного модема, используется параметр "клиент-иеднтификатор". Параметр "идентификатор-клиента" нужно установить в 01, за которым следует MAC-адрес устройства, которому соответствует запись. Этот 01 соответствует типу оборудования ethernet для DHCP.

Примечание: При изменении файлов config для модема необходимо сделать придерживающийся так, чтобы кабельный модем добрался вручную настроенные параметры:

  • Очистите таблицу связей ip dhcp с помощью команды clear ip dhcp binding <ip address>."

  • Перезагрузите кабельный модем рассматриваемое использование команды clear cable modem <мак адрес> res.

Кабельный модем 0010.7bed.9b23 также имеет специальное требование. Это установит различное качество обслуживания. Поэтому различные файлы загрузки связаны с областью действия. См. частичную конфигурацию ниже:

ip dhcp pool cm-0010.7bed.9b23
�� host 10.1.4.66 255.255.255.0
�� client-identifier 0100.107b.ed9b.23
�� bootfile silver.cm

!

В процессе настройки пулов DHCP для определенных кабельных модемов рекомендуется всегда назначать соответствующее имя. Кроме того, так как определенный IP-адрес назначен на пул с помощью команды host, мы должны добавить IP dhcp исключает 10.1.4.60 10.1.4.70 команды global. Эта команда указывает протоколу DHCP, что адреса, входящие в этот диапазон, выдавать не следует.

Улучшенная "конфигурация все в одном" 7246VXR
7246VXR# show run

version 12.1
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit
!
hostname 7246VXR
!
logging buffered 1000000 debugging
!
cable qos profile 8
cable qos profile 10
cable qos profile 10 grant-size 1500
cable qos profile 12 guaranteed-upstream 100000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
cable config-file disable.cm
�access-denied
�service-class 1 max-upstream 1
�service-class 1 max-downstream 1600
�cpe max 1
�timestamp
!
cable config-file platinum.cm
�service-class 1 max-upstream 128
�service-class 1 guaranteed-upstream 10
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 10
�timestamp
!
clock timezone PDT -8
clock summer-time PDT recurring
clock calendar-valid
ip subnet-zero
no ip finger
no ip domain-lookup
ip host vxr 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
ip dhcp excluded-address 10.1.4.60 10.1.4.70
!
ip dhcp pool cm-platinum
�� network 10.1.4.0 255.255.255.0
�� bootfile platinum.cm
�� next-server 10.1.4.1�
�� default-router 10.1.4.1�
�� option 7 ip 10.1.4.1�
�� option 4 ip 10.1.4.1�
�� option 2 hex ffff.8f80
�� lease 7 0 10
!
ip dhcp pool pcs-c4
�� network 172.16.29.0 255.255.255.224
�� next-server 172.16.29.1�
�� default-router 172.16.29.1�
�� dns-server 172.16.30.2�
�� domain-name cisco.com
�� lease 7 0 10
!
ip dhcp pool cm-0010.7bed.9b45
�� host 10.1.4.65 255.255.255.0
�� client-identifier 0100.107b.ed9b.45
�� bootfile disable.cm
!
ip dhcp pool cm-0010.7bed.9b23
�� host 10.1.4.66 255.255.255.0
�� client-identifier 0100.107b.ed9b.23
�� bootfile silver.cm
!
!
interface Ethernet2/0
�ip address 172.16.30.4 255.255.255.192
�no ip mroute-cache
�half-duplex
!
interface Cable4/0
�ip address 172.16.29.1 255.255.255.224 secondary
�ip address 10.1.4.1 255.255.255.0
�no keepalive
�cable downstream rate-limit token-bucket shaping
�cable downstream annex B
�cable downstream modulation 64qam
�cable downstream interleave-depth 32
�cable downstream frequency 555000000
�cable upstream 0 frequency 40000000
�cable upstream 0 power-level 0
�no cable upstream 0 shutdown
�cable upstream 1 shutdown
�cable upstream 2 shutdown
�cable upstream 3 shutdown
�cable upstream 4 shutdown
�cable upstream 5 shutdown
�cable dhcp-giaddr policy
!
router eigrp 202
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
�no eigrp log-neighbor-changes
!
router rip
�version 2
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
!
ip default-gateway 172.16.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
ip route 172.16.30.0 255.255.255.0 Ethernet2/0
ip http server
ip http authentication local
!
access-list 188 permit tcp any any eq www log
access-list 188 permit ip any any
route-map docsis permit 10
!
snmp-server engineID local 00000009020000E01ED77E40
snmp-server community public RO
snmp-server community private RW
tftp-server slot0:silver.cm alias silver.cm
tftp-server server

line con 0
�exec-timeout 0 0
�transport input none
line aux 0
�speed 19200
line vty 0 4
�session-timeout 60�
�exec-timeout 0 0
�login
!
ntp clock-period 17179973
end

Советы по проверке для расширенной конфигурации

Проверка данной конфигурации сосредоточена на службах, которые получают кабельные модемы, в особенности 0010.7bed.9b45 и 0010.7bed.9b23. Необходимо удостовериться, что они получают адреса, настроенные вручную с помощью службы.

Первая вещь протестировать состоит в том, что 0010.7bed.9b45 прибудет онлайн, но будет запрещен сервис. Для этого мы позволяем нам смотреть на команду show cable modem:

7246VXR#show cable modem
Interface�� Prim Online���� Timing Rec��� QoS CPE IP address����� MAC address
����������� Sid� State����� Offset Power
Cable4/0/U0 7��� online���� 2813��� 0.00� 7�� 0�� 10.1.4.7������� 0002.1685.b5db
Cable4/0/U0 8��� online���� 2809��� 0.25� 7�� 0�� 10.1.4.10������ 0002.fdfa.0a63
Cable4/0/U0 9��� online���� 2288�� -0.25� 5�� 1�� 10.1.4.66������ 0010.7bed.9b23
Cable4/0/U0 10�� online(d)� 2287��� 0.50� 6�� 0�� 10.1.4.65������ 0010.7bed.9b45
Cable4/0/U0 11�� online���� 2809�� -0.50� 7�� 0�� 10.1.4.6������� 0001.64ff.e47d
Cable4/0/U0 12�� online���� 2812�� -0.50� 7�� 0�� 10.1.4.9������� 0004.2752.ddd5

Здесь следует отметить несколько моментов:

  • Кабельный модем 0010.7bed.9b23 получил IP-адрес 10.4.1.66, как задано в см-0010.7bed.9b23 области. Имеется присоединенный к нему компьютер, и он получает IP-адреса из пула pcs-c4.

  • Кабельный модем 0010.7bed.9b23 имеет другой QoS.

  • Кабельный модем 0010.7bed.9b45 получил IP-адрес 10.1.4.65, как указано в области cm-0010.7bed.9b45. Существует компьютер, подключенный к нему, однако значение CPE 0. Причина состоит в том, что запрещен сервис.

  • Оперативное состояние 0010.7bed.9b45 - это online(d), что означает, что кабельный модем пытался подключиться к сети, но доступ к кабельной сети был отклонен. См. выходные данные debug cable mac log verbose кабельного модема.

21:52:16:� 78736.550 CMAC_LOG_RESET_RANGING_ABORTED��������������
21:52:16:� 78736.554 CMAC_LOG_STATE_CHANGE���������������������� reset_interface_state
21:52:16:� 78736.558 CMAC_LOG_STATE_CHANGE���������������������� reset_hardware_state
21:52:17:� 78737.024 CMAC_LOG_STATE_CHANGE���������������������� wait_for_link_up_state
21:52:17:� 78737.028 CMAC_LOG_DRIVER_INIT_IDB_RESET������������� 0x082B9CA8
21:52:17:� 78737.032 CMAC_LOG_LINK_DOWN��������������������������
21:52:17:� 78737.034 CMAC_LOG_LINK_UP����������������������������
21:52:17:� 78737.040 CMAC_LOG_STATE_CHANGE���������������������� ds_channel_scanning_state
21:52:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to down
21:52:18:� 78738.386 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:19:� 78739.698 CMAC_LOG_DS_64QAM_LOCK_ACQUIRED������������ 747000000
21:52:19:� 78739.702 CMAC_LOG_DS_CHANNEL_SCAN_COMPLETED����������
21:52:19:� 78739.704 CMAC_LOG_STATE_CHANGE���������������������� wait_ucd_state
21:52:20:� 78740.368 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:22:� 78742.396 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:22:� 78742.398 CMAC_LOG_ALL_UCDS_FOUND���������������������
21:52:22:� 78742.402 CMAC_LOG_STATE_CHANGE���������������������� wait_map_state
21:52:22:� 78742.406 CMAC_LOG_FOUND_US_CHANNEL������������������ 1
21:52:24:� 78744.412 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:24:� 78744.416 CMAC_LOG_UCD_NEW_US_FREQUENCY�������������� 39984000
21:52:24:� 78744.420 CMAC_LOG_SLOT_SIZE_CHANGED����������������� 8
21:52:24:� 78744.500 CMAC_LOG_UCD_UPDATED������������������������
21:52:24:� 78744.560 CMAC_LOG_MAP_MSG_RCVD�����������������������
21:52:24:� 78744.564 CMAC_LOG_INITIAL_RANGING_MINISLOTS��������� 41
21:52:24:� 78744.566 CMAC_LOG_STATE_CHANGE���������������������� ranging_1_state
21:52:24:� 78744.570 CMAC_LOG_RANGING_OFFSET_SET_TO������������� 9610
21:52:24:� 78744.574 CMAC_LOG_POWER_LEVEL_IS�������������������� 55.0� dBmV (commanded)
21:52:24:� 78744.578 CMAC_LOG_STARTING_RANGING�������������������
21:52:24:� 78744.580 CMAC_LOG_RANGING_BACKOFF_SET��������������� 0
21:52:24:� 78744.586 CMAC_LOG_RNG_REQ_QUEUED�������������������� 0
21:52:24:� 78744.622 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:24:� 78744.626 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:24:� 78744.628 CMAC_LOG_RNG_RSP_SID_ASSIGNED�������������� 10
21:52:24:� 78744.632 CMAC_LOG_ADJUST_RANGING_OFFSET������������� 2286
21:52:24:� 78744.636 CMAC_LOG_RANGING_OFFSET_SET_TO������������� 11896
21:52:24:� 78744.638 CMAC_LOG_STATE_CHANGE���������������������� ranging_2_state
21:52:24:� 78744.644 CMAC_LOG_RNG_REQ_QUEUED�������������������� 10
21:52:25:� 78745.654 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:25:� 78745.658 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:25:� 78745.660 CMAC_LOG_RANGING_SUCCESS��������������������
21:52:25:� 78745.680 CMAC_LOG_STATE_CHANGE���������������������� dhcp_state
21:52:25:� 78745.820 CMAC_LOG_DHCP_ASSIGNED_IP_ADDRESS���������� 10.1.4.65
21:52:25:� 78745.824 CMAC_LOG_DHCP_TFTP_SERVER_ADDRESS���������� 10.1.4.1
21:52:25:� 78745.826 CMAC_LOG_DHCP_TOD_SERVER_ADDRESS����������� 10.1.4.1
21:52:25:� 78745.830 CMAC_LOG_DHCP_SET_GATEWAY_ADDRESS�����������
21:52:25:� 78745.834 CMAC_LOG_DHCP_TZ_OFFSET�������������������� -28800
21:52:25:� 78745.836 CMAC_LOG_DHCP_CONFIG_FILE_NAME������������� disable.cm
21:52:25:� 78745.840 CMAC_LOG_DHCP_ERROR_ACQUIRING_SEC_SVR_ADDR��
21:52:25:� 78745.846 CMAC_LOG_DHCP_COMPLETE����������������������
21:52:25:� 78745.968 CMAC_LOG_STATE_CHANGE���������������������� establish_tod_state
21:52:25:� 78745.978 CMAC_LOG_TOD_REQUEST_SENT�������������������
21:52:26:� 78746.010 CMAC_LOG_TOD_REPLY_RECEIVED���������������� 3192525217
21:52:26:� 78746.018 CMAC_LOG_TOD_COMPLETE�����������������������
21:52:26:� 78746.020 CMAC_LOG_STATE_CHANGE���������������������� security_association_state
21:52:26:� 78746.024 CMAC_LOG_SECURITY_BYPASSED������������������
21:52:26:� 78746.028 CMAC_LOG_STATE_CHANGE���������������������� configuration_file_state
21:52:26:� 78746.030 CMAC_LOG_LOADING_CONFIG_FILE��������������� disable.cm
21:52:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to up
21:52:27:� 78747.064 CMAC_LOG_CONFIG_FILE_PROCESS_COMPLETE�������
21:52:27:� 78747.066 CMAC_LOG_STATE_CHANGE���������������������� registration_state
21:52:27:� 78747.070 CMAC_LOG_REG_REQ_MSG_QUEUED�����������������
21:52:27:� 78747.076 CMAC_LOG_REG_REQ_TRANSMITTED����������������
21:52:27:� 78747.080 CMAC_LOG_REG_RSP_MSG_RCVD�������������������
21:52:27:� 78747.082 CMAC_LOG_COS_ASSIGNED_SID������������������ 1/10
21:52:27:� 78747.088 CMAC_LOG_RNG_REQ_QUEUED�������������������� 10
21:52:27:� 78747.090 CMAC_LOG_NETWORK_ACCESS_DENIED��������������
21:52:27:� 78747.094 CMAC_LOG_REGISTRATION_OK��������������������
21:52:27:� 78747.096 CMAC_LOG_STATE_CHANGE���������������������� establish_privacy_state
21:52:27:� 78747.100 CMAC_LOG_PRIVACY_NOT_CONFIGURED�������������
21:52:27:� 78747.102 CMAC_LOG_STATE_CHANGE���������������������� maintenance_state
21:52:31:� 78751.122 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:31:� 78751.124 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:37:� 78757.164 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:37:� 78757.168 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:43:� 78763.206 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:43:� 78763.210 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:49:� 78769.250 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:49:� 78769.252 CMAC_LOG_RNG_RSP_MSG_RCVD

Выходные данные этой команды отладки свидетельствуют об ОТКАЗЕ в доступе к сети.

7246VXR#show cable modem detail
Interface�� SID� MAC address��� Max CPE� Concatenation� Rx SNR
Cable4/0/U0 7��� 0002.1685.b5db 10������ yes����������� 33.52
Cable4/0/U0 8��� 0002.fdfa.0a63 10������ yes����������� 33.24
Cable4/0/U0 9��� 0010.7bed.9b23 1������� no������������ 33.29
Cable4/0/U0 10�� 0010.7bed.9b45 1������� no������������ 33.23
Cable4/0/U0 11�� 0001.64ff.e47d 10������ yes����������� 33.20
Cable4/0/U0 12�� 0004.2752.ddd5 10������ yes����������� 33.44

Заметьте, что CPE Max для кабельных модемов с особыми областями действия равняется 1, и остальным 10 лет. Если вы видите platinum.cm конфигурации области, он имеет 10 заданных CPE, с другой стороны, определите объем disable.cm, имеет только 1 CPE. Предварительно сконфигурированный DOCSIS файл конфигурации silver.cm имеет только одно определенное CPE.

7246VXR#show interface cable 4/0 modem 0
SID�� Priv bits� Type����� State���� IP address��� method��� MAC address
7���� 00�������� modem���� up������� 10.1.4.7����� dhcp����� 0002.1685.b5db
8���� 00�������� modem���� up������� 10.1.4.10���� dhcp����� 0002.fdfa.0a63
9���� 00�������� host����� unknown�� 172.16.29.2�� static��� 00c0.4f97.61c5
9���� 00�������� modem���� up������� 10.1.4.66���� dhcp����� 0010.7bed.9b23
10��� 00�������� modem���� up������� 10.1.4.65���� dhcp����� 0010.7bed.9b45
11��� 00�������� modem���� up������� 10.1.4.6����� dhcp����� 0001.64ff.e47d
12��� 00�������� modem���� up������� 10.1.4.9����� dhcp����� 0004.2752.ddd5

Для того чтобы проверить, что кабельные модемы обслуживаются должным образом, следует посмотреть вывод команды show cable qos profile.

7246VXR#show cable qos profile
ID� Prio Max������ Guarantee Max������� Max�� TOS� TOS�� Create� B���� IP prec.
�������� upstream� upstream� downstream tx��� mask value by����� priv� rate
�������� bandwidth bandwidth bandwidth� burst������������������� enab� enab
1�� 0��� 0�������� 0�������� 0��������� 0���� 0x0� 0x0�� cmts(r) no��� no������
2�� 0��� 64000���� 0�������� 1000000��� 0���� 0x0� 0x0�� cmts(r) no��� no������
3�� 7��� 31200���� 31200���� 0��������� 0���� 0x0� 0x0�� cmts��� yes�� no������
4�� 7��� 87200���� 87200���� 0��������� 0���� 0x0� 0x0�� cmts��� yes�� no������
5�� 4��� 64000���� 0�������� 512000���� 0���� 0x0� 0x0�� cm����� no��� no������
6�� 0��� 1000����� 0�������� 1600000��� 0���� 0x0� 0x0�� cm����� no��� no������
7�� 0��� 128000��� 10000���� 10000000�� 1600� 0x0� 0x0�� cm����� no��� no������
8�� 0��� 0�������� 0�������� 0��������� 0���� 0x0� 0x0�� mgmt��� no��� no������
10� 0��� 0�������� 0�������� 0��������� 0���� 0x0� 0x0�� mgmt��� no��� no������
12� 0��� 0�������� 100000000 0��������� 0���� 0x0� 0x0�� mgmt��� no��� no

Обратите внимание, что qos ID 7 совпадает с конфигурацией в platinum.cm:

cable config-file platinum.cm
�service-class 1 max-upstream 128
�service-class 1 guaranteed-upstream 10
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 10
�timestamp

То же самое происходит с настройкой DOCSIS disable.cm.

7246VXR#show ip dhcp binding
IP address������ Hardware address������� Lease expiration������� Type
10.1.4.6�������� 0100.0164.ffe4.7d������ Mar 08 2001 07:58 AM��� Automatic
10.1.4.7�������� 0100.0216.85b5.db������ Mar 08 2001 07:58 AM��� Automatic
10.1.4.9�������� 0100.0427.52dd.d5������ Mar 08 2001 07:58 AM��� Automatic
10.1.4.10������� 0100.02fd.fa0a.63������ Mar 08 2001 08:36 AM��� Automatic
10.1.4.65������� 0100.107b.ed9b.45������ Infinite��������������� Manual
10.1.4.66������� 0100.107b.ed9b.23������ Infinite��������������� Manual

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 28990