Качество обслуживания (QoS) : Политики QoS

Общие сведения о счетчиках пакетов в выводе команды show interface rate с Committed Access Rate (CAR)

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 апреля 2015) | Отзыв


Содержание


Введение

Согласованная скорость доступа (CAR) представляет собой механизм ограничения скорости, который можно использовать для предоставления служб классификации и ограничения трафика. CAR может использоваться для классификации пакетов на основе определенных критериев, таких как IP-адрес и номер порта, используемых в списках контроля доступа (access-list). Можно указать действия, выполняемые над пакетами, которые соответствуют ограничению скорости или превышают его. Обратитесь к Согласованной скорости доступа Настройки для получения дополнительной информации о том, как настроить CAR.

В этом документе объясняется, почему выходные данные по команде show interface x/x rate-limit содержат ненулевое значение "exceeded bps" притом, что значение "conformed bps" меньше настроенной согласованной скорости передачи (CIR).

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения о выходных данных команды show interface rate

Существует три условия, в которых вы видите ненулевые превышенные скорости в выходных данных этой команды:

Посмотрите на пример выходных данных от интерфейса виртуального доступа. В этой конфигурации RADIUS используется для присвоения ограничения скорости на динамично созданный интерфейс виртуального доступа.

AV Pair from Radius 
Cisco-AVPair = "lcp:interface-config#1=rate-limit input 256000 7500 7500 
conform-action continue 
exceed-action drop", 
Cisco-AVPair = "lcp:interface-config#2=rate-limit output 512000 7500 7500 
conform-action continue 
exceed-action drop",

Используйте show interface x команда rate-limit для мониторинга производительности ограничителя традиционного синтаксиса Cisco, CAR. В данном примере выходные данные этой команды предоставляют подсказки, относительно того, почему существует ненулевой превышенный бит в секунду. В то время как преданное пакетное значение (bc), обозначенное значением предела, установлено в 7500 байтов, текущее пиковое значение составляет 7392 байта.

router#show interfaces virtual-access 26 rate-limit 
Virtual-Access26 Cable Customers 
  Input 
    matches: all traffic 
      params:  256000 bps, 7500 limit, 7500 extended limit 
      conformed 2248 packets, 257557 bytes; action: continue 
      exceeded 35 packets, 22392 bytes; action: drop 
      last packet: 156ms ago, current burst: 0 bytes 
      last cleared 00:02:49 ago, conformed 12000 bps, exceeded 1000 bps 
  Output 
    matches: all traffic 
      params:  512000 bps, 7500 limit, 7500 extended limit 
      conformed 3338 packets, 4115194 bytes; action: continue 
      exceeded 565 packets, 797648 bytes; action: drop 
      last packet: 188ms ago, current burst: 7392 bytes 
      last cleared 00:02:49 ago, conformed 194000 bps, exceeded 37000 bps

При настройке CAR или более нового ограничителя от Cisco, основанного на классе применения политик, необходимо настроить достаточно большие размеры пакета для уверения ожидаемой пропускной способности и чтобы гарантировать что отбрасывание пакета регулировщиком только для наказания краткосрочной перегрузки.

При выборе пиковых значений важно принять переходные увеличения размера очереди. Вы не можете просто предположить, что пакеты поступают и отбывают в то же время. Вы также не можете предположить, что очередь изменяется от пустого до одного пакета и что очередь остается в одном пакете на основе непротиворечивого во время прибытия. Если типичный трафик является довольно пульсирующим, то пиковые значения должны быть соответственно большими, чтобы позволить использованию соединения быть поддержанным в приемлемо высоком уровне. Размер пакета, который слишком низок, или минимальный порог, который слишком низок, может привести к неприемлемо низкому использованию соединения.

Пакет может быть определен просто как серия встречно-параллельных, кадров размера MTU, таких как 1500 битных фреймов, которые происходят на Сети Ethernet. Когда пакет таких кадров достигает выходного интерфейса, он может сокрушить буферы вывода и превысить настроенную глубину алгоритма Token bucket в мгновенно своевременно. С использованием маркерной системы измерения ограничитель делает двоичный выбор о том, приспосабливает ли поступающий пакет, превышает или нарушает настроенные значения применения политик. С пульсирующим трафиком, таким как поток FTP, мгновенная скорость прибытия этих пакетов может превысить значения настроенного пакета и привести к отбрасываниям CAR.

Кроме того, суммарная пропускная способность во времена перегрузки меняются в зависимости от типа трафика, который оценен ограничителем. В то время как Трафик TCP является быстро реагирующим к перегрузке, другие потоки не. Примеры небыстро реагирующих потоков включают основанные на UDP и основанные на ICMP пакеты.

TCP основывается на положительном подтверждении с повторной передачей. TCP использует раздвижное окно в качестве части его положительного механизма подтверждения. Протоколы скользящего окна используют пропускную способность сети лучше, потому что они позволяют отправителю передавать несколька пакетов, прежде чем они будут ждать подтверждения. Например, в протоколе скользящего окна с размером окна 8, отправителю разрешают передать 8 пакетов, прежде чем это получит подтверждение. При увеличении размера окна сетевое время простоя в основном устранено. Хорошо настроенный протокол скользящего окна поддерживает сеть полностью насыщаемой с пакетами и поддерживает высокую пропускную способность.

Так как оконечные точки не знают определенного статуса перегрузки сети, TCP, поскольку протокол разработан, реагируют на перегрузку в сети сокращением ее коэффициенты передачи, когда происходит перегрузка. В частности это использует два способа:

Способ Описание
Предотвращение перегрузки с мультипликативным сокращением На потерю сегмента (эквивалент пакета к TCP), уменьшите окно перегрузки наполовину. Окно перегрузки является вторым значением или окном, которое используется для ограничения количества пакетов, которые отправитель может передать в сеть, прежде чем это будет ждать подтверждения.
Восстановление с помощью медленной загрузки При начале трафика на новом соединении или трафика увеличения после периода перегрузки запустите окно перегрузки в размере одиночного сегмента и увеличьте окно перегрузки одним сегментом каждый раз, когда подтверждение поступает. TCP инициализирует окно перегрузки к 1, передает начальный сегмент и ждет. Когда подтверждение поступает, оно увеличивает окно перегрузки до 2, передает два сегмента и ждет. Для получения дополнительной информации посмотрите RFC 2001 leavingcisco.com.

Пакеты могут быть потеряны или уничтожены, когда ошибки трансляции вмешиваются в данные, когда сетевое оборудование отказывает, или когда сети становятся слишком в большой степени загруженными для размещения представленной загрузки. TCP предполагает, что потерянные пакеты или пакеты, которые не в состоянии быть подтвержденными во временном интервале из-за экстремальной задержки, указывают на перегрузку в сети.

Система измерения token-bucket ограничителя вызвана на каждом получении пакета. В частности скорость, которой приспосабливают, и превышает скорость, вычислены на основе этой простой формулы:

(conformed bits since last clear counter)/(time in seconds elapsed since last clear counter)

Так как формула вычисляет скорости за период от прошлый раз, что счетчики были очищены, Cisco рекомендует очистить счетчики для мониторинга текущей скорости. Если счетчики не очищены, то скорость предыдущей формулы эффективно означает, что выходные данные команды show отображают среднее число, вычисленное за потенциально очень долгий период, и значения возможно не значимы в определении текущей скорости.

Средняя пропускная способность должна совпасть с настраиваемой согласованной скоростью передачи информации (CIR) в течение времени. Размеры пакета позволяют продолжительность максимального пакета в установленный срок. Если существует "no traffic" (нет трафика) или меньше, чем ценность CIR трафика и алгоритма Token bucket не заполняется, очень большой пакет все еще ограничен определенным размером, вычисленным на основе обычного пакета и увеличенного пакета.

Уровень сброса следует из этого механизма

  1. Обратите внимание на текущее время.

  2. Обновите алгоритм Token bucket с количеством маркеров, которые накапливались постоянно, начиная с прошлый раз пакет поступил.

  3. Общее число суммарных маркеров не может превысить значение maxtokens. Отбросьте избыточные маркеры.

  4. Проверьте соответствие пакетов.

Ограничение скорости может также быть достигнуто с Применением политик. Это - пример конфигурации для обеспечения ограничения скорости на Интерфейсе Ethernet, который использует основанное применение политик Класса.

class-map match-all rtp1
   match ip rtp 2000 10
!
   policy-map p3b
   class rtp1
   police 200000 6250 6250 conform-action transmit exceed-action drop violate-action    drop
policy-map p2
   class rtp1
   police 250000 7750 7750 conform-action transmit exceed-action drop violate-action    drop
   !
interface Ethernet3/0
   service-policy output p3b
   service-policy input p2

Этот пример выходных данных от команды show policy-map interface иллюстрирует должным образом вычисленные и синхронизируемые значения для предложенной скорости и уровня сброса, а также приспособленный, и превысьте скорости бита в секунду.

router#show policy-map interface ethernet 3/0 
  Ethernet3/0 

   Service-policy input: p2 

     Class-map: rtp1 (match-all) 
       88325 packets, 11040625 bytes 
       30 second offered rate 400000 bps, drop rate 150000 bps 
       Match: ip rtp 2000 10 
       police: 
         250000 bps, 7750 limit, 7750 extended limit 
         conformed 55204 packets, 6900500 bytes; action: transmit 
         exceeded 33122 packets, 4140250 bytes; action: drop 
         conformed 250000 bps, exceed 150000 bps violate 0 bps 

       Service-policy : p3b 

         Class-map: rtp1 (match-all) 
           88325 packets, 11040625 bytes 
           30 second offered rate 400000 bps, drop rate 50000 bps 
           Match: ip rtp 2000 10 
           police: 
             200000 bps, 6250 limit, 6250 extended limit 
             conformed 44163 packets, 5520375 bytes; action: transmit 
             exceeded 11041 packets, 1380125 bytes; action: drop 
             conformed 200000 bps, exceed 50000 bps violate 0 bps 

         Class-map: class-default (match-any) 
           0 packets, 0 bytes 
           30 second offered rate 0 bps, drop rate 0 bps 
           Match: any 

Известные проблемы с CAR и счетчиками ограничения скорости на основе классов

Эта таблица приводит решенные проблемы со счетчиками, отображенными в командах покажите карту политик или show interface rate-limit. Зарегистрированные заказчики, в которых входят, могут просмотреть сведения об ошибке в Bug Toolkit, связанном от Программных средств и служебных программ (только зарегистрированные клиенты) страница.

Признак

Решенные идентификаторы ошибок и обходные пути
Ниже, чем ожидаемые счетчики сбросов Когда входная иерархическая политика обслуживания использует команду политики на родительских и дочерних уровнях, ограничитель может отбросить меньше, чем ожидаемый номер пакетов, так как ограничитель родительского уровня должен быть переполнен, прежде чем это отбросит пакеты. Это - пример такой политики:
policy-map child 
   class dscp1 
      police cir 100000 bc 3000 conform-action transmit exceed-action drop 
! 
policy-map parent 
   class rtp1 
      police cir 250000 bc 7750 conform-action transmit exceed-action drop 
    service-policy child 
Как обходной путь, создайте отдельную политику и применитесь один на входящий и один на исходящем во избежание конфигурации иерархической политики.
Удваивает ожидаемую оценку удалений и производительности Технология CEF определяет механизм Коммутации IOS, который передает пакеты от ввода до выходного интерфейса. До изменений, внедренных от этого идентификатора ошибки, и CEF и настроенные механизмы QoS, такие как CAR или основанное на классе применение политик инкрементно увеличили счетчики пакетов. Результат является так называемым двойным учетом и расширил пакеты, которым приспосабливают, и избыточные значения отбрасывания. На серии Cisco 12000, когда выходные данные CAR включены и входной линейной платой является Engine 2, выходные счетчики вывода удвоены. Этот двойной учет следует, как обрабатываются счетчики вывода. При глобальном включении команды ip cef distributed на маршрутизаторе Cisco серии 7500, немногоцелевой интерфейсный процессор (VIP), интерфейс карты появляется с командой ip route-cache distributed, включенной по умолчанию. Не-vip не поддерживают распределенный CEF и редкое побочное явление этой команды, которая появляется на не-VIP, двойной учет.
Без сбросов или при нулевом уровне сброса В целом при применении основанных на классе Характеристик QoS первый шаг в устранении проблем должен гарантировать, что механизм классификации QoS работает должным образом. Другими словами, гарантируйте, что пакеты, заданные в сообщениях о совпадении в class-map, поражают корректные классы.
router#show policy-map interface 
 ATM4/0.1 

  Service-policy input: drop-inbound-http-hacks (1061) 

    Class-map: http-hacks (match-any) (1063/2) 
      149 packets, 18663 bytes 
      5 minute offered rate 2000 bps, drop rate 0 bps 
      Match: protocol http url "*cmd.exe*" (1067) 
        145 packets, 18313 bytes 
        5 minute rate 2000 bps 
      Match: protocol http url "*.ida*" (1071) 
        0 packets, 0 bytes 
        5 minute rate 0 bps 
      Match: protocol http url "*root.exe*" (1075) 
        4 packets, 350 bytes 
        5 minute rate 0 bps 
      Match: protocol http url "*readme.eml*" (1079) 
        0 packets, 0 bytes 
        5 minute rate 0 bps 
      police: 
        1000000 bps, 31250 limit, 31250 extended limit 
        conformed 0 packets, 0 bytes; action: drop 
        exceeded 0 packets, 0 bytes; action: drop 
        violated 0 packets, 0 bytes; action: drop 
        conformed 0 bps, exceed 0 bps violate 0 bps
Классификация отказывает, когда CEF, и не DCEF, включен, и политика для входящих пакетов присоединена к постоянному виртуальному каналу ATM. В Cisco IOS Software Release 12.1T, отказывает классификация исходящих данных, когда CEF, и не DCEF, включен, и политика вывода присоединена к постоянному виртуальному каналу ATM.
Аномальный или противоречивый уровень сброса Уровень сброса, отображенный в class-map, не совпадает с уровнями сброса, обозначенными действием полиции по наведению порядка. В то время как уровень сброса, показанный действием полиции по наведению порядка, составляет 1072000 битов в секунду, в выходных данных данного примера уровень сброса для класса составляет 745000 битов в секунду.
router#show policy-map interface 
  Serial3/0.1: DLCI 13 - 

   Service-policy output: out 

     Class-map: c2 (match-all) 
       172483 packets, 91760956 bytes 
       30 second offered rate 1384000 bps, drop rate 745000 bps 
       Match: ip precedence 0 
       police: 
         384000 bps, 1500 limit, 1500 extended limit 
         conformed 38903 packets, 20696396 bytes; action: transmit 
         exceeded 133580 packets, 71064560 bytes; action: drop 
         conformed 311000 bps, exceed 1072000 bps violate 0 bps

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 28882