Cервисы организации сетевого доступа к приложениям : Программное обеспечение Cisco Application and Content Networking System (ACNS)

Как настроить Cache Engine для обратного прокси-кэширования с использованием WCCP


<ГРАНИЦА ТАБЛИЦЫ CELLSPACING=3 CELLPADDING=3 ШИРИНА = "70%-Й" BGCOLOR = "#FFFFFF" VALIGN = "TOP">

<НАЗВАНИЕ = "отладка">

отладка и показывает Команды

Перед выполнением команд debug посмотрите Важный Информация о командах отладки .

Команды debug и show Cache Engine:

  • show wccp cache - Показывает данные по CE WCCP
  • show wccp flows - Показывает потоки пакета WCCP
  • show wccp routers   - Показывают список маршрутизатора WCCP
  • show wccp services - Show WCCP services, настроенный
  • show wccp slowstart   - Показывают Медленный пуск WCCP
  • show wccp status   - Показывают состояние работы WCCP
  • show statistics http savings - Отображает статистику сохранений HTTP
  • debug wccp all - WCCP Включает всю отладку
  • debug wccp events - События WCCP
  • debug wccp packets - сведения, относящиеся к пакету WCCP
Команды маршрутизатора debug и show:
  • show ip wccp 99 detail - Эта команда отображает Cache Engine и Статистика маршрутизатора WCCP для группы сервисов.
  • show ip wccp 99 view - Группа сервисов просматривает информацию
  • debug ip wccp events -   События WCCP
  • debug ip wccp packets - сведения, относящиеся к пакету WCCP

<НАЗВАНИЕ = "проверка"> Проверка

Проверьте, что кэширование прокси - службы обратного пути работает с этими командами.

Выполните эту команду для проверки статуса Cache/Content Engine WCCP:

router#  sh подробность ip wccp 99  
Информация о Cache Engine WCCP: 
       IP-адрес: 10.0.0.2 
       Версия протокола: 2.0 
       Состояние: применимый                              
	    <ЦВЕТ ШРИФТА = "#0000FF">!---Этот кэш активен.  
       Начальная информация хэша: 00000000000000000000000000000000 
                              00000000000000000000000000000000 
       Назначенная информация хэша: FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
                              FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
       Выделение хэша: 256 (100.00%) 
       Перенаправленные пакеты: 93 
       Время соединения: 0:15:27

Выполните эту команду для проверки прозрачной обратной переадресации WCCP на маршрутизаторе:

router#  sh ip wccp 99  
Глобальная информация о WCCP: 
    Сведения о маршрутизаторе: 
        Идентификатор маршрутизатора: 172.17.63.194 
        Версия протокола: 2.0 
    Идентификатор сервиса: 99 
        Количество Cache Engine: 1 
        Количество маршрутизаторов: 1 
        Перенаправленные общие пакеты: 93                   
		 <ЦВЕТ ШРИФТА = "#0000FF">!---маршрутизатор перенаправляет.  
        Redirect access-list: Нет- 
        Общие пакеты запрещенное перенаправление: 0 
        Неназначенные общие пакеты: 0 
        Access-list группы: Нет- 
        Общие сообщения, запрещенные группе: 0 
        Общие Ошибки проверки подлинности: 0


Выполните эту команду для проверки статистики HTTP по Cache/Content Engine:

cache#  sh статистический запрос HTTP  
                              Statistics - Запросы 
                                                Общий % запросов 
                            --------------------------------------------------- 
     Общие полученные запросы: 23 - 
              Принудительные повторные загрузки: 2 8.7 
               Ошибки клиента: 0 0.0 
               Ошибки сервера: 0 0.0 
         URL, заблокированный (сброс): 0 0.0 
                 Заблокированный URL: 0 0.0 
      Передаваемый исходящему прокси: 0 0.0 
Сбои от исходящего прокси: 0 0.0 
Исключенный из исходящего прокси: 0 0.0 
             Соответствия клиента ICP: 0 0.0 
             Соответствия сервера ICP: 0 0.0 
               Соответствия если-диапазона: 0 0.0 
           Запросы HTTP 0.9: 0 0.0 
           Запросы HTTP 1.0: 0 0.0 
           Запросы HTTP 1.1: 23 100.0 
       HTTP неизвестные запросы: 0 0.0 
           Запросы HTTP non: 0 0.0 
          Ответы HTTP non: 0 0.0 
      Разделенные на блоки ответы HTTP: 0 0.0 
        Http мисс Дью к DNS: 0 0.0 
     Http удаляет из-за DNS: 0 0.0 
  Объекты кэшировались для ТТЛ-схемы min: 4 17.4

Выполните эту команду для проверки кэширования запросов:

cache#  sh http статистики sav  
                         Statistics - Сохранения 
                        Байты запросов 
         ----------------------------------------------------------- 
  Общее количество: 23 16481 
   Соответствия: 6 2205 
   Мисс: 17 14276 
Сохранения: 25.0% 13.4%

<НАЗВАНИЕ = "сводка"> Краткое описание команд

Эти команды Cache Engine использовались в этой конфигурации.
  • версия wccp { 1 | 2 }
  • wccp router-list IP-адрес номера
  • цифра списка маршрутизатора wccp номер
Эти команды маршрутизатора использовались в этой конфигурации.
  • ip wccp { веб - кэширование | служебное число}
  • ip wccp { веб - кэширование | служебное число} перенаправляет
  • версия 2 ip wccp


<НАЗВАНИЕ = "информация"> Дополнительные сведения


<РАЗМЕР ШРИФТА = "-1">

<час width=100%>
Document ID: 28832
20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

<ТЕЛО BGCOLOR =#FFFFFF>

Содержание

    Введение
      Версии Программного и аппаратного обеспечения
    Диаграмма сети
    Конфигурации
      Cache Engine 560
      Маршрутизатор Cisco 2600
    отладка и показывают Команды
    Проверка
    Краткое описание команд
    Дополнительные сведения

<НАЗВАНИЕ = "введение"> Введение

Этот документ описывает, как настроить Cisco Cache Engine для прокси - службы обратного пути кэширование при помощи Протокола координации веб-кэша (WCCP).

<НАЗВАНИЕ = "аппаратные средства"> Версии аппаратного программного обеспечения

Эта конфигурация разрабатывалась и проверялась с помощью программного и аппаратного обеспечения версии ниже.

  • Cisco Cache Engine 560 выполняющих Cisco Cache Software Release 2.3 и ACNS версия 4.0 и ACNS 5.0 в лабораторной среде с очищенными конфигурациями.

  • Маршрутизатор Cisco 2600 рабочая Cisco IOS® Software Release 12.1 (2)./LI>
Информация, содержащаяся в данном документе была создана с помощью оборудования в лабораторной работе среда. Устройства запустили с чистой (заданной по умолчанию) конфигурацией. Если вы работают в действующей сети, удостоверьтесь, что вы понимаете потенциальное воздействие из команды перед использованием его.

<НАЗВАНИЕ = "диаметр"> Диаграмма сети


<НАЗВАНИЕ = "конфигурации"> Конфигурации

<ГРАНИЦА ТАБЛИЦЫ CELLSPACING=3 CELLPADDING=3 ШИРИНА = "70%-Й" BGCOLOR = "#FFFFFF" VALIGN = "TOP">
<НАЗВАНИЕ = "устройство 1"> Cache Engine 560 (программное обеспечение Кэша Выпуск 2.3 или выпуск 4.0 или 5.0 программного обеспечения ACNS)
Текущая конфигурация:
!
!
пользователь добавляет uid admin 0 
пароль 1 "eeSdy9dcy"  
доступ администратора возможности
!
!
!
имя хоста ce
!
interface Ethernet0
  ip адрес 10.0.0.2 255.255.255.0
 <ЦВЕТ ШРИФТА = "#3366FF">!  Важно: Если вы настраиваете Cache Engine 
!---с частным адресом, это должно стать преобразованным
!---к общему адресу.
  ip broadcast-address 10.0.0.255 exit ! interface ethernet 1 exit ! IP-шлюз по умолчанию 10.0.0.1 ip name-server 171.70.168.183 cisco.com ip domain name ip route 0.0.0.0 0.0.0.0 10.0.0.1 файл крона/local/etc/crontab ! wccp router-list 1 10.0.0.1 цифра списка маршрутизатора прокси - службы обратного пути wccp 1 wccp version 2 ! локальное регистрационное имя для проверки подлинности включает локальная конфигурация аутентификации включает управляйте Url-regex без кэшей.*cgi-bin.* управляйте Url-regex без кэшей.*aw-cgi.* ! !
<НАЗВАНИЕ = "устройство 2"> Маршрутизатор Cisco 2600 (Cisco IOS Выпуск ПО 12.1 [2])
 Building configuration...

Текущая конфигурация:
!
версия 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
имя хоста 2611-5
!
enable secret 5$BTPbq8xlE2dsKwKPDDmpL/VQ. за $1$ 9
!
!
ip subnet-zero
ip wccp 99
!
!
interface Ethernet0/0
 описание Интерфейс к Интернету 
 IP-адрес 172.17.63.194 255.255.255.192
  no ip redirects
!
interface Serial0/0
  no ip address
  no ip mroute-cache
  отключение
!
interface ethernet0/1
  ip address 10.0.0.1 255.255.255.0
!
интерфейс Ethernet1/0
  IP-адрес 10.1.0.1 255.255.255.0
  перенаправление ip wccp 99
!
интерфейс Ethernet1/1
  no ip address
  отключение
  полный дуплекс
!
интерфейсный Ethernet1/2
  no ip address
  отключение
!
интерфейсный Ethernet1/3
  no ip address
  отключение
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.63.193
!
!
line con 0
  transport input none
line aux 0
line vty 0 4
  вход в систему
!
конец