Совместная работа : Cisco ICM CTI Desktop

Данные CTI не передаются Cisco Agent Desktop

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

Этот документ описывает одну причину, почему данные Интеграции компьютерной телефонии (CTI) не заполняют Cisco Agent Desktop в Cisco Intelligent Contact Management (ICM) Среда предприятия. Этот документ также предоставляет возможный обходной путь.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • ICM Enterprise Cisco

  • Cisco IP Contact Center (IPCC) предприятие

  • Сервер Cisco STI

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco ICM Version 5.x и позже

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Топология

Рисунок 1 представляет типовую конфигурацию CTI для демонстрации потока высокоуровневого протокола управления каналом. Этот поток данных позволяет вам понять проблему и разработать диагностический подход.

Рисунок 1 – типовая конфигурация CTI

cti_noreach_cad_01.gif

Проблема

Данные CTI не в состоянии достигать Cisco Agent Desktop. Через экранную популярность агенты не получают информацию, которую абоненты вводят в приглашение Интерактивного голосового ответа (IVR).

Примечание: Эта проблема происходит только при обновлении версии ICM 4.5.x или ранее к версии ICM 5 и позже.

Причина

Эта проблема происходит из-за двух настроек реестра на периферийном шлюзе (PG).

Решение

Чтобы устранить данную проблему, выполните следующие действия:

  1. Завершение работы оба PG в дуплексной среде.

  2. Перейдите к этому пути в реестре:

    HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, INC.\ICM\<Cust_Inst>\
    PG<xxA/B>\PG\CurrentVersion\OPC\OPIData
  3. Установите значение DWORD AgentVailableStateUpdateDelayInMilliSeconds к 0 (см. стрелку на рисунке 2).

  4. Установите значение DWORD CTIAgentEventFlushTimeoutInMilliSeconds к 0 (см. стрелку B на рисунке 2).

  5. Перезапустите оба PG.

  6. Это сообщение появляется в OPC, входят в систему стороны активного PG:

    CTIAgentEventFlushTimeoutInMilliSeconds to 0 disables agent-event buffering
    Рисунок 2 – ключ реестра

    cti_noreach_cad_02.gif

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения