Совместная работа : Cisco Outbound Option

Сбой программы набора IP-номера для IPCC Enterprise

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

Этот документ описывает одну причину, почему Номеронабиратель IP не в состоянии набирать клиента и предоставляет решение в Cisco IP Contact Center (IPCC) Среда предприятия.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • Cisco ICM

  • Cisco Outbound Option

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco ICM Version 5.x и позже

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

Вот типичный прогнозирующий или прогрессивный поток вызовов (см. рисунок 1):

  1. Номеронабиратель IP запрашивает агента через интерфейс Маршрутизации медиа-трафика (MR).

  2. Маршрутизатор выполняет сценарий маршрутизации для выбора доступного агента.

  3. Маршрутизатор возвращает доступного агента.

  4. Периферийный шлюз (PG) резервирует доступного агента.

  5. Номеронабиратель IP заказывает телефонный разговор с линией агента 1 для поддержания вызова резервирования.

  6. Номеронабиратель IP тогда заказывает телефонный разговор с клиентом.

  7. Номеронабиратель IP анализирует входящий поток Протокола RTP и обнаруживает оперативного человека.

  8. Вызов заказчика поступает в телефон агента через вторую линию. Резервирование Номеронабирателя отвечает на вызов заказчика через Сервер Интеграции компьютерной телефонии (CTI).

Рисунок 1 – типичная прогнозирующая или прогрессивная обработка вызовов

/image/gif/paws/64926/ipdialerfailure_01.gif

На рисунке 1 DLR представляет Номеронабирателя IP, и RTR представляет Маршрутизатор.

Проблема

Номеронабиратель IP не в состоянии заказывать телефонный разговор с клиентом. На основе этого журнала Номеронабиратель IP не в состоянии загружать файл конфигурации от TFTP server:

13:00:06 dialer-baDialer Trace: Unable to get XML Config file
 [SEPDA005002f000.cnf.xml] from Call Manager; 1 of 50 Attempts 
13:00:06 dialer-baDialer Trace: Getting Configuration File
 [SEPDA005002f000.cnf.xml] from TFTP Server [192.168.210.246] 
13:00:06 dialer-baDialer Trace: Unable to get XML Config file
 [SEPDA005002f000.cnf.xml] from Call Manager; 2 of 50 Attempts 

Причина

Когда вы не настраиваете значение регистра TFTPServer правильно, эта проблема конфигурации происходит. Эта проблема может также указать к Серверу CallManager без установленного TFTP server. В любом случае Номеронабиратель IP не заказывает телефонный разговор с клиентом.

Вот путь навигации к реестру для TFTPServer (см. рисунок 2):

HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\<inst_name>\Dialer\TFTPServer
Рисунок 2 – ключ реестра TFTPServer

ipdialerfailure_02.gif

Решение

Выполните эти шаги для решения этой проблемы:

  1. Выполните настройку Номеронабирателя ICM Cisco.

  2. Сохраните все существующие параметры, кроме названия TFTP server CallManager. Введите корректное имя TFTP Server CallManager в поле TFTP server Call Manager.

    Гарантируйте, что этот Сервер CallManager поддерживает функцию TFTP server.

    Рисунок 3 – свойства номеронабирателя параметра Outbound

    /image/gif/paws/64926/ipdialerfailure_03.gif

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения