???????-?????? : Cisco Agent Desktop

Cisco Agent Desktop разъединяет всех агентов одновременно

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает одну причину для Cisco Agent Desktop для разъединения всех агентов одновременно от их соответствующих сеансов в Cisco IP Contact Center (IPCC) Среда предприятия. Этот документ также предоставляет возможный обходной путь.

Примечание: Для получения дополнительной информации о разрешении этой проблемы обратитесь к идентификатору ошибки Cisco CSCsa79930 (только зарегистрированные клиенты).

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • Enterprise Edition Сisco IPCC

  • Cisco Agent Desktop

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Версия 6.x Enterprise Edition Сisco IPCC и ранее

  • Версия 6.x Cisco Agent Desktop и ранее

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

Контактные центры организуют агентов в группы умений. Агенты в каждой группе умений обучены обработать определенные типы вызовов. Например, литературные запросы маршрутизируются к группам умений, в которых агенты обучены предоставить общие информационные службы. Точно так же вызовы, которые включают сложные транзакции, направлены к более специализированным группам умений.

Вот обычная конфигурация, в которой происходит эта проблема:

Рисунок 1: Выпуск корпоративной версии IPCC

skildelete_01.gif

Проблема

Все агенты, настроенные для работы в контактном центре, теряют подключение Cisco Agent Desktop в то же время. Агенты включают:

  • Агенты, которые выполняют Cisco Agent Desktop на их ПК.

  • Агенты, которые выполняют Cisco Agent Desktop в среде тонких клиентов Citrix.

Когда массовое разъединение происходит, агенты должны перезагрузить телефоны и регистрировать назад в Cisco Agent Desktop.

В дополнение к массовому разъединению процесс Open peripheral controller (OPC) на Периферийном шлюзе (PG) завершается катастрофическим отказом с дампом Dr.Watson.

11:12:24 PG1A-opc Trace: Agent::GetSessionTimes - SkillGroup 40424 (0x9DE8)
priority=0 unknown for agent 1428 on Peripheral 5000. 

Причина

При рассмотрении входа в систему PG проверьте, была ли удалена группа умений. Вот соответствующий раздел журнала трассировки OPC:

11:12:20 PG1A-opc UPDATED 1 SkillGroups. 
11:12:20 PG1A-opc UPDATED 1 Routes. 
11:12:20 PG1A-opc UPDATED 5 Agents. 
11:12:20 PG1A-opc REMOVED 1 SkillGroups.

Удаление группы умений заставляет процесс OPC завершаться катастрофическим отказом. Вот соответствующий раздел журнала трассировки OPC:

11:12:24 PG1A-opc Trace:
Agent::GetSessionTimes - SkillGroup 40424 (0x9DE8) priority=0
unknown for agent 1428 on Peripheral 5000. 

Катастрофический отказ процесса OPC в свою очередь вызывает массовое разъединение агента.

Решение

Оптимальный метод, который рекомендует Cisco, должен удалить группу умений только, когда все агенты, которые принадлежат той группе умений, выходятся из системы.

Выполните эти шаги во избежание проблемы массовых отключений от Cisco Agent Desktop:

  1. Планируйте период технического обслуживания, когда вы захотите удалить группы умений.

  2. Уведомьте всех участвующих агентов в группе умений, чтобы выйти из системы Cisco Agent Desktop.

  3. Удалите группу умений.

  4. Уведомьте агентов для регистрации снова.


Дополнительные сведения


Document ID: 64373