Analytics and Automation Software : Cisco ONS 15454 SONET Multiservice Provisioning Platform (MSPP)

Использование PAT для установки сеанса между CTC и ONS 15454, когда CTC находится в межсетевом экране

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Когда CTC находится в межсетевом экране, этот документ предоставляет пример конфигурации для Преобразования адресов портов (PAT) для установления сеанса между Cisco Transport Controller (CTC) и ONS 15454.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Имейте базовые знания о Cisco ONS 15454.

  • Знайте, какие маршрутизаторы Cisco поддерживают PAT.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Версия 4.6. X Cisco ONS 15454 и позже

  • Cisco Выпуск ПО IOS� 12.1 (11) и позже

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Общие сведения

Топология

Топология состоит из этих элементов:

  • Один Cisco ONS 15454

  • Один ПК

  • Один маршрутизатор серии Cisco 2600

ONS 15454 находится во внешней сети и действует как сервер. ПК находится во внутренней сети и служит клиентом CTC. Маршрутизатор серии Cisco 2600 оказывает поддержку PAT.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В настоящем документе используется следующая схема сети:

Рисунок 1 – топология

ctc_ons_pat_01.gif

Конфигурации

Эти конфигурации используются в данном документе:

  • Cisco ONS 15454

  • ПК

  • Маршрутизатор серии Cisco 2600

Конфигурация Cisco ONS 15454

10.89.238.192 IP-адрес ONS 15454 (см. стрелку на рисунке 2), и 10.89.238.1 представляет маршрутизатор по умолчанию (см. стрелку B на рисунке 2).

Рисунок 2 – конфигурация ONS 15454

ctc_ons_pat_02.gif

Выполните эти шаги, чтобы гарантировать, что CTC связывается с ONS 15454 через PAT:

  1. Проверьте Разрешать прокси-сервер на флажке порта в разделе Настроек шлюза (см. стрелку C на рисунке 2).

  2. Выберите опцию Только для прокси (см. стрелку D на рисунке 2).

  3. Щелкните "Применить".

Если вы не включаете прокси-сервер, CTC отказывает с этими сообщениями об ошибках:

Рисунок 3 – ошибка EID 2199

ctc_ons_pat_03.gif

Рисунок 4 – ошибка инициализации CTC

ctc_ons_pat_04.gif

Конфигурация ПК

172.16.1.254 IP-адрес ПК (см. стрелку на рисунке 5), и 172.16.1.1 представляет шлюз по умолчанию (см. стрелку B на рисунке 5).

Рисунок 5 – конфигурация ПК

ctc_ons_pat_05.gif

Настройка маршрутизатора

Этот раздел предоставляет процедуру для настройки маршрутизатора.

Выполните следующие действия:

  1. Настройте внутренний интерфейс, где находится ONS 15454.

    !
    interface Ethernet1/0
     ip address 10.89.238.1 255.255.255.0
     ip nat outside
    !
  2. Настройте внешний интерфейс, где находится клиент CTC.

    interface Ethernet1/1
     ip address 172.16.1.1 255.255.255.0
     ip nat inside
    !
  3. Настройте поддержку PAT на маршрутизаторе. Конфигурация указывает, что любой пакет, который поступает во внутренний интерфейс, который список доступа 1 разрешение, совместно использует один внешний IP - адрес. Внешний IP - адрес 10.89.238.1 в этой конфигурации.

    !
    
    !--- Indicates that any packets that arrive on the internal interface, which
    !--- access list 1 permits, share one outside IP address (the address 
    !--- on ethernet1/0).
    
    
    ip nat inside source list 1 int ethernet1/0 overload
    access-list 1 permit 172.16.1.0 0.0.0.255
    !

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Процедура проверки

Выполните следующие действия:

  1. Выполните Microsoft Internet Explorer.

  2. Введите http://10.89.238.192 в Строке адреса окна браузера и нажмите ENTER.

    Окно входа CTC появляется.

  3. Введите корректное Имя пользователя и пароль.

    Клиент CTC успешно соединяется с ONS 15454.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Выполните команду debug ip nat detailed для включения IP NAT подробная трассировка. Можно просмотреть переадресации от 172.16.1.254 до 10.89.238.1 (см. стрелку на рисунке 6), и от 10.89.238.1 до 172.16.1.254 (см. стрелку B на рисунке 6).

Рисунок 6 – Debug IP NAT детализирован

ctc_ons_pat_06.gif


Дополнительные сведения


Document ID: 63775