Технологии IBM : Коммутация соединения передачи данных (DLSw) и Data-Link Switching Plus (DLSw +)

Настройка DLSw + через QLLC

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этой конфигурации, два других ресурса X.25 (мы использовали хост dspu для моделирования конечных устройств в этой настройке). Для получения дополнительной информации о нижерасположенном физическом модуле (DSPU) обратитесь к этим документам:

Они с двумя окончаниями устройства связываются с другими адаптерами в мэйнфреймовом узле по X.25. Удаленные ресурсы X.25 были настроены для других адресов назначения (DA) (в других длинах и других адресах). Любой входящий вызов, адрес назначения (DA) X.121 которого совпадает с "подадресом qllc dlsw маршрутизатора", отправлен Коммутации соединения передачи данных Плюс (DLSw+) (с IND ID.STN). То, когда DLSw+ получает, "Может Вы Достигать" запроса о виртуальном MAC - адресе в пуле, код Протокола QLLC пытается установить Виртуальный канал (VC) к Адресу X.121, который сопоставляет с заданным виртуальным MAC - адресом. Если входящий вызов принят, QLLC передает ID.STN.IND с виртуальным MAC - адресом от пула до DLSw+.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в этом документе, касаются следующих версий программного обеспечения и оборудования:

  • Cisco Выпуск ПО IOS� 12.2 (6a) использовалась в Пафосе (Cisco 2612)

  • Программное обеспечение Cisco IOS версии 12.0(20) использовалось в Namur & Goode (Cisco 2500, Cisco 4000)

  • Программное обеспечение Cisco IOS версии 12.1(7) использовалось в Nesle (Cisco 4500)

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Диаграмма топологии

/image/gif/paws/28401/Topo.gif

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Конфигурации

MAC-адреса мейнфрейма следующие:

  • 4000.7507.0000

  • 4000.7507.ffff

В данном документе используется следующая конфигурация:

Cisco 7507 (Meatfeast)
source-bridge ring-group 100 
dlsw local-peer peer-id 10.48.64.75 promiscuous 
! 
interface Channel4/2 
 ip address 10.48.64.225 255.255.255.240 
 no keepalive 
 lan TokenRing 0 
  source-bridge 88 1 100 
  adapter 0 4000.7507.0000 
  adapter 1 4000.7507.ffff 

Cisco 2612 (Пафос)
! 
source-bridge ring-group 200 
dlsw local-peer peer-id 10.48.64.40 
dlsw remote-peer 0 tcp 10.48.64.75 
! 
interface Ethernet0/0 
 ip address 10.48.64.40 255.255.255.0 
 half-duplex 
! 
interface Serial0/0 
 no ip address 
! 
interface TokenRing0/0 
 no ip address 
 ring-speed 16 
! 
interface Serial0/1 
 no ip address 
 encapsulation x25 
 x25 alias .*  

!--- It is used against the destination 
!--- address of a received call.

 x25 htc 10 
 x25 win 7 
 x25 wout 7 
 qllc accept-all-calls 
 qllc dlsw subaddress 123456789012345 vmacaddr 4000.3333.0000 2 partner 4000.7507.0000 
 qllc dlsw subaddress 2224 vmacaddr 4000.2222.0000 2 partner 4000.7507.ffff 
! 
ip default-gateway 10.48.64.1 
ip classless 
no ip http server 
ip pim bidir-enable 
! 
! 
dial-peer cor custom 
!  

Cisco 4500 (Nesle)
! 
x25 routing 
! 
! 
! 
interface Ethernet0 
 ip address 10.48.64.34 255.255.255.0 
 media-type 10BaseT 
! 
interface Ethernet1 
 no ip address 
 shutdown 
 media-type 10BaseT 
! 
interface Ethernet2 
 no ip address 
 media-type 10BaseT 
! 
interface Serial0 
 no ip address 
 encapsulation x25 dce 
 clockrate 250000 
! 
interface Serial1 
 no ip address 
! 
interface Serial2 
 no ip address 
 encapsulation x25 dce 
 no ip mroute-cache 
 clockrate 250000 
! 
interface Serial3 
 no ip address 
 encapsulation x25 dce 
 clockrate 250000 
 ! 
interface TokenRing0 
 no ip address 
 ring-speed 16 
! 
ip default-gateway 10.48.64.1 
ip classless 
no ip http server 
x25 route input-interface Serial2 interface Serial0 
x25 route input-interface Serial3 interface Serial0 
x25 route 555 interface Serial2 
x25 route 666 interface Serial3 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
 exec-timeout 0 0 
line vty 0 4 
 exec-timeout 0 0 
 password 7 071836 
 login 
! 
ntp clock-period 17179258 
ntp server 10.48.64.100 
end 

Cisco 2500 (Намюр)
hostname namur 
! 
logging buffered 150000 debugging 
enable password 7 120E12 
! 
dspu host OZDEN xid-snd 00000000 x25 2224 qllc 12 interface Serial1 
! 
interface Ethernet0 
 no ip address
 no ip directed-broadcast 
 shutdown 
! 
interface Serial0 
 no ip address 
 no ip directed-broadcast 
 shutdown 
! 
interface Serial1 
 no ip address 
 no ip directed-broadcast 
 encapsulation x25 
 no ip mroute-cache 
 x25 address 555 
 x25 htc 10 
 x25 win 7 
 x25 wout 7 
 dspu enable-host qllc 12 
 dspu start OZDEN 
! 
interface TokenRing0 
 no ip address 
 no ip directed-broadcast 
 shutdown 
! 

Cisco 4000 (Гуд)
dspu host GOODE xid-snd 11132323 x25 123456789012345 qllc 20 interface Serial1 
! 
interface Ethernet0 
 ip address 10.48.64.17 255.255.255.0 
 no ip directed-broadcast 
 media-type 10BaseT 
! 
interface Serial0 
 no ip address 
 no ip directed-broadcast 
 shutdown 
! 
interface Serial1 
 no ip address 
 no ip directed-broadcast 
 encapsulation x25 
 no ip mroute-cache 
 x25 address 666 
 x25 htc 10 
 x25 win 7 
 x25 wout 7 
 dspu enable-host qllc 20 
 dspu start GOODE 
! 

Проверка

Этот раздел предоставляет сведения, можно использовать, чтобы подтвердить, что конфигурация активна.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show llc2 — Отображает соединения LLC2, активные в маршрутизаторе.

  • show version Сведения о версии программного обеспечения Показов.

  • show dlsw peer Dlsw Показов взаимодействует с информацией о соединении.

  • схемный элемент show dlsw — Отображает подробные данные канала DLSW.

  • show qllc последовательный 0/1 — Отображает информацию на последовательном QLLC 0/1.

  • show x25 interface последовательный 0/1 — Отображает статус линии и протокола на последовательном интерфейсе X.25 0/1.

  • show x25 route — Отображает таблицу маршрутизации X.25.

  • show x25 interface последовательный 0 — Отображает статус линии и протокола на последовательном интерфейсе X.25 0.

  • show dspu — Отображает статус функции DSPU.

  • show x25 interface последовательный 1 — Отображает статус линии и протокола на последовательном интерфейсе X.25 1.

Meatfeast
#show llc2 
.... 
Channel4/2 DTE: 4000.7507.ffff 4000.2222.0000 04 04 state NORMAL 
   V(S)=1, V??)=1, Last N??)=1, Local window=7, Remote Window=127 
   akmax=3, n2=8, 
   xid-retry timer      0/0       ack timer       0/1000 
   p timer              0/1000    idle timer   5430/10000 
   rej timer            0/3200    busy timer      0/9600 
   adm timer            0/60000   llc1 timer      0/1000 
   akdelay timer        0/100     txQ count       0/200 
   RIF: 06B0.0581.0640 
Channel4/2 DTE: 4000.7507.0000 4000.3333.0000 04 04 state NORMAL 
   V(S)=6, V??)=6, Last N??)=6, Local window=7, Remote Window=127 
   akmax=3, n2=8, 
   xid-retry timer      0/0       ack timer       0/1000 
   p timer              0/1000    idle timer   5630/10000 
   rej timer            0/3200    busy timer      0/9600 
   adm timer            0/60000   llc1 timer      0/1000 
   akdelay timer        0/100     txQ count       0/200 
   RIF: 06B0.0581.0640 

Пафос
pathos#show version 
Cisco Internetwork Operating System Software 
IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(6a), RELEASE SOFTWARE (fc1) 
Copyright ??) 1986-2001 by cisco Systems, Inc. 
Compiled Sat 01-Dec-01 22:30 by pwade 
Image text-base: 0x80008088, data-base: 0x810616B4 
pathos#show dlsw peer 
Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime 
 TCP 10.48.64.75     CONNECT        118        91  conf      0    2   0 00:32:12 
Total number of connected peers: 1 
Total number of connections:     1 
pathos#show dlsw circuit detail
Index           local addr(lsap)    remote addr(dsap)  state          uptime 
234881048       4000.2222.0000(04)  4000.7507.ffff(04) CONNECTED      00:29:50 
        PCEP: 81C25730   UCEP: 81D88528 
        Port:Se0/1          peer 10.48.64.75(2065) 
        Flow-Control-Tx  CW:20, Permitted:19; Rx CW:20, Granted:39; Op: Repeat 
        Congestion: Low(02), Flow Op: Half: 0/0 Reset 0/0 
        RIF = --no rif-- 
        Bytes:             429/453        Info-frames:           1/1 
        XID-frames:          5/4          UInfo-frames:          0/0 
        HPR saps: local 0x0, remote 0x4 
1426063385      4000.3333.0000(04)  4000.7507.0000(04) CONNECTED      00:29:49 
        PCEP: 81D081B4   UCEP: 81D108B0 
        Port:Se0/1          peer 10.48.64.75(2065) 
        Flow-Control-Tx  CW:20, Permitted:34; Rx CW:20, Granted:34; Op: Repeat 
        Congestion: Low(02), Flow Op: Half: 0/0 Reset 0/0 
        RIF = --no rif-- 
        Bytes:             554/513        Info-frames:           6/6 
        XID-frames:          5/4          UInfo-frames:          0/0 
        HPR saps: local 0x0, remote 0x4 
Total number of circuits connected: 2 
pathos#show qllc serial 0/1
Interface Serial0/1 
 vc 2 66620 
   Circuit State P4/D1, Logical Link State QLOpened 4000.3333.0000(04)->4000.7507.0000(04) 
   0 packets held 
 vc 1 55512 
   Circuit State P4/D1, Logical Link State QLOpened 4000.2222.0000(04)->4000.7507.ffff(04) 
   0 packets held 
pathos# 
pathos#show x25 interface  serial 0/1
SVC 1,  State: D1,  Interface: Serial0/1 
  Started 00:30:51, last input 00:30:50, output 00:30:50 
  Connects 55512 <--> 
   qllc 4000.2222.0000 
  Window size input: 7, output: 7 
  Packet size input: 128, output: 128 
  PS: 0  PR: 7  ACK: 6  Remote PR: 0  RCNT: 1  RNR: no 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 463/441 packets 8/7 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
SVC 2,  State: D1,  Interface: Serial0/1 
  Started 00:30:51, last input 00:30:50, output 00:30:50 
  Connects 66620 <--> 
   qllc 4000.3333.0000 
  Window size input: 7, output: 7 
  Packet size input: 128, output: 128 
  PS: 5  PR: 4  ACK: 2  Remote PR: 5  RCNT: 2  RNR: no 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 523/566 packets 13/12 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
pathos# 

Nesle
nesle#show x25 route 
  #  Match                         Substitute          Route to 
  1  input-int Serial2                                 Serial0 
  2  input-int Serial3                                 Serial0 
  3  dest 555                                          Serial2 
  4  dest 666                                          Serial3 

nesle#show x25 interface serial 0
SVC 1,  State: D1,  Interface: Serial0 
  Started 00:32:47, last input 00:32:46, output 00:32:46 
  Connects 55512 <--> 2224 from Serial2 SVC 10 
  Window size input: 2, output: 2 
  Packet size input: 128, output: 128 
  PS: 7  PR: 0  ACK: 0  Remote PR: 6  RCNT: 0  RNR: no 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 441/463 packets 7/8 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
SVC 2,  State: D1,  Interface: Serial0 
  Started 00:32:47, last input 00:32:46, output 00:32:46 
  Connects 66620 <--> 123456789012345 from Serial3 SVC 1024 
  Window size input: 2, output: 2 
  Packet size input: 128, output: 128 
  PS: 4  PR: 5  ACK: 5  Remote PR: 2  RCNT: 0  RNR: no 
  Window is closed 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 566/523 packets 12/13 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
nesle#show x25 interface serial 2 
SVC 10,  State: D1,  Interface: Serial2 
  Started 00:32:51, last input 00:32:50, output 00:32:50 
  Connects 55512 <--> 2224 to Serial0 SVC 1 
  Window size input: 2, output: 2 
  Packet size input: 128, output: 128 
  PS: 0  PR: 7  ACK: 6  Remote PR: 0  RCNT: 1  RNR: no 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 463/441 packets 8/7 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
nesle#show x25 interface serial 3 
SVC 1024,  State: D1,  Interface: Serial3 
  Started 00:32:53, last input 00:32:52, output 00:32:52 
  Connects 66620 <--> 123456789012345 to Serial0 SVC 2 
  Window size input: 2, output: 2 
  Packet size input: 128, output: 128 
  PS: 5  PR: 4  ACK: 2  Remote PR: 5  RCNT: 2  RNR: no 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 523/566 packets 13/12 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0

Намюр
namur#show dspu 
dspu host OZDEN Serial1 (QLLC) PU STATUS Active 
     FRAMES RECEIVED 8 FRAMES SENT 8 
     LUs USED BY DSPU 0 LUs ACTIVE 0 
     LUs USED BY API 0 LUs ACTIVE 0 
     LUs ACTIVATED BY HOST BUT NOT USED 0 

namur#show x25 interface serial 1 
SVC 10,  State: D1,  Interface: Serial1 
  Started 00:34:55, last input 00:34:54, output 00:34:54 
  Connects 2224 <--> 
   qllc 
  Window size input: 7, output: 7 
  Packet size input: 128, output: 128 
  PS: 7  PR: 0  ACK: 0  Remote PR: 6  RCNT: 0  RNR: no 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 441/463 packets 7/8 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
namur# 

Гуд
goode#show dspu 
dspu host GOODE Serial1 (QLLC) PU STATUS Active 
     FRAMES RECEIVED 18 FRAMES SENT 18 
     LUs USED BY DSPU 0 LUs ACTIVE 0 
     LUs USED BY API 0 LUs ACTIVE 0 
     LUs ACTIVATED BY HOST BUT NOT USED 5 

goode#show x25 interface serial 1 
SVC 1024,  State: D1,  Interface: Serial1 
  Started 00:41:25, last input 00:41:25, output 00:41:25 
  Connects 123456789012345 <--> 
   qllc 
  Window size input: 2, output: 2 
  Packet size input: 128, output: 128 
  PS: 4  PR: 5  ACK: 5  Remote PR: 2  RCNT: 0  RNR: no 
  Window is closed 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 566/523 packets 12/13 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
goode# 

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 28401