Многопротокольная коммутация по меткам (MPLS) : Механизм MPLS over ATM

MPLS через туннели VP

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Поставщик услуг обычно дает вам один или несколько туннелей виртуального тракта (VP) для соединения устройств вместе вместо физического соединения "точка-точка". Этот документ объясняет шаги, необходимые для настройки Многопротокольной коммутации по меткам (MPLS) при использовании Туннелей VP.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/10476/mpls_vptunnel-1.gif

В этой настройке поставщик услуг предоставил два Туннеля VP:

  • Один между Ischia и Capri с VPI = 3 (идентификатор виртуального тракта)

  • Один между Alcazaba и Capri с VPI = 4

Ischia и Alcazaba являются два Маршрутизатора Cisco 7200, которые выполняют Cisco Выпуск ПО IOS� 12.1 (3a) E. Capri является Мультисервисным коммутируемым маршрутизатором (MSR) Catalyst 8540, который выполняет выпуск 12.0 (10) W5 (18c). Capri является соседним узлом Протокола распределения тегов (TDP) Alcazaba и Ischia.

Примечание: Необходимо выполнить выпуск 12.0 (3) T или выше для настройки этой функции.

Конфигурации, используемые здесь, для Catalyst 8500 MSR, или LightStream 1010 и маршрутизатора.

Конфигурации

Эти конфигурации используются в данном документе:

Ischia
ip cef 
! 
interface Loopback0 
 ip address 1.1.1.1 255.255.255.0 
! 
interface ATM2/0.3 tag-switching 
 ip address 3.0.0.1 255.255.255.0 
 tag-switching atm vp-tunnel 3 
 tag-switching ip 
! 
router ospf 6 
 log-adjacency-changes 
 network 1.1.1.1 0.0.0.0 area 0 
 network 3.0.0.0 0.0.0.255 area 0 

Alcazaba
 ip cef 
! 
interface Loopback0 
 ip address 2.2.2.2 255.255.255.0 
! 
interface ATM4/0.4 tag-switching 
 ip address 4.0.0.1 255.255.255.0 
 tag-switching atm vp-tunnel 4 
 tag-switching ip 
! 
router ospf 6 
 log-adjacency-changes 
 network 2.2.2.2 0.0.0.0 area 0 
 network 4.0.0.0 0.0.0.255 area 0 

Capri
 interface ATM3/1/1 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 atm pvp 3 
 atm pvp 4 
! 
interface ATM3/1/1.3 point-to-point 
 ip address 3.0.0.2 255.255.255.0 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 tag-switching ip 
! 
interface ATM3/1/1.4 point-to-point 
 ip address 4.0.0.2 255.255.255.0 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 tag-switching ip 

Примечание: Эта конфигурация подобна стандартным конфигурациям маршрутизатора, которые можно найти здесь. Единственная разница - то, что необходимо указать к маршрутизатору использование Туннеля VP. Можно сделать это с командой tag-switching atm vp-tunnel vpi, где vpi является значением VPI, которое привязано к туннелю, который заканчивается на этом маршрутизаторе.

Примечание: Для LightStream 1010 и Catalyst 8500 MSR, необходимо настроить один или несколько постоянных виртуальных трактов (PVPs) для каждого Туннеля VP с командой atm pvp vpi. Посмотрите здесь для примера конфигурации. Подинтерфейс привязан к каждому из этих туннелей. Например, атм 3/1/1.3 интерфейс привязан к PVP=3. Необходимо настроить этот подинтерфейс с коммутацией на основе тэгов, как вы делаете на основном интерфейсе.

Проверка

Использование эти команды показа коммутации на основе тэгов для тестирования той сети работает должным образом:

  • show tag-switching tdp neighbor

  • show tag-switching atm-tdp bindings — Это показывает динамические данные меток ATM.

  • show tag-switching forwarding-table Это показывает Tag Forwarding Information Base (TFIB).

  • show tag-switching interfaces atm [int number] detail — Это показывает подробную информацию о коммутации на основе тэгов для каждого интерфейса.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Эти выходные данные являются результатом этих команд, ввел в устройства, показанные в схеме сети.

Ischia#show tag-switching tdp neighbor
Peer TDP Ident: 10.200.10.57:1; Local TDP Ident 1.1.1.1:1
        TCP connection: 3.0.0.2.11001 - 3.0.0.1.711
        State: Oper; PIEs sent/rcvd: 92/93; ; Downstream on demand
        Up time: 01:16:52
        TDP discovery sources:
          ATM2/0.3
 
Ischia#show tag-switching atm-tdp bindings 
 Destination: 4.0.0.0/24
    Headend Router ATM2/0.3 (1 hop) 3/33  Active, VCD=127
 Destination: 1.1.1.0/24
    Tailend Router ATM2/0.3 3/33 Active, VCD=127
 Destination: 2.2.2.2/32
    Headend Router ATM2/0.3 (2 hops) 3/34  Active, VCD=128
 
Ischia#show tag-switching forwarding-table 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
26     3/33        4.0.0.0/24        0          AT2/0.3    point2point  
27     3/34        2.2.2.2/32        0          AT2/0.3    point2point   
 
Ischia#show tag-switching interfaces detail 
Interface ATM2/0.3:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        Tagswitching turbo vector
        MTU = 4470
        ATM tagging:
                Tag VPI = 3 (VP Tunnel)
                Tag VCI range = 33 - 65535
                Control VC = 3/32
 
Capri#show tag-switching atm-tdp bindings 
 Destination: 4.0.0.0/24
    Tailend Switch ATM3/1/1.3 3/33 Active -> Terminating Active
 Destination: 1.1.1.1/32
    Transit ATM3/1/1.4 4/33 Active -> ATM3/1/1.3 3/33 Active
 Destination: 3.0.0.0/24
    Tailend Switch ATM3/1/1.4 4/34 Active -> Terminating Active
 Destination: 2.2.2.2/32
    Transit ATM3/1/1.3 3/34 Active -> ATM3/1/1.4 4/33 Active
 
Capri#show tag-switching tdp neighbor 
Peer TDP Ident: 1.1.1.1:1; Local TDP Ident 10.200.10.57:1
        TCP connection: 3.0.0.1.711 - 3.0.0.2.11001
        State: Oper; PIEs sent/rcvd: 95/94; ; Downstream on demand
        Up time: 01:18:49
        TDP discovery sources:
          ATM3/1/1.3
Peer TDP Ident: 2.2.2.2:1; Local TDP Ident 10.200.10.57:2
        TCP connection: 4.0.0.1.711 - 4.0.0.2.11002
        State: Oper; PIEs sent/rcvd: 93/95; ; Downstream on demand
        Up time: 01:18:22
        TDP discovery sources:
          ATM3/1/1.4
 
Capri#show tag-switching interfaces detail 
Interface ATM3/1/1.3:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        MTU = 4470
        ATM tagging: Tag VPI = 3, Control VC = 3/32
Interface ATM3/1/1.4:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        MTU = 4470
        ATM tagging: Tag VPI = 4, Control VC = 4/32

Эти выходные данные подобны стандартным выходным данным коммутации на основе тэгов, но одно важное различие - то, что это указывает к Интерфейсу туннеля VP.


Дополнительные сведения


Document ID: 10476