Асинхронный режим передачи (ATM) : Эмуляция LAN (LANE)

Эмуляция локальной сети с использованием модуля маршрутизатора ATM

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание

Связанные обсуждения сообщества поддержки Cisco

Введение

Этот документ предоставляет пример конфигурации для Эмуляции LAN (локальной сети) с помощью модуля маршрутизатора ATM (ARM).

ARM предоставляет Мультисервисный коммутируемый маршрутизатор (MSR) Catalyst 8540 и 8510 MSR с высокоскоростными сетевыми технологиями между топологиями сети Уровня 3 и Уровнем 2. Когда ARM установлен, вы больше не должны выбирать Layer 3 или технологию ATM, поскольку часто имеет место с приложениями центральной зоны и предприятием. Вместо этого у вас может быть и Уровень 3 и технологии ATM в том же шасси маршрутизатора мультисервисного ATM - коммутатора.

Catalyst 8510 или 8540 MSR, оборудованных функциональностью ARM, предоставляют мостовое соединение и маршрутизацию от Ethernet до ATM и от ATM до ATM.

ARM предлагает совместимость между блоками взаимодействия Коммутации уровня 3, используемыми в Catalyst 8510 или 8540 CSR (Коммутируемый маршрутизатор для комплекса зданий) и адаптеры для порта ATM и блоки взаимодействия, используемые в Catalyst 8510 или 8540 шасси MSR. Можно поэтому объединить Уровень 3 и адаптеры для порта ATM и блоки взаимодействия в Catalyst 8510 или 8540 шасси MSR, оборудованных ARM. Обратитесь к Основным различиям Между Cisco Catalyst 8540 CSR и Cisco Catalyst 8540 MSR узнать больше о различиях между Catalyst 8500 MSR и Catalyst 8500 CSR.

Можно установить до двух ARMs в слотах, пронумерованных от 0 до 3 и от 9 до 12 в Catalyst 8510 или 8540 шасси MSR.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Эмуляция LAN с помощью ARM была представлена на MSR Catalyst 8510 в Cisco Release12.0 программного обеспечения IOS� (10) W5 (18b) и на MSR Catalyst 8540 в Release12.0 программного обеспечения Cisco IOS (4a) W5 (11a).

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Поддерживаемые функции

ARM основывается на технологии CEF и поддерживает эти функции:

  • Протокол OSPF, протокол RIP, RIP2, протокол IGRP и расширенный IGRP.

  • Протокол ICMP Destination Unreachable и сообщения Redirect.

  • Распределение нагрузки до двух равноценных путей.

  • Concurrent Routing and Bridging (IRB).

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети. В слоте 9 существует карта ARM.

/image/gif/paws/10403/atm_arm_rt.gif

Конфигурации

Эти конфигурации используются в данном документе:

Примечание: Эти конфигурации только показывают команды, важные для LANE.

Catalyst 5500 Switch
set vlan 3 4/5
set vlan 2 4/4

Catalyst 5500 (КАРТА LANE)
hostname ATM
!
!
!
lane database ARM
 name elan2 server-atm-address 47.009181000000009021449C01.00E01E2EE861.02
 name elan3 server-atm-address 47.009181000000009021449C01.00E01E2EE861.03
!
interface Ethernet0
!
interface ATM0
 atm preferred phy B
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address
 lane config database ARM
!
interface ATM0.2 multipoint
 lane server-bus ethernet elan2
 lane client ethernet 2 elan2
!
interface ATM0.3 multipoint
 lane server-bus ethernet elan3
 lane client ethernet 3 elan3

Cisco 7000
hostname 7000a
!
interface Loopback0
 ip address 140.40.40.1 255.255.255.0
!
interface Ethernet0/3
 ip address 45.45.45.2 255.255.255.0
!
router eigrp 1
 network 45.0.0.0
 network 140.40.0.0

Cisco 7206
hostname 7206B
!
interface Loopback0
 ip address 150.50.50.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet6/0
 ip address 40.40.40.2 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 network 40.0.0.0
 network 150.50.0.0

Catalyst 8540 MSR
hostname C8540-MSR
!
interface Loopback0
 ip address 160.60.60.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM9/0/0
 no ip address
 no ip directed-broadcast
!
interface ATM9/0/0.2 multipoint
 ip address 40.40.40.1 255.255.255.0
 no ip directed-broadcast
 lane client ethernet elan2
!
interface ATM9/0/0.3 multipoint
 ip address 45.45.45.1 255.255.255.0
 no ip directed-broadcast
 lane client ethernet elan3
!
router eigrp 1
 network 40.0.0.0
 network 45.0.0.0
 network 160.60.0.0
 no auto-summary

команды "show"

В этом разделе содержатся сведения, которые можно использовать для подтверждения правильности работы конфигурации.

Выполните эти команды, чтобы протестировать, работает ли сеть должным образом:

  • ping

  • show ip route

  • show ip cef

  • карта/субплата/порт interface atm show lane le-arp [.subinterface-количество]

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Следующий пример выходных данных является результатом ввода этих команд на устройствах, показанных в схеме сети. Выходные данные показывают, что сеть функционирует исправно. Эхо-запрос идет от интерфейса ATM9/0/0.3 MSR Catalyst 8540 к интерфейсу Ethernet0/3 маршрутизатора Cisco 7000.

C8540-MSR# ping 45.45.45.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 45.45.45.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Можно также протестировать подключение между MSR Catalyst 8540 и Маршрутизатором Cisco 7200 путем прозванивания интерфейса Ethernet6/0 Cisco 7206 от Catalyst 8540. Этот пример выходных данных показывает, что эхо-запрос успешен.

C8540-MSR# ping 40.40.40.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.40.40.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Другой способ протестировать подключение путем запуска команды show ip route. MSR Catalyst 8540 имеет маршрут к сети позади Маршрутизатора Cisco 7200 адресом 150.50.0.0 — изученный IGRP — и имеет маршрут к сети позади маршрутизатора Cisco 7000 адресом 140.40.0.0 — изученный через IGRP также.

C8540-MSR# show ip route

D  140.40.0.0/16 [90/130816] via 45.45.45.2, 00:34:58, ATM9/0/0.3
   172.16.0.0/24 is subnetted, 1 subnets
   160.60.0.0/24 is subnetted, 1 subnets
C  160.60.60.0 is directly connected, Loopback0
C  40.40.40.0 is directly connected, ATM9/0/0.2
D  150.50.0.0/16 [90/130816] via 40.40.40.2, 00:29:50, ATM9/0/0.2
   45.0.0.0/24 is subnetted, 1 subnets
C  45.45.45.0 is directly connected, ATM9/0/0.3

C8540-MSR# show ip cef

40.40.40.0/24       attached               ATM9/0/0.2
40.40.40.0/32       receive
40.40.40.1/32       receive
40.40.40.2/32       40.40.40.2             ATM9/0/0.2
40.40.40.255/32     receive
45.45.45.0/24       attached               ATM9/0/0.3
45.45.45.0/32       receive
45.45.45.1/32       receive
45.45.45.2/32       45.45.45.2             ATM9/0/0.3
45.45.45.255/32     receive
140.40.0.0/16       45.45.45.2             ATM9/0/0.3
150.50.0.0/16       40.40.40.2             ATM9/0/0.2
160.60.60.0/24      attached               Loopback0
160.60.60.0/32      receive
160.60.60.1/32      receive
160.60.60.255/32    receive

Для наблюдения таблицы ARP LANE для подинтерфейсов на Catalyst 8540 выполните команду show lane le-arp .

C8540-MSR# show lane le-arp interface atm 9/0/0.2

Hardware Addr   ATM Address                                  VCD  Interface
0030.7b1e.90a8  47.009181000000009021449C01.00E01E2EE860.02  878  ATM9/0/0.2

C8540-MSR# show lane le-arp interface atm 9/0/0.3

Hardware Addr   ATM Address                                  VCD  Interface
0000.0c0d.fdcb  47.009181000000009021449C01.00E01E2EE860.03  876  ATM9/0/0.3

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Дополнительные сведения


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Document ID: 10403