Совместная работа : Cisco Unified Contact Center Express

Исправление ошибок, возникающих при создании отчета в реальном времени

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

Этот документ описывает, почему ошибка происходит, когда вы пытаетесь выполнить оперативный отчёт, и предоставляет возможные решения в Среде быстрого доступа центра контактов Cisco IP Contact Center (IPCC).

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • Cisco CallManager

  • Решения Cisco Customer Response Solutions (CRS)

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Версия Cisco CallManager 3.x и позже

  • Cisco CRS версии 3.x и выше

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Проблема

Когда вы пытаетесь выполнить оперативный отчёт из Административной веб - страницы Customer Response Application (CRA) (см. рисунок 1), сбои отчёта и это сообщение об ошибках появляются:

Unable to connect to the server
Рисунок 1 – выполненный оперативный отчёт из веб-страницы администрирования CRA

/image/gif/paws/64057/realtime_report_error_01.gif

Причина

Эта ошибка может произойти из-за одной из этих причин:

  • Параметр настройки прокси-сервера на браузере препятствует исходной связи Вызова удаленного метода (RMI).

  • Или подсистема генератора отчетов о времени реагирования (RTR) или подсистема базы данных не работают.

  • Порядок привязки сетевой интерфейсной платы (NIC) является неправильным.

Решение

Этот раздел предоставляет пошаговые процедуры для исправления проблемы, в зависимости от причины.

Решение по причине 1: неподходящий параметр настройки прокси-сервера

Можно выключить параметр настройки прокси-сервера для браузера для решения этой проблемы. Выполните следующие действия:

  1. Откройте окно браузера Internet Explorer.

  2. Выберите Tools> Internet Options.

    Интернет-Окно параметров появляется.

  3. Нажмите вкладку Connections (см. рисунок 2).

  4. Щелкните Настройка LAN.

    Рисунок 2 – интернет-окно параметров

    /image/gif/paws/64057/realtime_report_error_02.gif

    Диалоговое окно Settings Локальной сети (LAN) появляется:

    Рисунок 3 – параметры настройки локальной сети

    realtime_report_error_03.gif

  5. Анчек Использование прокси-сервер для флажка LAN в разделе Прокси-сервера (см. рисунок 3).

  6. Дважды нажмите кнопку OK.

Решение по причине 2: RTR или подсистема базы данных, не работающая

Если ошибка происходит, потому что подсистема RTR или подсистема базы данных не работают, необходимо запустить соответствующую подсистему для решения проблемы. Выполните следующие действия:

  1. Выберите System> Engine от страницы CRA Administration.

  2. Проверьте, работают ли и RTR и подсистемы базы данных.

    Если любая из подсистем не работает, запустите подсистему.

Решение по причине 3: неправильный порядок привязки NIC

Когда CRS - сервер, который выполняет Передачу голоса по IP (VoIP) монитор, имеет два установленные NIC, гарантируйте что:

  • NIC для обычного трафика CRS поверх порядка привязки TCP/IP.

  • NIC для трафика монитора VoIP связан с TCP/IP позади другого NIC.

Если сообщение об ошибках появляется из-за неправильного порядка привязки NIC, выполните эти шаги для изменения порядка привязки NIC:

  1. Нажмите Start> Settings.

  2. Щелкните правой кнопкой мыши Сеть и Подключения удаленного доступа, и выберите Open из контекстного меню.

    Окно Network и Dial-up Connections появляется (см. рисунок 4).

  3. Выберите Advanced> Advanced Settings.

    Рисунок 4 – сеть и подключения удаленного доступа

    /image/gif/paws/64057/realtime_report_error_04.gif

    Диалоговое окно Advanced Settings появляется:

    Рисунок 5 – расширенные настройки

    realtime_report_error_05.gif

  4. Выберите Local Area Connections 2 в разделе Соединений.

  5. Нажмите кнопку Move Up (см. рисунок 5).

  6. Нажмите OK для осуществления изменения.

    Новый порядок привязки NIC теперь появляется:

    Рисунок 6 – новый порядок привязки NIC

    realtime_report_error_06.gif

    Примечание: Если предыдущие решения не решают вопрос, перезапустите Node Manager CRS от служб Windows как обходной путь.

Неспособный вытянуть IPCC 7.x вебы - представления отчета

На недавно установленном сервере HDS/webview, неспособном получить данные в вебе - представлении отчета. Проблема только для Отчетов агента в реальном времени.

Решение

Проверенный Периферийная конфигурация от менеджера конфигурации и найденный, что новый HDS не был добавлен к Распределению агента (список Рабочих станций администраторов, которые получат Отчеты агента).

Добавленный новые Рабочие станции администраторов (AWs) название сайта к листу распространения. Это решило вопрос.

Страница перенавыка агента не подходит

Неспособный запустить сервис Apache. Это сообщение об ошибках получено в журнале std.out: Can't load server.xml

Решение

Эта проблема вызвана, потому что server.xml отсутствовал в C:\icm\tomcat\conf folder. Для решения вопроса завершите этот обходной путь:

  1. Создайте копию server.xml.custom файла от папки C:\icm\tomcat\conf.

  2. Переименуйте тот файл как server.xml.

  3. Запустите сервис Apache.

    После этого страница Перенавыка загружена прекрасная.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения