Cервисы организации сетевого доступа к приложениям : Cisco LocalDirector серии 400

Использование серверов FTP для балансировки нагрузки через LocalDirector без использования службы-посредника FTP

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Cisco объявила о конце продажи для Cisco LocalDirector. "Для получения дополнительной информации см. касающиеся LocalDirector 400 Series ""Уведомления об окончании срока эксплуатации и продаж"" и ""Информационные бюллетени по продуктам (End-of-Life and End-of-Sale Notices and Product Bulletins).".


Содержание


Введение

Этот документ объясняет, как сбалансировать нагрузку серверов Протокола FTP через LocalDirector без использования сервиса FTP прокси.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Проблемы и решения

Основные трудности управляющего FTP через устройства как LocalDirector происходят главным образом из-за Канала данных. Ниже приводятся два возможных сценария:

  1. FTP ПОРТА: также известный как активный FTP. Соединение в режиме передачи данных открыто портом 20 сервера порту клиента, который передают через команду PORT по управляющему канал.

  2. FTP ПРОХОДА: соединение в режиме передачи данных инициируется клиентом. Сервер передает IP-адрес и порт, с которым клиент должен открыть соединение по управляющему канал.

Сценарий 1

Проблема в сценарии количество 1, FTP ПОРТА, состоит в том, что LocalDirector должен быть проинструктирован для создания записи потока для инициируемого трафика внутреннего сервера.

Как правило, решение в этом сценарии состоит в том, чтобы выполнить статическую команду. Для трафика FTP, однако, LocalDirector применяет его автоматически.

Сценарий 2

Существует две проблемы со сценарием количество 2, FTP ПРОХОДА. Первая проблема состоит в том, что балансировщик загрузки должен быть проинструктирован для ожидания соединения от клиента к порту TCP - получателя, который является другим от тех настроенных на виртуальных интерфейсах.

Решение в этой проблеме состоит в том, чтобы создать non портовая конфигурация такой как 172.17.241.254:0:0:tcp. При помощи никакого портового решения, LocalDirector принимает и создает потоки для каждого Уровня 4 (L4) протокол, которые поражают виртуальный IP - адрес. С FTP на LocalDirector, однако, это не необходимо, даже с портовой конфигурацией такой как 172.17.241.254:21:0:tcp.

LocalDirector продолжает изучать сеансы управления FTP для прерывания команд, которые инициируют пассивную Передачу данных.

Вторая проблема состоит в том, что LocalDirector должен заботиться о трансляции IP-адреса, передаваемого сервером клиенту в режиме FTP ПРОХОДА.

Это сделано автоматически, даже без сервиса прокси FTP. IP-адрес и порт, с которым должен будет соединиться клиент, показывают во время сеанса FTP каждый раз, когда команда, которая инициирует Соединение в режиме передачи данных, выполнена, как показано ниже.

> 227 Entering Passive Mode (172,17,241,254,95,57) 

Вы видите, что адрес возвратился, внешний VIP а не внутренний действительный адрес. Это означает, что LocalDirector продолжает наблюдать информационное наполнение пакетов контрольного соединения. Посмотрите приведенный ниже рисунок для получения дополнительной информации.

lb_ftp_servers.gif

Пример вывода команды предоставлен ниже.

[OK] 
localdirector# sho conf 
: Saved 
: LocalDirector 420 Version 4.2.2 
: Uptime is 0 weeks, 0 days, 3 hours, 0 minutes, 35 seconds 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 10baset 
interface ethernet 1 10baset 
interface ethernet 2 100basetx 
interface ethernet 3 100basetx 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure? 0 
no secure? 1 
no secure? 2 
no secure? 3 
no ping-allow 0 
no ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 172.17.241.11 255.255.255.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 172.17.241.27 
no failover 
failover hellotime 30 
password dfeaf10390e560aea745ccba53e044ed encrypted 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
virtual 172.17.241.254:21:0:tcp is 
real 172.17.241.126:21:0:tcp is 
bind 172.17.241.254:21:0:tcp 172.17.241.126:21:0:tcp 

Ниже журнал сеанса FTP.

smarsill@bru-cse-126% ftp 172.17.241.254 
Connected to 172.17.241.254. 
220 CISCO FTP server (Version wu-2.6.1(1) Wed Aug 9 05:54:50 EDT 2000) ready. 
Name (172.17.241.254:smarsill): cisco 
331 Password required for cisco. 
Password: 
230 User cisco logged in. 
Remote system type is UNIX. 
Using binary mode to transfer files. 
ftp> ls 
227 Entering Passive Mode (172,17,241,254,95,57) 
150 Opening ASCII mode data connection for /bin/ls. 
total 24 
-rw-------??? 1 cisco??? cisco??????? 4088 Sep? 3 11:55 .bash_history 
-rw-r--r--??? 1 cisco??? cisco????????? 24 Feb 16? 2001 .bash_logout 
-rw-r--r--??? 1 cisco??? cisco???????? 230 Feb 16? 2001 .bash_profile 
-rw-r--r--??? 1 cisco??? cisco???????? 124 Feb 16? 2001 .bashrc 
-rw-r--r--??? 1 cisco??? cisco???????? 688 Feb 16? 2001 .emacs 
-rw-r--r--??? 1 cisco??? cisco??????? 3651 Feb 16? 2001 .screenrc 
226 Transfer complete. 
ftp> pass 
Passive mode off. 
ftp> ls 
200 PORT command successful. 
150 Opening ASCII mode data connection for /bin/ls. 
total 24 
-rw-------??? 1 cisco??? cisco??????? 4088 Sep? 3 11:55 .bash_history 
-rw-r--r--??? 1 cisco??? cisco????????? 24 Feb 16? 2001 .bash_logout 
-rw-r--r--??? 1 cisco??? cisco???????? 230 Feb 16? 2001 .bash_profile 
-rw-r--r--??? 1 cisco??? cisco???????? 124 Feb 16? 2001 .bashrc 
-rw-r--r--??? 1 cisco??? cisco???????? 688 Feb 16? 2001 .emacs 
-rw-r--r--??? 1 cisco??? cisco??????? 3651 Feb 16? 2001 .screenrc 
226 Transfer complete. 
ftp> 

Ниже выходные данные netstat-n команда после того, как была выполнена последняя команда.

cisco@localhost cisco]$ netstat -n 
Active Internet connections (w/o servers) 
Proto Recv-Q Send-Q Local Address?????????? Foreign Address???????? State 
tcp??????? 0????? 0 172.17.241.126:20?????? 144.254.3.201:40411???? TIME_WAIT?? 

!--- Data Active expired.
 
tcp??????? 0????? 0 172.17.241.126:24377??? 144.254.3.201:40410???? TIME_WAIT?? 

!--- Data Passive expired.

tcp??????? 0????? 0 172.17.241.126:21?????? 144.254.3.201:40408???? ESTABLISHED 

!--- Control.

tcp??????? 0??? 126 172.17.241.126:23?????? 144.254.3.201:40220???? ESTABLISHED 

!--- Telnet session. 


Дополнительные сведения


Document ID: 4068