Протокол IP : Serial Tunnel (STUN)

Пример конфигурации туннелирования асинхронных протоколов в BSTUN

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Выделенный и собственные протоколы асинхронной связи непосредственно не поддерживаются ни с каким внедрением Cisco. Однако Блочный Последовательный Туннель (BSTUN) асинхронное общее туннелирование может предоставить ограниченную возможность для туннелирования этих данных.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в этом документе, касаются следующих версий программного обеспечения и оборудования:

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

Асинхронные протоколы, такие как TC500 Диболда для передачи с денежными ATM или туннелирующим HyperTerminal от ПК до другого ПК не имеют никакой непосредственной поддержки или реализации в Cisco IOS �. Поскольку название подразумевает, это - общее внедрение, которое имеет некоторую возможность нести этот тип данных. Это известно как async-generic BSTUN и требует IBM или набора функций IOS Предприятия.

Async-generic BSTUN был первоначально разработан для переноса однонаправленных, небольших пакетов с устройств безопасности на устройство создания отчетов. Async-generic BSTUN, однако, может нести интерактивный трафик. В сущности эта реализация подключает собственному компоненту, асинхронным устройствам и получает данные в последовательный интерфейс и затем в буфер памяти. Периодически, буферизированные данные тогда инкапсулируются в пакет TCP и передаются Одноранговому телефонному соединению BSTUN, где это декапсулировано и передано асинхронному устройству, подключенному на удаленном узле.

Async-generic BSTUN является упрощенной работой. Маршрутизатор не имеет никакой возможности, которая будет настроена для ознакомлений с запуском кадра (SOF), концом кадра (EOF) или схемой адресации асинхронного протокола. Если адресная часть кадра находится в каждом кадре, один байт длиной, и является одинаковой позицией в кадре, то команда asp address-offset может быть выполнена для определения к маршрутизатору, где найти адрес в кадре, как exampled позже в этом документе. Во многих ситуациях, однако, не будет адресной части, содержавшей в протокол. Не знание о конструкции асинхронного протокола означает, что маршрутизатор неспособен различить конкретные пакеты от других, если они не разделены периодом времени. Приблизительно 40 мс требуются между кадрами в 9600 бит/с предоставить необходимый объем маршрутизатора времени для надлежащего различения одного пакета от другого. Маршрутизатор просто видит поток данных в, он - последовательный интерфейс и затем обертывает эти данные в TCP. Нет никакой возможности, маршрутизатор в состоянии, принимают решения о маршрутизации основанный на любом отдельном аспекте входящего фрейма. Таким образом async-generic BSTUN должен быть физически разработан так только один атташе устройства в интерфейсе последовательного маршрутизатора. Нет никакой функции локального подтверждения. BSTUN поддерживает local-ack для Протокола синхронной передачи двоичных данных IBM3270 только.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме.

/image/gif/paws/41983/bstun_41983-A.gif

Оба PC используют HyperTerminal Microsoft, или вместо одного из PC могло быть соединение в консольный порт маршрутизатора Cisco. Эти примеры конфигурации представляют конфигурации, внедренные от маршрутизаторов, не ранее настроенных в лабораторном сценарии, и показывают соответствующие части необходимой конфигурации. Они настроены, приняв 9600 бит/с, 8N1 соединение.

Конфигурации

Этот документ использует конфигурации, показанные в этом разделе.

  • Магистральный маршрутизатор (Маршрутизатор Cisco 1700)

  • Удаленный маршрутизатор (маршрутизатор Cisco 3640)

  • Магистральный маршрутизатор (Маршрутизатор Cisco 3600)

  • Удаленный #1 (маршрутизатор Cisco 1700)

  • Удаленный #2 (маршрутизатор Cisco 1700)

Магистральный маршрутизатор (Маршрутизатор Cisco 1700)
main#show running-config 
Building configuration...
.
.
.
ip subnet-zero
bstun peer-name 10.1.1.1
bstun protocol-group 1 async-generic
interface loopback0
   ip address 10.1.1.1 255.0.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 1
   bstun route all tcp 30.1.1.1
interface serial1
   ip address 20.1.1.1 255.0.0.0
ip route 0.0.0.0 0.0.0.0 20.1.1.2
line 1
   speed 9600
   databits 8
   parity none
   stopbits 1
.
.
.
!
end

Удаленный маршрутизатор (маршрутизатор Cisco 3640)
REMOTE#show running-config 
Building configuration...
bstun peer-name 30.1.1.1.
bstun protocol-group 1 async-generic
interface loopback 0
   ip address 30.1.1.1
interface ethernet1/0
   shutdown
interface serial 2/0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 1
   bstun route all tcp 10.1.1.1
   
interface serial 2/1
   ip address 20.1.1.2 255.0.0.0
ip route 0.0.0.0 0.0.0.0 20.1.1.1
line 65
   speed 9600
   parity none
   databits 8
   stopbits 1
.
.
!
end

Примечание: При запуске команды physical-layer async на последовательном интерфейсе линия TTY назначена на последовательный интерфейс. Это определение линии TTY - то, где настроены биты данных, stopbits, паритет и скорость. Это - формула для определения, какая линия соответствует который последовательный интерфейс.

line# = (slot# x 32) + interface# + 1

Выставочный подвид в выходных данных конфигурации Удаленного маршрутизатора указывает в крайнем справа столбце на номер соответствующих линий. Serial2/0 представлен с методической точностью 65, и физические определения для этой ссылки настроены под линией 65

REMOTE#sh line 
   Tty Typ     Tx/Rx        A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int 
*    0 CTY                      -        -          -        -        -          0           0         0/0           - 
    65 TTY   9600/9600  -        -          -        -        -      0           0         0/0     Se2/0 
   129 AUX 9600/9600  -        -          -        -        -        0           0         0/0       - 
   130 VTY                     -        -          -        -        -          0           0         0/0       - 
   131 VTY                     -        -          -        -        -          0           0         0/0       - 
   132 VTY                     -        -          -        -        -          0           0         0/0       - 
   133 VTY                     -        -          -        -        -          0           0         0/0       - 
   134 VTY                     -        -          -        -        -          0           0         0/0       - 

Line(s) not in async mode -or- with no hardware support: 
1-64, 66-128 

В этом сценарии Тандем связывается с удаленными устройствами ATM. В этом примере конфигурации асинхронный протокол выполняет 4800 7E2, протокол и Магистральный маршрутизатор, связанный с TANDEM, являются маршрутизатором серии "3600" к удаленным маршрутизаторам серии "1700". Посмотрите эту схему сети.

bstun_41983-B.gif

Магистральный маршрутизатор (Маршрутизатор Cisco 3600)
main#show running-config 
Building configuration...
bstun peer-name 10.1.1.1.
bstun protocol-group 1 async-generic
bstun protocol-group 2 async-generic
interface loopback 0
   ip address 10.1.1.1
interface serial1/0
   encapsulation frame-relay
interface serial 1/0.1 point-to-point
   ip address 20.1.1.1 255.255.255.0
   frame-relay interface-dlci 100
interface serial 1/0.2 point-to-point
   ip address 20.2.1.1 255.255.255.0
   frame-relay interface-dlci 200
interface serial 2/0
   physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 1
   bstun route all tcp 30.1.1.1
   
interface serial 2/1
 physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 2
   bstun route all tcp 30.2.1.1
   
ip route 30.2.1.0 255.255.0.0 20.2.1.2
ip route 0.0.0.0 0.0.0.0 20.1.1.2
line 65
   speed 4800
   parity even
   databits 7
   stopbits 1
.
line 66
   speed 4800
   parity even
   databits 7
   stopbits 1
.
!
end

Удаленный #1 (маршрутизатор Cisco 1700)
REMOTE1#show running-config 
Building configuration...
bstun peer-name 30.1.1.1
bstun protocol-group 1 async-generic
interface loopback0
   ip address 30.1.1.1 255.255.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 1
   bstun route all tcp 10.1.1.1
interface serial1
   encapsulation frame-relay
interface serial1.1 point-to-point
   ip address 20.1.1.2 255.255.255.0
   frame-relay interface-dlci 100
ip route 0.0.0.0 0.0.0.0 20.1.1.1
line 1
   speed 4800
   databits 7
   parity even
   stopbits 2
.
.
.
!
end

Удаленный #2 (маршрутизатор Cisco 1700)
REMOTE2#show running-config
Building configuration...
bstun peer-name 30.2.1.1
bstun protocol-group 2 async-generic
interface loopback0
   ip address 30.2.1.1 255.255.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 2
   bstun route all tcp 10.1.1.1
interface serial1
   encapsulation frame-relay
interface serial1.1 point-to-point
   ip address 20.2.1.2 255.255.255.0
   frame-relay interface-dlci 100
ip route 0.0.0.0 0.0.0.0 20.2.1.1
line 1
   speed 4800
   databits 7
   parity even
   stopbits 2
.
.
.
!
end

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Когда команда bstun route all tcp выполнена, BSTUN получает пакет в последовательный интерфейс, инкапсулирует его и передает этот пакет TCP к удаленному маршрутизатору. Пакет TCP получен в удаленном маршрутизаторе и декапсулирован. Данные отосланы на последовательном интерфейсе. Если это соединение не работает, входящие данные должны сначала быть проверены с debug asp packet. Вы видите данные, полученные маршрутизатором на последовательном интерфейсе. Так как маршрутизатор не имеет никакого построения протокола и варьируется согласно асинхронному протоколу, пример отладки не предоставлен. Поток данных, замеченный маршрутизатором, должен совпасть с тем, что передается устройством. Если это не совпадает, более, чем вероятный, скорость, биты данных, паритет, или stopbits не настроен для соответствия с устройством. Если никакие данные не получены, это может иметь место также.

Если данные получены на последовательном интерфейсе, выполните команду show bstun, чтобы показать, открыто ли соединение или закрыто. Открытое состояние с только переданными пакетами указывает, что TCP передается удаленному Одноранговому телефонному соединению BSTUN. На этом этапе эхо - тест (ping test) от IP-адреса локального BSTUN peer-name к удаленному IP-адресу BSTUN peer-name проверяет, настроен ли IP и работающий должным образом. Если проверка ping успешна, то в удаленном, выполните команду debug asp packet, чтобы определить, получен ли пакет и передан на последовательный интерфейс к асинхронному устройству.

Выполните эти шаги, чтобы найти и устранить неисправность.

  1. Проверьте, что данные получены в узловой маршрутизатор с командой debug asp packet.

  2. Гарантируйте возможность подключения с помощью IP-адреса эхо-запросами определения источника эхо - теста (ping test) от IP-адреса bstun peer-name до удаленного IP-адреса удаленного BSTUN peer-name.

  3. В удаленном проверьте, что пакеты переданы к удаленному устройству с командой debug asp packet.

  4. Если асинхронному протоколу действительно содержали адрес в пакетах, переданных к маршрутизатору, это может быть выгодно для запуска команды asp offset-address под интерфейсом с соответствующим номером байта, соответствующим туда, где адрес содержится в пакете. Значение по умолчанию для этого 0. Например, если пакет является 01C1ABCDEF, где C1 является адресом, последовательный интерфейс может быть настроен с командой asp offset-address 01. В некоторых случаях это позволяет маршрутизатору определять пакет и увеличивает вероятность, что маршрутизатор обрабатывает данные как обрамленный пакет и не так же, как поток данных.


Дополнительные сведения


Document ID: 41983