Технологии коммутируемого доступа в сеть : "Технология ISDN, CAS"

Проверка подлинности ISDN и обратный вызов с ID вызывающей стороны

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Аутентификация, основанная на идентификаторе вызывающего абонента, обеспечивает большую степень безопасности благодаря тому, что при аутентификации удаленных клиентов используются не только идентификатор пользователя и пароль, но и место инициации соединения.

Предварительные условия

Требования

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

Этот документ сначала объясняет другие значения для команды dialer caller (кроме ее использования для обратного вызова), когда используется на интерфейсе профиля DDR, а не интерфейсе группы импульсного набора номера.

В последнем случае это - команда экранирования, аналогичная вызывающему абонент ISDN на интерфейсе ISDN. В прежнем случае это - команда, которая предоставляет механизм для привязки входящих вызовов с корректным профилем DDR на основе номера вызывающего абонента, который представлен во входящем сообщении SETUP Q.931. Если физический интерфейс настроен для проверки подлинности PPP, сбой для соответствия с представленным номером вызывающей стороны с номером вызывающей стороны в номеронабирателе на профиле DDR не обязательно заставляет вызов быть отклоненным как несвязываемый. Можно также совпасть с именем хоста, которому предоставляют, с настроенным значением dialer remote-name для привязывания этого основания. Это вызвано тем, что привязка на основе представленного номера вызывающей стороны не является единственным возможным критерием для успешного, связывают. См. Настройку и Профили DDR Устранения проблем для получения дополнительной информации о привязке и профили DDR.

От Cisco Выпуск ПО IOS� 12.0 (7) T и позже, удалите проверку подлинности PPP из физического интерфейса, чтобы быть в состоянии экранировать вызовы исключительно на основе номера вызывающего абонента. Вызовы, для которых маршрутизатор не может найти соответствующее значение вызывающей программы набора номера, в таких случаях отклоняются как несвязываемые. Если вы хотите должным образом аутентифицировать эти вызовы, можно использовать PAP или CHAP для настройки проверки подлинности PPP на интерфейсе номеронабирателя.

Первоначальный вызов отклонен (не отвеченный) с параметром обратного вызова, добавленным к аутентификации номера вызывающего абонента. Однако обратный вызов инициируется к вызывающему номеру для создания соединения. Можно использовать обратный вызов для:

  • Консолидация и централизация выставления телефонных счетов

  • Снижение себестоимости на междугородных телефонных разговорах

  • Контроль доступа

Этот пример конфигурации иллюстрирует использование команды dialer caller number [callback], чтобы настроить экранирование идентификатора вызывающего абонента и дополнительно включить обратный вызов идентификатора вызывающего абонента ISDN для DDR профиля DDR. Можно также использовать эту команду для унаследованного профиля DDR. Эта команда настраивает программное обеспечение Cisco IOS, чтобы принять или отклонить вызов ISDN на основе количества PSTN вызывающей стороны. Например, команда dialer caller 1234 позволяет маршрутизатору принимать вызов ISDN с вызывающим номером 1234.

Примечание: Эта конфигурация требует, чтобы Telco (телефонная компания) передал информацию об идентификаторе вызывающего абонента к маршрутизатору или серверу доступа. Если вы включаете экранирование идентификатора вызывающего абонента, но не имеете информации об идентификаторе вызывающего абонента переданной к маршрутизатору, никакие вызовы не приняты.

См. ISDN Caller ID Callback Настройки для получения дополнительной информации о предварительных условиях и других дополнительных функциях, доступных с Аутентификацией Caller ID Вызывающего абонент ISDN и обратным вызовом.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Примечание: Эти конфигурации являются усеченными для отображения только связанных сведений.

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/15925/ISDN_3Rt.gif

Конфигурации

Эти конфигурации используются в данном документе:

В этом сценарии маршрутизаторы 2 и 3 оба инициируют вызовы DDR к маршрутизатору 1. Маршрутизатор 1 аутентифицирует оба маршрутизатора 2 и 3 исключительно на основе идентификатора вызывающего абонента. Маршрутизатор 1 настроен к осуществлению обратного вызова маршрутизатора 2, но не к осуществлению обратного вызова маршрутизатора 3.

Совет: Выберите соответствующие разделы конфигурации для настройки или экранирования идентификатора вызывающего абонента или функции обратного вызова по номеру вызывающего абонента, но не обоих. Например, схема показывает, что для обратного вызова нужна конфигурация маршрутизатора 2 и маршрутизатор 1. Однако выберите только конфигурацию интерфейса программы для набора номера, привязанную к маршрутизатору 2 (это ясно отмечено в interface Dialer 1), так как маршрутизатор 1 выполняет обе задачи.

Маршрутизатор 1
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
isdn switch-type basic-net3
!
interface Loopback0
ip address 10.0.0.1 255.255.255.0
!
interface BRI0
no ip address
dialer pool-member 1

!--- BRI 0 is a member of dialer pool 1 which is defined 
!--- under interface Dialer 1.

isdn switch-type basic-net3
!
interface Dialer1

!---  DDR dialer interface to call Router 2.

description for Router2
ip unnumbered Loopback0
encapsulation ppp
dialer pool 1

!--- Interface BRI 0 is a member of dialer pool 1.

dialer enable-timeout 2

!--- The time (in seconds) to wait before initiating callback.

dialer string 6121  

!--- This number is used to call back Router 2.

dialer caller 6121 callback

!--- Permits calls from 6121 and initiates callback 
!--- to the same number.
 
dialer-group 1

!--- Use dialer-list 1 to define interesting traffic.

!
interface Dialer2

!--- This interface is used to authenticate calls from Router 3.
!--- (Callback is NOT initiated to Router 3.)

description for Router3
ip unnumbered Loopback0
encapsulation ppp
dialer pool 1

!--- Interface BRI 0 is a member of dialer pool 1.

dialer caller 6101

!--- Permit calls from number 6101.

dialer-group 1

!--- Use dialer-list 1 to define interesting traffic.

!
dialer-list 1 protocol ip permit

!--- Define IP as interesting traffic.

Router-2
version 12.1
service timestamps debug datetime msec
service timestamps log datetime ms
!
hostname Router2
!
isdn switch-type basic-net3
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface Dialer1
ip address 10.0.0.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 6122

!--- The number to dial for Router 1 
!--- (which initiates a callback).

dialer caller 6122

!--- Accept calls from 6122 (Router 1).

dialer-group 1
no cdp enable
!
dialer-list 1 protocol ip permit

Маршрутизатор 3
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router3
!
isdn switch-type basic-net3
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface Dialer1
ip address 10.0.0.3 255.255.255.0
dialer pool 1
encapsulation ppp
dialer string 6122

!--- The number to dial for Router 1.

dialer-group 1
no cdp enable
!
dialer-list 1 protocol ip permit

Примечание: Клиентский маршрутизатор набирает сервер обратного вызова в большинстве сценариев обратного вызова. Эти два маршрутизатора тогда выполняют согласование о параметрах ответного вызова. Сервер разъединяет вызов и инициирует обратный вызов. Вызывающая сторона могла бы разместить немного последовательных исходящих вызовов в сервер при ожидании сервера к обратному вызову во время интервала между отключением исходного вызова и обратным вызовом. Это - обычная работа DDR, потому что клиент обнаруживает, что отказавший первоначальный вызов и не знает, что обратный вызов происходит.

Выполните команду dialer redial на вызывающей стороне для предотвращения клиента от постоянного набора номера сервера обратного вызова. Это подавляет дополнительные исходящие вызовы к серверу во время ожидания обратного вызова. Вызовы подавляются, пока не истечет заранее установленное время. Например, если интервал повторного набора программы набора номера составляет 15 секунд, клиент ждет 15 секунд прежде, чем инициировать повторный набор. Обратный вызов завершен, и клиент не должен не набирать снова в течение того времени.

См. Таймеры повторного набора Настройки После Сбоев при попытке обратного вызова для получения дополнительной информации о реализации dialer redial.

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

команды "show"

Некоторые команды show поддерживаются OIT, который позволяет вам просматривать аналитику выходных данных команды show.

  • show isdn active — Отображает информацию о текущих вызовах и предоставляет сведения об обоих текущих входящих и исходящих вызовах ISDN.

  • show users – отображает сведения об активных линиях коммутатора. Можно также использовать команду show caller, если версия Cisco IOS поддерживает ее.

  • show dialer- Отображает общую диагностическую информацию об интерфейсах, настроенных для DDR.

Образец команды show output

Router1#show isdn active

---------------------------------------------------------------------------
ISDN ACTIVE CALLS
---------------------------------------------------------------------------
Call  Calling   Called    Remote  Seconds Seconds Seconds Charges
Type  Number    Number    Name    Used    Left    Idle    Units/Currency
---------------------------------------------------------------------------
Out              6121     6121       24      96      23      0
In       6101             6101        7     113       6
---------------------------------------------------------------------------

Обратите внимание, что выполняется один входящий и один исходящий вызовы. Исходящий вызов к номеру 6121, который соответствует маршрутизатору 2. Входящий вызов от 6101, который соответствует маршрутизатору 3. Также обратите внимание, что номер определяет удаленные маршрутизаторы в Удаленном Поле имени, а не названии, так как не настроена проверка подлинности PPP.

Router1#show user

Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
BR0:1                   Sync PPP             00:00:33   PPP: 10.0.0.2
BR0:2                   Sync PPP             00:00:15   PPP: 10.0.0.3
Interface  User      Mode                     Idle Peer Address

Заметьте, что один B-канал используется для соединения с маршрутизатором 2, в то время как другой B-канал соединяется с маршрутизатором 3. Проверьте, что IP-адреса совпадают с настроенными на маршрутизаторах 2 и 3.

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Команды для устранения неполадок

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

  • debug dialer [события | пакеты]

  • debug isdn event

  • debug isdn q931

  • отладка ppp согласования — Отображает сведения по трафику и обменам PPP во время согласования компонентов PPP, включая протокол управления каналом (LCP), проверку подлинности и протокол управления сетью (NCP). Процесс успешного согласования PPP состоит в том, что сначала выясняется состояние LCP, затем проводится аутентификация и, наконец, согласовывается NCP.

См. Использование Команды show isdn status для Устранения проблем BRI, если вы встречаетесь с Проблемами нижнего уровня ISDN.

Пример результата отладки

Router1#show debug
     Dial on demand: Dial on demand events debugging is on 
     PPP: PPP protocol negotiation debugging is on 
     ISDN: ISDN Q931 packets debugging is on

Этот раздел отображает выходные данные отладки от маршрутизатора 1 и показывает вызывающий маршрутизатор маршрутизатора 2 1. Маршрутизатор 1 тогда инициирует обратный вызов к маршрутизатору 2 и устанавливает соединение.

Примечание: Некоторые из этих линий выходных данных отладки разделены на составные строки для печатей.

*Mar  1 04:50:34.782: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x0B
*Mar  1 04:50:34.790:         Bearer Capability i = 0x8890
*Mar  1 04:50:34.798:         Channel ID i = 0x89
*Mar  1 04:50:34.802:         Calling Party Number i = 0xA1, '6121
',Plan:ISDN, Type:National

!--- Calling party information is provided by the switch.

*Mar  1 04:50:34.818:         Called Party Number i = 0xC1, '6122',Plan:ISDN,
   Type:Subscriber(local)

!--- Called party information is provided by the switch.

*Mar  1 04:50:34.838: ISDN BR0: Event: Received a DATA call from 6121 on
   B1at 64 Kb/s
*Mar  1 04:50:34.842: BR0:1 DDR: Caller id 6121 matched to profile  

!--- The ISDN call (from Router 2) is authenticated.

*Mar  1 04:50:34.842: Di1 DDR: Caller id Callback server starting to  6121

!--- Initiates callback to 6121.
 
*Mar  1 04:50:34.866: ISDN BR0: TX ->  RELEASE_COMP pd = 8  callref = 0x8B
*Mar  1 04:50:34.870:         Cause i = 0x8095 - Call rejected
*Mar  1 04:50:36.778: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x0C
*Mar  1 04:50:36.786:         Bearer Capability i = 0x8890
*Mar  1 04:50:36.794:         Channel ID i = 0x89
*Mar  1 04:50:36.798:         Calling Party Number i = 0xA1, '6121',Plan:ISDN,
   Type:National
*Mar  1 04:50:36.814:         Called Party Number i = 0xC1, '6122',Plan:ISDN,
   Type:Subscriber(local)
*Mar  1 04:50:36.834: ISDN BR0: Event: Received a DATA call from 6121 on B1at
   64 Kb/s
*Mar  1 04:50:36.838: BR0:1 DDR: Caller id 6121 matched to profile
*Mar  1 04:50:36.838: Di1 DDR: callback to 6121 already started
*Mar  1 04:50:36.862: ISDN BR0: TX ->  RELEASE_COMP pd = 8  callref = 0x8C
*Mar  1 04:50:36.866:         Cause i = 0x8095 - Call rejected

!--- Reject call (then initiate callback).

*Mar  1 04:50:36.878: DDR: Callback timer expired

!--- The timer is configured with the dialer enable-timeout command.

*Mar  1 04:50:36.878: Di1 DDR: beginning callback to  6121
*Mar  1 04:50:36.882: BR0 DDR: rotor dialout [priority]
*Mar  1 04:50:36.882: BR0 DDR: Dialing cause Callback return call

!--- The dialing cause is callback.

*Mar  1 04:50:36.886: BR0 DDR: Attempting to dial 6121

!--- Dialing 6121 (Router 2).

*Mar  1 04:50:36.902: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x0E
*Mar  1 04:50:36.906:         Bearer Capability i = 0x8890
*Mar  1 04:50:36.914:         Channel ID i = 0x83
*Mar  1 04:50:36.922:         Called Party Number i = 0x80, '6121',Plan:Unknown,
   Type:Unknown
*Mar  1 04:50:36.998: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x8E
*Mar  1 04:50:37.002:         Channel ID i = 0x89
*Mar  1 04:50:37.402: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x8E
*Mar  1 04:50:37.418: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x0E
*Mar  1 04:50:37.426: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

!--- The interface is up.

*Mar  1 04:50:37.446: DDR: Freeing callback to  6121
*Mar  1 04:50:37.446: BRI0:1: interface must be fifo queue, force FIFO
*Mar  1 04:50:37.450: BR0:1 PPP: Phase is DOWN, Setup
*Mar  1 04:50:37.454: BR0:1 PPP: Treating connection as a callout
*Mar  1 04:50:37.454: BR0:1 PPP: Phase is ESTABLISHING, Active Open
*Mar  1 04:50:37.462: BR0:1 LCP: O CONFREQ [Closed] id 1 len 10
*Mar  1 04:50:37.462: BR0:1 LCP:    MagicNumber 0xE1288054 (0x0506E1288054)
*Mar  1 04:50:37.466: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1
*Mar  1 04:50:37.478: BR0:1 PPP: Treating connection as a callout
*Mar  1 04:50:37.486: BR0:1 LCP: I CONFREQ [REQsent] id 2 Len 10
*Mar  1 04:50:37.490: BR0:1 LCP:    MagicNumber 0x000F4499 (0x0506000F4499)
*Mar  1 04:50:37.494: BR0:1 LCP: O CONFACK [REQsent] id 2 Len 10
*Mar  1 04:50:37.498: BR0:1 LCP:    MagicNumber 0x000F4499 (0x0506000F4499)
*Mar  1 04:50:37.502: BR0:1 LCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:37.506: BR0:1 LCP:    MagicNumber 0xE1288054 (0x0506E1288054)
*Mar  1 04:50:37.506: BR0:1 LCP: State is Open

!--- The LCP negotiation is complete.

*Mar  1 04:50:37.510: BR0:1 PPP: Phase is UP
*Mar  1 04:50:37.514: BR0:1 IPCP: O CONFREQ [Closed] id 1 Len 10
*Mar  1 04:50:37.518: BR0:1 IPCP:    Address 10.0.0.1 (0x03060A000001)
*Mar  1 04:50:37.522: BR0:1 IPCP: I CONFREQ [REQsent] id 2 Len 10
*Mar  1 04:50:37.526: BR0:1 IPCP:    Address 10.0.0.2 (0x03060A000002)
*Mar  1 04:50:37.530: BR0:1 IPCP: O CONFACK [REQsent] id 2 Len 10
*Mar  1 04:50:37.534: BR0:1 IPCP:    Address 10.0.0.2 (0x03060A000002)
*Mar  1 04:50:37.550: BR0:1 IPCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:37.550: BR0:1 IPCP:    Address 10.0.0.1 (0x03060A000001)

!--- IPCP address negotiation.

*Mar  1 04:50:37.554: BR0:1 IPCP: State is Open
*Mar  1 04:50:37.562: BR0:1 DDR: dialer protocol up
*Mar  1 04:50:37.570: Di1 IPCP: Install route to 10.0.0.2

!--- Route to Router 2 is installed.

*Mar  1 04:50:38.510: %LINEPROTO-5-UPDOWN: Line protocol on InterfaceBRI0:1,
   changed state to up

В этом разделе, вызывающий маршрутизатор маршрутизатора 3 примеров отладочных выходных данных 1. Маршрутизатор 3 тогда аутентифицируется на основе информации об идентификаторе вызывающего абонента и связан с маршрутизатором 1 без обратного вызова.

*Mar  1 04:50:54.230: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x0D

!--- Receive a call setup.

*Mar  1 04:50:54.238:         Bearer Capability i = 0x8890
*Mar  1 04:50:54.242:         Channel ID i = 0x8A
*Mar  1 04:50:54.250:         Calling Party Number i = 0xA1, '6101',Plan:ISDN,
   Type:National

!--- Calling party (Router 3) information is provided by the switch.

*Mar  1 04:50:54.266:         Called Party Number i = 0xC1, '6122',Plan:ISDN,
   Type:Subscriber(local)

!--- Called party (Router 1) information is provided by the switch.

*Mar  1 04:50:54.286: ISDN BR0: Event: Received a DATA call from 6101 on B2at
   64 Kb/s
*Mar  1 04:50:54.290: BR0:2 DDR: Caller id 6101 matched to profile 

!--- The ISDN call (from Router 3) is authenticated.

*Mar  1 04:50:54.290: BRI0:2: interface must be FIFO queue, force FIFO
*Mar  1 04:50:54.294: BR0:2 PPP: Phase is DOWN, Setup
*Mar  1 04:50:54.298: %DIALER-6-BIND: Interface BR0:2 bound to profile Di2

!--- The interface is bound to interface Dialer 2.

*Mar  1 04:50:54.314: ISDN BR0: TX ->  CALL_PROC pd = 8  callref = 0x8D
*Mar  1 04:50:54.318:         Channel ID i = 0x8A
*Mar  1 04:50:54.326: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up
*Mar  1 04:50:54.350: BR0:2 PPP: Treating connection as a callin
*Mar  1 04:50:54.354: BR0:2 PPP: Phase is ESTABLISHING, Passive Open
*Mar  1 04:50:54.354: BR0:2 LCP: State is Listen
*Mar  1 04:50:54.630: ISDN BR0: TX ->  CONNECT pd = 8  callref = 0x8D
*Mar  1 04:50:54.698: ISDN BR0: RX <-  CONNECT_ACK pd = 8  callref = 0x0D
*Mar  1 04:50:54.706:         Channel ID i = 0x8A
*Mar  1 04:50:54.766: BR0:2 LCP: I CONFREQ [Listen] id 31 Len 10
*Mar  1 04:50:54.770: BR0:2 LCP:    MagicNumber 0x099285FD (0x0506099285FD)
*Mar  1 04:50:54.774: BR0:2 LCP: O CONFREQ [Listen] id 1 Len 10
*Mar  1 04:50:54.778: BR0:2 LCP:    MagicNumber 0xE128C3F7 (0x0506E128C3F7)
*Mar  1 04:50:54.782: BR0:2 LCP: O CONFACK [Listen] id 31 Len 10
*Mar  1 04:50:54.786: BR0:2 LCP:    MagicNumber 0x099285FD (0x0506099285FD)
*Mar  1 04:50:54.790: BR0:2 LCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:54.794: BR0:2 LCP:    MagicNumber 0xE128C3F7 (0x0506E128C3F7)
*Mar  1 04:50:54.798: BR0:2 LCP: State is Open

!---  LCP negotiation is complete.

*Mar  1 04:50:54.802: BR0:2 PPP: Phase is UP
*Mar  1 04:50:54.806: BR0:2 IPCP: O CONFREQ [Closed] id 1 Len 10
*Mar  1 04:50:54.810: BR0:2 IPCP:    Address 10.0.0.1 (0x03060A000001)
*Mar  1 04:50:54.814: BR0:2 IPCP: I CONFREQ [REQsent] id 17 Len 10
*Mar  1 04:50:54.818: BR0:2 IPCP:    Address 10.0.0.3 (0x03060A000003)
*Mar  1 04:50:54.822: BR0:2 IPCP: O CONFACK [REQsent] id 17 Len 10
*Mar  1 04:50:54.826: BR0:2 IPCP:    Address 10.0.0.3 (0x03060A000003)
*Mar  1 04:50:54.830: BR0:2 IPCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:54.834: BR0:2 IPCP:    Address 10.0.0.1 (0x03060A000001)

!--- IPCP address negotiation is complete.

*Mar  1 04:50:54.834: BR0:2 IPCP: State is Open
*Mar  1 04:50:54.842: BR0:2 DDR: dialer protocol up
*Mar  1 04:50:54.850: Di2 IPCP: Install route to 10.0.0.3

!--- Route to Router 3 is installed.

*Mar  1 04:50:55.802: %LINEPROTO-5-UPDOWN: Line protocol on InterfaceBRI0:2,
   changed state to up

Дополнительные сведения


Document ID: 15925