Интерфейсы и модули Cisco : Процессоры канального интерфейса Cisco

Конфигурация OMPROUTE для работы на мейнфрейме

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ выделяет пример хоста и конфигурации маршрутизатора для выполнения процедуры OMPROUTE на мейнфрейме для обмена обновлениями маршрута с остатком сети TCP/IP. OMPROUTE часто используется, как в данном примере, в сочетании с Виртуальным IP - адресом (VIPA), который позволяет IP-адресу мейнфрейма, настроенного в клиентах быть независимым от любого канального интерфейса. Это обеспечивает избыточность для канала. Первоначально, мэйнфреймовая реализация TCP/IP IBM только поддержала Протокол RIP как протокол маршрутизации с использованием Процедуры OROUTED. Более новый OMPROUTE поддерживает или V1 RIP или V2 и Протокол OSPF. IBM рекомендует, чтобы OMPROUTE использовался, а не OROUTED, и IBM в конечном счете удалит поддержку OROUTED.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Cisco, которой Выпуск ПО IOS�, который использовался для этой конфигурации, был 12.1 (3a) T2 с микропрограммой xCPA 27-9, который был последним в то время, когда это было протестировано. При использовании CLAW, однако, это должно работать с любой версией программного обеспечения Cisco IOS. Использование CMPC + требует минимума Cisco IOS Software Release 12.1T.

Маршрутизатор был Cisco 7206 с адаптером порта xCPA. Также Маршрутизатор Cisco 7500 с картой CIP мог использоваться с незначительными изменениями в конфигурации, как обращено внимание позже в этом документе.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Конфигурации

Конфигурация Mainframe - файлы OMPROUTE

Конфигурация OMPROUTE на мейнфрейме подобна конфигурации OROUTED. OMPROUTE также использует минимум двух файлов конфигурации. Необходимо указать к местоположению этих файлов конфигурации, в Пространстве для адреса OMVS, с этими двумя переменными среды:

  • export resolver_conf=/etc/resolv.conf

  • export omproute_file=/etc/omproute.conf

Это - пример содержания resolver_conf:

TCPJobName TCPIP
DomainOrigin cisco.com
domain cisco.com
Datasetprefix TCPIP
HostName P390
Messagecase mixed

omproute_file будет зависеть от или RIP, или OSPF используется. Это - пример конфигурации для RIP:

;
Originate_RIP_Default Condition=Always Cost=1
;
RIP_Interface IP_Address=10.64.3.34
Name=LDIPTG
Subnet_Mask=255.255.255.240
Receive_Dynamic_Nets=YES
Receive_Dynamic_Subnets=YES
MTU=1470
Destination_Addr=10.64.3.33
;
RIP_Interface IP_Address=10.64.3.17
Name=VIPALINK
Subnet_Mask=255.255.255.240
MTU=1470
;

Для OSPF существует больше доступных параметров конфигурации, которые включают способность сделать мэйнфреймовое действие как изолированную область. Это может значительно уменьшить обновления маршрута загрузки, которые размещены в канал, когда много логических разделов (LPAR) соединяются по тому же каналу. Ниже представлен пример:

Area Area_Number=0.0.0.0 Authentication_Type=None Stub_Area=NO
;
Comparison=Type2
;
AS_Boundary_Routing Import_Subnet_Routes=YES
Import_Direct_Routes=YES
;
OSPF_Interface IP_Address=10.64.3.34
Name=LDIPTG
Subnet_Mask=255.255.255.240
Attaches_To_Area=0.0.0.0
MTU=1470
Destination_Addr=10.64.3.33
Hello_Interval=30
Dead_Router_Interval=120
;
OSPF_Interface IP_Address=10.64.3.17
Name=VIPALINK
Subnet_Mask=255.255.255.240

Конфигурация мэйнфрейма - стек TCP/IP

Набор данных профиля TCP/IP не требует никакой специальной конфигурации для OMPROUTE кроме факта, что необходимо прокомментировать всю статическую конфигурацию и конфигурацию маршрута по умолчанию и раздел BSDROUTINGPARMS (который только используется OROUTED). Это извлечение показывает только, что должно быть прокомментировано и параметры, к которым обращаются файлы конфигурации OMPROUTE:

TCPIP Profile dataset
---------------------
 -----------------------------------------------------------------------
; Hardware definitions:
 -----------------------------------------------------------------------
; NOTE: To use these device and link statements, update the statements
; to reflect your installation configuration and remove the semicolon
;
DEVICE DIPTG MPCPTP
LINK LDIPTG MPCPTP DIPTG
DEVICE VIPADEV VIRTUAL 0
LINK VIPALINK VIRTUAL 0 VIPADEV
;
;
; -----------------------------------------------------------------------
;
; HOME Internet (IP) addresses of each link in the host.
;
; NOTE: To use this home statement, update the ipaddress and linknames 
; to reflect your installation configuration and remove the semicolon
;
HOME
10.64.3.17    VIPALINK
10.64.3.34    LDIPTG
; -----------------------------------------------------------------------
;
; IP routing information for the host.	All static IP routes should
; be added here.
;
; NOTE: To use this GATEWAY statement, update the addresses and links
; to reflect your installation configuration and remove the semicolon
;
; GATEWAY
;
; Direct Routes - Routes that are directly connected to my interfaces.
;
; Network  First Hop  Link Name Packet Size  Subnet Mask  Subnet Value
; 10           =       CIS1      1500       0.255.255.0    0.101.1
; 10           =       LDIPTG    1500       0.255.255.240  0.64.3.32
; 9            =       LIS1      1500       0.255.255.0    0.117.56.0
; 130.50       =       TR1       2000       0.0.255.0      0.0.10.0
; 193.5.2      =       ETH1      1500       0
; 9            =       FDDI1     4000       0.255.255.0    0.67.43.0
; 193.7.2.2    =       SNA1      2000       HOST
;
; Indirect Routes - Routes that are reachable through routers on my
;		    network.
;
; Network     First Hop   Link Name Packet Size  Subnet Mask  Subnet Value
; DEFAULTNET  10.64.3.33  LDIPTG    DEFAULTSIZE  0
; 193.12.2    130.50.10.1 TR1       2000         0
; 10.5.6.4    193.5.2.10  ETH1      1500         HOST
;
; Default Route - All packets to an unknown destination are routed
;		  through this route.
;
; Network     First Hop   Link Name Packet Size  Subnet Mask  Subnet Value
; DEFAULTNET  9.67.43.1   FDDI1     DEFAULTSIZE  0
;
; -----------------------------------------------------------------------
;
; orouted Routing Information
;
; if you are using orouted, comment out the GATEWAY statement and
; update the BSDROUTINGPARMS statement to reflect your installation
; configuration and remove the semicolon
;
;    Link     Maxmtu   Metric   Subnet Mask     Dest Addr
; BSDROUTINGPARMS false
; LDIPTG       1500       0     255.255.255.240 10.64.3.33
; VIPALINK     1500       0     255.255.255.240 0
;    TR1       2000       0     255.255.255.0   0
;    ETH1      1500       0     255.255.255.0   0
;    FDDI1  DEFAULTSIZE   0     255.255.255.0   0
; ENDBSDROUTINGPARMS

!--- Note that all of the last two sections have been commented out.

Конфигурация мэйнфрейма - определения VTAM и стартовый TCP/IP

Обновлениями маршрута можно обменяться или по CLAW или по CMPC + соединения. При использовании CLAW никакая дополнительная настройка не требуется на мейнфрейме. Данный пример использует CMPC, который требует записи Transport Resource List (TRL) VTAM. Это - член VTAM:

DIPTGTRL VBUILD TYPE=TRL
*
*
DIPTG	 TRLE  LNCTL=MPC,MAXBFRU=16,READ=(E24),WRITE=(E25)
*

TRL должен быть активирован, прежде чем TCPIP запустился, задача запущена. Пример:

V NET,ACT,ID=DIPTRL1,UPDATE=ALL
IST097I VARY ACCEPTED
ISTTRL ACTIVE

Затем активируйте запущенную задачу TCP/IP с командой консоли TCPIP MV S. Как только TCP/IP запустился, задача работает, процедура OMPROUTE может быть запущена, или с использованием языка управления заданиями (JCL) как запущенная задача или из Пространства для адреса OMVS. Для начала в OMVS выполните эти команды:

cd /usr/lpp/tcpip/sbin

omproute &

Чтобы проверить, что OMPROUTE работает, выполните эту команду консоли, где p390 является идентификатором пользователя, под которым был запущен демон OMPROUTE:

d omvs,u=p390

Настройка маршрутизатора

И CLAW и CMPC должны быть в частности настроены для передачи широковещательных сообщений по каналу с широковещательным ключевым словом. Например, для CLAW:

claw 0100 20 10.101.1.10 P390D C7000D TCPIP TCPIP broadcast

В данном примере используется CMPC +, таким образом, это соответствующие части конфигурации маршрутизатора:

!
interface Channel2/0
 ip address 10.64.3.33 255.255.255.240
 ip ospf network point-to-multipoint
 no keepalive
 cmpc 0100 24 DIPTG READ
 cmpc 0100 25 DIPTG WRITE
 tg DIPTG    ip 10.64.3.34 10.64.3.33 broadcast
 router ospf 1
  network 10.0.0.0 0.255.255.255 area 0
!

Если бы это был Маршрутизатор Cisco 7500 с картой CIP вместо 7200 с адаптером порта xCPA, то оператор tg был бы настроен под интерфейсом virtual /2. Обратите внимание на команду ip ospf network point-to-multipoint, которая требуется для OSPF функционировать правильно. Канальный интерфейс считают многоточечным интерфейсом во многом как Frame Relay. Если вы не хотите выполнять OSPF всюду по своей сети, можно выполнить его только на самом канальном интерфейсе и использовать перераспределение между другими протоколами маршрутизации. Пример:

!
router eigrp 1
 redistribute ospf 1
 passive-interface Channel2/0
 network 10.0.0.0
 no eigrp log-neighbor-changes
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 1
 network 10.64.3.33 0.0.0.0 area 0
!

Показы на маршрутизаторе

diplodocus# show extended channel 2/0 status

Path: 0100  -- ESTABLISHED
       Command    Selective   System     Device    CU
Dev    Connects    Retries    Cancels    Reset    Reset    Errors    Busy
24        30         21          1         0        0        0        0
25        29         0           1         0        0        0        0
Blocks         Bytes         Dropped Blk         Memd
Dev-Lnk    Read    Write    Read    Write    Read    Write    wait    Con
24-00       29       6      3484     789      0        0       0       Y
25-00        9      29       801    3920      0        0       0       Y
Path 0100
Total:      38      35      4285    4709      0        0       0
Last statistics 0 seconds old, next in 10 seconds

diplodocus# show extended channel 2/0 cmpc

Path    Dv    TGName    Dir    Bfrs     Status
CMPC   0100     24     DIPTG  READ  16  Active+
CMPC   0100     25     DIPTG  WRITE 16  Active+

diplodocus# show ip ospf i

Channel2/0 is up, line protocol is up
Internet Address 10.64.3.33/28, Area 0
Process ID 1, Router ID 200.100.100.9, Network Type POINT_TO_MULTIPOINT,
Cost: 4
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:10
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.64.3.17
Suppress hello for 0 neighbor(s)

diplodocus# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address       Interface
10.64.3.17       1    FULL/  -        00:01:35
Neighbor is up for 00:04:01           10.64.3.34  Channel2/0

diplodocus# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 10.64.3.1 to network 0.0.0.0
1.0.0.0/27 is subnetted, 1 subnets
C	1.1.1.0 is directly connected, Loopback1
200.100.100.0/29 is subnetted, 1 subnets
C	200.100.100.8 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D	10.0.0.0/8 is a summary, 00:06:40, Null0
C	10.64.3.0/28 is directly connected, Ethernet6/0
O E2	10.64.3.17/32 [110/1] via 10.64.3.34, 00:03:57, Channel2/0
O	10.64.3.16/28 [110/5] via 10.64.3.34, 00:03:57, Channel2/0
C	10.64.3.32/28 is directly connected, Channel2/0
S	10.64.3.34/32 [1/0] via 10.64.3.34, Channel2/0
S	10.64.3.37/32 [1/0] via 10.64.3.37, Channel2/0
C	10.64.3.48/28 is directly connected, Serial1/3.1
C	10.64.3.128/28 is directly connected, Serial1/3.2
S*   0.0.0.0/0 [1/0] via 10.64.3.1

Отображения на мэйнфрейме

VTAM-дисплеи на системной консоли

D NET,TRL

IST097I DISPLAY ACCEPTED
ST350I DISPLAY TYPE = TRL 042
IST1314I TRLE = DIPTG	  STATUS = ACTIV       CONTROL = MPC
IST1454I 1 TRLE(S) DISPLAYED
IST314I END

D NET,TRL,TRLE=DIPTG

IST097I DISPLAY ACCEPTED
IST075I NAME = DIPTG, TYPE = TRLE 045
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST087I TYPE = LEASED		  , CONTROL = MPC , HPDT = YES
IST1715I MPCLEVEL = HPDT       MPCUSAGE = SHARE
IST1577I HEADER SIZE = 4092 DATA SIZE = 60 STORAGE = ***NA***
IST1221I WRITE DEV = 0E25 STATUS = ACTIVE     STATE = ONLINE
IST1577I HEADER SIZE = 4092 DATA SIZE = 60 STORAGE = DATASPACE
IST1221I READ  DEV = 0E24 STATUS = ACTIVE     STATE = ONLINE
IST314I END

Показы Сведений о маршрутизации Под TSO от Команды netstat

маршрут netstat отображает таблицу маршрутизации. Пример:

===> netstat route

EZZ2350I MVS TCP/IP NETSTAT CS V2R7       TCPIP NAME: TCPIP       15:56:33
EZZ2755I Destination       Gateway       Flags  Refcnt  Interface
EZZ2756I -----------       -------       -----  ------  ---------
EZZ2757I 10.0.0.0          10.64.3.33    UG     000000  LDIPTG
EZZ2757I 10.64.3.32        0.0.0.0       U      000000  LDIPTG
EZZ2757I 10.64.3.33        0.0.0.0       UH     000000  LDIPTG

выводы данных устройства на экран netstat статус и т.д всех присоединенных устройств или ссылок. Пример:

===> netstat device

EZZ2350I MVS TCP/IP NETSTAT CS V2R7	  TCPIP NAME: TCPIP	   15:58:04
EZZ2760I DevName: LOOPBACK	    DevType: LOOPBACK  DevNum: 0000
EZZ2761I   LnkName: LOOPBACK	      LnkType: LOOPBACK    Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000004278   ByteOut: 0000004278
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 00000		 Metric: 00
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 0.0.0.0
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: No
EZZ2760I DevName: DIPTG 	    DevType: MPC       DevNum: 0000
EZZ2761I   LnkName: LDIPTG	      LnkType: MPC	   Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000001848   ByteOut: 0000001936
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 01470		 Metric: 01
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 255.255.255.240
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: Yes
EZZ2812I     Group            RefCnt
EZZ2813I     -----            ------
EZZ2814I     224.0.0.5        0000000001
EZZ2814I     224.0.0.1        0000000001
EZZ2760I DevName: VIPADEV	    DevType: VIPA      DevNum: 0000
EZZ2761I   LnkName: VIPALINK	      LnkType: VIPA	   Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000000000   ByteOut: 0000000000
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 01470		 Metric: 01
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 255.255.255.240
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: No

Существует еще много опций, доступных с netstat. Можно ли выполнить netstat? команда для отображения их всех.


Дополнительные сведения


Document ID: 12257