Многопротокольная коммутация по меткам (MPLS) : Механизм MPLS over ATM

MPLS через ATM: Слияние VC

21 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации Многопротокольной коммутации по меткам (MPLS) over ATM с помощью слияния Виртуального канала (VC).

Предварительные условия

Требования

Прежде чем вы будете делать попытку этой конфигурации, будете гарантировать, что у вас есть основное понимание ATM, MPLS и Протокола OSPF.

Используемые компоненты

Используйте один из этих маршрутизаторов для реализации этой конфигурации:

  • Краевой маршрутизатор с использованием меток (LSR) — Любой маршрутизатор ATM, который выполняет Cisco Выпуск ПО IOS� 12.0 или позже с функциями MPLS. Эта конфигурация использует Маршрутизаторы серии Cisco 3600, которые выполняют программное обеспечение Cisco IOS версии 12.1(3)T и Маршрутизатор Cisco 7200, который выполняет программное обеспечение Cisco IOS версии 12.0(8)S.

  • LSR ATM — Любой коммутатор ATM, такой как MSR LightStream 1010 или Catalyst 85xx. Cisco рекомендует использовать версию программного обеспечения WA4.8d или позже. LightStream 1010 требует Функциональной карты Организация очереди PerFlow (FC-PFQ).

Можно найти более точное описание поддерживаемых платформ в Разработке MPLS для ATM.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

См. эти ссылки для получения дополнительной информации о конфигурации MPLS и условных обозначениях:

  • Средство слияния VC стандартизировано в Архитектуре Multiprotocol Label Switching инженерной группы по развитию Интернета (IETF) и MPLS с помощью Протокола распределения меток (LDP) и документов Коммутации VC ATM. Можно обратиться к обоим из этих документов из Чартера MPLS IETF leavingcisco.com.

  • Можно найти инструкции по конфигурации в MPLS по документации ATM.

  • Определение размеров количества VC, используемых в сети MPLS, покрыто разделом Пространства VC MPLS Label Определения размеров Разработки MPLS для ATM.

Общие сведения

Средство слияния VC позволяет коммутатору объединять множественные входящие потоки с тем же адресом назначения (DA) в одиночный исходящий поток. Везде, где слияние VC происходит, несколько входящих меток сопоставлены с одной одиночной исходящей меткой. Ячейки от других Идентификаторов виртуального канала (VCI), которые переходят к тому же назначению, переданы к тому же исходящему VC с использованием соединений мульти"точка-точка". Это совместное использование меток уменьшает общее число VC, требуемых для коммутации по меткам. Без слияния VC каждый путь (с тем же Входным маршрутизатором и тем же Классом эквивалентности при передаче (FEC) (FEC)) использует один VC метки на каждом интерфейсе вдоль пути. Слияние VC уменьшает дефицит пространства меток путем совместного использования меток для других потоков с тем же назначением, т.е. тем же FEC.

Эти данные показывают пример слияния VC. На этом рисунке маршрутизаторы A и B передают трафик для добавления префикса 171.69.0.0/16 на маршрутизаторе C. Коммутатор ATM в середине настроен с одиночным исходящим VCI 50, связанным снабжать префиксом 171.69.0.0/16. Потоки данных от маршрутизаторов A и B собираются в коммутаторе ATM и совместно используют тот же исходящий VC. Ячейки, которые прибывают из VCI 40 и VCI 70, буферизованы во входных очередях коммутатора ATM, пока не получены завершенные кадры AAL5. Полный кадр тогда передан к маршрутизатору C на VCI 50.

/image/gif/paws/10475/mpls_vcmerge1.gif

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети.

/image/gif/paws/10475/mpls_vcmerge2.gif

Конфигурации

В данном примере используются Идентификаторы Виртуального тракта ATM (VPI) 2, 3, или 4. Но, это не является обязательным для определения, какие Виртуальные тракты (VP) используются для MPLS.

Настройте технологию CEF IP на маршрутизаторах. При использовании Маршрутизатора Cisco 7500 необходимо гарантировать, что включена команда ip cef distributed.

Эти конфигурации используются в данном документе.

Маршрутизатор 1
!
interface Loopback0
 ip address 223.0.0.12 255.255.255.255
!
interface Loopback1
 ip address 100.100.1.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 100.100.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 100.100.0.0 0.0.0.255 area 10
 network 100.100.1.0 0.0.0.255 area 10
 network 223.0.0.12 0.0.0.0 area 10
!

Router-2
!
ip cef
!
interface Loopback0
 ip address 223.0.0.11 255.255.255.255
!
interface Ethernet0/1
 ip address 100.100.0.1 255.255.255.0
!
interface ATM1/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
!
interface ATM1/0.1 label-switching
 ip address 10.0.0.2 255.255.255.252
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 100.100.0.0 0.0.0.255 area 10
 network 223.0.0.11 0.0.0.0 area 0
!

Маршрутизатор 3
!
ip cef
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Loopback1
 ip address 200.200.0.1 255.255.255.255
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 !
 pvc ilmi 0/16 ilmi
 !
!
interface ATM4/0.1 label-switching
 ip address 10.0.0.6 255.255.255.252
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 redistribute static
 network 10.0.0.0 0.0.0.255 area 0
 network 200.200.0.0 0.0.0.255 area 20
 network 223.0.0.21 0.0.0.0 area 0
!
ip route 158.0.0.0 255.0.0.0 Null0
!

Маршрутизатор 4
!
ip cef
!
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
 no ip directed-broadcast
! 
interface Loopback1
 ip address 150.150.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM4/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no atm ilmi-keepalive
!
interface ATM4/0.1 label-switching
 ip address 10.0.0.13 255.255.255.252
 no ip directed-broadcast
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 150.150.0.0 0.0.255.255 area 30
 network 223.0.0.3 0.0.0.0 area 0
!
ip route 150.150.150.0 255.255.255.0 Null0
!

Коммутатор ATM 1
!
interface Loopback0
 ip address 223.0.0.1 255.255.255.255
 no ip directed-broadcast
!
interface ATM4/1/2
 ip address 10.0.0.1 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
interface ATM4/1/3
 ip address 10.0.0.21 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.1 0.0.0.0 area 0
!

Коммутатор ATM 2
!
interface Loopback0
 ip address 223.0.0.2 255.255.255.255
 no ip directed-broadcast
!
interface ATM0/1/0
 ip address 10.0.0.14 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!         
interface ATM0/1/2
 ip address 10.0.0.5 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
interface ATM0/1/3
 ip address 10.0.0.22 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.2 0.0.0.0 area 0
!

Проверка

В данном разделе содержатся сведения для проверки работы текущей конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show tag-switching atm-tdp capability

  • show tag-switching atm-tdp bindings

  • show atm vc

Выполните команду show tag atm-tdp для получения информации о Слиянии виртуальных соединений. Эти выходные данные, генерируемые командой show tag-switching atm-tdp capability, показывают, что Слияние виртуальных соединений включено на этих интерфейсах:

ATMswitch2#show tag-switching atm-tdp capability 
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/0       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 1023]   UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 1023]   UNIDIR           -    -    
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/2       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 1018]   UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 1018]   UNIDIR           -    -    
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/3       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 16383]  UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 16383]  UNIDIR           -    -

Также можно проверить слияние VC для одного определенного FEC – например, 100.100.1.1/32 – как замечено в этих выходных данных:

ATMswitch2#show tag atm-tdp bindings
Destination: 100.100.1.1/32
    Transit ATM0/1/2 2/47 Active -> ATM0/1/3 2/52 Active
    Transit ATM0/1/0 2/47 Active -> ATM0/1/3 2/52 Active

ATMswitch2#show atm vc
Interface  VPI  VCI   Type   X-Interface     X-VPI X-VCI Encap  Status
ATM0/1/0    2    47   TVC(I) ATM0/1/3          2   52           UP
ATM0/1/2    2    47   TVC(I) ATM0/1/3          2   52           UP
ATM0/1/3    2    52   TVC(O) ATM0/1/2          2   47           UP
                             ATM0/1/0          2   47           UP

Если слияние VC не работает (или если оно отключено с командой no tag-switching atm vc-merge), вы получаете эти выходные данные команды:

ATMswitch2#show tag atm-tdp bindings
Destination: 100.100.1.1/32
    Transit ATM0/1/2 2/38 Active -> ATM0/1/3 2/35 Active
    Transit ATM0/1/0 2/43 Active -> ATM0/1/3 2/43 Active

ATMswitch2#show atm vc
Interface  VPI  VCI   Type   X-Interface     X-VPI X-VCI Encap  Status
ATM0/1/0   2    43    TVC(I) ATM0/1/3          2   43           UP
ATM0/1/2   2    38    TVC(I) ATM0/1/3          2   35           UP
ATM0/1/3   2    35    TVC(O) ATM0/1/2          2   38           UP
ATM0/1/3   2    43    TVC(O) ATM0/1/0          2   43           UP

Вы видите от этих выходных данных, что отключение функции слияния VC приводит к системе с помощью еще многих VC.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 10475